PSM 1.20beta problems

For help and support with PS3 Media Server in general
Forum rules
Please make sure you follow the Problem Reporting Guidelines before posting if you want a reply.

PSM 1.20beta problems

Postby jebise101 » Mon May 18, 2009 5:12 pm

I installed the beta yesterday and every time i run it i get this, look near the end

Code: Select all
[main] TRACE 12:09:40.809 Starting Java PS3 Media Server v1.20
[main] TRACE 12:09:40.825 by shagrath / 2008-2009
[main] TRACE 12:09:40.825 http://ps3mediaserver.blogspot.com
[main] TRACE 12:09:40.825 http://code.google.com/p/ps3mediaserver
[main] TRACE 12:09:40.825
[main] TRACE 12:09:40.825 Java 1.6.0_07-Sun Microsystems Inc.
[main] TRACE 12:09:40.825 OS Windows Vista x86 6.0
[main] TRACE 12:09:40.825 Encoding: Cp1252
[main] TRACE 12:09:40.825 Temp folder: C:\Users\---\AppData\Local\Temp\javaps3media
[main] TRACE 12:09:40.825 Loading configuration file: FreeboxHD.conf
[main] TRACE 12:09:40.825 Loading configuration file: PopcornHour.conf
[main] TRACE 12:09:40.840 Loading configuration file: PS3.conf
[main] TRACE 12:09:40.840 Loading configuration file: XBOX360.conf
[main] TRACE 12:09:40.840 Found AviSynth plugins dir: C:\Program Files\Codecs\AviSynth 2.5\plugins
[main] TRACE 12:09:40.840 Found VideoLAN version 0.9.9 at: C:\Program Files\VideoLAN\VLC\vlc.exe
[main] TRACE 12:09:40.856 Registering transcoding engine AviSynth/FFmpeg
[main] TRACE 12:09:40.856 Registering transcoding engine FFmpeg Audio
[main] TRACE 12:09:40.856 Registering transcoding engine MEncoder
[main] TRACE 12:09:40.856 Registering transcoding engine Avisynth/MEncoder
[main] TRACE 12:09:40.856 Registering transcoding engine MPlayer Audio
[main] TRACE 12:09:40.856 Registering transcoding engine MEncoder Web
[main] TRACE 12:09:40.856 Registering transcoding engine MPlayer Video Dump
[main] TRACE 12:09:40.856 Registering transcoding engine MPlayer Web
[main] TRACE 12:09:40.856 Registering transcoding engine TsMuxer
[main] TRACE 12:09:40.856 Registering transcoding engine Audio High Fidelity
[main] TRACE 12:09:40.856 Registering transcoding engine VideoLan Audio Streaming
[main] TRACE 12:09:40.872 Registering transcoding engine VideoLan Video Streaming
[main] TRACE 12:09:40.872 Registering transcoding engine FFmpeg DVR-MS Remux
[main] TRACE 12:09:40.872 Registering transcoding engine Raws Thumbnailer
[main] TRACE 12:09:41.028 Scanning network interface lo / Software Loopback Interface 1
[main] TRACE 12:09:41.028 Scanning network interface net0 / WAN Miniport (L2TP)
[main] TRACE 12:09:41.028 Scanning network interface net1 / WAN Miniport (PPTP)
[main] TRACE 12:09:41.028 Scanning network interface ppp0 / WAN Miniport (PPPOE)
[main] TRACE 12:09:41.043 Scanning network interface eth0 / WAN Miniport (IPv6)
[main] TRACE 12:09:41.043 Scanning network interface eth1 / WAN Miniport (IP)
[main] TRACE 12:09:41.043 Scanning network interface ppp1 / RAS Async Adapter
[main] TRACE 12:09:41.043 Scanning network interface net2 / WAN Miniport (SSTP)
[main] TRACE 12:09:41.043 Scanning network interface eth2 / WAN Miniport (Network Monitor)
[main] TRACE 12:09:41.059 Scanning network interface eth3 / Realtek RTL8168C(P)/8111C(P) Family PCI-E GBE NIC
[main] TRACE 12:09:41.059 Using address /192.168.2.10 found on network interface: name:eth3 (Realtek RTL8168C(P)/8111C(P) Family PCI-E GBE NIC) index: 10 addresses: /192.168.2.10;
[main] TRACE 12:09:41.059 Created socket: /192.168.2.10:5001
[main] TRACE 12:09:41.106 org.jboss.netty.channel.ChannelException: Failed to bind to: /192.168.2.10:5001
[main] TRACE 12:09:41.106    at org.jboss.netty.bootstrap.ServerBootstrap.bind(ServerBootstrap.java:284)
[main] TRACE 12:09:41.106    at net.pms.network.HTTPServer.start(HTTPServer.java:146)
[main] TRACE 12:09:41.106    at net.pms.PMS.init(PMS.java:374)
[main] TRACE 12:09:41.106    at net.pms.PMS.get(PMS.java:968)
[main] TRACE 12:09:41.106    at net.pms.PMS.main(PMS.java:1032)
[main] TRACE 12:09:41.106 Caused by: java.net.BindException: Address already in use: bind
[main] TRACE 12:09:41.106    at sun.nio.ch.Net.bind(Native Method)
[main] TRACE 12:09:41.106    at sun.nio.ch.ServerSocketChannelImpl.bind(Unknown Source)
[main] TRACE 12:09:41.106    at sun.nio.ch.ServerSocketAdaptor.bind(Unknown Source)
[main] TRACE 12:09:41.106    at org.jboss.netty.channel.socket.nio.NioServerSocketPipelineSink.bind(NioServerSocketPipelineSink.java:151)
[main] TRACE 12:09:41.106    at org.jboss.netty.channel.socket.nio.NioServerSocketPipelineSink.handleServerSocket(NioServerSocketPipelineSink.java:103)
[main] TRACE 12:09:41.106    at org.jboss.netty.channel.socket.nio.NioServerSocketPipelineSink.eventSunk(NioServerSocketPipelineSink.java:77)
[main] TRACE 12:09:41.106    at org.jboss.netty.channel.Channels.bind(Channels.java:655)
[main] TRACE 12:09:41.106    at org.jboss.netty.channel.AbstractChannel.bind(AbstractChannel.java:177)
[main] TRACE 12:09:41.106    at org.jboss.netty.bootstrap.ServerBootstrap$Binder.channelOpen(ServerBootstrap.java:325)
[main] TRACE 12:09:41.106    at org.jboss.netty.channel.SimpleChannelUpstreamHandler.handleUpstream(SimpleChannelUpstreamHandler.java:103)
[main] TRACE 12:09:41.106    at org.jboss.netty.channel.Channels.fireChannelOpen(Channels.java:197)
[main] TRACE 12:09:41.106    at org.jboss.netty.channel.socket.nio.NioServerSocketChannel.<init>(NioServerSocketChannel.java:87)
[main] TRACE 12:09:41.106    at org.jboss.netty.channel.socket.nio.NioServerSocketChannelFactory.newChannel(NioServerSocketChannelFactory.java:147)
[main] TRACE 12:09:41.106    at org.jboss.netty.channel.socket.nio.NioServerSocketChannelFactory.newChannel(NioServerSocketChannelFactory.java:95)
[main] TRACE 12:09:41.106    at org.jboss.netty.bootstrap.ServerBootstrap.bind(ServerBootstrap.java:268)
[main] TRACE 12:09:41.106    ... 4 more
 
jebise101
 
Posts: 42
Joined: Sun May 10, 2009 1:59 am

Re: PSM 1.20beta problems

Postby shagrath » Tue May 19, 2009 7:02 pm

and you have no troubles with the previous versions ?
shagrath
Project Lead
 
Posts: 2667
Joined: Wed Jan 14, 2009 1:39 pm

Re: PSM 1.20beta problems

Postby pmos69 » Tue May 19, 2009 7:16 pm

[main] TRACE 12:09:41.106 Caused by: java.net.BindException: Address already in use: bind

are you sure the port was/is free?

do a netstat -tan and check if there's nothing allready on port 5001
pmos69
 
Posts: 147
Joined: Mon Jan 19, 2009 3:37 pm

Re: PSM 1.20beta problems

Postby shagrath » Tue May 19, 2009 7:34 pm

well, I forgot to report the reuseAddress socket parameter from the old engine to the new one, so I guess it's a bug :p
shagrath
Project Lead
 
Posts: 2667
Joined: Wed Jan 14, 2009 1:39 pm

Re: PSM 1.20beta problems

Postby pmos69 » Tue May 19, 2009 8:24 pm

at least you found it allready.
now you just have to squash it ;-)
pmos69
 
Posts: 147
Joined: Mon Jan 19, 2009 3:37 pm

Re: PSM 1.20beta problems

Postby jebise101 » Wed May 20, 2009 5:47 am

yeah it seems like a bug, when i first installed it it ran fine saying you shoukld see psm on the xmb the second time it gave me that and everytime after. Glad it was a bug because i rarely use the GUI unless i need to do any changes. I have it installed as a service. As for the port maybe its because of the serice? for some reason the service acts like a different psm rather then the GUI. For example if i have my ps3 open and the service running everything is fine, but when i open the gui it shows up as there is no ps3 connected, but it really is connected and working fine but with the service. So the service is using it and working the way it should but the GUI reports as there is no ps3 connect, i don't think the service and the GUI are talking to each other.
jebise101
 
Posts: 42
Joined: Sun May 10, 2009 1:59 am


Return to General Help and Support

Who is online

Users browsing this forum: Exabot [Bot], Google [Bot], Majestic-12 [Bot] and 14 guests