PS3mediaserver on Debian

For help and support with issues specific to Linux/Unix
Forum rules
Please make sure you follow the Problem Reporting Guidelines before posting if you want a reply.

PS3mediaserver on Debian

Postby lavvan » Mon Jan 19, 2009 12:30 am

I have a server that runs Debian (without screen)

I was wondering how i can install your application on the server?

And do i need to install other apps, like codecs etc

Thanks for making this software! Keep up the good work!
lavvan
 
Posts: 14
Joined: Mon Jan 19, 2009 12:26 am

Re: PS3mediaserver on Debian

Postby Topguy » Mon Jan 19, 2009 9:42 pm

I will just cover the basics here:
* First you will need Java, personally I'm running the JDK from java.sun.com but it may be sufficient with the JRE.
* Then you should install "mplayer", "mencoder" and "ffmpeg" with the standard package tools in debian.
(You didn't specify which release of Debian you used, I'm using Debian Lenny and that has quite good versions of the tools. I dont know if Sarge is just as up to date.)

After installing this you should be able to start the PMS.sh script. (Might have to set the correct path to Java in "JAVA_HOME" environment variable)
Topguy
 
Posts: 219
Joined: Mon Jan 19, 2009 9:27 pm

Re: PS3mediaserver on Debian

Postby lavvan » Mon Jan 19, 2009 11:25 pm

Thanx for the reply.

I have successfully installed mplayer,mencoder,ffmpeg and pms.
though, i`m getting this message on startup:

"[main] 23:01:28.107 Cannot launch FFmpeg / Check the presence of /storage/disk1/
PMS/pms-linux-1.03/ffmpeg ...: Index: 0, Size: 0"

does this mean that ffmpeg are`nt working?

I have tested one .mkv file and it worked great. There are som things i would like to change in pms settings, but i can`t find pms.conf file..
Is there a solution to this?

On my PS3, every map on the server is listed twise.. is that normal?

And finally :D, is there a way to get debian to start pms.sh on startup?

Thanx again for all the great support. I`m a noob to linux so sorry for all the stupid questions :)
lavvan
 
Posts: 14
Joined: Mon Jan 19, 2009 12:26 am

Re: PS3mediaserver on Debian

Postby Topguy » Tue Jan 20, 2009 1:06 pm

lavvan wrote:Thanx for the reply.

I have successfully installed mplayer,mencoder,ffmpeg and pms.
though, i`m getting this message on startup:

"[main] 23:01:28.107 Cannot launch FFmpeg / Check the presence of /storage/disk1/
PMS/pms-linux-1.03/ffmpeg ...: Index: 0, Size: 0"

does this mean that ffmpeg are`nt working?

I have tested one .mkv file and it worked great. There are som things i would like to change in pms settings, but i can`t find pms.conf file..
Is there a solution to this?

On my PS3, every map on the server is listed twise.. is that normal?

And finally :D, is there a way to get debian to start pms.sh on startup?

Thanx again for all the great support. I`m a noob to linux so sorry for all the stupid questions :)


You can copy or create a link to ffmpeg if its installed. Find ffmpeg by "which ffmpeg" and just copy that file to pms catalog. ( Better to use link really: "ln -s /usr/bin/ffmpeg /storage/disk1/
PMS/pms-linux-1.03/ffmpeg" )

I think its just a packaging mistake that PMS.conf isnt in the package, you can copy it from Windows installation or maybe use an old Linux release.

There is many ways to get PMS up and running at startup. I just haven't seen any good examples of startup scripts yet, and I haven't had time to make my own yet.
Topguy
 
Posts: 219
Joined: Mon Jan 19, 2009 9:27 pm

Re: PS3mediaserver on Debian

Postby lavvan » Sun Jan 25, 2009 3:35 pm

You can copy or create a link to ffmpeg if its installed. Find ffmpeg by "which ffmpeg" and just copy that file to pms catalog. ( Better to use link really: "ln -s /usr/bin/ffmpeg /storage/disk1/
PMS/pms-linux-1.03/ffmpeg" )

I think its just a packaging mistake that PMS.conf isnt in the package, you can copy it from Windows installation or maybe use an old Linux release.

There is many ways to get PMS up and running at startup. I just haven't seen any good examples of startup scripts yet, and I haven't had time to make my own yet.
Well, your tip on the .conf file worked and the ffmpeg problem is gone, so thanx again for your help!

Regarding a script, I have tried a little bit on writing one, but no luck yet.. but I think I could get it to work. I can post it when i do.

Another thing, does anyone know if the linux version can run on multiple cores? I had problems with a 1080p video. The server is on a Gbit network and i`m running it on an intel dual core 2,3 GHz with 2gig ram. That should be enough? the video setting on pms is on losseless (1,1,1)..
lavvan
 
Posts: 14
Joined: Mon Jan 19, 2009 12:26 am

Re: PS3mediaserver on Debian

Postby shagrath » Sun Jan 25, 2009 3:55 pm

lavvan wrote:Another thing, does anyone know if the linux version can run on multiple cores? I had problems with a 1080p video.


Nope, you have to build mencoder and the multithread branch yourself ( good luck ;) )
shagrath
Project Lead
 
Posts: 2667
Joined: Wed Jan 14, 2009 1:39 pm

Re: PS3mediaserver on Debian

Postby lavvan » Mon Jan 26, 2009 1:52 pm

Nope, you have to build mencoder and the multithread branch yourself ( good luck ;) )
I`m gessing that`s not a job for an newbie :D
Just have to wait for someone else to do the durty work ;)
lavvan
 
Posts: 14
Joined: Mon Jan 19, 2009 12:26 am

Re: PS3mediaserver on Debian

Postby Topguy » Tue Jan 27, 2009 4:52 pm

shagrath wrote:
lavvan wrote:Another thing, does anyone know if the linux version can run on multiple cores? I had problems with a 1080p video.


Nope, you have to build mencoder and the multithread branch yourself ( good luck ;) )


Will it be enough to build mplayer/mencoder while using ffmpeg MT branch code ??
Topguy
 
Posts: 219
Joined: Mon Jan 19, 2009 9:27 pm

Re: PS3mediaserver on Debian

Postby shagrath » Tue Jan 27, 2009 6:46 pm

that's I've done on Windows, so I guess yes
shagrath
Project Lead
 
Posts: 2667
Joined: Wed Jan 14, 2009 1:39 pm

Re: PS3mediaserver on Debian

Postby vmlinuz » Tue Jan 27, 2009 10:35 pm

shagrath wrote:that's I've done on Windows, so I guess yes

Could you please post your src links ?
This could help to work on same way.
Thanks,
CPU Intel Q9550 & RAM 4GB Lan : <100Mb/s wired> Router <100Mb/s> <CPL 200Mb/s @ 160Mb/s >=< 100Mb/s> PS3
old config til Feb 22th : Athlon x64 4200+ oc@2.6Gh RAM 4Gb
vmlinuz
 
Posts: 35
Joined: Mon Jan 19, 2009 10:25 am

Next

Return to Linux/Unix Support

Who is online

Users browsing this forum: Yahoo [Bot] and 2 guests