Digging into subtitles (subdelay)

For help and support with issues specific to Mac OS X
Forum rules
Please make sure you follow the Problem Reporting Guidelines before posting if you want a reply.

Digging into subtitles (subdelay)

Postby radekb » Fri May 01, 2009 10:24 pm

Hi folks,

I'm not quite sure where to start, but i'll do my best to describe the problem and my findings so far.
I've been using PS3 Media Server for music and ordinary videos without any probs so far. I've been trying to do something else today - watch videos WITH subtitles.
They did not show up no matter which options i've used, so i started digging a bit into the debug.log trying to identify the problem. After consulting mencoder/mplayer manual i was lucky to found the guilty: -subdelay 20000. Believe it or not, PMS is telling mencoder to delay subtitles by five and a half hours! :lol:
I'm sure it's this one, because running mplayer from the shell with and without this option confirmed it. So... there's no way to override it in mencoder system-wide nor user config. I've tried adding "-subdelay 0" in "Transcoding settings" / "Custom options", but as it turns PMS adds these somewhere in the middle of mencoder arguments, so it gets overriden by 20000 seconds delay later in the arguments list.
The last thing i was trying to do, was to write shell wrapper around mencoder and put it in Resources/Java/osx, moving the original to a different name and calling it from the wrapper. Still no luck, thanks to the shell stdin/stdout handling.
PMS doesn't come with a source code, so i gave up at this point.

Sadly, i'm gonna have to spend this evening doing something other than watching subtitled videos :|

Could you possibly:
- look into the strange subtitle delay argument thingy
and/or
- add a custom mencoder options to the GUI that would be inserted at the end of mencoder's argument list
please?

Thanks in advance,
Radek

P.S. Same behaviour noticed in 1.10.5 and the latest beta build.
radekb
 
Posts: 3
Joined: Fri May 01, 2009 10:02 pm

Re: Digging into subtitles (subdelay)

Postby shagrath » Sat May 02, 2009 10:30 am

this option is only used when no subtitles are detected...
shagrath
Project Lead
 
Posts: 2668
Joined: Wed Jan 14, 2009 1:39 pm

Re: Digging into subtitles (subdelay)

Postby radekb » Sat May 02, 2009 7:43 pm

There is most propably something wrong with subtitle detection procedure in PMS then, i guess.
Notice few things on the attached screenshot:

- when using mplayer that comes with PMS, the subtitles load fine (and they do show up properly in mplayer window)
- at the same time PMS is transcoding this particular video to PS3 and the subtitle do not show up, as there is -subdelay 20000 argument there
- my custom "-subdelay 0" parameter got inserted in the middle between "-channels 6" and "-lavcopts", so it doesn't do anything since it gets overwritten later on by "-subdelay 20000"
- there are as much as nine "-quiet" arguments passed to mencoder, do we really need that much?

Also attached is a debug.log from start-stop playback sequence.
Can you shed any light on this?

P.S. It's not possible to attach file with .log or .txt or without any extension on this forum, so i'm gonna paste it below

Code: Select all
[Timer-8] DEBUG 20:20:33.751 Buffered Space: 417390592 bytes / inputs: 1
[Thread-263] DEBUG 20:33:10.144 Opened handler on socket Socket[addr=/192.168.1.104,port=57651,localport=5001]
[Thread-263] DEBUG 20:33:10.145 Received on socket: POST /upnp/control/content_directory HTTP/1.1
[Thread-263] DEBUG 20:33:10.145 Received on socket: X-AV-Client-Info: av=5.0; cn="Sony Computer Entertainment Inc."; mn="PLAYSTATION 3"; mv="1.0";
[Thread-263] DEBUG 20:33:10.146 Received on socket: Host: 192.168.1.102:5001
[Thread-263] DEBUG 20:33:10.146 Received on socket: User-Agent: UPnP/1.0 DLNADOC/1.50
[Thread-263] DEBUG 20:33:10.146 Received on socket: Content-Length: 276
[Thread-263] DEBUG 20:33:10.146 Received on socket: Content-Type: text/xml; charset="utf-8"
[Thread-263] DEBUG 20:33:10.146 Received on socket: SOAPACTION: "urn:schemas-upnp-org:service:ContentDirectory:1#GetSystemUpdateID"
[Thread-264] DEBUG 20:33:10.148 Opened handler on socket Socket[addr=/192.168.1.104,port=57650,localport=5001]
[Thread-264] DEBUG 20:33:10.148 Received on socket: HEAD /get/0$1$1$0$0/myvideo.avi HTTP/1.0
[Thread-264] DEBUG 20:33:10.148 Received on socket: Host: 192.168.1.102:5001
[Thread-264] DEBUG 20:33:10.148 Received on socket: User-Agent: PLAYSTATION 3
[Thread-264] DEBUG 20:33:10.148 Received on socket: Connection: close
[Thread-264] DEBUG 20:33:10.148 Received on socket: Accept-Encoding: identity
[Thread-264] DEBUG 20:33:10.148 Received on socket: Cache-Control: no-cache
[Thread-264] INFO  20:33:10.148 HTTP: get/0$1$1$0$0/myvideo.avi / 0-0
[Thread-264] DEBUG 20:33:10.148 Wrote on socket: HTTP/1.0 200 OK
[Thread-264] DEBUG 20:33:10.148 Searching for objectId: 0$1$1$0$0 with children option: false
[Thread-264] DEBUG 20:33:10.148 Asked stream chunk [0-0] timeseek: 0.0 of myvideo.avi and player MEncoder
[Thread-264] TRACE 20:33:10.148 Starting transcode/remux of myvideo.avi
[Thread-264] DEBUG 20:33:10.149 Searching an audio track with lang: fre
[Thread-264] DEBUG 20:33:10.149 Searching an audio track with lang: jpn
[Thread-264] DEBUG 20:33:10.149 Searching an audio track with lang: ger
[Thread-263] INFO  20:33:10.148 HTTP: upnp/control/content_directory / 0-0
[Thread-264] DEBUG 20:33:10.149 Searching an audio track with lang: eng
[Thread-263] DEBUG 20:33:10.149 Wrote on socket: HTTP/1.1 200 OK
[Thread-263] DEBUG 20:33:10.149 Wrote on socket: CONTENT-TYPE: text/xml; charset="utf-8"
[Thread-264] DEBUG 20:33:10.149 Choosed a default audio track: Audio: AC3 / lang: und / ID: 1
[Thread-263] DEBUG 20:33:10.149 Wrote on socket: Server: Mac_OS_X-i386-10.5.6, UPnP/1.0, PMS/1.11
[Thread-263] DEBUG 20:33:10.149 Wrote on socket: Content-Length: 335
[Thread-263] DEBUG 20:33:10.149 Wrote on socket:
[Thread-263] DEBUG 20:33:10.149 Close Connection
[Thread-264] DEBUG 20:33:10.150 Searching a subtitle track with lang: fre
[Thread-264] DEBUG 20:33:10.150 Searching a subtitle track with lang: eng
[Thread-265] DEBUG 20:33:10.156 Opened handler on socket Socket[addr=/192.168.1.104,port=57649,localport=5001]
[osx/mencoder] INFO  20:33:10.156 Starting /Applications/PS3 Media Server.app/Contents/Resources/Java/osx/mencoder -ss 0 -quiet /Users/radekb/moje/myvideo.avi -quiet -quiet -oac lavc -of mpeg -lavfopts format=asf -mpegopts format=mpeg2:muxrate=500000:vbuf_size=1194:abuf_size=64 -ovc lavc -channels 6 -subdelay 0 -lavdopts debug=0:threads=2 -lavcopts autoaspect=1:vcodec=mpeg2video:acodec=ac3:abitrate=384:threads=2:keyint=1:vqscale=1:vqmin=2 -subfont /System/Library/Frameworks/JavaVM.framework/Versions/1.5.0/Home/lib/fonts/LucidaSansRegular.ttf -subfont-text-scale 3 -subfont-outline 1 -subfont-blur 1 -subpos 98 -quiet -quiet -subdelay 20000 -quiet -quiet -ofps 24000/1001 -quiet -quiet -mc 0 -noskip -af lavcresample=48000 -srate 48000 -o - -really-quiet -msglevel all=-1
[Thread-265] DEBUG 20:33:10.156 Received on socket: POST /upnp/control/content_directory HTTP/1.1
[Thread-265] DEBUG 20:33:10.156 Received on socket: X-AV-Client-Info: av=5.0; cn="Sony Computer Entertainment Inc."; mn="PLAYSTATION 3"; mv="1.0";
[Thread-265] DEBUG 20:33:10.156 Received on socket: Host: 192.168.1.102:5001
[Thread-265] DEBUG 20:33:10.156 Received on socket: User-Agent: UPnP/1.0 DLNADOC/1.50
[Thread-265] DEBUG 20:33:10.156 Received on socket: Content-Length: 907
[Thread-265] DEBUG 20:33:10.156 Received on socket: Content-Type: text/xml; charset="utf-8"
[Thread-265] DEBUG 20:33:10.156 Received on socket: SOAPACTION: "urn:schemas-upnp-org:service:ContentDirectory:1#Browse"
[Thread-265] INFO  20:33:10.167 HTTP: upnp/control/content_directory / 0-0
[Thread-265] DEBUG 20:33:10.293 Wrote on socket: HTTP/1.1 200 OK
[Thread-265] DEBUG 20:33:10.293 Wrote on socket: CONTENT-TYPE: text/xml; charset="utf-8"
[Thread-265] DEBUG 20:33:10.293 Searching for objectId: 0$1$1$0 with children option: false
[Thread-265] DEBUG 20:33:10.293 Wrote on socket: Server: Mac_OS_X-i386-10.5.6, UPnP/1.0, PMS/1.11
[Thread-265] DEBUG 20:33:10.293 Wrote on socket: Content-Length: 807
[Thread-265] DEBUG 20:33:10.293 Wrote on socket:
[Thread-265] DEBUG 20:33:10.293 Close Connection
[osx/mencoder] INFO  20:33:10.368 Attaching thread: osx/mencoder
[Timer-9] DEBUG 20:33:10.368 Buffered Space: 0 bytes / inputs: 0
[Thread-266] DEBUG 20:33:10.369 Using SSE optimized IMDCT transform
[Thread-266] DEBUG 20:33:10.369 Using MMX optimized resampler
[Thread-266] DEBUG 20:33:10.369 [ac3 @ 0x1053600]No channel layout specified. The encoder will guess the layout, but it might be incorrect.
[Timer-9] DEBUG 20:33:12.368 Buffered Space: 10258432 bytes / inputs: 0
[Timer-9] DEBUG 20:33:14.369 Buffered Space: 31309824 bytes / inputs: 0
[Thread-267] DEBUG 20:33:16.068 freeMemory: 14206696
[Thread-267] DEBUG 20:33:16.068 totalMemory: 70623232
[Thread-267] DEBUG 20:33:16.068 maxMemory: 799145984
[Thread-267] DEBUG 20:33:16.068 Extending buffer to 419430400
[Thread-264] DEBUG 20:33:16.295 Wrote on socket: Content-Type: video/mpeg
[Thread-264] DEBUG 20:33:16.295 Wrote on socket: Connection: keep-alive
[Thread-264] DEBUG 20:33:16.295 Wrote on socket: Server: Mac_OS_X-i386-10.5.6, UPnP/1.0, PMS/1.11
[Thread-264] DEBUG 20:33:16.296 Wrote on socket:
[Thread-264] DEBUG 20:33:16.296 Sending stream: 0 bytes of get/0$1$1$0$0/myvideo.avi
[Thread-264] DEBUG 20:33:16.296 Ready to Stop: true
[Thread-264] DEBUG 20:33:16.306 Close Connection
[Thread-270] DEBUG 20:33:16.313 Opened handler on socket Socket[addr=/192.168.1.104,port=57648,localport=5001]
[Thread-270] DEBUG 20:33:16.313 Received on socket: GET /get/0$1$1$0$0/myvideo.avi HTTP/1.0
[Thread-270] DEBUG 20:33:16.313 Received on socket: Host: 192.168.1.102:5001
[Thread-270] DEBUG 20:33:16.313 Received on socket: User-Agent: PLAYSTATION 3
[Thread-270] DEBUG 20:33:16.313 Received on socket: Connection: close
[Thread-270] DEBUG 20:33:16.313 Received on socket: Accept-Encoding: identity
[Thread-270] DEBUG 20:33:16.313 Received on socket: Cache-Control: no-cache
[Thread-270] INFO  20:33:16.313 HTTP: get/0$1$1$0$0/myvideo.avi / 0-0
[Thread-270] DEBUG 20:33:16.314 Wrote on socket: HTTP/1.0 200 OK
[Thread-270] DEBUG 20:33:16.314 Searching for objectId: 0$1$1$0$0 with children option: false
[Thread-270] DEBUG 20:33:16.314 Asked stream chunk [0-0] timeseek: 0.0 of myvideo.avi and player MEncoder
[Thread-270] DEBUG 20:33:16.314 Ready to Stop: false
[Thread-270] DEBUG 20:33:16.314 Wrote on socket: Content-Type: video/mpeg
[Thread-270] DEBUG 20:33:16.314 Wrote on socket: Connection: keep-alive
[Thread-270] DEBUG 20:33:16.314 Wrote on socket: Server: Mac_OS_X-i386-10.5.6, UPnP/1.0, PMS/1.11
[Thread-270] DEBUG 20:33:16.314 Wrote on socket:
[Thread-270] DEBUG 20:33:16.341 Sending stream with premature end : 131072 bytes of get/0$1$1$0$0/myvideo.avi. Reason: Broken pipe
[Thread-270] DEBUG 20:33:16.341 Ready to Stop: true
[Thread-270] DEBUG 20:33:16.341 Sending stream: 131072 bytes of get/0$1$1$0$0/myvideo.avi
[Thread-270] DEBUG 20:33:16.342 Close Connection
[Thread-273] DEBUG 20:33:16.349 Opened handler on socket Socket[addr=/192.168.1.104,port=57647,localport=5001]
[Thread-273] DEBUG 20:33:16.349 Received on socket: GET /get/0$1$1$0$0/myvideo.avi HTTP/1.1
[Thread-273] DEBUG 20:33:16.349 Received on socket: Host: 192.168.1.102:5001
[Thread-273] DEBUG 20:33:16.349 Received on socket: User-Agent: PLAYSTATION 3
[Thread-273] DEBUG 20:33:16.349 Received on socket: Connection: Keep-Alive
[Thread-273] DEBUG 20:33:16.349 Received on socket: Accept-Encoding: identity
[Thread-273] DEBUG 20:33:16.349 Received on socket: transferMode.dlna.org: Streaming
[Thread-273] DEBUG 20:33:16.349 Received on socket: TimeSeekRange.dlna.org: npt=0.000-
[Thread-273] INFO  20:33:16.349 HTTP: get/0$1$1$0$0/myvideo.avi / 0-0
[Thread-273] DEBUG 20:33:16.350 Wrote on socket: HTTP/1.1 200 OK
[Thread-273] DEBUG 20:33:16.350 Searching for objectId: 0$1$1$0$0 with children option: false
[Thread-273] DEBUG 20:33:16.350 Asked stream chunk [0-0] timeseek: 0.0 of myvideo.avi and player MEncoder
[Thread-273] DEBUG 20:33:16.350 Ready to Stop: false
[Thread-273] DEBUG 20:33:16.350 Wrote on socket: Content-Type: video/mpeg
[Thread-273] DEBUG 20:33:16.350 Wrote on socket: Connection: keep-alive
[Thread-273] DEBUG 20:33:16.350 Wrote on socket: Server: Mac_OS_X-i386-10.5.6, UPnP/1.0, PMS/1.11
[Thread-273] DEBUG 20:33:16.350 Wrote on socket:
[Timer-9] DEBUG 20:33:16.369 Buffered Space: 49793024 bytes / inputs: 1
[Thread-267] DEBUG 20:33:16.674 Done extending
[Thread-274] DEBUG 20:33:17.337 Opened handler on socket Socket[addr=/192.168.1.104,port=57646,localport=5001]
[Thread-274] DEBUG 20:33:17.337 Received on socket: HEAD /get/0$1$1$0$0/myvideo.avi HTTP/1.0
[Thread-274] DEBUG 20:33:17.337 Received on socket: Host: 192.168.1.102:5001
[Thread-274] DEBUG 20:33:17.337 Received on socket: User-Agent: PLAYSTATION 3
[Thread-274] DEBUG 20:33:17.337 Received on socket: Connection: close
[Thread-274] DEBUG 20:33:17.337 Received on socket: Accept-Encoding: identity
[Thread-274] DEBUG 20:33:17.337 Received on socket: Cache-Control: no-cache
[Thread-274] INFO  20:33:17.337 HTTP: get/0$1$1$0$0/myvideo.avi / 0-0
[Thread-274] DEBUG 20:33:17.337 Wrote on socket: HTTP/1.0 200 OK
[Thread-274] DEBUG 20:33:17.338 Searching for objectId: 0$1$1$0$0 with children option: false
[Thread-274] DEBUG 20:33:17.338 Asked stream chunk [0-0] timeseek: 0.0 of myvideo.avi and player MEncoder
[Thread-274] DEBUG 20:33:17.338 Wrote on socket: Content-Type: video/mpeg
[Thread-274] DEBUG 20:33:17.338 Wrote on socket: Connection: keep-alive
[Thread-274] DEBUG 20:33:17.338 Wrote on socket: Server: Mac_OS_X-i386-10.5.6, UPnP/1.0, PMS/1.11
[Thread-274] DEBUG 20:33:17.338 Wrote on socket:
[Thread-274] DEBUG 20:33:17.338 Sending stream: 0 bytes of get/0$1$1$0$0/myvideo.avi
[Thread-274] DEBUG 20:33:17.338 Ready to Stop: true
[Thread-274] DEBUG 20:33:17.339 Close Connection
[Thread-276] DEBUG 20:33:17.348 Opened handler on socket Socket[addr=/192.168.1.104,port=57645,localport=5001]
[Thread-276] DEBUG 20:33:17.351 Received on socket: GET /get/0$1$1$0$0/myvideo.avi HTTP/1.0
[Thread-276] DEBUG 20:33:17.351 Received on socket: Host: 192.168.1.102:5001
[Thread-276] DEBUG 20:33:17.351 Received on socket: User-Agent: PLAYSTATION 3
[Thread-276] DEBUG 20:33:17.351 Received on socket: Connection: close
[Thread-276] DEBUG 20:33:17.351 Received on socket: Accept-Encoding: identity
[Thread-276] DEBUG 20:33:17.351 Received on socket: Cache-Control: no-cache
[Thread-276] INFO  20:33:17.351 HTTP: get/0$1$1$0$0/myvideo.avi / 0-0
[Thread-276] DEBUG 20:33:17.351 Wrote on socket: HTTP/1.0 200 OK
[Thread-276] DEBUG 20:33:17.351 Searching for objectId: 0$1$1$0$0 with children option: false
[Thread-276] DEBUG 20:33:17.351 Asked stream chunk [0-0] timeseek: 0.0 of myvideo.avi and player MEncoder
[Thread-276] DEBUG 20:33:17.351 Ready to Stop: false
[Thread-276] DEBUG 20:33:17.351 Wrote on socket: Content-Type: video/mpeg
[Thread-276] DEBUG 20:33:17.351 Wrote on socket: Connection: keep-alive
[Thread-276] DEBUG 20:33:17.352 Wrote on socket: Server: Mac_OS_X-i386-10.5.6, UPnP/1.0, PMS/1.11
[Thread-276] DEBUG 20:33:17.352 Wrote on socket:
[Thread-276] DEBUG 20:33:17.384 Sending stream with premature end : 131072 bytes of get/0$1$1$0$0/myvideo.avi. Reason: Broken pipe
[Thread-276] DEBUG 20:33:17.385 Ready to Stop: true
[Thread-276] DEBUG 20:33:17.385 Sending stream: 131072 bytes of get/0$1$1$0$0/myvideo.avi
[Thread-276] DEBUG 20:33:17.385 Close Connection
[Thread-279] DEBUG 20:33:17.387 Opened handler on socket Socket[addr=/192.168.1.104,port=57644,localport=5001]
[Thread-279] DEBUG 20:33:17.387 Received on socket: GET /get/0$1$1$0$0/myvideo.avi HTTP/1.1
[Thread-279] DEBUG 20:33:17.387 Received on socket: Host: 192.168.1.102:5001
[Thread-279] DEBUG 20:33:17.387 Received on socket: User-Agent: PLAYSTATION 3
[Thread-279] DEBUG 20:33:17.387 Received on socket: Connection: Keep-Alive
[Thread-279] DEBUG 20:33:17.387 Received on socket: Accept-Encoding: identity
[Thread-279] DEBUG 20:33:17.387 Received on socket: transferMode.dlna.org: Streaming
[Thread-279] DEBUG 20:33:17.387 Received on socket: TimeSeekRange.dlna.org: npt=0.000-
[Thread-279] INFO  20:33:17.387 HTTP: get/0$1$1$0$0/myvideo.avi / 0-0
[Thread-279] DEBUG 20:33:17.387 Wrote on socket: HTTP/1.1 200 OK
[Thread-279] DEBUG 20:33:17.387 Searching for objectId: 0$1$1$0$0 with children option: false
[Thread-279] DEBUG 20:33:17.388 Asked stream chunk [0-0] timeseek: 0.0 of myvideo.avi and player MEncoder
[Thread-279] DEBUG 20:33:17.388 Ready to Stop: false
[Thread-279] DEBUG 20:33:17.388 Wrote on socket: Content-Type: video/mpeg
[Thread-279] DEBUG 20:33:17.388 Wrote on socket: Connection: keep-alive
[Thread-279] DEBUG 20:33:17.388 Wrote on socket: Server: Mac_OS_X-i386-10.5.6, UPnP/1.0, PMS/1.11
[Thread-279] DEBUG 20:33:17.388 Wrote on socket:
[Thread-279] DEBUG 20:33:18.240 Sending stream with premature end : 1179648 bytes of get/0$1$1$0$0/myvideo.avi. Reason: Broken pipe
[Thread-279] DEBUG 20:33:18.240 Ready to Stop: true
[Thread-279] DEBUG 20:33:18.241 Sending stream: 1179648 bytes of get/0$1$1$0$0/myvideo.avi
[Thread-279] DEBUG 20:33:18.241 Close Connection
[Thread-273] DEBUG 20:33:18.288 Sending stream with premature end : 1212416 bytes of get/0$1$1$0$0/myvideo.avi. Reason: Broken pipe
[Thread-273] DEBUG 20:33:18.289 Sending stream: 1212416 bytes of get/0$1$1$0$0/myvideo.avi
[Thread-273] DEBUG 20:33:18.289 Close Connection
[Thread-284] DEBUG 20:33:18.292 Opened handler on socket Socket[addr=/192.168.1.104,port=57643,localport=5001]
[Thread-284] DEBUG 20:33:18.293 Received on socket: GET /get/0$1$1$0$0/myvideo.avi HTTP/1.1
[Thread-284] DEBUG 20:33:18.293 Received on socket: Host: 192.168.1.102:5001
[Thread-284] DEBUG 20:33:18.293 Received on socket: User-Agent: PLAYSTATION 3
[Thread-284] DEBUG 20:33:18.293 Received on socket: Connection: Keep-Alive
[Thread-284] DEBUG 20:33:18.293 Received on socket: Accept-Encoding: identity
[Thread-284] DEBUG 20:33:18.293 Received on socket: TimeSeekRange.dlna.org: npt=324.073-
[Thread-284] DEBUG 20:33:18.293 Received on socket: transferMode.dlna.org: Streaming
[Thread-284] INFO  20:33:18.293 HTTP: get/0$1$1$0$0/myvideo.avi / 0-0
[Thread-284] DEBUG 20:33:18.293 Wrote on socket: HTTP/1.1 200 OK
[Thread-284] DEBUG 20:33:18.293 Searching for objectId: 0$1$1$0$0 with children option: false
[Thread-284] DEBUG 20:33:18.293 Asked stream chunk [0-0] timeseek: 324.073 of myvideo.avi and player MEncoder
[Thread-284] INFO  20:33:18.293 Requesting Time Seeking: 324.073 seconds
[Thread-284] DEBUG 20:33:18.293 Searching an audio track with lang: fre
[Thread-285] INFO  20:33:18.293 Stopping process: osx/mencoder
[Thread-284] DEBUG 20:33:18.294 Searching an audio track with lang: jpn
[Thread-284] DEBUG 20:33:18.294 Searching an audio track with lang: ger
[Thread-267] INFO  20:33:18.294 Error consuming stream of spawned process:Stream closed
[Thread-284] DEBUG 20:33:18.294 Searching an audio track with lang: eng
[Thread-284] DEBUG 20:33:18.294 Choosed a default audio track: Audio: AC3 / lang: und / ID: 1
[Thread-284] DEBUG 20:33:18.295 Searching a subtitle track with lang: fre
[Thread-284] DEBUG 20:33:18.295 Searching a subtitle track with lang: eng
[osx/mencoder] INFO  20:33:18.302 Starting /Applications/PS3 Media Server.app/Contents/Resources/Java/osx/mencoder -ss 324.073 -quiet /Users/radekb/moje/myvideo.avi -quiet -quiet -oac lavc -of mpeg -lavfopts format=asf -mpegopts format=mpeg2:muxrate=500000:vbuf_size=1194:abuf_size=64 -ovc lavc -channels 6 -subdelay 0 -lavdopts debug=0:threads=2 -lavcopts autoaspect=1:vcodec=mpeg2video:acodec=ac3:abitrate=384:threads=2:keyint=1:vqscale=1:vqmin=2 -subfont /System/Library/Frameworks/JavaVM.framework/Versions/1.5.0/Home/lib/fonts/LucidaSansRegular.ttf -subfont-text-scale 3 -subfont-outline 1 -subfont-blur 1 -subpos 98 -quiet -quiet -subdelay 20000 -quiet -quiet -ofps 24000/1001 -quiet -quiet -mc 0 -noskip -af lavcresample=48000 -srate 48000 -o - -really-quiet -msglevel all=-1
[osx/mencoder] DEBUG 20:33:18.312 EOF
[Thread-285] DEBUG 20:33:18.313 Killing the Unix process: 3051
[Thread-272] INFO  20:33:18.911 Destroying buffer
[Thread-271] INFO  20:33:18.911 Destroying buffer
[Thread-269] INFO  20:33:18.911 Destroying buffer
[Timer-9] DEBUG 20:33:18.911 Buffered Space: 69015552 bytes / inputs: 0
[osx/mencoder] INFO  20:33:19.284 Attaching thread: osx/mencoder
[Timer-10] DEBUG 20:33:19.460 Buffered Space: 0 bytes / inputs: 0
[Thread-289] DEBUG 20:33:19.460 kill: 3051: No such process
[Thread-286] DEBUG 20:33:19.460 Using SSE optimized IMDCT transform
[Thread-286] DEBUG 20:33:19.460 Using MMX optimized resampler
[Thread-286] DEBUG 20:33:19.460 [ac3 @ 0x1053600]No channel layout specified. The encoder will guess the layout, but it might be incorrect.
[Thread-285] INFO  20:33:19.461 Destroying buffer
[Thread-275] INFO  20:33:19.839 Destroying buffer
[Thread-278] INFO  20:33:19.973 Destroying buffer
[Thread-277] INFO  20:33:19.973 Destroying buffer
[Thread-284] DEBUG 20:33:20.030 Wrote on socket: Content-Type: video/mpeg
[Thread-284] DEBUG 20:33:20.031 Wrote on socket: Connection: keep-alive
[Thread-284] DEBUG 20:33:20.031 Wrote on socket: Server: Mac_OS_X-i386-10.5.6, UPnP/1.0, PMS/1.11
[Thread-284] DEBUG 20:33:20.031 Wrote on socket:
[Thread-281] INFO  20:33:20.741 Destroying buffer
[Thread-283] INFO  20:33:20.852 Destroying buffer
[Thread-280] INFO  20:33:20.852 Destroying buffer
[Thread-282] INFO  20:33:20.852 Destroying buffer
[Timer-10] DEBUG 20:33:21.461 Buffered Space: 4780032 bytes / inputs: 1
[Timer-10] DEBUG 20:33:23.460 Buffered Space: 14710784 bytes / inputs: 1
[Timer-10] DEBUG 20:33:25.461 Buffered Space: 25731072 bytes / inputs: 1
[Timer-10] DEBUG 20:33:27.460 Buffered Space: 39497728 bytes / inputs: 1
[Thread-287] DEBUG 20:33:27.609 freeMemory: 143456992
[Thread-287] DEBUG 20:33:27.609 totalMemory: 200179712
[Thread-287] DEBUG 20:33:27.609 maxMemory: 799145984
[Thread-287] DEBUG 20:33:27.609 Extending buffer to 419430400
[Thread-287] DEBUG 20:33:28.143 Done extending
[Thread-284] DEBUG 20:33:28.929 Sending stream with premature end : 10682368 bytes of get/0$1$1$0$0/myvideo.avi. Reason: Broken pipe
[Thread-284] DEBUG 20:33:28.929 Ready to Stop: true
[Thread-284] DEBUG 20:33:28.929 Sending stream: 10682368 bytes of get/0$1$1$0$0/myvideo.avi
[Thread-284] DEBUG 20:33:28.930 Close Connection
[Thread-293] DEBUG 20:33:29.033 Opened handler on socket Socket[addr=/192.168.1.104,port=57642,localport=5001]
[Thread-293] DEBUG 20:33:29.034 Received on socket: GET /get/0$1$1$0$0/thumbnail0000myvideo.avi HTTP/1.1
[Thread-293] DEBUG 20:33:29.034 Received on socket: Host: 192.168.1.102:5001
[Thread-293] DEBUG 20:33:29.034 Received on socket: User-Agent: PLAYSTATION 3
[Thread-293] DEBUG 20:33:29.034 Received on socket: Connection: Keep-Alive
[Thread-293] DEBUG 20:33:29.034 Received on socket: Accept-Encoding: identity
[Thread-293] DEBUG 20:33:29.034 Received on socket: transferMode.dlna.org: Interactive
[Thread-293] INFO  20:33:29.034 HTTP: get/0$1$1$0$0/thumbnail0000myvideo.avi / 0-0
[Thread-293] DEBUG 20:33:29.035 Wrote on socket: HTTP/1.1 200 OK
[Thread-293] DEBUG 20:33:29.035 Searching for objectId: 0$1$1$0$0 with children option: false
[Thread-293] DEBUG 20:33:29.035 Wrote on socket: Content-Type: image/png
[Thread-293] DEBUG 20:33:29.035 Wrote on socket: Accept-Ranges: bytes
[Thread-293] DEBUG 20:33:29.035 Wrote on socket: Expires: Wed, 26 Aug 2009 12:20:09 GMT
[Thread-293] DEBUG 20:33:29.035 Wrote on socket: Connection: keep-alive
[Thread-293] DEBUG 20:33:29.035 Wrote on socket: Server: Mac_OS_X-i386-10.5.6, UPnP/1.0, PMS/1.11
[Thread-293] DEBUG 20:33:29.035 Available Content-Length: 1597
[Thread-293] DEBUG 20:33:29.035 Wrote on socket: Content-Length: 1597
[Thread-293] DEBUG 20:33:29.035 Wrote on socket:
[Thread-293] DEBUG 20:33:29.035 Sending stream: 1597 bytes of get/0$1$1$0$0/thumbnail0000myvideo.avi
[Thread-293] DEBUG 20:33:29.035 Close Connection
[Timer-10] DEBUG 20:33:29.460 Buffered Space: 59506688 bytes / inputs: 0
[Thread-292] INFO  20:33:31.430 Stopping process: osx/mencoder
[Thread-291] INFO  20:33:31.430 Destroying buffer
[Thread-287] INFO  20:33:31.487 Error consuming stream of spawned process:Stream closed
[Thread-292] DEBUG 20:33:31.487 Killing the Unix process: 3052
[osx/mencoder] DEBUG 20:33:31.630 EOF
[Thread-292] INFO  20:33:31.755 Destroying buffer
[Thread-294] DEBUG 20:33:31.755 kill: 3052: No such process
[Thread-292] INFO  20:33:32.021 Destroying buffer
 
Attachments
mplayer_vs_pms.jpg
mplayer_vs_pms.jpg (202.59 KiB) Viewed 2682 times
radekb
 
Posts: 3
Joined: Fri May 01, 2009 10:02 pm

Re: Digging into subtitles (subdelay)

Postby shagrath » Sat May 02, 2009 8:46 pm

it's an exernal subtitles file, or embedded in the video ?
shagrath
Project Lead
 
Posts: 2668
Joined: Wed Jan 14, 2009 1:39 pm

Re: Digging into subtitles (subdelay)

Postby radekb » Sat May 02, 2009 8:47 pm

As you can see from mplayer output on the screenshot, it's external, myvideo.txt file.
radekb
 
Posts: 3
Joined: Fri May 01, 2009 10:02 pm


Return to Mac OS X Support

Who is online

Users browsing this forum: Bing [Bot] and 5 guests