FIREWALL: Error sending ALIVE message

For help and support with issues specific to Linux/Unix
Forum rules
Please make sure you follow the Problem Reporting Guidelines before posting if you want a reply.

FIREWALL: Error sending ALIVE message

Postby Routhinator » Thu Mar 13, 2014 8:28 pm

I'm plagued by this error when my firewall is active:

Code: Select all
DEBUG 2014-03-13 15:15:21.503 [UPNP-AliveMessageSender] Sending ALIVE...
DEBUG 2014-03-13 15:15:21.504 [UPNP-AliveMessageSender] Error sending ALIVE message
java.io.IOException: Operation not permitted
   at java.net.PlainDatagramSocketImpl.send(Native Method) ~[na:1.7.0_51]
   at java.net.DatagramSocket.send(DatagramSocket.java:676) ~[na:1.7.0_51]
   at net.pms.network.UPNPHelper.sendMessage(UPNPHelper.java:303) ~[pms.jar:1.90.1]
   at net.pms.network.UPNPHelper.sendAlive(UPNPHelper.java:176) ~[pms.jar:1.90.1]
   at net.pms.network.UPNPHelper$1.run(UPNPHelper.java:329) [pms.jar:1.90.1]
   at java.lang.Thread.run(Thread.java:744) [na:1.7.0_51]
INFO  2014-03-13 15:16:14.582 [UPNPHelper] Access granted to /192.168.0.193 by rule: 192.168.0-1.*


Specifics:

OS: Debian Wheezy
PMS Version: 1.90 generic linux
Firewall: APF-Firewall
Ports opened:
- TCP: 2869 (UPNP STANDARD)
- UDP: 5001 (FORCED PORT FOR PMS)
- UDP: 1900 (UPNP STANDARD)
IP Address Forced?: Yes

PS3 Media Server works perfectly with the firewall off. However this is NOT ACCEPTABLE. The firewall must be enabled on this server. I have opened the port required for PMS as well as the standard UPNP ports and the server fails to send it's alive message. Turn the firewall off and it works without error. The local IP range (192.168.0.0/24) is also whitelisted.

Is there another firewall rule required for the ALIVE multicast to send? (APF egress filtering is off, so outbound traffic should not be filtered)
User avatar
Routhinator
 
Posts: 2
Joined: Thu Mar 13, 2014 8:20 pm
Location: Gatineau, Quebec, Canada

Re: FIREWALL: Error sending ALIVE message

Postby meskibob » Thu Mar 13, 2014 8:40 pm

You need TCP on 5001 as well (used for the HTTP traffic).
Check the firewall FAQ post for additional info (directions are for Windows but the ports are the same) - viewtopic.php?f=6&t=3507&p=18802#p18802
I provide NO application support via PM or email, so please post your question to the forum per the Forum Rules.
meskibob
Moderator
 
Posts: 4761
Joined: Mon Jan 19, 2009 4:11 pm

Re: FIREWALL: Error sending ALIVE message

Postby Routhinator » Thu Mar 13, 2014 8:51 pm

Adding tcp:5001 had the server show up on the network. It works, however the logs are still being spammed with this same error while the firewall is on. This tells me something needs to be fine tuned, though I am not certain what.. any ideas about the java error in relation to the firewall? Perhaps another rule for the ALIVE message?
User avatar
Routhinator
 
Posts: 2
Joined: Thu Mar 13, 2014 8:20 pm
Location: Gatineau, Quebec, Canada

Re: FIREWALL: Error sending ALIVE message

Postby meskibob » Thu Mar 13, 2014 9:16 pm

While it should be handled with 1900 UDP rule, maybe it's an issue the UPNP broadcast address - 239.255.255.250
At this point I'd expect a conflict somewhere. Pull a list of all your configured rules and check for any conflicts.

Maybe enabling the trace log will help identify a specific thing to check - viewtopic.php?f=6&t=3507&p=38484#pms-faq-trace-log
I provide NO application support via PM or email, so please post your question to the forum per the Forum Rules.
meskibob
Moderator
 
Posts: 4761
Joined: Mon Jan 19, 2009 4:11 pm


Return to Linux/Unix Support

Who is online

Users browsing this forum: No registered users and 4 guests