[solved] two nearly identical files; one works, one doesn't

For help and support with PS3 Media Server in general
Forum rules
Please make sure you follow the Problem Reporting Guidelines before posting if you want a reply.

[solved] two nearly identical files; one works, one doesn't

Postby voidacity » Sun Feb 16, 2014 5:27 pm

OS: archlinux renderer: ps3
I have been looking at this for awhile, and I cannot understand what is going wrong, because everything appears to be just about the same, with the exception of resolution and content (I don't see how these could be problematic). both files run flawless locally.
please tell me why it doesn't work :cry:

working file log snippet:
Code: Select all
INFO  2014-02-16 10:24:57.618 [New I/O server worker #1-14] Starting transcode/remux of [UTW]_Shinsekai_Yori_-_01_[h264-720p][CCE0A4AB].mkv
DEBUG 2014-02-16 10:24:57.620 [New I/O server worker #1-14] Launching transcode with media info: container: mkv, bitrate: 1978002, size: 336028187, video codec: h264, duration: 00:22:39.00, width: 1280, height: 720, frame rate: 23.976, thumb size : 11533, muxing mode: null, mime type: video/x-matroska
   Audio track id: 0, lang: ja, flavor: aac 2.0 192kbps, audio codec: AAC, sample frequency:48000, number of channels: 2, bits per sample: 16
   Subtitle track id: 0, type: ASS, flavor: styled subtitles, lang: en, externalFileCharacterSet: null
DEBUG 2014-02-16 10:24:57.699 [New I/O server worker #1-14] Starting mkfifo --mode=777 /tmp/ps3mediaserver/mencoder1392564297698
DEBUG 2014-02-16 10:24:57.701 [New I/O server worker #1-14] Unix process ID (mkfifo): 5241
DEBUG 2014-02-16 10:24:57.702 [mencoder-14] Starting mencoder -ss 0 "/home/patrick/videos/Shinsekai yori [UTW][720p]/[UTW]_Shinsekai_Yori_-_01_[h264-720p][CCE0A4AB].mkv" -msglevel statusline=2 -oac lavc -of mpeg -mpegopts format=mpeg2:muxrate=500000:vbuf_size=1194:abuf_size=64 -ovc lavc -channels 6 -vf spp,scale -lavdopts debug=0:threads=8 -lavcopts autoaspect=1:vcodec=mpeg2video:acodec=ac3:abitrate=448:threads=8:keyint=25:vqscale=1:vqmin=2:vqmax=3:vrc_maxrate=499000:vrc_buf_size=7000 -ass -fontconfig -noautosub -sid 0 -ofps 24000/1001 -lavdopts fast -mc 0 -noskip -af lavcresample=48000 -srate 48000 -o /tmp/ps3mediaserver/mencoder1392564297698
DEBUG 2014-02-16 10:24:57.703 [mencoder-14] Reading pipe: /tmp/ps3mediaserver/mencoder1392564297698
INFO  2014-02-16 10:24:57.801 [mencoder-14] Successfully initialized buffer to 50,000,000 bytes.
DEBUG 2014-02-16 10:24:57.802 [mencoder-14] Attaching thread: mencoder-14
DEBUG 2014-02-16 10:24:57.803 [mencoder-14] Unix process ID (mencoder): 5245
DEBUG 2014-02-16 10:24:57.803 [Thread-66] MEncoder SVN-r36498-snapshot-4.8.2 (C) 2000-2013 MPlayer Team
DEBUG 2014-02-16 10:24:57.803 [Thread-66] 206 audio & 433 video codecs
DEBUG 2014-02-16 10:24:57.803 [Thread-66] success: format: 0  data: 0x0 - 0x1407621b
DEBUG 2014-02-16 10:24:57.803 [Thread-66] libavformat version 55.19.104 (internal)
DEBUG 2014-02-16 10:24:57.803 [Thread-66] libavformat file format detected.
DEBUG 2014-02-16 10:24:57.803 [Thread-66] [matroska,webm @ 0x7fe425e6e2c0]Unknown entry 0x437E
DEBUG 2014-02-16 10:24:57.804 [Thread-66] [matroska,webm @ 0x7fe425e6e2c0]Unknown entry 0x437E
WARN  2014-02-16 10:24:57.802 [New I/O server worker #1-14] External input stream instance is null... sounds not good, waiting 500ms
DEBUG 2014-02-16 10:24:57.804 [Thread-66] [matroska,webm @ 0x7fe425e6e2c0]Unknown entry 0x437E
DEBUG 2014-02-16 10:24:57.804 [Thread-66] [matroska,webm @ 0x7fe425e6e2c0]Unknown entry 0x437E
DEBUG 2014-02-16 10:24:57.804 [Thread-66] [matroska,webm @ 0x7fe425e6e2c0]Unknown entry 0x437E
DEBUG 2014-02-16 10:24:57.804 [Thread-66] [lavf] stream 0: video (h264), -vid 0, H.264 720p HDTV
DEBUG 2014-02-16 10:24:57.804 [Thread-66] [lavf] stream 1: audio (aac), -aid 0, -alang jpn, AAC 2.0 192Kbps
DEBUG 2014-02-16 10:24:57.804 [Thread-66] [lavf] stream 2: subtitle (ssa), -sid 0, -slang eng, Styled Subtitles
DEBUG 2014-02-16 10:24:57.804 [Thread-66] VIDEO:  [H264]  1280x720  0bpp  23.976 fps    0.0 kbps ( 0.0 kbyte/s)
DEBUG 2014-02-16 10:24:57.804 [Thread-66] [V] filefmt:44  fourcc:0x34363248  size:1280x720  fps:23.976  ftime:=0.0417
DEBUG 2014-02-16 10:24:57.804 [Thread-66] ==========================================================================
DEBUG 2014-02-16 10:24:57.805 [Thread-66] Opening audio decoder: [ffmpeg] FFmpeg/libavcodec audio decoders
DEBUG 2014-02-16 10:24:57.805 [Thread-66] libavcodec version 55.39.100 (internal)
DEBUG 2014-02-16 10:24:57.805 [Thread-66] AUDIO: 48000 Hz, 2 ch, floatle, 0.0 kbit/0.00% (ratio: 0->384000)
DEBUG 2014-02-16 10:24:57.805 [Thread-66] Selected audio codec: [ffaac] afm: ffmpeg (FFmpeg AAC (MPEG-2/MPEG-4 Audio))
DEBUG 2014-02-16 10:24:57.805 [Thread-66] ==========================================================================
DEBUG 2014-02-16 10:24:57.805 [Thread-66] PACKET SIZE: 2048 bytes, deltascr: 884
DEBUG 2014-02-16 10:24:57.805 [Thread-66] Opening video filter: [ass auto=1]
DEBUG 2014-02-16 10:24:57.805 [Thread-66] [ass] auto-open
DEBUG 2014-02-16 10:24:57.805 [Thread-66] Opening video filter: [scale]
DEBUG 2014-02-16 10:24:57.805 [Thread-66] Opening video filter: [spp]
DEBUG 2014-02-16 10:24:57.950 [Buffered IO End Checker] Stopping Unix process 5205: ffmpeg-13
INFO  2014-02-16 10:24:57.951 [Buffered IO End Checker] Destroying buffer
DEBUG 2014-02-16 10:24:58.083 [Thread-66] ==========================================================================
DEBUG 2014-02-16 10:24:58.084 [Thread-66] Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
DEBUG 2014-02-16 10:24:58.086 [Thread-66] Selected video codec: [ffh264] vfm: ffmpeg (FFmpeg H.264)
DEBUG 2014-02-16 10:24:58.086 [Thread-63] [ac3 @ 0x7fe425e7c5e0]Channel layout not specified
DEBUG 2014-02-16 10:24:58.086 [Thread-66] ==========================================================================
DEBUG 2014-02-16 10:24:58.087 [Thread-63] [ac3 @ 0x7fe425e7c5e0]No channel layout specified. The encoder will guess the layout, but it might be incorrect.
DEBUG 2014-02-16 10:24:58.087 [Thread-63] Limiting audio preload to 0.4s.
DEBUG 2014-02-16 10:24:58.087 [Thread-63] Increasing audio density to 4.
DEBUG 2014-02-16 10:24:58.135 [Thread-66] [PP] Using external postprocessing filter, max q = 6.
DEBUG 2014-02-16 10:24:58.135 [Thread-66] Could not find matching colorspace - retrying with -vf scale...
DEBUG 2014-02-16 10:24:58.135 [Thread-66] Opening video filter: [scale]
DEBUG 2014-02-16 10:24:58.136 [Thread-66] Movie-Aspect is 1.78:1 - prescaling to correct movie aspect.
DEBUG 2014-02-16 10:24:58.138 [Thread-66] [swscaler @ 0x7fe425e8c6c0]BICUBIC scaler, from yuv420p10le to yuv444p using MMXEXT
DEBUG 2014-02-16 10:24:58.142 [Thread-66] videocodec: libavcodec (1280x720 fourcc=3267706d [mpg2])
DEBUG 2014-02-16 10:24:58.142 [Thread-66] [VE_LAVC] Using constant qscale = 1.000000 (VBR).
DEBUG 2014-02-16 10:24:58.174 [Thread-66] Writing header...
DEBUG 2014-02-16 10:24:58.174 [Thread-66] INITV: 0.200, 0.158, fps: 23.976
INFO  2014-02-16 10:24:58.307 [StartPlaying Event] Started sending /home/patrick/videos/Shinsekai yori [UTW][720p]/[UTW]_Shinsekai_Yori_-_01_[h264-720p][CCE0A4AB].mkv to PlayStation 3 on 192.168.0.8
INFO  2014-02-16 10:25:17.084 [Thread-64] Successfully grown buffer from 50,000,000 bytes to 209,715,200 bytes.


broken file log snippet:
Code: Select all
INFO  2014-02-16 10:29:12.814 [New I/O server worker #1-1] Starting transcode/remux of [HorribleSubs] Shingeki no Kyojin - 01 [1080p].mkv
DEBUG 2014-02-16 10:29:12.816 [New I/O server worker #1-1] Launching transcode with media info: container: mkv, bitrate: 3200391, size: 580105247, video codec: h264, duration: 00:24:10.00, width: 1920, height: 1080, frame rate: 23.976, thumb size : 6196, muxing mode: null, mime type: video/x-matroska
   Audio track id: 0, lang: und, flavor: null, audio codec: AAC, sample frequency:44100, number of channels: 2, bits per sample: 16
   Subtitle track id: 0, type: ASS, flavor: null, lang: und, externalFileCharacterSet: null
DEBUG 2014-02-16 10:29:12.939 [New I/O server worker #1-1] Starting mkfifo --mode=777 /tmp/ps3mediaserver/mencoder1392564552939
DEBUG 2014-02-16 10:29:12.944 [New I/O server worker #1-1] Unix process ID (mkfifo): 5495
DEBUG 2014-02-16 10:29:12.947 [mencoder-5] Starting mencoder -ss 0 "/home/patrick/videos/[HorribleSubs] Shingeki no Kyojin [1080p]/[HorribleSubs] Shingeki no Kyojin - 01 [1080p].mkv" -msglevel statusline=2 -oac lavc -of mpeg -mpegopts format=mpeg2:muxrate=500000:vbuf_size=1194:abuf_size=64 -ovc lavc -channels 6 -vf spp,scale -lavdopts debug=0:threads=8 -lavcopts autoaspect=1:vcodec=mpeg2video:acodec=ac3:abitrate=448:threads=8:keyint=25:vqscale=1:vqmin=2:vqmax=3:vrc_maxrate=499000:vrc_buf_size=7000 -ass -fontconfig -noautosub -sid 0 -ofps 24000/1001 -lavdopts fast -mc 0 -noskip -af lavcresample=48000 -srate 48000 -o /tmp/ps3mediaserver/mencoder1392564552939
DEBUG 2014-02-16 10:29:12.949 [mencoder-5] Reading pipe: /tmp/ps3mediaserver/mencoder1392564552939
INFO  2014-02-16 10:29:13.040 [mencoder-5] Successfully initialized buffer to 50,000,000 bytes.
DEBUG 2014-02-16 10:29:13.042 [mencoder-5] Attaching thread: mencoder-5
DEBUG 2014-02-16 10:29:13.043 [Thread-30] MEncoder SVN-r36498-snapshot-4.8.2 (C) 2000-2013 MPlayer Team
DEBUG 2014-02-16 10:29:13.044 [Thread-30] 206 audio & 433 video codecs
DEBUG 2014-02-16 10:29:13.044 [Thread-30] success: format: 0  data: 0x0 - 0x2293b41f
DEBUG 2014-02-16 10:29:13.044 [Thread-30] libavformat version 55.19.104 (internal)
DEBUG 2014-02-16 10:29:13.044 [Thread-30] libavformat file format detected.
DEBUG 2014-02-16 10:29:13.044 [mencoder-5] Unix process ID (mencoder): 5499
DEBUG 2014-02-16 10:29:13.044 [Thread-30] [lavf] stream 0: video (h264), -vid 0
DEBUG 2014-02-16 10:29:13.047 [Thread-30] [lavf] stream 1: audio (aac), -aid 0
DEBUG 2014-02-16 10:29:13.047 [Thread-30] [lavf] stream 2: subtitle (ssa), -sid 0
DEBUG 2014-02-16 10:29:13.047 [Thread-30] VIDEO:  [H264]  1920x1080  0bpp  23.810 fps    0.0 kbps ( 0.0 kbyte/s)
DEBUG 2014-02-16 10:29:13.048 [Thread-30] [V] filefmt:44  fourcc:0x34363248  size:1920x1080  fps:23.810  ftime:=0.0420
DEBUG 2014-02-16 10:29:13.048 [Thread-30] ==========================================================================
DEBUG 2014-02-16 10:29:13.048 [Thread-30] Opening audio decoder: [ffmpeg] FFmpeg/libavcodec audio decoders
DEBUG 2014-02-16 10:29:13.048 [Thread-30] libavcodec version 55.39.100 (internal)
DEBUG 2014-02-16 10:29:13.048 [Thread-30] AUDIO: 44100 Hz, 2 ch, floatle, 0.0 kbit/0.00% (ratio: 0->352800)
DEBUG 2014-02-16 10:29:13.048 [Thread-30] Selected audio codec: [ffaac] afm: ffmpeg (FFmpeg AAC (MPEG-2/MPEG-4 Audio))
DEBUG 2014-02-16 10:29:13.048 [Thread-30] ==========================================================================
DEBUG 2014-02-16 10:29:13.048 [Thread-30] PACKET SIZE: 2048 bytes, deltascr: 884
DEBUG 2014-02-16 10:29:13.049 [Thread-30] Opening video filter: [ass auto=1]
DEBUG 2014-02-16 10:29:13.049 [Thread-30] [ass] auto-open
DEBUG 2014-02-16 10:29:13.049 [Thread-30] Opening video filter: [scale]
DEBUG 2014-02-16 10:29:13.049 [Thread-30] Opening video filter: [spp]
DEBUG 2014-02-16 10:29:13.049 [Thread-30] ==========================================================================
DEBUG 2014-02-16 10:29:13.049 [Thread-30] Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
INFO  2014-02-16 10:29:13.051 [StartPlaying Event] Started sending /home/patrick/videos/[HorribleSubs] Shingeki no Kyojin [1080p]/[HorribleSubs] Shingeki no Kyojin - 01 [1080p].mkv to PlayStation 3 on 192.168.0.8
DEBUG 2014-02-16 10:29:13.052 [Thread-30] Selected video codec: [ffh264] vfm: ffmpeg (FFmpeg H.264)
DEBUG 2014-02-16 10:29:13.052 [Thread-30] ==========================================================================
DEBUG 2014-02-16 10:29:13.056 [Thread-27] [ac3 @ 0x7fabbfb045e0]Channel layout not specified
DEBUG 2014-02-16 10:29:13.057 [Thread-27] [ac3 @ 0x7fabbfb045e0]No channel layout specified. The encoder will guess the layout, but it might be incorrect.
DEBUG 2014-02-16 10:29:13.057 [Thread-27] Limiting audio preload to 0.4s.
DEBUG 2014-02-16 10:29:13.057 [Thread-27] Increasing audio density to 4.
DEBUG 2014-02-16 10:29:13.062 [Thread-30] [VD_FFMPEG] Trying pixfmt=0.
DEBUG 2014-02-16 10:29:13.062 [Thread-27] The selected video_out device is incompatible with this codec.
DEBUG 2014-02-16 10:29:13.062 [Thread-30] [VD_FFMPEG] XVMC-accelerated MPEG-2.
DEBUG 2014-02-16 10:29:13.062 [Thread-27] Try appending the scale filter to your filter list,
DEBUG 2014-02-16 10:29:13.062 [Thread-30] [PP] Using external postprocessing filter, max q = 6.
DEBUG 2014-02-16 10:29:13.062 [Thread-27] e.g. -vf spp,scale instead of -vf spp.
DEBUG 2014-02-16 10:29:13.063 [Thread-30] [VD_FFMPEG] Trying pixfmt=0.
DEBUG 2014-02-16 10:29:13.063 [Thread-27] The selected video_out device is incompatible with this codec.
DEBUG 2014-02-16 10:29:13.063 [Thread-30] [VD_FFMPEG] XVMC-accelerated MPEG-2.
DEBUG 2014-02-16 10:29:13.063 [Thread-27] Try appending the scale filter to your filter list,
DEBUG 2014-02-16 10:29:13.063 [Thread-30] [PP] Using external postprocessing filter, max q = 6.
DEBUG 2014-02-16 10:29:13.063 [Thread-27] e.g. -vf spp,scale instead of -vf spp.
DEBUG 2014-02-16 10:29:13.070 [Thread-30]
DEBUG 2014-02-16 10:29:13.070 [Thread-30] Exiting...
INFO  2014-02-16 10:29:13.082 [mencoder-5] Process mencoder has a return code of 1! Maybe an error occurred... check the log file
DEBUG 2014-02-16 10:29:13.084 [mencoder-5] Stopping Unix process 5495: mkfifo-6
DEBUG 2014-02-16 10:29:13.271 [Thread-20] frame=    0 fps=0.0 q=0.0 size=N/A time=00:00:00.00 bitrate=N/A   
DEBUG 2014-02-16 10:29:13.780 [Buffered IO End Checker] Stopping Unix process 5420: ffmpeg-3
INFO  2014-02-16 10:29:13.781 [Buffered IO End Checker] Destroying buffer


I would be more than happy to supply complete log and config files, I just think all pertinant information is already included.
thanks for your help.
Last edited by voidacity on Sun Feb 23, 2014 1:53 pm, edited 1 time in total.
voidacity
 
Posts: 2
Joined: Sun Feb 16, 2014 5:08 pm

Re: two nearly identical files; one works, one doesn't; help

Postby ExSport » Mon Feb 17, 2014 2:01 pm

Problem is your compiled MEncoder build. It seems it automatically tries to use VDPAU which will fail with some files due to codec/video_out incompatibility:
Code: Select all
DEBUG 2014-02-16 10:29:13.062 [Thread-30] [VD_FFMPEG] XVMC-accelerated MPEG-2.
DEBUG 2014-02-16 10:29:13.062 [Thread-27] The selected video_out device is incompatible with this codec.

http://forum.doom9.org/showthread.php?p=1668554
Recompile MEncoder with "--disable-vdpau", download more recent MEncoder,...
ExSport
 
Posts: 2167
Joined: Mon Jan 19, 2009 5:40 pm

Re: two nearly identical files; one works, one doesn't; help

Postby voidacity » Sun Feb 23, 2014 1:52 pm

everything is working flawlessly now, you have my sincere gratitude <3
voidacity
 
Posts: 2
Joined: Sun Feb 16, 2014 5:08 pm


Return to General Help and Support

Who is online

Users browsing this forum: Google [Bot], Yahoo [Bot] and 19 guests