Video Playing Too Fast on MKVs

For help and support with PS3 Media Server in general
Forum rules
Please make sure you follow the Problem Reporting Guidelines before posting if you want a reply.

Re: Video Playing Too Fast on MKVs

Postby esprit » Sat Apr 10, 2010 10:36 pm

Your fix is working very well, thank you very much for the tip ! :D
esprit
 
Posts: 3
Joined: Thu Apr 01, 2010 6:10 pm

Re: Video Playing Too Fast on MKVs

Postby Redth » Mon May 17, 2010 2:20 am

agreed, your fix is crucial. I can now watch content on my old xbox v1 with xbmc! Thanks!
Redth
 
Posts: 2
Joined: Mon May 03, 2010 3:06 pm

Re: Video Playing Too Fast on MKVs

Postby mooshimuushi » Tue Oct 05, 2010 4:26 am

anachron wrote:esprit:
I have the same problem you're experiencing. After a lot of research (triggered by your findings) I have concluded that it is a bug in ffmpeg. I have confirmed a previously filed bug over at their place (https://roundup.ffmpeg.org/issue1756).

You can work around the bug (well, atleast I can) by adding this to the "Transcoding options -> MEncoder -> Expert Settings" dialog:
Code: Select all
container == matroska && framerate == 50 :: -fps 25 -ofps 25



This is my first post here. Thanks for making this great program!


Wait...wouldn't this only work on those videos that has 25fps?
What if the video has a framerate of 29.970?
How do you change the code so that it will work with the 29.970?
mooshimuushi
 
Posts: 7
Joined: Sun Aug 15, 2010 1:29 am

Re: Video Playing Too Fast on MKVs

Postby Jani » Mon Nov 22, 2010 6:42 pm

mooshimuushi wrote:
anachron wrote:esprit:
I have the same problem you're experiencing. After a lot of research (triggered by your findings) I have concluded that it is a bug in ffmpeg. I have confirmed a previously filed bug over at their place (https://roundup.ffmpeg.org/issue1756).

You can work around the bug (well, atleast I can) by adding this to the "Transcoding options -> MEncoder -> Expert Settings" dialog:
Code: Select all
container == matroska && framerate == 50 :: -fps 25 -ofps 25



This is my first post here. Thanks for making this great program!


Wait...wouldn't this only work on those videos that has 25fps?
What if the video has a framerate of 29.970?
How do you change the code so that it will work with the 29.970?



More help on this one. I Just found too-fast-going videos with 23,9 frame rate.
Jani
 
Posts: 2
Joined: Sat Nov 14, 2009 5:07 pm

Re: Video Playing Too Fast on MKVs

Postby cheungs7 » Sat Jan 04, 2014 5:04 am

Hi esteem PMS gurus,

I am wondering whether there has been a sure fire solution to this issue?

I come across the issue of the video playback being too quick and out of sync with the audio with DVD vob files and HD mkv files too. I'm using version 1.90.1 build 3a4304c72 (2013-08-17).
I have tried the various methods mentioned on this thread, but to no avail.

This is an awsome piece of software, and seems to work on some of my other, older, media files. But seems to be an issue on HD mkv and DVD files.

Any help and guidance would be greatly appreciated.
Please let me know if you need more debug information, and advise me on how to get that for you (total newbie here I'm afraid).

Many thanks.

Kowtow to show my humbleness : Orz
cheungs7
 
Posts: 5
Joined: Sat Jan 04, 2014 4:58 am

Re: Video Playing Too Fast on MKVs

Postby stephanie » Sat Jan 04, 2014 9:24 pm

THERE IS A SOLUTION MKV (720P) movies now .

Settings - Maximal bandwith in mb/s ... : set it to 15 , not 100

works :)
stephanie
 
Posts: 7
Joined: Fri Dec 13, 2013 8:59 pm

Re: Video Playing Too Fast on MKVs

Postby cheungs7 » Sun Jan 05, 2014 10:14 am

Re: Video Playing Too Fast on MKVs
Post by stephanie » Sun Jan 05, 2014 4:24 am

THERE IS A SOLUTION MKV (720P) movies now .

Settings - Maximal bandwith in mb/s ... : set it to 15 , not 100

works :)


Hi Stephanie,

Could you be more specific as to where to change this setting?

In addition, any workarounds for DVD vob/ISO files? I'm also experiencing the same sync issues with the video and sound (where video is played back quicker).

Many thanks to you all!
cheungs7
 
Posts: 5
Joined: Sat Jan 04, 2014 4:58 am

Re: Video Playing Too Fast on MKVs

Postby stephanie » Sun Jan 12, 2014 12:01 am

Sorry late reply. Yes I can.

In Playstation Meda Server - Goto Settings - Scroll down too you see Networks Settings - change the Maximal bandwith in mb/s ... : set it to 15 , not 100

Picture of this - http://i.imgur.com/xGUbLoz.jpg
stephanie
 
Posts: 7
Joined: Fri Dec 13, 2013 8:59 pm

Re: Video Playing Too Fast on MKVs

Postby NJDevil031 » Sun Jan 26, 2014 7:57 pm

Hi. I'm having a similar problem (similar enough that I'm sure it's related anyhow). I'm using PSM v 1.90.0 to a PS3 via a good wireless network. Every file format seems to play properly except .img disc images. Iso plays perfectly fine, as do all of the actual video formats (avi, mp4, mkv, etc) but .imgs play the video somewhere around 2x regular speed with audio playing correctly. If the format in question makes this a new issue let me know and I'll start a new thread but any help would be appreciated. Thanks

NJD

PS I tried changing Maximum Bandwidth to 15 but this doesn't seem to have done anything. Thanks again

PPS Ok, it now seems that some ISO files are having the same issue. Guess I spoke too soon.
NJDevil031
 
Posts: 2
Joined: Sun Jan 26, 2014 7:45 pm

Re: Video Playing Too Fast on MKVs

Postby cheungs7 » Thu Jan 30, 2014 10:16 pm

@stephanie

Thanks for the instructions. MKV files are working now, with no lag!

Now, if only there was a solution for the DVD vob and ISO files sound/video sync issue, that would be perfect!

Many thanks!!
cheungs7
 
Posts: 5
Joined: Sat Jan 04, 2014 4:58 am

PreviousNext

Return to General Help and Support

Who is online

Users browsing this forum: Google [Bot] and 16 guests