xbox 360 transcode broken in PSM v1.90.0?

For help and support with PS3 Media Server in general
Forum rules
Please make sure you follow the Problem Reporting Guidelines before posting if you want a reply.

xbox 360 transcode broken in PSM v1.90.0?

Postby resque1980 » Fri Aug 02, 2013 2:06 pm

Is transcoding broken for xbox 360 in PSM v1.90.0?

If i play a supported video format like AVC/ACC through PSM 1.90.0 the movie plays fine on my xbox 360. But if i play a file that needs transcoding it fails to play on the xbox 360.

I am sure the issue is with transcode settings. I installed PMS version 1.82.0 and 1.90.0 and found that the same file will transcode and play just fine on the xbox 360 in PMS 1.82.0, but the same file transcoded on PMS 1.90.0 will fail. Below is the mencoder.exe arugments from both versions PMS 1.82.0 and PMS 1.90.0. The main difference between being version 1.90.0 uses -acodec=ac3 (I dont think the xbox supports the ac3 audio codec) and version 1.82.0 use acodec=wmav2 (which the xbox does support).

xbox supported video formats:
http://support.xbox.com/en-GB/xbox-360/ ... vds-movies


PMS Version 1.90.0 mencoder.exe arguments (fails to play on xbox 360):
Code: Select all
mencoder.exe" -ss 0 "D:\jdrama\The Sacred Blacksmith - 01 - Knight[BD][720p][Uncensored].mkv" -msglevel statusline=2 -oac lavc -of lavf -lavfopts format=asf -mpegopts format=mpeg2:muxrate=500000:vbuf_size=1194:abuf_size=64 -ovc lavc -channels 2 -lavdopts debug=0:threads=2 -lavcopts autoaspect=1:vcodec=wmv2:acodec=ac3:abitrate=448:threads=2:keyint=5:vqscale=1:vqmin=2:vqmax=3:vrc_maxrate=54000:vrc_buf_size=1835 -ass -fontconfig -noautosub -sid 0 -ofps 24000/1001 -lavdopts fast -mc 0 -noskip -af lavcresample=44100 -srate 44100 -o \\.\pipe\mencoder1375450195279


PMS Version 1.82.0 mencoder.exe arguments (plays fine on the xbox 360):
Code: Select all
mencoder.exe" -ss 0 "D:\jdrama\The Sacred Blacksmith - 01 - Knight[BD][720p][Uncensored].mkv" -msglevel statusline=2 -oac lavc -of lavf -lavfopts format=asf -mpegopts format=mpeg2:muxrate=500000:vbuf_size=1194:abuf_size=64 -ovc lavc -channels 2 -lavdopts debug=0:threads=2 -lavcopts autoaspect=1:vcodec=wmv2:acodec=wmav2:abitrate=448:threads=1:keyint=5:vqscale=1:vqmin=2:vrc_maxrate=14000:vrc_buf_size=1835 -ass -fontconfig -noautosub -sid 0 -ofps 24000/1001 -lavdopts fast -mc 0 -noskip -af lavcresample=44100 -srate 44100 -o \\.\pipe\mencoder1375450326355



Debug.log:
http://pastebin.com/byirYaFc


Is transcoding working for anyone else when streaming to a xbox 360?
resque1980
 
Posts: 6
Joined: Tue Dec 11, 2012 10:21 pm

Re: xbox 360 transcode broken in PSM v1.90.0?

Postby resque1980 » Fri Aug 02, 2013 2:48 pm

Ok i am now sure that the issue is as described above, ac3 audio codec is not supported on the xbox 360, at lest not within an asf container and wmv video.

To prove this is manually transcoded the same video file i used in the problem i posted above, but i used set acodec=wmav2 (it used to be set to acodec=ac3). I then tried to stream this file to my xbox 360 using both PMS v1.82.0 and PMS v1.90.0 the file played perfectly.

Here is the mencoder command i used to manulay transcode the video file and it plays fine on the 360:
Code: Select all
"C:\Program Files (x86)\PS3 Media Server\win32\mencoder.exe" -ss 0 "D:\jdrama\The Sacred Blacksmith - 01 - Knight[BD][720p][Uncensored].mkv" -msglevel statusline=2 -oac lavc -of lavf -lavfopts format=asf -mpegopts format=mpeg2:muxrate=500000:vbuf_size=1194:abuf_size=64 -ovc lavc -channels 2 -lavdopts debug=0:threads=2 -lavcopts autoaspect=1:vcodec=wmv2:acodec=wmav2:abitrate=448:threads=2:keyint=5:vqscale=1:vqmin=2:vqmax=3:vrc_maxrate=54000:vrc_buf_size=1835 -ass -fontconfig -noautosub -sid 0 -ofps 24000/1001 -lavdopts fast -mc 0 -noskip -af lavcresample=44100 -srate 44100 -o outputwmav2.asf




Is there a settings file i can edit to make the change myself, or do we have to wait for a patch from the admins. I want to force all transcoding to use the acodec=wmav2.
resque1980
 
Posts: 6
Joined: Tue Dec 11, 2012 10:21 pm

Re: xbox 360 transcode broken in PSM v1.90.0?

Postby resque1980 » Fri Aug 02, 2013 3:23 pm

Here is a quick fix until the admin release a patch for this issue:

1. "Transcoding Settings" > "Video Files Engines" > "Mencoder Video" > "Expert Settings: Codec-specific parameters" (its a button on the right panel)
2. Untick "Use application default codec parameters (Recommended!)"
3. under "Custom parameters:" past the following:
Code: Select all
container == iso :: -nosync
(container == avi || container == matroska) && vcodec == mpeg4 && acodec == mp3 :: -mc 0.1
container == flv :: -mc 0.1
container == mov :: -mc 0.1
container == rm  :: -mc 0.1
container == matroska :: -lavcopts autoaspect=1:vcodec=wmv2:acodec=wmav2:abitrate=448:threads=2:keyint=5:vqscale=1:vqmin=2:vqmax=3:vrc_maxrate=54000:vrc_buf_size=1835 -nomux -mc 0
container == mp4 :: -lavcopts autoaspect=1:vcodec=wmv2:acodec=wmav2:abitrate=448:threads=2:keyint=5:vqscale=1:vqmin=2:vqmax=3:vrc_maxrate=54000:vrc_buf_size=1835 -nomux -mc 0
container == mp4 && vcodec == h264 :: -mc 0.1

4. click "Save" (top center of the application window)
5. Close and reopen Playstation Media Server

Why does this work, put very simply this will add the following string to the end of the mencoder transcode command. The arguments for "-lavcopts" will now appear twice, but because our argument comes last it overrides the default argument with our own. the argument basically sets the transcode video codec to wmv and the audio codec to wmva2.
Code: Select all
-lavcopts autoaspect=1:vcodec=wmv2:acodec=wmav2:abitrate=448:threads=2:keyint=5:vqscale=1:vqmin=2:vqmax=3:vrc_maxrate=54000:vrc_buf_size=1835 -nomux -mc 0
resque1980
 
Posts: 6
Joined: Tue Dec 11, 2012 10:21 pm

Re: xbox 360 transcode broken in PSM v1.90.0?

Postby FrankieIceCream » Sun Sep 15, 2013 3:43 am

Thanks, resque1980. This worked for me. Much appreciated!
FrankieIceCream
 
Posts: 1
Joined: Sun Sep 15, 2013 3:41 am

Re: xbox 360 transcode broken in PSM v1.90.0?

Postby poopypants » Thu Sep 26, 2013 4:20 am

Do you guys mind sharing which codecs you use, what Windows operating system your using and which selection to look for in the transcode folders on the Xbox for mkv video formats to get it to pay correctly(I've noticed I can choose what looks like an audio file in the transcode folder and a video will still start up then skip and buffer into a freeze)??

I have a horrible video card on my computer and it won't play 1080p videos, no matter what codec pack I install...but the k-lite pack gets closest to paying correctly and I figured it would work for sending it to the Xbox?

Please help guys, General instruction on setup are easy enough to follow and execute but still leaves me with failing mkv video files...either file type not supported or connection to pc/server lost (despite going right out of that video and into an mp4 plays perfectly fine)...

I've already run through multiple threads with the search feature and can't nail down any ground up step by step stop info on detailed transcoding settings and required codecs(preferably on Windows 7), so any help or pointers to existing threads would be very much appreciated.
poopypants
 
Posts: 1
Joined: Thu Sep 26, 2013 4:05 am

Re: xbox 360 transcode broken in PSM v1.90.0?

Postby rustedshut » Tue Nov 12, 2013 4:57 am

This worked fine for me. Thanks dude.
rustedshut
 
Posts: 1
Joined: Tue Nov 12, 2013 4:56 am

Re: xbox 360 transcode broken in PSM v1.90.0?

Postby henkew » Wed Dec 18, 2013 11:11 pm

This works for the 360, but then my PS3 doesn't work. Any solutions that would enable both to work?
henkew
 
Posts: 4
Joined: Wed Dec 18, 2013 6:37 pm

Re: xbox 360 transcode broken in PSM v1.90.0?

Postby henkew » Thu Dec 19, 2013 5:18 am

Is there a way to modify the transcoding that takes place when the Xbox 360 renderer is recognized? Changing the defaults does mess it up for my PS3. Seems like this is a pretty big issues...I'm surprised there isn't a better fix out there.
henkew
 
Posts: 4
Joined: Wed Dec 18, 2013 6:37 pm

Re: xbox 360 transcode broken in PSM v1.90.0?

Postby Telawang » Sat Jan 04, 2014 6:59 pm

I am also experiencing problems with transcoding on the Xbox 360, although I am not playing mkv-files, but files with subtitles (which also triggers transcoding). The same file plays fine when using my Sony Bravia tv as a renderer, but I get an error when playing using the same file using the Xbox ("Can't play this content because it may not be supported. [...] Status code: 69-C00D3E98"). If no transcoding is necessary (i.e., other files without subs) they play fine on the Xbox.

Any ideas how to solve this? I have pasted a log to Pastebin (http://pastebin.com/9wBVx5F1).
Telawang
 
Posts: 3
Joined: Sat Jan 04, 2014 6:46 pm

Re: xbox 360 transcode broken in PSM v1.90.0?

Postby Telawang » Sat Jan 04, 2014 7:47 pm

I tried downgrading to PMS 1.82.0 and indeed the same video file plays without problems and including the subtitles. So with that version transcoding works as expected.
Telawang
 
Posts: 3
Joined: Sat Jan 04, 2014 6:46 pm

Next

Return to General Help and Support

Who is online

Users browsing this forum: Google [Bot], Yahoo [Bot] and 10 guests