Mencoder slow, FFmpeg audio delay

For help and support with PS3 Media Server in general
Forum rules
Please make sure you follow the Problem Reporting Guidelines before posting if you want a reply.

Mencoder slow, FFmpeg audio delay

Postby necrovamp » Fri Nov 08, 2013 4:43 am

Mencoder was always my favorite, now after not using it for awhile, I was trying to start up again, got the new PMS, and am good to go.
That being said if I can get FFmpeg to work flawlessly I could care less bout mencoder
Anyways this is a 1080p video, streaming to an xbox 360.
I'll post media info and system spec at end of post

I first got the content cannot be played on all items except FFmpeg.
So lets talk about FF, it works great in terms of picture quality, I get an audio delay of about 100-150ms and that is my problem with that.
http://pastebin.com/kGT0kB7Y FFmpeg Log

To even get mencoder to work I had to use a config from this post
http://www.ps3mediaserver.org/forum/viewtopic.php?f=6&t=17109
Code: Select all
container == iso :: -nosync
(container == avi || container == matroska) && vcodec == mpeg4 && acodec == mp3 :: -mc 0.1
container == flv :: -mc 0.1
container == mov :: -mc 0.1
container == rm  :: -mc 0.1
container == matroska :: -lavcopts autoaspect=1:vcodec=wmv2:acodec=wmav2
container == mp4 :: -lavcopts autoaspect=1:vcodec=wmv2:acodec=wmav2
container == mp4 && vcodec == h264 :: -mc 0.1

Now that its working, I start playing, it starts far slower than ff but it starts, video seems slow, then I notice audio is playing at normal speed and video cannot keep up.
Eventually the entire thing start lagging audio and video

I tried setting the General audio quality to lowest and it helped at the start but still went slower than the audio etcc and started lagging



and now for tech info
PMS:all default except the custom config to get mencoder working

Media info for file being played
Code: Select all
Format                                   : Matroska
Format version                           : Version 2
File size                                : 3.23 GiB
Duration                                 : 1h 36mn
Overall bit rate                         : 4 807 Kbps
Movie name                               : Track01
Encoded date                             : UTC 2013-10-22 02:56:31
Writing application                      : mkvmerge v5.8.0 ('No Sleep / Pillow') built on Sep  2 2012 15:37:04
Writing library                          : libebml v1.2.3 + libmatroska v1.3.0

Video
ID                                       : 1
Format                                   : AVC
Format/Info                              : Advanced Video Codec
Format profile                           : High@L4.0
Format settings, CABAC                   : Yes
Format settings, ReFrames                : 5 frames
Codec ID                                 : V_MPEG4/ISO/AVC
Duration                                 : 1h 36mn
Width                                    : 1 916 pixels
Height                                   : 812 pixels
Display aspect ratio                     : 2.35:1
Frame rate mode                          : Constant
Frame rate                               : 23.976 fps
Color space                              : YUV
Chroma subsampling                       : 4:2:0
Bit depth                                : 8 bits
Scan type                                : Progressive
Title                                    : Track01
Language                                 : English
Default                                  : Yes
Forced                                   : No
Color primaries                          : BT.709
Transfer characteristics                 : BT.709
Matrix coefficients                      : BT.709

Audio
ID                                       : 2
Format                                   : AAC
Format/Info                              : Advanced Audio Codec
Format profile                           : LC
Codec ID                                 : A_AAC
Duration                                 : 1h 36mn
Channel count                            : 2 channels
Channel positions                        : Front: L R
Sampling rate                            : 48.0 KHz
Compression mode                         : Lossy
Title                                    : Track01
Language                                 : English
Default                                  : Yes
Forced                                   : No


AMD 8120 8-core 3.9gig
16GB ddr3 Ram@ 2133
nvidia gtx 470
Wired 360 network
necrovamp
 
Posts: 3
Joined: Fri Nov 08, 2013 4:32 am

Re: Mencoder slow, FFmpeg audio delay

Postby mazey » Sat Nov 09, 2013 2:17 am

you can get mencoder to start faster by adding TranscodeFastStart=true to your renderer config

you can try updating mencoder to the latest, pms one hasnt been updated in forever. the new one runs alot faster.
http://www.spirton.com/mplayer-mencoder-subjunk-build/
PMS 1.90.2 Snapshot - Intel Celeron G1840 2.8Ghz / Asus Z97m-plus / Corsair Vengeance 8GB / Windows 8.1 Pro (64 bit)
mazey
 
Posts: 783
Joined: Sat Oct 24, 2009 9:07 am

Re: Mencoder slow, FFmpeg audio delay

Postby necrovamp » Sat Nov 09, 2013 3:43 am

thnx for the reply ill try that when I get home, wont be till sunday night, any idea on the FF? i was thinking since it seems to be bout the same lag on other files to just add some sort of -audiodelay -150 or something however it works
necrovamp
 
Posts: 3
Joined: Fri Nov 08, 2013 4:32 am

Re: Mencoder slow, FFmpeg audio delay

Postby mazey » Sat Nov 09, 2013 5:24 am

necrovamp wrote:thnx for the reply ill try that when I get home, wont be till sunday night, any idea on the FF? i was thinking since it seems to be bout the same lag on other files to just add some sort of -audiodelay -150 or something however it works


no idea, works fine for me, its most likely caused by your custom parameters but im not sure.

you can try updating ffmpeg below, just grab the 32 bit static build and extract copy the ffmpeg.exe in the bin folder to the one in "c:\program files (x86)\ps3 media server\win32" folder, overwriting the older version ffmpeg.

http://ffmpeg.zeranoe.com/builds/
PMS 1.90.2 Snapshot - Intel Celeron G1840 2.8Ghz / Asus Z97m-plus / Corsair Vengeance 8GB / Windows 8.1 Pro (64 bit)
mazey
 
Posts: 783
Joined: Sat Oct 24, 2009 9:07 am


Return to General Help and Support

Who is online

Users browsing this forum: Google [Bot], Yahoo [Bot] and 13 guests