[1.90.1] Problem streaming Spotify via DSBridge

For help and support with PS3 Media Server in general
Forum rules
Please make sure you follow the Problem Reporting Guidelines before posting if you want a reply.

[1.90.1] Problem streaming Spotify via DSBridge

Postby b0ris » Sun Nov 03, 2013 11:49 pm

Hi,

I really need to stream Spotify to my PS3 and it would be nice to do it with PMS 1.90.1, because expect of this problem PMS 1.90.1 is the best. I have no problem streaming Spotify with UMS 2.6.5. I would be really thankful if someone could help me to find a solution to this problem. My PS3 only throws "The data type is not supported." and my log gives this:

INFO 2013-11-03 23:45:04.074 [New I/O server worker #3-5] Starting transcode/remux of Spotify
WARN 2013-11-03 23:45:04.075 [New I/O server worker #3-5] External input stream instance is null... sounds not good, waiting 500ms
INFO 2013-11-03 23:45:04.092 [ffmpeg.exe-10] Successfully initialized buffer to 50 000 000 bytes.
INFO 2013-11-03 23:45:04.575 [StartPlaying Event] Started sending http://localhost:8124 to PlayStation 3 on 192.168.1.5
INFO 2013-11-03 23:45:22.076 [Buffered IO End Checker] Destroying buffer
INFO 2013-11-03 23:45:23.578 [StopPlaying Event] Stopped sending http://localhost:8124 to PlayStation 3 on 192.168.1.5


Thanks in advance!
b0ris
 
Posts: 5
Joined: Sun Nov 03, 2013 11:33 pm

Re: [1.90.1] Problem streaming Spotify via DSBridge

Postby b0ris » Thu Nov 07, 2013 5:46 pm

Please?
b0ris
 
Posts: 5
Joined: Sun Nov 03, 2013 11:33 pm

Re: [1.90.1] Problem streaming Spotify via DSBridge

Postby Kddogg » Thu Nov 07, 2013 8:00 pm

b0ris, I posted a thread on this forum for what worked for me. Check the number of processors under the Transcoding Settings tab and make sure you have the correct number of processor cores, do not include any hyperthread or virtual cores in the count, physical cores only. Also, make sure your file buffer size is set to 400mb which is the maximum size the program will allow. I hope this works for you.
Kddogg
 
Posts: 2
Joined: Thu Nov 07, 2013 7:14 pm

Re: [1.90.1] Problem streaming Spotify via DSBridge

Postby b0ris » Thu Nov 07, 2013 9:01 pm

The change to number of cores instead of threads and file buffer size is set to 400 MB, didn't do any difference. But transcode with VLC Web Audio (Legacy) make the playback to work, sometimes, only sometimes. Heres my log:

INFO 2013-11-07 20:54:03.568 [New I/O server worker #1-1] No IP filter specified, access granted to /192.168.1.8
INFO 2013-11-07 20:54:03.577 [pool-7-thread-1] Checking IP: 192.168.1.8 for PlayStation 3
INFO 2013-11-07 20:54:08.179 [pool-7-thread-1] Renderer PlayStation 3 found on this address: 192.168.1.8
INFO 2013-11-07 20:54:09.124 [New I/O server worker #1-11] Checking shared folder: C:\Users\Tobias\Downloads
INFO 2013-11-07 20:54:09.125 [New I/O server worker #1-11] Checking shared folder: E:\TV
INFO 2013-11-07 20:54:26.043 [New I/O server worker #1-3] Starting transcode/remux of Spotify
INFO 2013-11-07 20:54:26.219 [vlc.exe-1] Successfully initialized buffer to 50 000 000 bytes.
INFO 2013-11-07 20:54:32.203 [StartPlaying Event] Started sending http://localhost:8124 to PlayStation 3 on 192.168.1.8
INFO 2013-11-07 20:54:34.706 [Buffered IO End Checker] Destroying buffer
INFO 2013-11-07 20:54:35.044 [New I/O server worker #1-8] Starting transcode/remux of Spotify
INFO 2013-11-07 20:54:35.211 [vlc.exe-2] Successfully initialized buffer to 50 000 000 bytes.
INFO 2013-11-07 20:54:36.207 [StopPlaying Event] Stopped sending http://localhost:8124 to PlayStation 3 on 192.168.1.8
INFO 2013-11-07 20:54:41.196 [StartPlaying Event] Started sending http://localhost:8124 to PlayStation 3 on 192.168.1.8
INFO 2013-11-07 20:54:43.697 [Buffered IO End Checker] Destroying buffer
INFO 2013-11-07 20:54:46.003 [New I/O server worker #1-4] Starting transcode/remux of Spotify
INFO 2013-11-07 20:54:46.170 [vlc.exe-3] Successfully initialized buffer to 50 000 000 bytes.
INFO 2013-11-07 20:54:47.439 [StopPlaying Event] Stopped sending http://localhost:8124 to PlayStation 3 on 192.168.1.8
INFO 2013-11-07 20:54:52.156 [StartPlaying Event] Started sending http://localhost:8124 to PlayStation 3 on 192.168.1.8
INFO 2013-11-07 20:54:54.657 [Buffered IO End Checker] Destroying buffer
INFO 2013-11-07 20:54:57.311 [New I/O server worker #1-16] Starting transcode/remux of Spotify
INFO 2013-11-07 20:54:57.478 [vlc.exe-4] Successfully initialized buffer to 50 000 000 bytes.
INFO 2013-11-07 20:54:58.440 [StopPlaying Event] Stopped sending http://localhost:8124 to PlayStation 3 on 192.168.1.8
INFO 2013-11-07 20:55:03.463 [StartPlaying Event] Started sending http://localhost:8124 to PlayStation 3 on 192.168.1.8
INFO 2013-11-07 20:59:44.555 [Thread-34] Successfully grown buffer from 50 000 000 bytes to 209 715 200 bytes.


Any more ideas?
b0ris
 
Posts: 5
Joined: Sun Nov 03, 2013 11:33 pm

Re: [1.90.1] Problem streaming Spotify via DSBridge

Postby b0ris » Thu Nov 07, 2013 9:05 pm

And the music stutters for a moment approximately one time per three songs. The 10 second delay isn't so nice either, sometimes it goes up to 30 seconds.
b0ris
 
Posts: 5
Joined: Sun Nov 03, 2013 11:33 pm

Re: [1.90.1] Problem streaming Spotify via DSBridge

Postby b0ris » Fri Nov 08, 2013 12:54 am

And again: No problem streaming Spotify with UMS 2.6.5
b0ris
 
Posts: 5
Joined: Sun Nov 03, 2013 11:33 pm


Return to General Help and Support

Who is online

Users browsing this forum: Bing [Bot], Google [Bot] and 7 guests