Panel Icon Creates Dead Square Pixel Area on Screen

For help and support with issues specific to Linux/Unix
Forum rules
Please make sure you follow the Problem Reporting Guidelines before posting if you want a reply.

Panel Icon Creates Dead Square Pixel Area on Screen

Postby j03 » Sun Sep 22, 2013 7:58 pm

Xubuntu 12.04.3
XFCE 4.8
PMS 1.90.1, but also tried 1.80 from outdated Launchpad repo.
openjdk-7-jre, also had openjdk-6-jre before.

When I launch PMS I get dead pixel area under the left side of the upper panel approximately the dimensions of the PMS panel icon. If I quit PMS, the dead pixel area goes away. Please see image below - upper left corner - mouse cursor is pointing at it. PMS icon is in the top panel on the right - click image to enlarge and see it. How to fix? Thanks.

Edit: Oh yeah, BTW, notice I don't have any minimize/maximize/close buttons on the PMS GUI either. Possibly related? Thanks.

Image
Last edited by j03 on Mon Sep 23, 2013 1:49 am, edited 2 times in total.
j03
 
Posts: 2
Joined: Sun Sep 22, 2013 7:34 pm

Re: Panel Icon Creates Dead Square Pixel Artifact on Screen

Postby j03 » Mon Sep 23, 2013 1:38 am

I figured it out. In XFCE you can activate a feature at Settings > Window Manager Tweaks > Focus > Activate Focus Stealing Prevention. I had this option ON, which is not normal PC behavior, and was causing the issue. I turned it off and the artifact no longer appears.

Edit: Disregard above fix, it doesn't work. This problem consistently happens every other time I open PMS. Open once: dead area is there, open again: gone, open again: it's back, etc. Using the latest snapshot 1.90.2 does not fix. Some sort of conflict with GTK or default Greybird Xubuntu theme? Thanks.

Edit 2: Definite fix. You have to disable "Display Compositing" in XFCE (Settings > Window Manger Tweaks > Compositor > uncheck Enable display compositing.

This means you can't have a semi transparent dock, etc. Kind sucks. Would be great to see a fix in PMS.

As far as the missing minimize/maximize/close buttons, it still persists with display compositing disabled. Workaround: when you have the Main Panel GUI open and want to close it, but do not want to Quit PMS, use Alt-F4.
j03
 
Posts: 2
Joined: Sun Sep 22, 2013 7:34 pm


Return to Linux/Unix Support

Who is online

Users browsing this forum: No registered users and 8 guests