Problem with embedded subs priority

For help and support with PS3 Media Server in general
Forum rules
Please make sure you follow the Problem Reporting Guidelines before posting if you want a reply.

Problem with embedded subs priority

Postby Pochodave » Tue Sep 10, 2013 8:15 am

Good Morning Guys,
i've got this stupid problem and i hope you'll help me finding a solution.I use the 1.90.1 version for Mac OS X - Mountain Lion

Generally i don't have any kind of problem with subs.If i have a MKV file with not embedded subtitles automatically the .srt with the same file name is associated.The problem comes when i've got files with embedded subtitles.Even tough i've got in the settings "Load automatically subtitles with the same file name" the problem persists.Could you help me with the setting of the priority?i tried in many ways but nothing.

I've got this Breaking Bad Episode in 1080p with an english subtitle embedded.I need to watch the episode with my italian external sub.
Just a little thing:i have a PS3 but also a Samsung Smart TV that automatically recognizes the Server.It would be very useful solve at least just on one of the two Clients.
I post a screenshot and i really hope you will help me.

P.S If there's no way anybody knows a program that allow to removing the embedded subtitle from the file?
Thanks in advance.
Attachments
Schermata 2013-09-10 alle 09.11.25.png
Schermata 2013-09-10 alle 09.11.25.png (174.23 KiB) Viewed 1019 times
Pochodave
 
Posts: 10
Joined: Tue Jul 31, 2012 9:32 am

Re: Problem with embedded subs priority

Postby ExSport » Tue Sep 10, 2013 10:49 am

Try to learn from here:
https://code.google.com/p/pms-exsport/wiki/FAQ
Anyway your priority settings is "it,eng,und".
If embedded subs are correctly tagged, PMS will recognise them as ENG.
If external subs are named exactly as a movie (like moviename.mkv + moviename.srt), PMS recognises them as UND.
If external subs are named in this way: moviename.mkv + moviename.it.srt, PMS recognises them as IT.
So in your case I suppose first IT is not found but second one ENG is found as embeded and loaded. Third UND (your external subs) is not taken into account.
ExSport
 
Posts: 2168
Joined: Mon Jan 19, 2009 5:40 pm

Re: Problem with embedded subs priority

Postby Pochodave » Tue Sep 10, 2013 11:31 am

Yeeeees :) :) :) it was the only combination that i didn't try last night :) :) :) it works on the PS3 so the problem can be considered solved.Any idea for the Smart TV?automatically even in the setting that you gave to me doesn't work,but it takes the embedded.Do you think i've got to try in the TRANSCODE folder?(Generally i disable this one).

However thank you very much for you help :) :) :)
Pochodave
 
Posts: 10
Joined: Tue Jul 31, 2012 9:32 am

Re: Problem with embedded subs priority

Postby ExSport » Tue Sep 10, 2013 12:32 pm

If your Smart TV supports MKV then PMS is using direct streaming of MKV file. It means you have to disable subs on your TV. In this case external ones are not sent to TV but you can force it via TRANSCODE folder.
ExSport
 
Posts: 2168
Joined: Mon Jan 19, 2009 5:40 pm

Re: Problem with embedded subs priority

Postby Pochodave » Tue Sep 10, 2013 12:50 pm

It Worked :) :) :).....you're brilliant!Thank you :)
I think that the moderators can close the topic :)
Thank You Very Much ;)
Pochodave
 
Posts: 10
Joined: Tue Jul 31, 2012 9:32 am


Return to General Help and Support

Who is online

Users browsing this forum: Yahoo [Bot] and 9 guests