Windows 7/PMS 1.81: the server can't find the renderer

For help and support with PS3 Media Server in general
Forum rules
Please make sure you follow the Problem Reporting Guidelines before posting if you want a reply.

Windows 7/PMS 1.81: the server can't find the renderer

Postby chris38 » Sat May 18, 2013 9:30 am

On Windows 7 PC.

Uninstalled Version 1.80, installed Version 1.81. The server does not find any renderer. Red cross appears.
Restarting the server - doesn`t help.

Deletion of the config file would fix the problem for one time only - server found renderers and started, but after closing and restarting the red cross appeared again.

Downgrade to 1.80 (including deletion of the config file): Everything works again without any issue.
Posts: 3
Joined: Sat Apr 27, 2013 9:11 am

Re: The server does not find any renderer with 1.81.0

Postby sttngds9 » Sat May 18, 2013 3:25 pm

Try to open pms.jar instead pms.exe. That´s the only thing that worked for me.
Posts: 3
Joined: Sat May 18, 2013 3:12 pm

Re: The server does not find any renderer with 1.81.0

Postby droogy » Sat May 18, 2013 7:14 pm

I too can confirm that if I double click the .jar file then it immediately finds the PS3 as a renderer. If I use the executable (via startup or manual) it does not find the PS3. Pls fix this.
Posts: 1
Joined: Sat May 18, 2013 7:12 pm

Re: The server does not find any renderer with 1.81.0

Postby meskibob » Sat May 18, 2013 7:16 pm

I provide NO application support via PM or email, so please post your question to the forum per the Forum Rules.
Posts: 4806
Joined: Mon Jan 19, 2009 4:11 pm

Re: The server does not find any renderer with 1.81.0

Postby Mr. Deltoid » Sun May 19, 2013 2:45 am

I am also having this same problem. I ran the java file and it found my PS3 as an "unknown device", and none of the engines loaded so I couldn't watch any videos. So, I quit the PMS. I then restarted it as the .exe file and it worked. I don't know if this action "kicked it into gear", though.

I was having all sorts of errors when trying to update to the current PMS version. Through restarting, uninstalling, re-downloading, etc. I eventually got the latest PMS to completely install properly.

I believe this issue is java related. I completely uninstalled all versions of java and reinstalled just the latest version.

Still this problem persisted. But I ran the pms.jar, it failed to load all my engines, I quit, then restarted the pms regularly and it worked fine.

After using it today, I quit the PMS and re-started it and got the same problem. And so this time I simply ran the pms.jar and THIS time it ran fine with all appropriate engines running.

This issue seems to have variations of behavior. For now I just created a desktop icon for the PMS.JAR file and am running it through that.

Here is my entry per the Problem Reporting Guidelines:

1. My computer specs:
Windows 7/32 bit/4GB ram (3.25 usable)/3.10GHz processor
PMS version: 1.81.0
Java Version: 7, update 21

2. Streaming to my PS3

3. wifi connection through Apple Airport Extreme, using a netgear external wifi card on my PC (I have to admit this thing has been giving me problems lately, dropping connection; and I often have to pull it out and plug it back in to get it to work)

4. No transcoding

5. What is not working: PMS not finding any renderers

6. debug.log is here:

7. No file specific info applicable.
Mr. Deltoid
Posts: 1
Joined: Sat May 18, 2013 8:50 pm

Re: Windows 7/PMS 1.81: the server can't find the renderer

Postby chocolateboy » Sun May 19, 2013 8:05 am

debug.log wrote:
Code: Select all
INFO  2013-05-18 21:38:44.297 [main] Created socket:
DEBUG 2013-05-18 21:38:44.438 [main] Sending ALIVE...
DEBUG 2013-05-18 21:38:44.442 [main] Error sending ALIVE message No usable network interface found for UPnP multicast

1. Make sure your PC has a valid IP address (that isn't conflicting with anything else on the network):

If a computer is in a state where it has no valid IP address lease (for example, when starting or when the lease has expired), the computer's TCP/IP stack is initialized with the address

Best way to solve this problem is to manually change the static IP address.

2. It might be related to this, in which case it may have been fixed already. Try a snapshot build.

3. If all else fails (don't do this unless you've tried the other two options), try the workaround posted here.
Project Member
Posts: 2581
Joined: Wed Sep 16, 2009 10:05 am

Return to General Help and Support

Who is online

Users browsing this forum: Yahoo [Bot] and 6 guests