PMS will not start - cannot locate debug.log file

For help and support with issues specific to Mac OS X
Forum rules
Please make sure you follow the Problem Reporting Guidelines before posting if you want a reply.

PMS will not start - cannot locate debug.log file

Postby chrama » Sun Apr 28, 2013 8:08 am

Hi all,

I have searched forums for some hours trying to troubleshoot 2 problems but to no avail.

I am running Mac OS X 10.7.5. I have been running PMS 1.50 for many months with no issues. I recently updated Java to Oracle version 7u21 and soon after noticed problems with PMS. I have reverted back to Apple 1.6.0_45 after reading the forums but the problems remain. I have verified that the correct Apple version of Java is running.

Problem 1: When 1.50 first starts up I get the message "No renderers found". After some time if I click on "restart server" it then detects the renderers and operates correctly.

Problem 2: In trying to troubleshoot the above problem I tried installing later versions including 1.72, 1.80 and 1.81. All of these versions start in the dock and run for 5-10 seconds before crashing out. The main GUI does not load - and again there is no debug.log file. If I go back to 1.50 the program will load but then I am back to Problem 1.

I have been trying to find the debug.log file following the advice in the forums for finding this file. However under all the PMS versions - there is nothing in the trace screen and no debug.log file is produced on the mac in the appropriate location.

I have done all the obvious things including reboots, re-installs, checking network and firewall connections, reverting back to Apple Java and searching the forums .. but I am now stuck!

I know that this does point to Java issues, but the Java version does appear to be now correct.

Any suggestions will be appreciated!
chrama
 
Posts: 4
Joined: Fri Apr 26, 2013 8:46 am

Re: PMS will not start - cannot locate debug.log file

Postby Raptor399 » Sun Apr 28, 2013 9:39 am

I googled a bit and found these links:

Does that help?
Raptor399
Project Member
 
Posts: 1916
Joined: Thu Mar 10, 2011 12:06 am

Re: PMS will not start - cannot locate debug.log file

Postby chrama » Sun Apr 28, 2013 10:44 am

Thanks for the quick reply.

Following the info in your first link I found a "crash" log file referring to mencoder within the PMS app (attached). The log file is from 7 days ago - which is about when the issue began, but there have been no further log file entries. It may not be relevant.
Attachments
mencoder_2013-04-21-202614_iMac.crash.zip
(9.87 KiB) Downloaded 29 times
chrama
 
Posts: 4
Joined: Fri Apr 26, 2013 8:46 am

Re: PMS will not start - cannot locate debug.log file

Postby Raptor399 » Sun Apr 28, 2013 3:11 pm

That log is a bit old, I would expect more recent entries.

You can try editing the file "/Applications/PS3 Media Server.app/Contents/Info.plist" with your favorite text editor.
The app directory is hidden, use CMD-SHIFT-G to open the path.

Almost at the bottom, it contains these lines:

Code: Select all
                        <key>VMOptions</key>
                        <string>-Xmx768M -Xss16M -Dfile.encoding=UTF-8 -Djava.net.preferIPv4Stack=true -jar</string>

Try adding the -XX flag by editing that to:

Code: Select all
                        <key>VMOptions</key>
                        <string>-Xmx768M -Xss16M -Dfile.encoding=UTF-8 -Djava.net.preferIPv4Stack=true -jar -XX:ErrorFile=$APP_PACKAGE/Contents/Resources/Java/jvm.log</string>

When you start PMS it should write a file "/Applications/PS3 Media Server.app/Contents/Resources/Java/jvm.log" whenever the Java virtual machine crashes.
Raptor399
Project Member
 
Posts: 1916
Joined: Thu Mar 10, 2011 12:06 am

Re: PMS will not start - cannot locate debug.log file

Postby chrama » Mon Apr 29, 2013 9:58 am

Thanks again for the reply.

But .. still nothing positive to report. I have followed the instructions you have given and I do not see any log file created in that directory.

I have uninstalled PMS versions many times and re-installed, as well as rebooting, and also uninstalling and re-installing versions of Java (Oracle and Apple). I have even completely uninstalled Java and started from scratch (http://www.macworld.com/article/2028900 ... r-mac.html).

The behaviour of the PMS versions is consistent across all of this. Version 1.50 will only work after I click on "Restart Server" and later versions will not load up, and leave no debug.log file.

Everything else on my mac appears to be functioning fine. To me this all points to Java not functioning correctly, but I cannot see what more I can do to fix this?
chrama
 
Posts: 4
Joined: Fri Apr 26, 2013 8:46 am

Re: PMS will not start - cannot locate debug.log file

Postby michaelross » Fri May 03, 2013 1:18 pm

I also have 10.7.5 and have the same issues.

Does not start and no debug files created even with editing Info.plist and adding -XX flag.

M
michaelross
 
Posts: 1
Joined: Fri May 03, 2013 1:16 pm

Re: PMS will not start - cannot locate debug.log file

Postby chrama » Mon May 13, 2013 12:47 pm

After running out of troubleshooting approaches, I decided that it was time to do a clean install to Mountain Lion. Clearly there was something on my mac that was not happy, and I had no idea what else it might effect. After a few hours of re-installing updates and applications, all was good. I am now running 1.81.0 with no issues.
chrama
 
Posts: 4
Joined: Fri Apr 26, 2013 8:46 am

Re: PMS will not start - cannot locate debug.log file

Postby Raptor399 » Tue May 14, 2013 9:38 pm

chrama wrote:I am now running 1.81.0 with no issues.

That is great news!
Glad to see you're up and running again. :-)
Raptor399
Project Member
 
Posts: 1916
Joined: Thu Mar 10, 2011 12:06 am


Return to Mac OS X Support

Who is online

Users browsing this forum: No registered users and 9 guests