No sound on newer MKV files?

For help and support with PS3 Media Server in general
Forum rules
Please make sure you follow the Problem Reporting Guidelines before posting if you want a reply.

Re: No sound on newer MKV files?

Postby codeine » Mon Apr 22, 2013 11:45 am

Update 1.81 doesnt fix it.
codeine
 
Posts: 10
Joined: Sat Apr 13, 2013 4:10 am

Re: No sound on newer MKV files?

Postby snoochems » Mon Apr 22, 2013 1:01 pm

This same issue is driving me nuts.

GoT gets through the "previously on GoT...", however, after the HBO snow, I only get muffled background noises.
snoochems
 
Posts: 2
Joined: Fri Feb 22, 2013 7:30 am

Re: No sound on newer MKV files?

Postby codeine » Tue Apr 23, 2013 8:00 am

Yea, thats the main issue im having. I havent been able to watch GoT since its come out.
codeine
 
Posts: 10
Joined: Sat Apr 13, 2013 4:10 am

Re: No sound on newer MKV files?

Postby mikeromeoooo » Tue Apr 23, 2013 11:53 pm

Is there a fix for this yet? very annoying
mikeromeoooo
 
Posts: 1
Joined: Tue Apr 23, 2013 11:52 pm

Re: No sound on newer MKV files?

Postby pjamedia » Thu Apr 25, 2013 10:35 am

I fixed it. Well not really a fix, but a work around - downgraded pms to v1.54. Both sound and image play fine now in glorious 5.1ch sound through Men coder - even Game of thrones mkv audio playing flawlessly. So something serious had happened since 1.54 to screw the channel interpretation on some mkvs.
pjamedia
 
Posts: 7
Joined: Sat Apr 13, 2013 7:24 pm

Re: No sound on newer MKV files?

Postby happy.neko » Thu Apr 25, 2013 11:26 am

pjamedia
Can you replace ffmpeg and mencoder binaries from 1.54 with new ones (from ps3ms 1.81) to see if the problem is related with mencoder version?
happy.neko
Project Member
 
Posts: 478
Joined: Fri Sep 23, 2011 5:38 pm

Re: No sound on newer MKV files?

Postby pjamedia » Thu Apr 25, 2013 5:58 pm

OK, I uninstalled 1.54, and installed 1.81 from fresh. Tested that version and sound is screwed!
I copied out the Win32 folder from under PS3 Media Server, then un-installed 1.81, reinstalled 1.54 from scratch - tested that version again, and sound works fine on all channels. I then overwrote the Win32 folder with the version taken from 1.81. Sound is still fine! So its not MEncoder which is the source of the issue, but how PS3MS uses Mencoder in versions of PMS newer than 1.54!

Would be great if the devs could get to the bottom of this one. Its very easy to reproduce - just get hold of a copy of any (EMERSE or EVOLVE) Game of thrones MKV from Season 3 with 720p and 5.1ch sound. Install 1.81 with default options and try playing it on a PS3! I actually found same issues with the S2 episodes I tried to play.

Cheers, Paul
pjamedia
 
Posts: 7
Joined: Sat Apr 13, 2013 7:24 pm

Re: No sound on newer MKV files?

Postby happy.neko » Thu Apr 25, 2013 6:29 pm

check SNAPSHOT build viewtopic.php?f=14&t=14753 your issue should be fixed.
Don't forget to enable "Keep AC3 track" option.
happy.neko
Project Member
 
Posts: 478
Joined: Fri Sep 23, 2011 5:38 pm

Re: No sound on newer MKV files?

Postby codeine » Fri Apr 26, 2013 7:50 am

The issue is fixed, but java is crashing alot when browsing content.
codeine
 
Posts: 10
Joined: Sat Apr 13, 2013 4:10 am

Re: No sound on newer MKV files?

Postby Zenwolf » Fri Apr 26, 2013 8:05 am

I have the same problem, but when I tried the latest build, javaw crashes when I try to open a folder. I get DLNA exception on PS3 and a crash window on Windows 7 64bit. Here is the crash info:

Code: Select all
Problem signature:
  Problem Event Name:   APPCRASH
  Application Name:   javaw.exe
  Application Version:   7.0.210.11
  Application Timestamp:   515d68ec
  Fault Module Name:   jna823299119286764676.dll
  Fault Module Version:   3.4.0.86
  Fault Module Timestamp:   4ec28db1
  Exception Code:   c0000005
  Exception Offset:   0000d300
  OS Version:   6.1.7601.2.1.0.256.48
  Locale ID:   1033
  Additional Information 1:   0785
  Additional Information 2:   07852146339b7763cce96bd913276c0c
  Additional Information 3:   d0eb
  Additional Information 4:   d0eb5158128bdb6353ad55d26544f2bb
Zenwolf
 
Posts: 2
Joined: Fri Apr 26, 2013 8:02 am

PreviousNext

Return to General Help and Support

Who is online

Users browsing this forum: No registered users and 21 guests