MEncoder ISO Asynch Playback

For help and support with PS3 Media Server in general
Forum rules
Please make sure you follow the Problem Reporting Guidelines before posting if you want a reply.

MEncoder ISO Asynch Playback

Postby meskibob » Sun Apr 07, 2013 3:08 am

Per updated comments to Issue 16, as well as Issue 1547 and Issue 1543, I finally played an ISO again, one that worked previously (don't remember which version) but has asynch playback now. As listed in another user's comment, I tested with version 1.54.0 and had correct playback.
I tested the MEncoder commands used in 1.80.1 and 1.54.0 (fresh PMS.confs for each) against the MEncoder builds from 1.80.1 (SB41) and 1.54.0 (SB32). Both builds of MEncoder created synched files with the 1.54.0 command (~10KB apart in filesize for a 10min file), and both builds of MEncoder created asynch files with the 1.80.1 command (~.5MB apart in filesize, and about 80MB larger than the 1.54.0 command).

It looks like there are a few differences in the commands (assuming flag order doesn't matter), but I do not know MEncoder very well, so any recommendations on which flags to modify/delete to test and fix the problem would be appreciated.

1.54.0 MEncoder Command:
Code: Select all
mencoder.exe -ss 0 -dvd-device "Z:\Videos\Movies\_Kiss the Girls.iso" dvd://1 -quiet -oac copy -of mpeg -quiet -quiet -mpegopts format=mpeg2:muxrate=500000:vbuf_size=1194:abuf_size=64:vaspect=16/9 -ovc lavc -channels 6 -lavdopts debug=0:threads=1 -lavcopts autoaspect=1:vcodec=mpeg2video:acodec=ac3:abitrate=640:threads=8:keyint=5:vqscale=1:vqmin=2:vrc_maxrate=54000:vrc_buf_size=1835 -quiet -quiet -subdelay 20000 -quiet -quiet -ofps 30000/1001 -quiet -quiet -quiet -af lavcresample=48000 -srate 48000

1.80.1 MEncoder Command:
Code: Select all
mencoder.exe -ss 0 -dvd-device "Z:\Videos\Movies\_Kiss the Girls.iso" dvd://1 -msglevel statusline=2 -oac copy -of mpeg -mpegopts format=mpeg2:muxrate=500000:vbuf_size=1194:abuf_size=64:vaspect=16/9 -ovc lavc -channels 6 -lavdopts debug=0:threads=1 -lavcopts autoaspect=1:vcodec=mpeg2video:acodec=ac3:abitrate=640:threads=8:keyint=5:vqscale=1:vqmin=2:vrc_maxrate=54000:vrc_buf_size=1835 -nosub -noautosub -ofps 30000/1001 -mc 0 -noskip
I provide NO application support via PM or email, so please post your question to the forum per the Forum Rules.
meskibob
Moderator
 
Posts: 4789
Joined: Mon Jan 19, 2009 4:11 pm

Re: MEncoder ISO Asynch Playback

Postby Raptor399 » Sun Apr 07, 2013 8:44 am

Nice work on the research, meskibob!

I'm no mencoder buff either, but I know the "-quiet" flags are irrelevant. So the two command lines are identical, except for these flags:

In 1.54.0 MEncoder Command, missing in 1.80.0:
Code: Select all
-subdelay 20000 -af lavcresample=48000 -srate 48000


In 1.80.0 MEncoder Command, missing in 1.54.0
Code: Select all
-nosub -noautosub


I guess the 'sub' flags are irrelevant to this problem, so that leaves the "-af lavcresample=48000 -srate 48000" flags as possible culprits. What happens if you add those to the 1.80.0 command line?
Raptor399
Project Member
 
Posts: 1916
Joined: Thu Mar 10, 2011 12:06 am

Re: MEncoder ISO Asynch Playback

Postby meskibob » Sun Apr 07, 2013 5:55 pm

Thanks for the guidance.
Unfortunately, I tested both flags separately, as well as combined, with no change. In addition, I fully copied the 1.80.1 command, removed the "-nosub -noautosub", and added the "-subdelay 20000 -af lavcresample=48000 -srate 48000", so the commands should match in theory. However, this still spat out an asynch file. That leads me to think that while I wouldn't expect them to matter, the "quiet" flags are actually influencing the output file.
I tried adding the triple quiets in front of the -af, but that didn't change anything. I added the double quiets in front of the -ofps, same results.
Any thoughts on which other flags to check?

Edit: thinking I might have had it backwards, tried triple quiets after -ofps, with no success as well.
I provide NO application support via PM or email, so please post your question to the forum per the Forum Rules.
meskibob
Moderator
 
Posts: 4789
Joined: Mon Jan 19, 2009 4:11 pm

Re: MEncoder ISO Asynch Playback

Postby Raptor399 » Tue Apr 09, 2013 7:49 pm

Not really, as I really know little about MEncoder. Googling for "mencoder audio sync" gave me this result, not sure if it helps.
Raptor399
Project Member
 
Posts: 1916
Joined: Thu Mar 10, 2011 12:06 am


Return to General Help and Support

Who is online

Users browsing this forum: Bing [Bot] and 25 guests