MKV and memory bloating

For help and support with PS3 Media Server in general
Forum rules
Please make sure you follow the Problem Reporting Guidelines before posting if you want a reply.

MKV and memory bloating

Postby UArchive » Tue Mar 19, 2013 10:55 am

I've searched all over for the answer to this issue, but with no real luck. So here goes. PMS one day decided it was no longer going to play MKV files. Not just that, but if any attempt is made to play a MKV file the memory use of PMS (javaw.exe) goes up into the 550mb-900mb or more range and no longer will function until closed and reopened.

I have tried:
1. Uninstalling/reinstalling PMS
2. Uninstalling/reinstalling Java
3. Installing avisynth and Matroska
4. Uninstalling and reinstalling VLC
5. Rebooting PC
6. Rebooting router
7. Replacing router with a much more quality model
and likely some other things I am forgetting.

Required info as per the "[IMPORTANT] Problem Reporting Guidelines" topic in the forum:

Your computer specs (CPU, memory, OS) and the exact version of PMS you are using (e.g. "1.53.0" or "Build 99932ae01", not "latest version").

I am using the windows version, 1.72.0 build: d9fd0a44c (2012-11-18)
My pc is running Win7 Home Premium 64-bit, AMD E-450 APU 1.65ghz,8GB of ram

The device you are streaming to (PS3, XBox360, etc). If you are using a custom renderer profile, provide the .conf as well.

I am streaming to a PS3, both from the XMB menu and from the showtime homebrew application. Problems occur in both. No custom profile.

If you're reporting a connection or streaming problem, please indicate your local network setup (WAN/ISP bandwidth does not matter) including connection type (Wifi, homeplugs, 100mbit ethernet, gigabit) and what you are connected through (direct connection, switch, router). E.g. PC <-Wifi G-> Linksys WRT54G Router <-100mbps-> PS3

I have tried multiple routers and multiple connections (wifi and lan) with no real difference.

Which engine you are using if you are transcoding (MEncoder, AviSynth/MEncoder, FFmpeg, tsMuxeR).

I am using the default installation settings, with the exception of the folders it is set to explore.

Detailed information on what is not working.

Hope I am doing that now.

A copy of the debug.log per the following directions - FAQ: How can I supply details to help diagnose my problem?

Here is a pastebin:

File-specific information - if you're having an issue with a specific file or set of files:

It's anything MKV. Small, large, it's indifferent. The same thing happens. Occasionally if I let it sit for a substantial amount of time (20 minutes or more) the video will come on, but rarely. And if it does it comes on in the middle of whatever I am playing.

Post the "Text" output from MediaInfo.

Unique ID : 214695277299308076668853512900128870478 (0xA184CE6CC08BCAC38A138002B3D5104E)
Complete name : C:\Users\Outhouse VI\Downloads\WwW.Thalathalapathy.CoM - Endhiran.2010.720p.Blu.Ray.Rip.x264.AC3.5.1.ESub.2.22GB.mkv
Format : Matroska
Format version : Version 2
File size : 2.22 GiB
Duration : 2h 56mn
Overall bit rate : 1 801 Kbps
Encoded date : UTC 2012-07-23 11:32:00
Writing application : mkvmerge v5.4.0 ('Piper') built on Mar 10 2012 13:34:39
Writing library : libebml v1.2.3 + libmatroska v1.3.0

ID : 1
Format : AVC
Format/Info : Advanced Video Codec
Format profile : High@L3.1
Format settings, CABAC : Yes
Format settings, ReFrames : 4 frames
Muxing mode : Header stripping
Duration : 2h 56mn
Bit rate : 1 672 Kbps
Width : 1 280 pixels
Height : 544 pixels
Display aspect ratio : 2.35:1
Frame rate mode : Constant
Frame rate : 23.976 fps
Color space : YUV
Chroma subsampling : 4:2:0
Bit depth : 8 bits
Scan type : Progressive
Bits/(Pixel*Frame) : 0.100
Stream size : 2.02 GiB (91%)
Title : (Radjaramane&Shivashankar)
Writing library : x264 core 120 r2164 da19765
Encoding settings : cabac=1 / ref=3 / deblock=1:0:0 / analyse=0x3:0x111 / me=hex / subme=7 / psy=1 / psy_rd=1.00:0.00 / mixed_ref=1 / me_range=16 / chroma_me=1 / trellis=1 / 8x8dct=1 / cqm=0 / deadzone=21,11 / fast_pskip=1 / chroma_qp_offset=-2 / threads=3 / sliced_threads=0 / nr=0 / decimate=1 / interlaced=0 / bluray_compat=0 / constrained_intra=0 / bframes=3 / b_pyramid=2 / b_adapt=1 / b_bias=0 / direct=1 / weightb=1 / open_gop=0 / weightp=2 / keyint=240 / keyint_min=23 / scenecut=40 / intra_refresh=0 / rc_lookahead=40 / rc=2pass / mbtree=1 / bitrate=1672 / ratetol=1.0 / qcomp=0.60 / qpmin=0 / qpmax=69 / qpstep=4 / cplxblur=20.0 / qblur=0.5 / ip_ratio=1.40 / aq=1:1.00
Language : Tamil
Default : Yes
Forced : No

ID : 2
Format : AC-3
Format/Info : Audio Coding 3
Mode extension : CM (complete main)
Format settings, Endianness : Big
Muxing mode : Header stripping
Codec ID : A_AC3
Duration : 2h 56mn
Bit rate mode : Constant
Bit rate : 128 Kbps
Channel(s) : 6 channels
Channel positions : Front: L C R, Side: L R, LFE
Sampling rate : 44.1 KHz
Bit depth : 16 bits
Compression mode : Lossy
Stream size : 162 MiB (7%)
Title : (Radjaramane&Shivashankar)
Language : Tamil
Default : Yes
Forced : No

ID : 3
Format : UTF-8
Codec ID : S_TEXT/UTF8
Codec ID/Info : UTF-8 Plain Text
Title : (Radjaramane&Shivashankar)
Language : English
Default : Yes
Forced : No

If your player is a PlayStation 3, press the SELECT button during playback to display media information and report video and audio codecs from upper-right screen corner.

Since it is not functioning I cannot provide this.

If appropriate, upload a file sample (< 100 MB) to a public file-sharing site e.g.

I don't think it would be appropriate.

I also have an incredibly difficult time getting directories to load as well.
Posts: 1
Joined: Tue Mar 19, 2013 10:16 am

Re: MKV and memory bloating

Postby Raptor399 » Sat Mar 23, 2013 11:20 am

The log says:

Code: Select all
INFO  2013-03-18 21:33:17.795 [New I/O server worker #1-2] Media renderer was not recognized. Possible identifying HTTP headers: User-Agent: Showtime PS3 4.2

You may want to force a renderer profile or create a new one that works for you (FAQ: My device is not supported by PMS. How can I create a custom renderer.conf to make PMS recognize my device?).

I see stack traces in the log coming from BufferedOutputFile, which (if memory serves me correctly) should only be used when transcoding. However, the log does not show any signs of transcoding firing up. So the files appear to be streamed via the buffer, which probably causes the rapid rise of memory usage.

Try forcing a rendering profile that streams everything under "General Configuration > Default renderer when automatic detection fails", e.g. "AirPlayer".

Hope that helps!
Project Member
Posts: 1916
Joined: Thu Mar 10, 2011 12:06 am

Return to General Help and Support

Who is online

Users browsing this forum: Bing [Bot], Google [Bot] and 17 guests