Windows Service Stopped Working - Error Code 2

For help and support with PS3 Media Server in general
Forum rules
Please make sure you follow the Problem Reporting Guidelines before posting if you want a reply.

Windows Service Stopped Working - Error Code 2

Postby Spuggy68 » Tue Jan 22, 2013 7:44 pm

I've been using PS3 Media Server for years, and a couple of times out of no where it will stop working, or rather the Service will stop working if you have it installed that way. In the past, I would just open the Server and leave it running, because soon after there would be an update, and everything would work again.

On Sunday Jan 20th, I was watching using PMS, and everything worked great. I went out for a couple of hours, and when I came home, I tried to access PMS, and it was not running. I simple thought the computer it runs on was turned off. I checked, no that was not the problem... I tried to start the Service multiple times, and it always came back with the same Error 2.... so I reinstalled the software... still did not work. I could open the PMS on my desktop, and it would work fine.

I searched high and low of answers, nothing seems to be posted about this.... then I saw a message somewhere about the log for the "Wrapper" software that is executed by the Windows Service. When I checked the log, all of this made sense. The problem that was happening was the "Wrapper" is looking for Current Version 1.6 of Java. I looked at the registry entry that it was looking for, and sure enough, my system must have updated, and the current version is 1.7.

Because I could not find any fix, I thought about rolling back my Java, but then realized there was a recent warning about a security issue, so I simple decided to change the Current Version number from 1.7 back to 1.6.

I started the Service, and all has been running perfectly since then. Maybe the next update will be looking for Version 1.7, but my system is working now.

Hope this helps anyone dealing with a Service that stopped working....

Cheers,
Spuggy68
Spuggy68
 
Posts: 5
Joined: Tue Jan 22, 2013 7:29 pm

Re: Windows Service Stopped Working - Error Code 2

Postby netman63129 » Fri Feb 01, 2013 12:04 am

Thanks, same problem here...will try your fix...

Where did you make this change from 1.7 to 1.6?
netman63129
 
Posts: 19
Joined: Sun Feb 13, 2011 7:59 pm


Return to General Help and Support

Who is online

Users browsing this forum: Yahoo [Bot] and 13 guests