Panasonic viera

For help and support with PS3 Media Server in general
Forum rules
Please make sure you follow the Problem Reporting Guidelines before posting if you want a reply.

Re: Panasonic viera

Postby zzricezz » Mon Dec 31, 2012 3:09 am

ok i tried a few things and here are the out come.

When i changed mediainfo=false the divx would start to play but then my mkv stop playing.

so it is one or the other :(
zzricezz
 
Posts: 11
Joined: Fri Feb 13, 2009 1:41 am

Re: Panasonic viera

Postby ExSport » Mon Dec 31, 2012 9:44 am

zzricezz wrote:I also set the mediainfo=false and it still the same error.

I don't understand you. One time you wrote changing MediaInfo didn't helped, now that it helped.
Without debug log no way to help you.
ExSport
 
Posts: 2167
Joined: Mon Jan 19, 2009 5:40 pm

Re: Panasonic viera

Postby zzricezz » Mon Dec 31, 2012 7:22 pm

sorry let start from the beginning.

I have PMS 1.72 and UMS 2.2.1 installed, I notice the panasonic.conf file is different between the two.

PMS had the video/x-divx line but the UMS was missing it.

PMS had DLNALocalizationRequired=True but UMS had DLNALocalizationRequired=False

I played around with the settings so now I'm able to get both mkv and divx to stream to the tv.

But mencoder on PMS seems to stretch the mkv to fill the tv screen while UMS would show it in widescreen format.

Also doesn't the panny support mkv? I would thought tsMuxer would work. Streaming hangover 2 to the panny lag on ethernet but my kuro has no problem at all which I find odd.
zzricezz
 
Posts: 11
Joined: Fri Feb 13, 2009 1:41 am

Re: Panasonic viera

Postby zzricezz » Mon Dec 31, 2012 10:04 pm

after playing some more with the settings I'm finally able to get MKV files to use tsmuxer.

under the common transcode setting -> audio setting -> uncheck keep AC-3.

I played around with use LPCM but that play video with no audio. then I tried keep DTS and that seems to work if it is on or off.

The only problem now is when using tsMuxer the video is stretch out like if I was using FFMPEG. When I use mencoder the video is properly in widescreen but it using transcode :(..
zzricezz
 
Posts: 11
Joined: Fri Feb 13, 2009 1:41 am

Re: Panasonic viera

Postby vgossain » Tue Jan 01, 2013 1:18 am

ExSport wrote:@vgossain: Your file has 60fps. Do you have some with 23.976, 25 or 29.97 to test if it will play?
I never tested 60fps file but in log it seems data are sent to the TV correctly. Do you have a short sample I can test?


Sorry, I only have 60fps files. These .ts files are generated via NextPVR, an open source DVR program that I am using.

I have a 2 minute sample and updated logs from trying to play this 2 minute sample unsuccessfully on my Panasonic tv and successfully via my PS3.

I uploaded the sample and log files to mediafire - here's the link: http://www.mediafire.com/?8y9oiu44948ecky

In the log file, this is the file that I am trying to render: C:\Users\Public\Videos\NPVR\Manual Recordings\Default_20121231_13501400.ts
vgossain
 
Posts: 6
Joined: Fri Jan 13, 2012 10:19 pm

Re: Panasonic viera

Postby ExSport » Tue Jan 01, 2013 12:44 pm

@zzricezz:
Different conf files are due to PMS is older build so new changes are not merged and rebuilt officially.
Missing divx line in one config is due to the bug in PMS/UMS code which I already mentioned in PMS forum but no officially released version includes it so better was to reencode all Avi files automatically(deleted line).
viewtopic.php?f=6&t=15841&p=76201#p76099
About the tsMuxeR, this works without problems for me, including "keep ac3" checked. Never unchecked it.
About the bad AR(aspect ratio): when file is remuxed or transcoded, PanTv ignores AR. Only solution is adding special MEncoder params which transcodes video with automatically added black bars so AR is fixed.
PMS right now has a bug that custom mencoder settings on renderer level are ignored so it does not work in PMS right now. Bug mentioned here:
https://github.com/ps3mediaserver/ps3me ... er/pull/98
We need to wait so bugs will be fixed and new versions released.
ExSport
 
Posts: 2167
Joined: Mon Jan 19, 2009 5:40 pm

Re: Panasonic viera

Postby ExSport » Tue Jan 01, 2013 12:50 pm

@vgossain:
Thanks for debug.Log and sample, will download later.
Try to find some ts/m2ts file with max 30fps somewhere on net and try it if you reproduce same problem to avoid 30fps limitation for streamed material via dlna. Not at home right now so can't test your sample on my TV with custom PMS version if problem is 60fps or something else.
ExSport
 
Posts: 2167
Joined: Mon Jan 19, 2009 5:40 pm

Re: Panasonic viera

Postby vgossain » Wed Jan 02, 2013 7:26 pm

I couldn't find any 30fps ts files. If you have one that I could try, please post it and I will test it out. The only thing weird about it being the fps rate is that it works fine on the PS3 but not directly on the TV. Does the PS3 not use DLNA?
vgossain
 
Posts: 6
Joined: Fri Jan 13, 2012 10:19 pm

Re: Panasonic viera

Postby ExSport » Fri Jan 04, 2013 1:39 am

Eg. PS3 supports some formats via browser (from HDD,USB,...) but not via dlna/upnp.
Same can be with TV that 60fps is supported from USB but not via dlna,you never know.
Because I asked to test 23.976,24,25 or max 30 fps .TS file. It is not hard to find some short sample on net for testing ;)
ExSport
 
Posts: 2167
Joined: Mon Jan 19, 2009 5:40 pm

Previous

Return to General Help and Support

Who is online

Users browsing this forum: Bing [Bot], Google [Bot] and 10 guests