Latest Version 1.72.0 Problem

For help and support with PS3 Media Server in general
Forum rules
Please make sure you follow the Problem Reporting Guidelines before posting if you want a reply.

Latest Version 1.72.0 Problem

Postby lanky71 » Fri Nov 23, 2012 9:38 am

Ever since upgrading to Version 1.72.0 all the mkv files have become unstable when streaming and basically hog system resources so badly that they stutter then stop playing.

I'm running all the latest codecs as of 2 weeks ago and only had this occur since installing V 1.72.0. Version 1.70.1 runs without problem.
lanky71
 
Posts: 10
Joined: Sun Apr 22, 2012 1:58 pm

Re: Latest Version 1.72.0 Problem

Postby Raptor399 » Fri Nov 23, 2012 7:49 pm

Raptor399
Project Member
 
Posts: 1916
Joined: Thu Mar 10, 2011 12:06 am

Re: Latest Version 1.72.0 Problem

Postby ziatonic » Sun Nov 25, 2012 7:39 am

This is happening to me too. Movies that have never transcoded before (and when played made the buffer shoot to 80 MB immediately) seem to now be transcoding and bogging my computer down. Transcoding can sometimes take a bit to buffer on my setup, but now my cpu is 100% and the buffer crawls. I installed 1.70.1 and things are back to normal. Here are the logs for the problem with 1.72 installed.

1.72.0 on Win 7 Ultimate x64
Core 2 Duo @3.8 gighz, 8 gig ram, solid state drive
Streaming to fat 60 Gb PS3 via full gigabit wired network.
Java Version 7 Update 9

attached debug.log
debug.zip
(3.63 KiB) Downloaded 73 times


pms.conf http://pastebin.com/PPu092gX

media info for file used to test. http://pastebin.com/jmQBnbvb
Let me know if you want the log from 1.70.1 where the movie doesnt transcode and uses little cpu.
ziatonic
 
Posts: 12
Joined: Wed Nov 21, 2012 10:24 am

Re: Latest Version 1.72.0 Problem

Postby ExSport » Sun Nov 25, 2012 11:47 am

I suppose your "problem" is https://github.com/ps3mediaserver/ps3me ... a06be770c2
PMS never switch to remuxing when transcoding is not needed so MEncoder waste your CPU and memory. On WIFI or slower PC file is not played at all or it stutter.
You need to manually go to TRANSCODE folder and play [tsMuxeR] alternative if it helps.
EDIT:
Checked your log and I see:
Code: Select all
Starting "C:\Program Files (x86)\PS3 Media Server\win32\mencoder.exe" -ss 0 G:\Movies\sample.mkv -msglevel statusline=2 -nosound -of rawvideo -mpegopts format=mpeg2:muxrate=500000:vbuf_size=1194:abuf_size=64 -ovc lavc -channels 2 -lavdopts debug=0:threads=2 -lavcopts autoaspect=1:vcodec=mpeg2video:acodec=ac3:abitrate=640:threads=2:keyint=5:vqscale=2:vqmin=3:vrc_maxrate=53000:vrc_buf_size=7000 -subdelay 20000 -ofps 24000/1001 -vf softskip,scale=1920:796 -lavdopts fast -mc 0 -noskip -o \\.\pipe\1353824885217ffmpegvideo

What setting are you using that it tries to rescale your video???
Code: Select all
-vf softskip,scale=1920:796

I can understand using "expand" instead of "scale" to fix aspect ratio or for resoulutions not divisible by 8/16/32 etc. It is much faster and with better quality so loosing/adding 2 pixels with "expand" is worth it.
Maybe this scale is incorrectly used by PMS so it has nothing to do with your settings.
Last edited by ExSport on Mon Dec 10, 2012 12:09 pm, edited 1 time in total.
ExSport
 
Posts: 2168
Joined: Mon Jan 19, 2009 5:40 pm

Re: Latest Version 1.72.0 Problem

Postby ExSport » Mon Dec 10, 2012 12:09 pm

About the scale and expand "bug".
https://github.com/ps3mediaserver/ps3me ... java#L2008
We should use "expand" instead of slow/lower in quality "scale".
I can't do it by own via PULL request because my tree is quite obsolete (no time to sync all the changes right now)
Thx for fix
ExSport
 
Posts: 2168
Joined: Mon Jan 19, 2009 5:40 pm

Re: Latest Version 1.72.0 Problem

Postby ExSport » Mon Dec 10, 2012 1:32 pm

:idea: I was able to modify only this file directly from Web browser 8-)
https://github.com/ps3mediaserver/ps3me ... er/pull/96
ExSport
 
Posts: 2168
Joined: Mon Jan 19, 2009 5:40 pm

Re: Latest Version 1.72.0 Problem

Postby Raptor399 » Wed Dec 26, 2012 12:03 pm

Pull request merged, thanks!
Raptor399
Project Member
 
Posts: 1916
Joined: Thu Mar 10, 2011 12:06 am


Return to General Help and Support

Who is online

Users browsing this forum: No registered users and 20 guests