MKV cuts out after 8m27s

For help and support with PS3 Media Server in general
Forum rules
Please make sure you follow the Problem Reporting Guidelines before posting if you want a reply.

MKV cuts out after 8m27s

Postby Lakmir » Sat Dec 01, 2012 7:15 am

Hey folks, just upgraded to 1.72 from... god, I think 1.30? 1.12? Something fairly old, anyway. Had problems getting MKV-embedded subtitles to display, but the upgrade fixed that. Huzzah! Picture quality is now much, much nicer too.

Problem is, the film I was watching just... stopped playing after roughly 8 minutes and 27 seconds.

Reporting info:
1: PMS 1.72.0 is running on a Windows XP SP3 machine, Athlon 64x2 2.70GHz 1.93GB RAM. Video is an NVIDIA Geforce 8400GS. Fairly old, yeah, but it doesn't do much other than stream stuff.
2: Streaming to a 360. Don't think I'm using any custom renderer stuff.
3: Both the 360 and the PC are connected to the same network, wired, via a switch which itself is hooked up to a central router where from my internet comes, but the data shouldn't need to travel past the switch (or the router).
4: MEncoder, tsMuxer, FFmpeg are all enabled. Debug log reports that it's using mencoder.
5: Film stops after 8min 27sec. Haven't tried with other files. mencoder exists with return code -1073741819
6: Debug log:
7: Text output:
Code: Select all
Unique ID                                : 183054665153475304653438204613807342802 (0x89B70BCDB9F5128091AE035D440084D2)
Complete name                            : K:\Anime\Persona 4\[Commie] Persona 4 - 01v2 [D13B7533].mkv
Format                                   : Matroska
Format version                           : Version 2
File size                                : 258 MiB
Duration                                 : 24mn 29s
Overall bit rate                         : 1 475 Kbps
Encoded date                             : UTC 2012-02-06 22:47:28
Writing application                      : mkvmerge v5.0.1 ('Es ist Sommer') built on Oct  9 2011 11:55:43
Writing library                          : libebml v1.2.2 + libmatroska v1.3.0
Attachment                               : Yes / Yes / Yes / Yes / Yes / Yes

ID                                       : 1
Format                                   : AVC
Format/Info                              : Advanced Video Codec
Format profile                           : High 10@L5.0
Format settings, CABAC                   : Yes
Format settings, ReFrames                : 16 frames
Muxing mode                              : Header stripping
Codec ID                                 : V_MPEG4/ISO/AVC
Duration                                 : 24mn 29s
Width                                    : 1 280 pixels
Height                                   : 720 pixels
Display aspect ratio                     : 16:9
Frame rate mode                          : Constant
Frame rate                               : 23.976 fps
Color space                              : YUV
Chroma subsampling                       : 4:2:0
Bit depth                                : 10 bits
Scan type                                : Progressive
Writing library                          : x264 core 118 r2085+614 d1cc25d
Encoding settings                        : cabac=1 / ref=16 / deblock=1:-1:-1 / analyse=0x3:0x133 / me=umh / subme=10 / psy=1 / fade_compensate=0.80 / psy_rd=0.60:0.05 / mixed_ref=1 / me_range=24 / chroma_me=1 / trellis=2 / 8x8dct=1 / cqm=0 / deadzone=21,11 / fast_pskip=1 / chroma_qp_offset=-3 / threads=12 / sliced_threads=0 / nr=0 / decimate=1 / interlaced=0 / bluray_compat=0 / constrained_intra=0 / fgo=0 / bframes=10 / b_pyramid=2 / b_adapt=2 / b_bias=0 / direct=3 / weightb=1 / open_gop=0 / weightp=2 / keyint=250 / keyint_min=23 / scenecut=40 / intra_refresh=0 / rc_lookahead=40 / rc=crf / mbtree=1 / crf=19.0 / qcomp=0.80 / qpmin=0 / qpmax=81 / qpstep=4 / ip_ratio=1.40 / aq=2:1.00
Language                                 : English
Default                                  : Yes
Forced                                   : No

ID                                       : 2
Format                                   : AAC
Format/Info                              : Advanced Audio Codec
Format profile                           : LC
Codec ID                                 : A_AAC
Duration                                 : 24mn 29s
Channel(s)                               : 2 channels
Channel positions                        : Front: L R
Sampling rate                            : 48.0 KHz
Compression mode                         : Lossy
Title                                    : Commie
Language                                 : Japanese
Default                                  : Yes
Forced                                   : No

ID                                       : 3
Format                                   : ASS
Codec ID                                 : S_TEXT/ASS
Codec ID/Info                            : Advanced Sub Station Alpha
Compression mode                         : Lossless
Default                                  : Yes
Forced                                   : No

00:00:00.033                             : en:Intro
00:01:52.029                             : en:OP
00:03:21.451                             : en:Part A
00:14:43.816                             : en:Part B
00:22:44.654                             : en:ED
00:24:14.631                             : en:Preview

I've been mostly using an older version of tversity, for whatever that's worth, but switched to PMS for its subtitle capabilities. It's really nice! But this is the first video I've tried to watch with it in a fairly long time. I don't think I'm using a custom rendering profile; haven't tweaked any of the program's settings other than the subtitle stuff.

Any help on this? I'd really rather not have to hook up my PC's speakers every time I want to watch one of these.
Posts: 4
Joined: Sat Dec 01, 2012 6:46 am

Re: MKV cuts out after 8m27s

Postby resque1980 » Tue Dec 11, 2012 10:25 pm

I am also having the same issue.

What information and log files should i post that would help solve this problem
Posts: 6
Joined: Tue Dec 11, 2012 10:21 pm

Re: MKV cuts out after 8m27s

Postby ihatehume » Wed Dec 12, 2012 6:31 pm

I'm also having similar issues with .mkvs streaming through an XBOX; similar specs on my PC and I only use it to stream video over a wired connection; Windows 7. Happens with 1.71.0 and 1.72.0. 1.70.0 will play the file all the way through. Seems to be about 10 minutes in (don't have an exact time). It's worth noting that when the file stops, there is no resume option, almost like it considers the file completed. I am also using it for commie mkvs :D

I've tried with several .mkvs from different sites, same problem. Looks like it's producing this error over and over in the debug file (attached).
DEBUG 2012-12-12 19:11:01.844 [Thread-21] [wmv2 @ 0113f220]warning, clipping 1 dct coefficients to -255..255

I too also get "mencoder has a return code -1073741819" statement int he trace file.
Debug file with DEBUG 2012-12-12 19:11:01.844 [Thread-21] [wmv2 @ 0113f220]warning, clipping 1 dct coefficients to -255..255
(168.14 KiB) Downloaded 137 times
Posts: 13
Joined: Wed Dec 12, 2012 6:25 pm

Re: MKV cuts out after 8m27s

Postby ihatehume » Mon Dec 17, 2012 3:48 am

anyone else had this issue?
Posts: 13
Joined: Wed Dec 12, 2012 6:25 pm

Re: MKV cuts out after 8m27s

Postby Lakmir » Sat Dec 22, 2012 4:43 am

I can actually report that this occurs on multiple videos, always at the same point in each video (but not at the same time from video to video.) I can also report that these files stream to my PS3 without the interruption seen on the 360.
Posts: 4
Joined: Sat Dec 01, 2012 6:46 am

Re: MKV cuts out after 8m27s

Postby Slab » Sat Dec 22, 2012 10:43 pm

Same issue, although I cannot say at what point the MKV file quits, It just stops & takes me back to the Xbox title screen for the movie. Some MKV = no problem. Others = quit at same point in the individual file. Also, no fast forward, rewind, etc.

Still new to PMS so working through it...
Posts: 1
Joined: Sat Dec 22, 2012 10:39 pm

Re: MKV cuts out after 8m27s

Postby mazey » Sat Dec 22, 2012 11:32 pm

seems this might be a problem with mencoder u can try a newer version to see if it fixes the issue, find it here just copy them over the old mencoder files in the c:\program files x86\ps3 media server\win32 folder.

pms comes with sb41, sb46 is available now.
Posts: 786
Joined: Sat Oct 24, 2009 9:07 am

Re: MKV cuts out after 8m27s

Postby ihatehume » Sat Dec 29, 2012 10:32 pm

Ahhh... I tried copying it over the files but that just seemed to break it (get an error now when I try to play files on the xbox). On the other hand, the release notes look promising to fix the problem including fixing a bunch of memory leaks...

2012-12-21 - SB46

Synchronised with r35701, which:
Makes ASS/SSA subtitle rendering up to 3.5x faster
Improves sync for files with negative timestamps
Updated FFmpeg to r48065 (cfa5300), which
Improves AC-3 audio buffering
Fixes memory leaks
Updated libass to r775 (7e45532)
Updated GMP to 5.1.0
Updated opus to 1.0.2

2012-12-05 - SB45

Synchronised with r35596, which:
Fixed alpha for ASS subtitles
Fixed audio stuttering/repeating bug
Updated FFmpeg to r47416 (d913883)
Updated fontconfig to 2.10.2, which:
Improves permissions handling on Windows
Removes incorrectly categorised fonts
Added enca 1.13

2012-12-01 - SB44

Fixed subtitle bug on certain CPUs
Improved audio/video sync in some cases
Synchronised with r35518, which:
Fixes memory leaks
Improves support for avi files
Updated FFmpeg to r47297 (bc16031), which:
Supports more rare avi files

2012-11-22 - SB43

Synchronised with r35438, which:
Improves WAV support
Detects more CPU types
Faster ASS/SSA subtitle rendering (up to 220%)
Fixes crashes
Fixes a lot of memory leaks
Streaming improvements
Faster performance on 64-bit systems
Updated FFmpeg to r46973 (8e69579), which:
Improves support for demuxing DTS-HD
Improves opus support
Improves GCC compatibility when compiled with MinGW
Improves URL-handling
Fixes dozens of memory leaks
Improves audio sync for some AVI files using MP3 audio
Fixes parsing of old lossless H.264 profile
Improves FPS detection
Improved sync for interlaced video
Corrected blu-ray bitrate calculation
Supports WAV metadata
Automatically sets VBV buffer size for MPEG-1, 2 and 4 when none is specified
Allows mid-stream channel layout change for flac audio
Supports 24-bit flac encoding
Improves audio sync when seeking
Improves support for some CPU-optimisations
Fixed a lot of bugs with the implementation of h264
Updated x264 to r2230

2012-10-30 - SB42

Rolled back to r35226 until the bugs caused by FFmpeg's planar audio changes are fixed
Rolled back FFmpeg to r44967 (82db8ee) (pre-planar)
Updated libass to 0.10.1
Added SDL 1.2.15
Changed from shared to static pthreads
Stripped executables for smaller filesize
Disabled vidix support (don't think anyone is using it? Let me know if you want it)
Posts: 13
Joined: Wed Dec 12, 2012 6:25 pm

Re: MKV cuts out after 8m27s

Postby mazey » Sat Dec 29, 2012 10:51 pm

do u have the cache enabled in navigation/share settings, you might need to reset it and rescan. since ure upgrading from a really old version. id try resetting all the settings also go in c:\programdata\pms and delete pms.conf relaunch pms.
Posts: 786
Joined: Sat Oct 24, 2009 9:07 am

Re: MKV cuts out after 8m27s

Postby ihatehume » Sat Dec 29, 2012 11:02 pm

By the way, thanks so much for taking the time to help out with this issue!

Ok - just tried that. Made sure to clear the cashe, then disabled. Plus I deleted the c:\programdata\pms folder then restarted. Still no luck getting the xbox to play the file.
Posts: 13
Joined: Wed Dec 12, 2012 6:25 pm


Return to General Help and Support

Who is online

Users browsing this forum: Google [Bot] and 3 guests