mp4 and m4v files identified as image/jpeg

For help and support with issues specific to Mac OS X
Forum rules
Please make sure you follow the Problem Reporting Guidelines before posting if you want a reply.

mp4 and m4v files identified as image/jpeg

Postby passchieri » Thu Dec 20, 2012 1:44 pm

Many of my mp4 video files show up as type image/jpeg when I use the browser of the MediaHouse app on my Samsung Galaxy SII tablet. If I then try to play any of these movies, it fails, because it tries to open them as an image. On my HTC One X I use the app PlugPlayer. Although this app does not show explicitly the content type of a media file, it does not play exactly the videos that are incorrectly identified as images.

Some mp4 video files are identified correctly as video, and actually play perfectly on both renderer devices. Furthermore, if a first let the renderer get the info about the content type, and then put a misidentified file in the place of a correctly identified file, it plays perfectly fine, which suggests to me that the problem is indeed only in the initial identification of the content type.

I currently use
PMS 1.72.0, build d9fd0a44c
MacOs 10.6.8, 3.06 GHz Intel Core 2 Duo processor, 8GB 1067 MHz DDR3 memory
java version "1.6.0_33"
Java(TM) SE Runtime Environment (build 1.6.0_33-b03-424-10M3720)
Java HotSpot(TM) 64-Bit Server VM (build 20.8-b03-424, mixed mode)

I do not have this problem with PMS 1.5 in combination with exactly the same video files and renderer devices. All files are not transcoded, so that can not be the problem. I do not see any messages regarding the media type in the debug.log file, but will attach it anyway.

Anyone with an idea what has changed after PMS 1.5 that can cause this?
Attachments
debug.log.gz
debug.log file
(3.81 KiB) Downloaded 65 times
passchieri
 
Posts: 1
Joined: Thu Dec 20, 2012 1:13 pm

Return to Mac OS X Support

Who is online

Users browsing this forum: No registered users and 4 guests