Samsung AllShare uPnP/DLNA

Discuss alternative media renderers (not PS3) supported by PS3 Media Server (e.g. Xbox 360, TVs &c.)

Re: Samsung AllShare uPnP/DLNA

Postby rTn » Sat Oct 13, 2012 12:54 pm

Hi there,

I recently bought the new Samsung ES8000, wich has the DLNA support (Allshare).
After a little search trough the internet, i was recommeded to install PS3 Media server on my laptop so i could stream my movies to my TV.
I installed the latest version from the PS3 Media server software. Everything is going well so far...
The software detects my tv, on my tv i can see all my movie maps and it can play .avi, .mkv files.

So that's pretty good. The only thing that isn't working are the subtitles. In all my movie maps are .srt files included that carries the same name as the .mkv or .avi file.
When i play them on my pc with VLC it plays the subtitles but when i start the movie on my samsung tv using the streaming software it won't play subtitles.
In some of the .mkv's i got, english subtitles are included. So the play the english subtitles. i recently discoverd that i need to extract those subtitles out of the .mkv
So that problem is also solved.

Then their is only one problem to solve and that the one of the .srt files that won't work. i'm using the latest config file from the first post.
Can someone give me advice?
rTn
 
Posts: 2
Joined: Sat Oct 13, 2012 12:45 pm

Re: Samsung AllShare uPnP/DLNA

Postby slooff » Sat Oct 13, 2012 5:19 pm

Hi rTn, maybe you can share the srt file and your PMS.conf file so we can have a closer look?
opensuse 12.1, latest PMS build, mplayer/mencoder with static libraries, movieinfo, pmsencoder, edl plugin, PS3, XBOX, Samsung ES7000
slooff
 
Posts: 54
Joined: Fri Dec 11, 2009 11:28 am

Re: Samsung AllShare uPnP/DLNA

Postby rTn » Sun Oct 14, 2012 12:23 am

The srt files are just files that i download from subtitles sites like podnapisi or ondertitel.com
The are not edited or something. I just download the correct subtitle for the movie. if the movie is video.720P.BRRIP-Xvid.avi then my srt file is video.720P.BRRIP-Xvid.srt

this is my allshare config..

Code: Select all
# ps3mediaserver renderer profile for Samsung AllShare
#http://ps3mediaserver.org/forum/viewtopic.php?f=15&t=8889&start=0
#Conf: Version 1.4.1

RendererName=Samsung AllShare
RendererIcon=samsung.png
UserAgentSearch=notused
UserAgentAdditionalHeader=X-AV-Client-Info
UserAgentAdditionalHeaderSearch=(\w{3}_\w{3}_\w{2}-\w{2}\d{2}\w\d{4}/\d.\d)|(\w{3}_\w{3}_\[\w{2}\]-\w{2}\d{2}\w\d{4}/\d.\d)|(\w{3}_\w{3}_\w{2}-\w{2}\d{2}\w\d{3}/\d.\d)|(\w{3}_\w{3}_\[\w{2}\]-\w{2}\d{2}\w\d{3}/\d.\d)
Video=true
Audio=true
Image=true
SeekByTime=false
TranscodeVideo=MPEGAC3
TranscodeAudio=PCM
DefaultVBVBufSize=true
MuxH264ToMpegTS=true
MuxDTSToMpeg=true
WrapDTSIntoPCM=false
MuxLPCMToMpeg=true
MaxVideoBitrateMbps=25
MaxVideoWidth=0
MaxVideoHeight=0
MimeTypesChanges=audio/wav=audio/L16|video/x-matroska=video/avi|video/x-flv=video/mp4|audio/mp3=audio/L16|video/mp4=video/mpeg
TranscodeExtensions=flv,wav
StreamExtensions=mkv,mp3,mp4,avi,mov


and this is my PMS.CONFIG

Code: Select all
thumbnails = true
image_thumbnails = true
language = en
folders = D:\\Warez\\Movies
alternativeffmpegpath = C:\\Program Files (x86)\\PS3 Media Server\\win32\\dvrms\\ffmpeg_MPGMUX.exe
mencoder_ass = true
mencoder_fontconfig = true
mencoder_ass_defaultstyle = true
uuid = 97da0e64-fcce-41a8-8f8f-32e4cc2bb9d2
hide_transcode_folder = true
audio_thumbnails_method = 0
mencoder_audiosublangs = loc,off;eng,off;
mencoder_disablesubs = false
rTn
 
Posts: 2
Joined: Sat Oct 13, 2012 12:45 pm

Re: Samsung AllShare uPnP/DLNA

Postby slooff » Wed Oct 17, 2012 5:33 pm

I think I don't understand completely what your problem is. Can you play mkv with external srt or not, or do you only have issues with a few srt files? Also, can you see the subtitles when browsing the TRANSCODE folder?
opensuse 12.1, latest PMS build, mplayer/mencoder with static libraries, movieinfo, pmsencoder, edl plugin, PS3, XBOX, Samsung ES7000
slooff
 
Posts: 54
Joined: Fri Dec 11, 2009 11:28 am

Re: Samsung AllShare uPnP/DLNA

Postby mc_eddy » Thu Oct 18, 2012 4:10 pm

Hi on my Samsung ES6710 i have an problem with the Transcoding,
my NW (Win7 Ult. 64 bit ) with java 7 32 bit and PS3 MS V1.70.1 everything will work fine.

But when i try to decode an WMF file the Transcodingbuffer will be filled with 10-40 MB and then jump to -95.291 MB.
The TV will only show Loading and then tell me that possible the file is not correct to play.
Then the Screen gets Black and the Transcodingbuffer is Empty.


What can i do to make it work ?

As Transcoder i use FFmpeg and FFmpeg Audio, but other Engines will also fail.


the file info :

General
Unique ID : 179111599709465259870260521324082422732 (0x86BFA3AAEB142AD98CBA09706510E3CC)
Complete name : D:\720p.wmv
Format : Matroska
Format version : Version 2
File size : 3.85 GiB
Duration : 2h 40mn
Overall bit rate : 3 431 Kbps
Encoded date : UTC 2012-09-01 23:26:22
Writing application : mkvmerge v5.7.0 ('The Whirlwind') built on Jul 8 2012 20:08:51
Writing library : libebml v1.2.3 + libmatroska v1.3.0

Video
ID : 1
Format : AVC
Format/Info : Advanced Video Codec
Format profile : High@L3.2
Format settings, CABAC : Yes
Format settings, ReFrames : 4 frames
Codec ID : V_MPEG4/ISO/AVC
Duration : 2h 40mn
Bit rate : 3 044 Kbps
Width : 1 280 pixels
Height : 720 pixels
Display aspect ratio : 16:9
Frame rate mode : Constant
Frame rate : 50.000 fps
Color space : YUV
Chroma subsampling : 4:2:0
Bit depth : 8 bits
Scan type : Progressive
Bits/(Pixel*Frame) : 0.066
Stream size : 3.34 GiB (87%)
Writing library : x264 core 125 r2208 d9d2288
Encoding settings : cabac=1 / ref=3 / deblock=1:0:0 / analyse=0x3:0x111 / me=hex / subme=7 / psy=1 / psy_rd=1.00:0.00 / mixed_ref=1 / me_range=16 / chroma_me=1 / trellis=1 / 8x8dct=1 / cqm=0 / deadzone=21,11 / fast_pskip=1 / chroma_qp_offset=-2 / threads=3 / lookahead_threads=1 / sliced_threads=0 / nr=0 / decimate=1 / interlaced=0 / bluray_compat=0 / constrained_intra=0 / bframes=3 / b_pyramid=2 / b_adapt=1 / b_bias=0 / direct=1 / weightb=1 / open_gop=0 / weightp=2 / keyint=500 / keyint_min=50 / scenecut=40 / intra_refresh=0 / rc_lookahead=40 / rc=2pass / mbtree=1 / bitrate=3044 / ratetol=1.0 / qcomp=0.60 / qpmin=0 / qpmax=69 / qpstep=4 / cplxblur=20.0 / qblur=0.5 / ip_ratio=1.40 / aq=1:1.00
Default : Yes
Forced : No

Audio
ID : 2
Format : AC-3
Format/Info : Audio Coding 3
Mode extension : CM (complete main)
Format settings, Endianness : Big
Codec ID : A_AC3
Duration : 2h 40mn
Bit rate mode : Constant
Bit rate : 384 Kbps
Channel(s) : 2 channels
Channel positions : Front: L R
Sampling rate : 48.0 KHz
Bit depth : 16 bits
Compression mode : Lossy
Stream size : 442 MiB (11%)
Default : Yes
Forced : No
mc_eddy
 
Posts: 2
Joined: Wed Oct 17, 2012 9:37 pm

Re: Samsung AllShare uPnP/DLNA

Postby ginjaninjanick » Sun Oct 28, 2012 7:22 pm

rTn wrote:Hi there,

I recently bought the new Samsung ES8000, wich has the DLNA support (Allshare).
After a little search trough the internet, i was recommeded to install PS3 Media server on my laptop so i could stream my movies to my TV.
I installed the latest version from the PS3 Media server software. Everything is going well so far...
The software detects my tv, on my tv i can see all my movie maps and it can play .avi, .mkv files.

So that's pretty good. The only thing that isn't working are the subtitles. In all my movie maps are .srt files included that carries the same name as the .mkv or .avi file.
When i play them on my pc with VLC it plays the subtitles but when i start the movie on my samsung tv using the streaming software it won't play subtitles.
In some of the .mkv's i got, english subtitles are included. So the play the english subtitles. i recently discoverd that i need to extract those subtitles out of the .mkv
So that problem is also solved.

Then their is only one problem to solve and that the one of the .srt files that won't work. i'm using the latest config file from the first post.
Can someone give me advice?


I have found that the ES'es are able to select subtitle track or switch off subtitle track natively when the subtitle track is embeded into the MKV. Have you considered using mkvmerge to embed the subtitle track natively? but whilst on the subject have you found away that the PS3MS can overlay subtitles that are not embedded?
ginjaninjanick
 
Posts: 20
Joined: Sun Apr 25, 2010 8:08 pm

Re: Samsung AllShare uPnP/DLNA

Postby kalivas » Wed Oct 31, 2012 10:01 pm

mc_eddy wrote:Hi on my Samsung ES6710 i have an problem with the Transcoding,
my NW (Win7 Ult. 64 bit ) with java 7 32 bit and PS3 MS V1.70.1 everything will work fine.

But when i try to decode an WMF file the Transcodingbuffer will be filled with 10-40 MB and then jump to -95.291 MB.
The TV will only show Loading and then tell me that possible the file is not correct to play.
Then the Screen gets Black and the Transcodingbuffer is Empty.


What can i do to make it work ?



I'm having the exact same problem on my ES7100. Works fine on the PS3 however no transcoded files are playing on the TV. Mostly use mEncoder but I've tried all the different options, only says "loading" then after about 30 seconds it closes. Media server shows a negative buffer as well.

Any solutions?
kalivas
 
Posts: 2
Joined: Wed Oct 31, 2012 8:54 pm

Re: Samsung AllShare uPnP/DLNA

Postby Nambit » Fri Nov 02, 2012 11:18 pm

Hi! First I'd like to say this thing is amazing and I'm so happy it works for the most part.

However, I'm having issues with transcoding on my Samsung ES8000 (allshare). Seems I get a blank screen and it just
sits there. I mainly need transcoding for 10-bit .mkv files (japanese anime). I modified the config file to transcode .mp4
files instead of streaming, and figured I can rename the 10-bit files as .mp4 so PSM will trigger transcoding. Well, it's going
blank and sitting there.

Before all this, I tried transcoding everything (ie: no streaming) by de-selecting the "Remux videos with tsMuxer
when possible instead of transcoding" but it still attempts to stream even though the samsung doesn't support 10-bit.
Basically I want to force transcoding and it's not working for me (too bad PSM doesn't detect 10-bit and transcode automatically).
Help!
Nambit
 
Posts: 6
Joined: Fri Nov 02, 2012 11:12 pm

Re: Samsung AllShare uPnP/DLNA

Postby madmaxx » Sat Nov 03, 2012 12:31 am

Hi, I just setup my Samsung ES7000 and based on my huge research I installed PMS to my Mac to use UPNP streaming. However I'm facing some trouble in subtitles.

I was able to work .mkv streaming with subtitles but some Turkish characters are rendered incorrectly. I read earlier messages and the suggested solution was to set Codepage for non-Unicode subtitles to Windows-Turkish (cp1254). However, this doesn't solution work when streaming Samsung AllShare. I also played with other settings about subtitle but none seemed to work for Samsung TV.

I'm attaching my the subtitle link and most noticeably the Turkish character 'ı' or 'İ' is rendered weirdly like a 'Y' with an accent. If you can test in your system, or come with a solution I'll be much appreciated. Thanks.

http://pastebin.com/DADTZnsM
madmaxx
 
Posts: 1
Joined: Sat Nov 03, 2012 12:04 am

Re: Samsung AllShare uPnP/DLNA

Postby Nambit » Fri Nov 09, 2012 5:21 am

Seriously, is there something wrong with PMS and Samsung's ES8000 series?
Every time I try to transcode something (forced), the TV will show loading and
sit there forever... I've seen the transfer rate show a ridiculous number and the
TV hangs (doesn't respond to anything). One time I got fed up and unplugged the
TV only to see my system settings had to be re-entered (including clock). Something
weird is going on with it. I see someone else experiences this problem. I tried it with
my brother's D6500 (last year's model) and it transcodes fine. HELP!!
Nambit
 
Posts: 6
Joined: Fri Nov 02, 2012 11:12 pm

PreviousNext

Return to Alternative Media Renderers

Who is online

Users browsing this forum: No registered users and 3 guests