MKV with DTS - How to stop audio transcode?

For help and support with PS3 Media Server in general
Forum rules
Please make sure you follow the Problem Reporting Guidelines before posting if you want a reply.

MKV with DTS - How to stop audio transcode?

Postby morpheleon » Mon Oct 29, 2012 12:58 am

For some reason I am unable to get my MKV files to pass through the DTS signal unmolested. I have some WAV files that are DTS encoded and those are working well.

The MKV's when I play them are coming through to the PS3 as Dolby Digital instead of their native DTS streams. So I think it's doing a forced AC3 re-encode, but I can't figure out how to stop that. I have the check mark for "Keep DTS Track", but that seems to be ignored or something. I'm using PMS 1.7.0 on Ubuntu Linux.
morpheleon
 
Posts: 2
Joined: Sun Feb 14, 2010 12:58 am

Re: MKV with DTS - How to stop audio transcode?

Postby ExSport » Thu Nov 01, 2012 4:14 pm

There is another settings on renderer level so check your renderer.conf file for:
Code: Select all
TranscodeVideo=MPEGPSAC3
TranscodeAudio=WAV
MuxDTSToMpeg=false
WrapDTSIntoPCM=false

PS3 should have "WrapDTSIntoPCM=true" to obey firmware limitation (due to missing DTS license)
Another renderers should use "MuxDTSToMpeg" if they support DTS.
WrapDTSToMpeg is hack to fool PS3 so DTS is played. It is wraped to LPCM2.0 which PS3 automatically pass to receiver which play it (it receiver has DTS support)
ExSport
 
Posts: 2168
Joined: Mon Jan 19, 2009 5:40 pm


Return to General Help and Support

Who is online

Users browsing this forum: Bing [Bot], Yahoo [Bot] and 15 guests