Still Stuttering - way too frustrating!

For help and support with PS3 Media Server in general
Forum rules
Please make sure you follow the Problem Reporting Guidelines before posting if you want a reply.

Still Stuttering - way too frustrating!

Postby DevlshOne » Fri Oct 19, 2012 12:02 am

This is a continuation of thread viewtopic.php?f=6&t=15390&start=10#p74390, since I was scolded about adding to it.

I must say, I understand that this software is free (to a point), but there are some real problems! First of all, the answer to nearly every VERY SPECIFIC (as demanded by the problem reporting guidelines) problem is "READ THE FAQ" or "THE FAQ IS YOUR FRIEND". I'm pretty sure that anyone putting even a minute effort into getting this software to work has viewed the FAQ - over and over and over. So, when that doesn't work, the answer is "READ THESE 400 OTHER POSTS". Really? If your new car had to be tinkered with every day to get it to act right, would you "READ THESE 400 POSTS" or would you expect the manufacturer to fix it? Sure, everyone's network and computer configuration is different but shouldn't the software be intelligent enough to recognize that and auto-tune and even auto-correct some bad settings? I've been a programmer for 20 years and this app looks like all it does is say "hey, Java and MEncoder, here's a file, here's what I'm GUESSING it is comprised of, would you serve it to IP address X.X.X.X". Am I right? Put a little effort into it, sir, build some intelligence into this app and then instead of asking for $15 donations (YEP, I donated), you can charge a $39.95 license fee. How long have you been working on this app? Four years? Five? And you're on version 1.7? Egads. Can I have the source code, since you're not charging for it, and I'll build some intelligence into it myself. You can't expect the hundred, maybe thousands, of people that run this app to sit and fiddle with their settings for hours on end every time there is a new version.

As for the stuttering issue I am having. I've read all the posts, the FAQ three times over and spent countless hours RDP'd into my WHS2011 box changing settings and restarting the PS3M server. My WHS2011x64 box is a custom-built AMD Athlon 7850 Black Edition Dual Core on an MSI 785GTM motherboard with 4GB of Crucial PC2-6400 RAM. I've got three GB NIC cards in the machine as well as the onboard GB NIC running through a D-Link N150 router and two Netgear GB 8-port switches. My renderers consist of two PS3s, an Android Excite 10 Tablet and a Samsung GSIII for video/audio. as well as an Onkyo HT-RC360 receiver for audio only. Only my tablet and my phone are wireless, everything is hard wired with CAT6E double shielded cables run through my attic.
My problems are strictly video related. As stated before, I get severe stutter which can only be relieved by pausing playback and waiting for the PS3 to "catch up". I've changed duplexes and speeds on the console. I've tweaked the bandwidth on my PS3MS to almost exactly what the debug.log quoted ~60 Mbps (I guess the PS3's NIC is a major bottleneck). I've adjusted buffers up and down. Not a single video file works properly. Not BluRay MKV, M2TS, DVD MKV, not even AVI! Audio... no problems, clean as a whistle and quite beautiful to hear through this receiver. To keep inline with the stringent problem reporting, my PS3 says this particular file is Dolby Digital 5.1Ch @ 48KHz (640kbps), MPEG-2 (30Mbps). Debug log excerpt:

Code: Select all
INFO  2012-10-18 18:24:29.246 [main] Loading MediaInfo library
INFO  2012-10-18 18:24:29.637 [main] Loaded MediaInfoLib - v0.7.58
INFO  2012-10-18 18:24:29.668 [main] Loading renderer configurations from C:\Program Files (x86)\PS3 Media Server\renderers
INFO  2012-10-18 18:24:29.709 [main] Loading configuration file: Android.conf
DEBUG 2012-10-18 18:24:29.710 [main] Base path set to file:///C:/Program%20Files%20(x86)/PS3%20Media%20Server/renderers/Android.conf
INFO  2012-10-18 18:24:29.713 [main] Loading configuration file: OnkyoHT-RC360.conf
DEBUG 2012-10-18 18:24:29.715 [main] Base path set to file:///C:/Program%20Files%20(x86)/PS3%20Media%20Server/renderers/OnkyoHT-RC360.conf
INFO  2012-10-18 18:24:29.728 [main] Loading configuration file: PS3.conf
DEBUG 2012-10-18 18:24:44.332 [Thread-24] Can't open VMG info!
DEBUG 2012-10-18 18:24:44.332 [Thread-24] No stream found to handle url dvd://1
DEBUG 2012-10-18 18:24:48.885 [UPNP-AliveMessageSender] Sending ALIVE...
INFO  2012-10-18 18:24:50.223 [New I/O server worker #1-2] The file G:\ServerFolders\BluRay\BD.MKV\Madagascar 3.mkv was badly parsed. It will be hidden
DEBUG 2012-10-18 18:24:52.399 [New I/O server worker #1-4] Starting "C:\Program Files (x86)\PS3 Media Server\win32\mplayer.exe" -ss 1.0 -quiet "G:\ServerFolders\BluRay\BD.MKV\Dr Seus' The Lorax 3D.mkv" -msglevel all=4 -vf scale=320:-2,expand=:180 -frames 1 -vo jpeg:outdir=mplayer_thumbs:subdirs="2463255" -nosound
DEBUG 2012-10-18 18:24:52.529 [Thread-28] MPlayer SB32 (C) 2000-2012 MPlayer Team
DEBUG 2012-10-18 18:24:52.529 [Thread-28] Custom build by SubJunk,
DEBUG 2012-10-18 18:24:52.529 [Thread-28]
DEBUG 2012-10-18 18:24:52.548 [Thread-28] getch2: 6 can't get number of input events  [disabling console input]
DEBUG 2012-10-18 18:24:52.548 [Thread-28]
DEBUG 2012-10-18 18:24:52.548 [Thread-28] Playing G:\ServerFolders\BluRay\BD.MKV\Dr Seus' The Lorax 3D.mkv.
DEBUG 2012-10-18 18:24:52.670 [Thread-28] libavformat version 54.3.100 (internal)
DEBUG 2012-10-18 18:24:53.191 [Thread-28] libavformat file format detected.
DEBUG 2012-10-18 18:24:53.266 [DVDISO Failsafe] Stopping process: mplayer.exe-2
INFO  2012-10-18 18:24:53.436 [New I/O server worker #1-3] Starting transcode/remux of A Turtle's Tale - Sammy's Adventure.mkv
DEBUG 2012-10-18 18:24:53.563 [New I/O server worker #1-3] Starting "C:\Program Files (x86)\PS3 Media Server\win32\ffmpeg.exe" -i "G:\ServerFolders\BluRay\BD.MKV\A Turtle's Tale - Sammy's Adventure.mkv" -vframes 1 -vcodec copy -f h264 -vbsf h264_mp4toannexb -an -y pipe:
DEBUG 2012-10-18 18:24:53.668 [New I/O server worker #1-3] Attaching thread: ffmpeg.exe-5
DEBUG 2012-10-18 18:24:53.875 [Thread-30] ffmpeg version N-35509-gfd36cbf-Sherpya, Copyright (c) 2000-2011 the FFmpeg developers
DEBUG 2012-10-18 18:24:53.875 [Thread-30]   built on Dec  7 2011 06:17:11 with gcc 4.6.2
DEBUG 2012-10-18 18:24:53.875 [Thread-30]   libavutil    51. 30. 0 / 51. 30. 0
DEBUG 2012-10-18 18:24:53.875 [Thread-30]   libavcodec   53. 41. 0 / 53. 41. 0
DEBUG 2012-10-18 18:24:53.875 [Thread-30]   libavformat  53. 24. 0 / 53. 24. 0
DEBUG 2012-10-18 18:24:53.875 [Thread-30]   libavdevice  53.  4. 0 / 53.  4. 0
DEBUG 2012-10-18 18:24:53.875 [Thread-30]   libavfilter   2. 51. 0 /  2. 51. 0
DEBUG 2012-10-18 18:24:53.875 [Thread-30]   libswscale    2.  1. 0 /  2.  1. 0
DEBUG 2012-10-18 18:24:53.875 [Thread-30]   libpostproc  51.  2. 0 / 51.  2. 0
DEBUG 2012-10-18 18:24:53.875 [Thread-30]
DEBUG 2012-10-18 18:24:53.876 [Thread-30] Seems stream 0 codec frame rate differs from container frame rate: 47.95 (5994/125) -> 23.98 (24000/1001)
DEBUG 2012-10-18 18:24:53.876 [Thread-30] Input #0, matroska,webm, from 'G:\ServerFolders\BluRay\BD.MKV\A Turtle's Tale - Sammy's Adventure.mkv':
DEBUG 2012-10-18 18:24:53.876 [Thread-30]   Duration: 01:25:43.76, start: 0.000000, bitrate: 10946 kb/s
DEBUG 2012-10-18 18:24:53.876 [Thread-30]     Stream #0:0(eng): Video: h264 (High), yuv420p, 1920x1080, SAR 1:1 DAR 16:9, 23.98 fps, 23.98 tbr, 1k tbn, 47.95 tbc (default)
DEBUG 2012-10-18 18:24:53.876 [Thread-30]     Stream #0:1(eng): Audio: dts (DTS), 48000 Hz, 5.1(side), s16, 1536 kb/s (default)
DEBUG 2012-10-18 18:24:53.876 [Thread-30] Output #0, h264, to 'pipe:':
DEBUG 2012-10-18 18:24:53.876 [Thread-30]   Metadata:
DEBUG 2012-10-18 18:24:53.876 [Thread-30]     encoder         : Lavf53.24.0
DEBUG 2012-10-18 18:24:53.876 [Thread-30]     Stream #0:0(eng): Video: h264, yuv420p, 1920x1080 [SAR 1:1 DAR 16:9], q=2-31, 23.98 fps, 90k tbn, 23.98 tbc (default)
DEBUG 2012-10-18 18:24:53.876 [Thread-30] Stream mapping:
DEBUG 2012-10-18 18:24:53.876 [Thread-30]   Stream #0:0 -> #0:0 (copy)
DEBUG 2012-10-18 18:24:53.876 [Thread-30] Press [q] to stop, [?] for help
DEBUG 2012-10-18 18:24:53.876 [Thread-30] frame=    1 fps=  0 q=-1.0 Lsize=       1kB time=00:00:00.-4 bitrate=-224.8kbits/s   
DEBUG 2012-10-18 18:24:53.955 [Thread-30]
DEBUG 2012-10-18 18:24:53.955 [Thread-30] video:1kB audio:0kB global headers:0kB muxing overhead 3.259912%
DEBUG 2012-10-18 18:24:54.271 [DVDISO Failsafe] Stopping process: mplayer.exe-3
DEBUG 2012-10-18 18:24:54.598 [Thread-28] [lavf] stream 0: video (h264), -vid 0
DEBUG 2012-10-18 18:24:54.599 [Thread-28] [lavf] stream 1: audio (ac3), -aid 0
DEBUG 2012-10-18 18:24:54.600 [Thread-28] VIDEO:  [H264]  1920x1080  0bpp  23.976 fps    0.0 kbps ( 0.0 kbyte/s)
DEBUG 2012-10-18 18:24:54.611 [Thread-28] Clip info:
DEBUG 2012-10-18 18:24:54.612 [Thread-28]  title: DR_SEUSS_THE_LORAX_G71.Title800.Bluray3DRiphalf
DEBUG 2012-10-18 18:24:54.612 [Thread-28]  creation_time: 2012-07-29 13:56:43
DEBUG 2012-10-18 18:24:54.612 [Thread-28] Load subtitles in G:\ServerFolders\BluRay\BD.MKV\
DEBUG 2012-10-18 18:24:54.690 [Thread-28] jpeg: Progressive JPEG disabled.
DEBUG 2012-10-18 18:24:54.691 [Thread-28] jpeg: Baseline JPEG enabled.
DEBUG 2012-10-18 18:24:54.768 [Thread-28] Opening video filter: [expand h=180]
DEBUG 2012-10-18 18:24:54.819 [Thread-28] Expand: -1 x 180, -1 ; -1, osd: 0, aspect: 0.000000, round: 1
DEBUG 2012-10-18 18:24:54.819 [Thread-28] Opening video filter: [scale w=320 h=-2]
DEBUG 2012-10-18 18:24:54.819 [Thread-28] ==========================================================================
DEBUG 2012-10-18 18:24:54.929 [New I/O server worker #1-3] Creating pipe \\.\pipe\mencoder1350599094925
DEBUG 2012-10-18 18:24:55.170 [Thread-33] Waiting for pipe connection \\.\pipe\mencoder1350599094925
DEBUG 2012-10-18 18:24:55.220 [mencoder.exe-6] Starting "C:\Program Files (x86)\PS3 Media Server\win32\mencoder.exe" -ss 0 "G:\ServerFolders\BluRay\BD.MKV\A Turtle's Tale - Sammy's Adventure.mkv" -msglevel statusline=2 -oac lavc -of mpeg -mpegopts format=mpeg2:muxrate=500000:vbuf_size=1194:abuf_size=64 -ovc lavc -channels 6 -lavdopts debug=0:threads=2 -lavcopts autoaspect=1:vcodec=mpeg2video:acodec=ac3:abitrate=640:threads=2:keyint=5:vqscale=1:vqmin=1:vrc_maxrate=29000:vrc_buf_size=7000 -subdelay 20000 -ofps 24000/1001 -lavdopts fast -mc 0 -noskip -af lavcresample=48000 -srate 48000 -o \\.\pipe\mencoder1350599094925
DEBUG 2012-10-18 18:24:55.222 [mencoder.exe-6] Reading pipe: \\.\pipe\mencoder1350599094925
DEBUG 2012-10-18 18:24:55.223 [mencoder.exe-6] Attaching thread: mencoder.exe-6
DEBUG 2012-10-18 18:24:55.248 [Thread-37] MEncoder SB32 (C) 2000-2012 MPlayer Team
DEBUG 2012-10-18 18:24:55.248 [Thread-37] Custom build by SubJunk,
DEBUG 2012-10-18 18:24:55.249 [Thread-37]
DEBUG 2012-10-18 18:24:55.256 [Thread-37] success: format: 0  data: 0x0 - 0xa38714d3
DEBUG 2012-10-18 18:24:55.256 [Thread-37] libavformat version 54.3.100 (internal)
DEBUG 2012-10-18 18:24:55.261 [Thread-37] libavformat file format detected.
INFO  2012-10-18 18:24:55.329 [StartPlaying Event] renderer:, file: G:\ServerFolders\BluRay\BD.MKV\A Turtle's Tale - Sammy's Adventure.mkv
DEBUG 2012-10-18 18:24:55.362 [Thread-37] [lavf] stream 0: video (h264), -vid 0
DEBUG 2012-10-18 18:24:55.362 [Thread-37] [lavf] stream 1: audio (dca), -aid 0, -alang eng
DEBUG 2012-10-18 18:24:55.363 [Thread-37] VIDEO:  [H264]  1920x1080  0bpp  23.976 fps    0.0 kbps ( 0.0 kbyte/s)
DEBUG 2012-10-18 18:24:55.363 [Thread-37] [V] filefmt:44  fourcc:0x34363248  size:1920x1080  fps:23.976  ftime:=0.0417
DEBUG 2012-10-18 18:24:55.363 [Thread-37] ==========================================================================
DEBUG 2012-10-18 18:24:55.363 [Thread-37] Opening audio decoder: [ffmpeg] FFmpeg/libavcodec audio decoders
DEBUG 2012-10-18 18:24:55.363 [Thread-37] libavcodec version 54.17.101 (internal)
DEBUG 2012-10-18 18:24:55.363 [Thread-37] AUDIO: 48000 Hz, 6 ch, s16le, 1536.0 kbit/33.33% (ratio: 192000->576000)
DEBUG 2012-10-18 18:24:55.363 [Thread-37] Selected audio codec: [ffdca] afm: ffmpeg (FFmpeg DTS)
DEBUG 2012-10-18 18:24:55.363 [Thread-33] Result of \\.\pipe\mencoder1350599094925 : true
DEBUG 2012-10-18 18:24:55.366 [Thread-37] ==========================================================================
DEBUG 2012-10-18 18:24:55.399 [MPlayer Thumbnail Failsafe] Stopping process: mplayer.exe-4
DEBUG 2012-10-18 18:24:55.586 [Thread-37] PACKET SIZE: 2048 bytes, deltascr: 884
DEBUG 2012-10-18 18:24:55.654 [Thread-37] Opening video filter: [expand osd=1]
DEBUG 2012-10-18 18:24:55.792 [Thread-37] Expand: -1 x -1, -1 ; -1, osd: 1, aspect: 0.000000, round: 1
DEBUG 2012-10-18 18:24:55.837 [Thread-37] ==========================================================================
DEBUG 2012-10-18 18:24:56.278 [Thread-37] Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
DEBUG 2012-10-18 18:24:56.417 [Thread-37] Selected video codec: [ffh264] vfm: ffmpeg (FFmpeg H.264)
DEBUG 2012-10-18 18:24:56.417 [Thread-37] ==========================================================================
DEBUG 2012-10-18 18:24:56.464 [Buffered IO End Checker] Stopping process: ffmpeg.exe-5
DEBUG 2012-10-18 18:24:56.468 [Thread-36] [ac3 @ 010da6a0]channel_layout not specified
DEBUG 2012-10-18 18:24:56.468 [Thread-36] [ac3 @ 010da6a0]No channel layout specified. The encoder will guess the layout, but it might be incorrect.
DEBUG 2012-10-18 18:24:56.568 [Thread-36] Limiting audio preload to 0.4s.
DEBUG 2012-10-18 18:24:56.568 [Thread-36] Increasing audio density to 4.
DEBUG 2012-10-18 18:24:56.624 [Thread-36] Unsupported PixelFormat 61
DEBUG 2012-10-18 18:24:56.624 [Thread-36] Unsupported PixelFormat 53
DEBUG 2012-10-18 18:24:56.624 [Thread-36] Unsupported PixelFormat 81
DEBUG 2012-10-18 18:24:56.701 [Thread-37] Movie-Aspect is 1.78:1 - prescaling to correct movie aspect.
DEBUG 2012-10-18 18:24:56.701 [Thread-37] videocodec: libavcodec (1920x1080 fourcc=3267706d [mpg2])
DEBUG 2012-10-18 18:24:56.701 [Thread-37] [VE_LAVC] Using constant qscale = 1.000000 (VBR).
DEBUG 2012-10-18 18:24:57.649 [Thread-37] Writing header...
DEBUG 2012-10-18 18:24:57.649 [Thread-37] INITV: 0.200, 0.158, fps: 23.976
DEBUG 2012-10-18 18:24:57.649 [Thread-37]
DEBUG 2012-10-18 18:25:12.655 [UPNP-AliveMessageSender] Sending ALIVE...

Any help appreciated. Source code would be MOST helpful and if I get banned because you don't like my post, then this truly is an uptight community!
Server: WHS 2011 - AMD Athlon 2.8GHz {Black Edition} - 4GB PC2-6400 - 7TB
Renderers: 2 PS3s {500GB SSHybridD}, 1 HT-RC360, 1 Excite10, 1 GSIII, 1 BDP-S280
Helping the PS3MS team with development and problem resolution
User avatar
Posts: 20
Joined: Sat Oct 13, 2012 3:13 am

Re: Still Stuttering - way too frustrating!

Postby meskibob » Fri Oct 19, 2012 1:59 am

I wouldn't call it getting scolded, but w/e.

I would expect your CPU to be able to handle most content, but I'm not sure what kind of background load you have on the system. 2.8GHz dual core is the minimum for transcoding 1080P, and that's with minimal system overhead.
What does the "buffer status" bar look like on the Status tab in the PMS GUI when you're experiencing stuttering?
If it's empty, your CPU isn't able to keep up. You may be able to help this by lowering the MPEG-2 quality settings and setting the max bandwidth setting correctly (in this case it'd be zero since you're gigabit).
If there's some buffer left, then you're having some kind of network buffering issue. In that case, it can be a duplex/MTU mismatch, a NIC driver choking the output, etc. The FAQ post gives several examples of what people have seen and fixed, but maybe you have something new that we can figure out and add to the post. If you can help us help you by listing what you've checked from that FAQ post, that would be appreciated.

Regarding your rant:
  • I'm not sure where this hostility is coming from, but it's not from myself or the devs from what I've seen from your posts. Note: please do not mistake terseness for hostility.
  • I'm not seeing donation drives or any sort of asking for money by the devs. People are free to contribute if they like the project, but there is nothing stating they should or have to.
  • Your "specific" problem and resulting question in the other thread had no resemblance of you reading the FAQ (where at all in there does suggest downgrading to an old version?) or having tried anything in there. Nor did you provide any additional information to even begin to figure out your potential issue(s).
  • The FAQ contains a lot of useful information, like where the source code is at (second link under the "Links" section in the first post) and compilations of years worth of experience with this product and diagnosing issues. A little reading on a user's part doesn't seem that much to ask, and asking for clarification or assistance with an existing point is welcomed. Corrections or constructive criticism are welcomed even more.
  • Specifically regarding the stuttering FAQ, there are some general rules of thumb for fixing stuttering (see the first 6 bullet points), but there are a significant number of other potential factors that could cause stuttering, many completely outside of the control of PMS. The only real settings in PMS to configure (see bullet points 5 & 6) are the max bandwidth (pretty simple to enter, although it can be a bit more of a challenge to determine your actual network throughput from start to end) and the MPEG-2 options (which have clearly worded descriptions of what they entail, but the flexibility is there for those that really feel like tinkering with the parameters).
  • But if you can find a way to make this all work more smoothly (or fix whatever else you find), please feel free to do so and submit a pull request to help the project.
I provide NO application support via PM or email, so please post your question to the forum per the Forum Rules.
Posts: 4806
Joined: Mon Jan 19, 2009 4:11 pm

Re: Still Stuttering - way too frustrating!

Postby DevlshOne » Fri Oct 19, 2012 5:40 am

A few interesting finds since my last post...

With a couple more hours of monitoring and fiddling. Here's what I've tried and discovered:
  • Locking into one of my three NIC cards was no help although I still plan to see if there is a driver update for any of them.
  • MTU sizes, duplex and window size changes have no effect.
  • I never thought to actually watch the buffer on the status tab but it seems to indicate that I'm having CPU or FSB issues - Northbridge, I would guess.
  • When the stuttering begins, the buffer drops to 0 - 1MB and does not recover until I pause playback. Simultaneously, my CPU shoots into 100% usage. With PS3MS stopped, it never exceeds 11%, even when transferring massive files and running RDP. Nothing else in my processes list uses more than 3%.
  • The 2.8GHz dual-core SHOULD be able to handle 1080p encoding and anything else that gets thrown at it. Maybe MEncoder is leaky? Would a different engine be more CPU efficient? I ask because I do not know enough about enc/dec engines to make that determination.
Next up... checking for new drivers for the NICs, checking for updated AMD drivers for the CPU and chipset, running some end-to-end large scale throughput tests.
More details to come.
Also, grabbed the source and will be looking to see if I would be a worthwhile contributor or not. :)

And there we have it. After updating the CPU/GPU/Chipset drivers, the Realtek GBE drivers and setting max bandwidth to 0, I can now stream 1080p stutter-free with a buffer hovering around the 200MB mark and hitting peak speeds of 186Mbps. I'd call this one solved.
Server: WHS 2011 - AMD Athlon 2.8GHz {Black Edition} - 4GB PC2-6400 - 7TB
Renderers: 2 PS3s {500GB SSHybridD}, 1 HT-RC360, 1 Excite10, 1 GSIII, 1 BDP-S280
Helping the PS3MS team with development and problem resolution
User avatar
Posts: 20
Joined: Sat Oct 13, 2012 3:13 am

Return to General Help and Support

Who is online

Users browsing this forum: Google [Bot] and 7 guests