Easy setup guide for Ubuntu / Debian (DEB packages and repo)

For help and support with issues specific to Linux/Unix
Forum rules
Please make sure you follow the Problem Reporting Guidelines before posting if you want a reply.

Re: Easy setup guide for Ubuntu / Debian (DEB packages and r

Postby donricouga » Sun Sep 09, 2012 9:03 pm

I may be the only one trying this, but as I said in my earlier post, i'm installing the PS3 Media Server on Open Media Vault which is based on Debian Squeeze.
I tried installing this package
https://launchpad.net/~happy-neko/+archive/ps3mediaserver/+files/ps3mediaserver_1.60.0%2Bgit%2Bmencoder35003-1_amd64.deb

But i get the following errors :

Code: Select all
ps3mediaserver depends on libc6 (>= 2.14); however:
  Version of libc6 on system is 2.11.3-3.
 ps3mediaserver depends on upstart-job; however:
  Package upstart-job is not installed.
 ps3mediaserver depends on flac; however:
  Package flac is not installed.
 ps3mediaserver depends on imagemagick; however:
  Package imagemagick is not installed.
 ps3mediaserver depends on openjdk-6-jre; however:
  Package openjdk-6-jre is not installed.
 ps3mediaserver depends on ps3mediaserver-multiarch; however:
  Package ps3mediaserver-multiarch is not installed.


So I tried installing all the missing packages but I'm having trouble with ps3mediaserver-multiarch and libc6

So i downloaded ps3mediaserver-multiarch from https://launchpad.net/~happy-neko/+archive/ps3mediaserver/+files/ps3mediaserver-multiarch_1.0_amd64.deband did the following

Code: Select all
root@nas4free:/downloadtmp# dpkg -i ps3mediaserver-multiarch_1.0_amd64.deb
Selecting previously deselected package ps3mediaserver-multiarch.
(Reading database ... 25782 files and directories currently installed.)
Unpacking ps3mediaserver-multiarch (from ps3mediaserver-multiarch_1.0_amd64.deb) ...
dpkg: dependency problems prevent configuration of ps3mediaserver-multiarch:
 ps3mediaserver-multiarch depends on ps3mediaserver-multiarch-all; however:
  Package ps3mediaserver-multiarch-all is not installed.
dpkg: error processing ps3mediaserver-multiarch (--install):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 ps3mediaserver-multiarch


So I'm missing dependency ps3mediaserver-multiarch-all?? But I don't see that, I only see a i386 version? Am I missing something else?
Also having trouble with libc6 saying i have the newest which is 2.11.3-3

Code: Select all
root@nas4free:/downloadtmp# apt-get install libc6
Reading package lists... Done
Building dependency tree
Reading state information... Done
libc6 is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
root@nas4free:/downloadtmp#


What should I do in this case?
donricouga
 
Posts: 2
Joined: Sat Sep 08, 2012 10:34 pm

Re: Easy setup guide for Ubuntu / Debian (DEB packages and r

Postby shaneo » Tue Sep 18, 2012 9:44 pm

Where are the icons stored for PMS? I wanted to change them from the default green arrow but can seem to find them anywhere.
shaneo
 
Posts: 11
Joined: Sat May 19, 2012 8:09 pm

Re: Easy setup guide for Ubuntu / Debian (DEB packages and r

Postby pmshero » Thu Sep 20, 2012 9:56 pm

Hi

I just installed ubuntu server a few days ago, then also followed this guide to install pms, and it worked like a charm.
But since I managed to fuck up the ubuntu installation with some overcreative work i decided to do the whole thing from the start again.

So, i have installed ubuntu server just like the first time. Then i installed pms by following this guide just a before.
But now for some reason none of the renderers in the network will discover the server, not ps3, bravia tv, pc, tablet, mac or anything! :(

I use the command 'start/stop ps3mediaserver' to start/stop the daemon. Obviously...
But I don't know very much about how to trace this problem, I just tried the command 'ps3mediserver' and understand that there is some problem with the configuration:
Code: Select all
22:36:18.792 [main] DEBUG o.a.c.c.ConfigurationUtils - ConfigurationUtils.locate(): base is null, name is /usr/lib/ps3mediaserver/PMS.conf
22:36:18.795 [main] DEBUG o.a.c.c.DefaultFileSystem - Could not locate file /usr/lib/ps3mediaserver/PMS.conf at null: no protocol: /usr/lib/ps3mediaserver/PMS.conf
22:36:18.796 [main] DEBUG o.a.c.c.ConfigurationUtils - Loading configuration from the absolute path /usr/lib/ps3mediaserver/PMS.conf
22:36:18.796 [main] DEBUG o.a.c.c.PropertiesConfiguration - Base path set to file:///usr/lib/ps3mediaserver/PMS.conf
22:36:18.821 [main] DEBUG o.a.c.c.PropertiesConfiguration - FileName set to PMS.conf
22:36:18.821 [main] DEBUG o.a.c.c.PropertiesConfiguration - Base path set to /usr/lib/ps3mediaserver


I edited the /etc/default file and set the following, as described in the first post in this thread:
PMS_START="yes"
PMS_USER="aleksander"
PMS_PROFILE="/home/$PMS_USER/.config/ps3mediaserver"

Please please help me! I was so happy with how things worked the first time! :(
pmshero
 
Posts: 2
Joined: Thu Sep 20, 2012 9:40 pm

Re: Easy setup guide for Ubuntu / Debian (DEB packages and r

Postby pmshero » Thu Sep 20, 2012 10:01 pm

Ooh ooh ooh, found this in the log file also:

Code: Select all

 A serious error occurred during PMS init
org.jboss.netty.channel.ChannelException: Failed to bind to: /192.168.122.1:5001
        at org.jboss.netty.bootstrap.ServerBootstrap.bind(ServerBootstrap.java:303) ~[pms.jar:na]
        at net.pms.network.HTTPServer.start(HTTPServer.java:118) ~[pms.jar:na]
        at net.pms.PMS.init(PMS.java:458) [pms.jar:na]
        at net.pms.PMS.createInstance(PMS.java:801) [pms.jar:na]
        at net.pms.PMS.main(PMS.java:873) [pms.jar:na]
Caused by: java.net.BindException: Address already in use
        at sun.nio.ch.Net.bind(Native Method) ~[na:1.6.0_24]
        at sun.nio.ch.ServerSocketChannelImpl.bind(ServerSocketChannelImpl.java:137) ~[na:1.6.0_24]
        at sun.nio.ch.ServerSocketAdaptor.bind(ServerSocketAdaptor.java:77) ~[na:1.6.0_24]
        at org.jboss.netty.channel.socket.nio.NioServerSocketPipelineSink.bind(NioServerSocketPipelineSink.java:148) ~[pms.jar:na]
        at org.jboss.netty.channel.socket.nio.NioServerSocketPipelineSink.handleServerSocket(NioServerSocketPipelineSink.java:100) ~[pms.jar:na]
        at org.jboss.netty.channel.socket.nio.NioServerSocketPipelineSink.eventSunk(NioServerSocketPipelineSink.java:74) ~[pms.jar:na]
        at org.jboss.netty.channel.Channels.bind(Channels.java:468) ~[pms.jar:na]
        at org.jboss.netty.channel.AbstractChannel.bind(AbstractChannel.java:200) ~[pms.jar:na]
        at org.jboss.netty.bootstrap.ServerBootstrap$Binder.channelOpen(ServerBootstrap.java:348) ~[pms.jar:na]
        at org.jboss.netty.channel.Channels.fireChannelOpen(Channels.java:176) ~[pms.jar:na]
        at org.jboss.netty.channel.socket.nio.NioServerSocketChannel.<init>(NioServerSocketChannel.java:85) ~[pms.jar:na]
        at org.jboss.netty.channel.socket.nio.NioServerSocketChannelFactory.newChannel(NioServerSocketChannelFactory.java:142) ~[pms.jar:na]
        at org.jboss.netty.channel.socket.nio.NioServerSocketChannelFactory.newChannel(NioServerSocketChannelFactory.java:90) ~[pms.jar:na]
        at org.jboss.netty.bootstrap.ServerBootstrap.bind(ServerBootstrap.java:282) ~[pms.jar:na]
        ... 4 common frames omitted
pmshero
 
Posts: 2
Joined: Thu Sep 20, 2012 9:40 pm

Re: Easy setup guide for Ubuntu / Debian (DEB packages and r

Postby zeroc » Tue Sep 25, 2012 9:04 am

I have the same problem as donricouga.

i got debian squeeze and i did try to install it manually , but i get the exact same error. Any help how to solve this problem ?
zeroc
 
Posts: 4
Joined: Sun Jun 05, 2011 9:41 am

Re: Easy setup guide for Ubuntu / Debian (DEB packages and r

Postby Spanjard » Wed Sep 26, 2012 1:06 pm

I just added the PPA to my kubuntu software manager and installed PMS through the terminal / Console. It seems however that i am only getting 1.6.0+
Is there another PPA for PMS 1.7 or will the new version be made available through a simple terminal apt-get upgrade command?

Either way... awesome work guys! Keep up the good job.
Spanjard
 
Posts: 2
Joined: Wed Sep 26, 2012 1:03 pm

Re: Easy setup guide for Ubuntu / Debian (DEB packages and r

Postby zeroc » Thu Sep 27, 2012 11:15 am

i still can´t install this on debian 6.0 , ive been trying everything i possible know( that´s not much). Any help ?
zeroc
 
Posts: 4
Joined: Sun Jun 05, 2011 9:41 am

Re: Easy setup guide for Ubuntu / Debian (DEB packages and r

Postby Spanjard » Sat Sep 29, 2012 6:11 pm

i'll repeat the question;

Will update to 1.7 be available through the PPA?
Spanjard
 
Posts: 2
Joined: Wed Sep 26, 2012 1:03 pm

Re: Easy setup guide for Ubuntu / Debian (DEB packages and r

Postby bobthemailman90 » Thu Oct 04, 2012 6:04 am

Hello,
I'm running 12.04 fresh install and I cant seem to get the headless package to start on boot.
I followed the aboe guide and I also added the ps3mediauser to the system with the following:

adduser --system --group ps3mediauser


couple of questions? will the PMS_PROFILE="/home/$PMS_USER/.config/ps3mediaserver" work if the PMS_USER is set correctly? that looks like a variable to me, just wanting to confirm.

do I need to use medumunster (my account) for the PMS_USER even though that user is not logging in on startup? wouldn't I just use the ps3mediauser?

here is the current conf file, mediamunster is my username.
Code: Select all
PMS_START="yes"

PMS_USER="mediamunster"


PMS_PROFILE="/home/mediamunster/.config ps3mediaserver"


PS3MS_MEM="768M"

JAVA_OPTS="-Djava.awt.headless=true"

DAEMON_OPTS=""



thanks
bobthemailman90
 
Posts: 1
Joined: Thu Oct 04, 2012 5:53 am

Re: Easy setup guide for Ubuntu / Debian (DEB packages and r

Postby paulmadejong » Thu Oct 04, 2012 6:21 pm

After updating to 12.04 and reading this forum topic about an easy way of installing PS3mediaserver, I decided to remove my old 1.70 installation (used in my previous ubuntu 10.04) and go with this one from now on. Every thing works great except for the fact that after a cold boot, my PS3 cannot find the mediaserver which requires a manual reset to actually be found. I checked my debug.log file and noticed this part which probably caused the error:
Code: Select all
INFO  2012-10-04 18:50:43.585 [main] No plugins found
INFO  2012-10-04 18:50:43.594 [main] Registering transcoding engine: FFmpeg Audio
INFO  2012-10-04 18:50:43.598 [main] Registering transcoding engine: MEncoder
INFO  2012-10-04 18:50:43.598 [main] Registering transcoding engine: FFmpeg
INFO  2012-10-04 18:50:43.598 [main] Registering transcoding engine: MPlayer Audio
INFO  2012-10-04 18:50:43.598 [main] Registering transcoding engine: MEncoder Web
INFO  2012-10-04 18:50:43.599 [main] Registering transcoding engine: MPlayer Video Dump
INFO  2012-10-04 18:50:43.599 [main] Registering transcoding engine: MPlayer Web
INFO  2012-10-04 18:50:43.599 [main] Registering transcoding engine: tsMuxeR
INFO  2012-10-04 18:50:43.599 [main] Registering transcoding engine: Audio High Fidelity
INFO  2012-10-04 18:50:43.600 [main] Registering transcoding engine: VLC Audio Streaming
INFO  2012-10-04 18:50:43.600 [main] Registering transcoding engine: VLC Video Streaming
INFO  2012-10-04 18:50:43.600 [main] Registering transcoding engine: dcraw Thumbnailer
INFO  2012-10-04 18:50:43.603 [main] Using localhost address

INFO  2012-10-04 18:50:43.603 [main] Created socket: 0.0.0.0/0.0.0.0:5001

DEBUG 2012-10-04 18:50:43.646 [main] Using database URL: jdbc:h2:/var/lib/ps3mediaserver/database-pmadejong/medias
INFO  2012-10-04 18:50:43.646 [main] Using database located at: /var/lib/ps3mediaserver/database-pmadejong
DEBUG 2012-10-04 18:50:43.820 [main] Database file count: 195
DEBUG 2012-10-04 18:50:43.820 [main] Database version: 1.60.0+git+mencoder35003-1 (ppa:happy-neko)
INFO  2012-10-04 18:50:43.827 [main] A tiny cache admin interface is available at: http://127.0.1.1:5001/console/home
INFO  2012-10-04 18:50:43.831 [main] Checking shared folder: /storage/video/
INFO  2012-10-04 18:50:43.864 [main] Checking shared folder: /storage/music/
DEBUG 2012-10-04 18:50:43.932 [main] Sending ALIVE...

ERROR 2012-10-04 18:50:43.939 [main] A serious error occurred during PMS init
java.net.SocketException: No such device
        at java.net.PlainDatagramSocketImpl.join(Native Method) ~[na:1.6.0_24]
        at java.net.AbstractPlainDatagramSocketImpl.join(AbstractPlainDatagramSocketImpl.java:168) ~[na:1.6.0_24]
        at java.net.MulticastSocket.joinGroup(MulticastSocket.java:300) ~[na:1.6.0_24]
        at net.pms.network.UPNPHelper.getNewMulticastSocket(UPNPHelper.java:149) ~[pms.jar:na]
        at net.pms.network.UPNPHelper.sendAlive(UPNPHelper.java:115) ~[pms.jar:na]
        at net.pms.PMS.init(PMS.java:531) [pms.jar:na]
        at net.pms.PMS.createInstance(PMS.java:801) [pms.jar:na]
        at net.pms.PMS.main(PMS.java:873) [pms.jar:na]

The lines that are separated from the text do not appear after a mediaserver restart and my valid ip address is inserted in those lines (no error as well). For your convenience, here's the debug.log from today http://pastebin.com/re99qAmT

As I am running my server headless and thus no GUI is available to me, I have no idea how to solve this using the Force Internet Connection function or how to set an IP in PMS.conf? Moreover, another user in this thread reported that this did not solve his problem. My previous, self-installed instaltion of PMS used a start-up script/service that worked fine.

Is there a way to make PS3 autoload during boot after my network adapter is up and running?

[FIX=27/10/2012]
I was able to fix this by editing the upstart job in /etc/init/ps3mediaserver.conf. I changed the line with the start on command to: start on (local-filesystems and net-device-up IFACE=eth0)
And it works fine upon boot now.
[/FIX]
Last edited by paulmadejong on Sat Oct 27, 2012 10:11 am, edited 1 time in total.
paulmadejong
 
Posts: 11
Joined: Sat Oct 09, 2010 2:36 pm

PreviousNext

Return to Linux/Unix Support

Who is online

Users browsing this forum: No registered users and 2 guests