Having Problems Installing...

For help and support with issues specific to Linux/Unix
Forum rules
Please make sure you follow the Problem Reporting Guidelines before posting if you want a reply.

Having Problems Installing...

Postby Duskye » Mon Sep 03, 2012 2:51 am

Alright, I've taken a couple of hours trying to get this to install, but I cannot, for the life me, figure out how too.

I'm on Fedora, and I've searched high and low, used almost every tutorial, but I cannot install this, I even tried using WINE to install and use this. I've had no problem doing this in any other Linux distro.

Any help would be very, very nice. I'm at my witts end here.
Posts: 2
Joined: Mon Sep 03, 2012 2:48 am

Re: Having Problems Installing...

Postby Seve » Thu Sep 13, 2012 1:45 am

Assuming that you are on F17 using a Gnome DE environment?

This is from memory, so it may or may not be 100% complete, however, it should get you well on your way.

Make sure you have http://rpmfusion.org/ repositories installed, both free and non-free. Then follow the instructiions here for installing the ATRPMS repos (required to install libdvdcss)
http://www.mjmwired.net/resources/mjm-f ... 7.html#mp3 You can also install extra codecs for mplayer as well, the instructions are on the page.

Once the above is complete.
Code: Select all
# yum -y install mplayer mencoder mplayer-gui mplayer-common vlc-core vlc gstreamer-plugins-ugly gstreamer-plugins-bad gstreamer-ffmpeg xine-lib-extras-freeworld gstreamer-plugins-bad-nonfree alacarte libdvd-devel libdvdcss-devel libdvdnav-devel

Code: Select all
# yum --enablerepo=atrpms install libdvdcss2

You are required/recommended to install and use Oracle Java, the instructions are located here: http://www.mjmwired.net/resources/mjm-f ... .html#java

Download the latest pms-generic-linux-unix-1.XX.X.tgz, to your /home/username directory, save it and then right click on the file and select 'extract here'

The only thing left at this point is the installation of the following two libraries.

Code: Select all

As far as I know there are no Fedora rpms for these two packages, so your options are to a) install the source code directly b)create your own rpms c) search for a Centos rpm(s) and try those
Or if, you tell us what arch you are using, I may be able to upload the required rpms. (Dunno as I have never tried uploading anything here?), but I will give it a whirl if you like.

At this point you have to open a terminal as user and type and enter

Code: Select all
$ alacarte

This will allow you to add PMS Mediaserver to your applications menu - under Other. The start command is located in the folder you created in your home directory PMS.sh
Simply browse for it.

To test the installation, open a terminal as user and

Code: Select all
$ cd /home/username/pms-1.XX.X

then type and enter

Code: Select all
$ ./PMS.sh

Then you can browse the debug.log and the traces to see what if any errors appear.
Posts: 13
Joined: Tue Apr 06, 2010 7:06 am

Return to Linux/Unix Support

Who is online

Users browsing this forum: No registered users and 1 guest