Particular MKV has no video, only audio while streaming

For help and support with PS3 Media Server in general
Forum rules
Please make sure you follow the Problem Reporting Guidelines before posting if you want a reply.

Particular MKV has no video, only audio while streaming

Postby nirman23 » Sat Jul 28, 2012 4:40 pm

I am getting no video with tsmuxer in this particular mkv, only auido. Then i go to transcode folder and choose mencoder with this file but then it starts extremely stuttering. I have mkv files which are larger @1080p and transcode pretty well without any hassle. This file is troubling me. Please Help?

Code: Select all
(MKVInfo) + EBML head
(MKVInfo) |+ EBML version: 1
(MKVInfo) |+ EBML read version: 1
(MKVInfo) |+ EBML maximum ID length: 4
(MKVInfo) |+ EBML maximum size length: 8
(MKVInfo) |+ Doc type: matroska
(MKVInfo) |+ Doc type version: 2
(MKVInfo) |+ Doc type read version: 2
(MKVInfo) + Segment, size 4691997547
(MKVInfo) |+ Seek head
(MKVInfo) | + Seek entry
(MKVInfo) |  + Seek ID: 0x15 0x49 0xa9 0x66 (KaxInfo)
(MKVInfo) |  + Seek position: 4099
(MKVInfo) | + Seek entry
(MKVInfo) |  + Seek ID: 0x16 0x54 0xae 0x6b (KaxTracks)
(MKVInfo) |  + Seek position: 4248
(MKVInfo) | + Seek entry
(MKVInfo) |  + Seek ID: 0x1c 0x53 0xbb 0x6b (KaxCues)
(MKVInfo) |  + Seek position: 4691946677
(MKVInfo) |+ EbmlVoid (size: 4043)
(MKVInfo) |+ Segment information
(MKVInfo) | + Timecode scale: 1000000
(MKVInfo) | + Muxing application: libebml v1.2.1 + libmatroska v1.1.1
(MKVInfo) | + Writing application: mkvmerge v4.9.1 ('Ich will') built on Jul 11 2011 23:53:15
(MKVInfo) | + Duration: 9263.338s (02:34:23.338)
(MKVInfo) | + Date: Wed Oct 05 06:17:16 2011 UTC
(MKVInfo) | + Segment UID: 0xbd 0x4f 0x2e 0x47 0xba 0x84 0x3b 0x94 0x87 0x19 0xbf 0x76 0x60 0xb7 0xa2 0x4c
(MKVInfo) |+ Segment tracks
(MKVInfo) | + A track
(MKVInfo) |  + Track number: 1 (track ID for mkvmerge & mkvextract: 0)
(MKVInfo) |  + Track UID: 1761861031
(MKVInfo) |  + Track type: video
(MKVInfo) |  + Lacing flag: 0
(MKVInfo) |  + MinCache: 1
(MKVInfo) |  + Codec ID: V_MPEG4/ISO/AVC
(MKVInfo) |  + CodecPrivate, length 42 (h.264 profile: High @L5.0)
(MKVInfo) |  + Default duration: 41.708ms (23.976 frames/fields per second for a video track)
(MKVInfo) |  + Language: und
(MKVInfo) |  + Video track
(MKVInfo) |   + Pixel width: 1920
(MKVInfo) |   + Pixel height: 800
(MKVInfo) |   + Display width: 1920
(MKVInfo) |   + Display height: 800
(MKVInfo) | + A track
(MKVInfo) |  + Track number: 2 (track ID for mkvmerge & mkvextract: 1)
(MKVInfo) |  + Track UID: 4173284496
(MKVInfo) |  + Track type: audio
(MKVInfo) |  + Codec ID: A_AAC
(MKVInfo) |  + CodecPrivate, length 2
(MKVInfo) |  + Default duration: 21.333ms (46.875 frames/fields per second for a video track)
(MKVInfo) |  + Language: und
(MKVInfo) |  + Audio track
(MKVInfo) |   + Sampling frequency: 48000
(MKVInfo) |   + Channels: 6
(MKVInfo) | + A track
(MKVInfo) |  + Track number: 3 (track ID for mkvmerge & mkvextract: 2)
(MKVInfo) |  + Track UID: 958716306
(MKVInfo) |  + Track type: subtitles
(MKVInfo) |  + Default flag: 0
(MKVInfo) |  + Lacing flag: 0
(MKVInfo) |  + Codec ID: S_TEXT/UTF8
(MKVInfo) | + A track
(MKVInfo) |  + Track number: 4 (track ID for mkvmerge & mkvextract: 3)
(MKVInfo) |  + Track UID: 3277156761
(MKVInfo) |  + Track type: subtitles
(MKVInfo) |  + Default flag: 0
(MKVInfo) |  + Lacing flag: 0
(MKVInfo) |  + Codec ID: S_TEXT/UTF8
(MKVInfo) |  + Language: rum
(MKVInfo) |+ EbmlVoid (size: 1144)
(MKVInfo) |+ Cluster
Last edited by chocolateboy on Sat Jul 28, 2012 4:51 pm, edited 1 time in total.
Reason: reformatted: please read the FAQ: http://tinyurl.com/4294qo2
nirman23
 
Posts: 8
Joined: Sun Jul 22, 2012 6:16 pm

Re: Particular MKV has no video, only audio while streaming

Postby happy.neko » Sat Jul 28, 2012 7:01 pm

Tsmuxer does not support this video file. Play it with mecoder. Stuttering issues are covered in FAQ.
happy.neko
Project Member
 
Posts: 478
Joined: Fri Sep 23, 2011 5:38 pm

Re: Particular MKV has no video, only audio while streaming

Postby nirman23 » Sun Jul 29, 2012 4:45 am

Hi,

Please tell me how can I make tsmuxer to support this file? I have a couple of huge 1080p mkv files which play without any problem. I am no expert in these stuff, I only know little bit. This mkv is particularly giving me problems. When I play ths file there is no video, only audio is what I get. Also, none of my movies stutter, this is the only one that is stuttering. I have been through FAQs, but I can't see anything that I can improve because already my other files play at best quality.

Please shed some light on this. Give me some tools to cure this file? Thank you.
nirman23
 
Posts: 8
Joined: Sun Jul 22, 2012 6:16 pm

Re: Particular MKV has no video, only audio while streaming

Postby happy.neko » Sun Jul 29, 2012 2:57 pm

nirman23 wrote:Please tell me how can I make tsmuxer to support this file?

You can't without transcoding. Tsmuxer does not support videos with variable framerate. It also can not change h264 profile level. PS3 supports level 4.1 max so videos with h264 High@L5.0+ will give you black screen.
You can check media properties with mediainfo utility.
happy.neko
Project Member
 
Posts: 478
Joined: Fri Sep 23, 2011 5:38 pm

Re: Particular MKV has no video, only audio while streaming

Postby nirman23 » Sun Jul 29, 2012 3:24 pm

Yes I checked that with info-tool from mkvtoolnix. I saw that previous mkvs which work are HL@4 and this one is HL@5 (something like that). That's what I am asking. Tell me a tool which either converts this without re-encoding OR if no simple solution is truly not available then tell me a way to transcode (safest possible with highest quality).

Thanks.
nirman23
 
Posts: 8
Joined: Sun Jul 22, 2012 6:16 pm

Re: Particular MKV has no video, only audio while streaming

Postby nirman23 » Sun Jul 29, 2012 4:42 pm

You know what? Just never mind. I did some research and found the way to get h264 profile level from 5 to 4.1 (tsmuxer, without re-encoding) but the problem lies with the the ref frame rate. And hence an entire re-encoding process is certainly what I don't have on my mind.

So thanks for the help. :)
nirman23
 
Posts: 8
Joined: Sun Jul 22, 2012 6:16 pm

Re: Particular MKV has no video, only audio while streaming

Postby ExSport » Mon Jul 30, 2012 3:53 pm

Yes, also level 5.1 is supported but only important (with newer PS3 firmwares) is reference frames. More than 4 for 1080p is impossible for h264 certified HW.
But e.g. 1920x800 can have more ref. frames. From PMS code:
Code: Select all
// Check if file is compliant with Level4.1
                     if (avcHeader.getLevel() >= 41 && getWidth() > 0 && getHeight() > 0) {
                        int maxref = (int) Math.floor(8388608 / (getWidth() * getHeight()));
                        if (avcHeader.getRef_frames() > maxref) {
                           muxable = false;
                        }

And yes, lowering ref.frames can't be done without re-encoding.
ExSport
 
Posts: 2167
Joined: Mon Jan 19, 2009 5:40 pm

Re: Particular MKV has no video, only audio while streaming

Postby nirman23 » Mon Jul 30, 2012 4:03 pm

ExSport wrote:Yes, also level 5.1 is supported but only important (with newer PS3 firmwares) is reference frames. More than 4 for 1080p is impossible for h264 certified HW.
But e.g. 1920x800 can have more ref. frames. From PMS code:
Code: Select all
// Check if file is compliant with Level4.1
                     if (avcHeader.getLevel() >= 41 && getWidth() > 0 && getHeight() > 0) {
                        int maxref = (int) Math.floor(8388608 / (getWidth() * getHeight()));
                        if (avcHeader.getRef_frames() > maxref) {
                           muxable = false;
                        }

And yes, lowering ref.frames can't be done without re-encoding.


Unfortunately, I deleted the large video file. I felt it was not wise to waste the time to re-encode. I will have to live without it now . :(
nirman23
 
Posts: 8
Joined: Sun Jul 22, 2012 6:16 pm

Re: Particular MKV has no video, only audio while streaming

Postby happy.neko » Mon Jul 30, 2012 5:04 pm

ExSport wrote:Yes, also level 5.1 is supported but only important (with newer PS3 firmwares) is reference frames

h264 level determines allowed references frames count. 5.1 allows 16 reframes max for 1080p videos. So ps3 does not support HL 5.1.

nirman23 wrote: I did some research and found the way to get h264 profile level from 5 to 4.1 (tsmuxer, without re-encoding)

Changing level name is useless, it is like renaming mkv to mp4 with hope of "fooling" the player. Content is what matters, not label.
happy.neko
Project Member
 
Posts: 478
Joined: Fri Sep 23, 2011 5:38 pm

Re: Particular MKV has no video, only audio while streaming

Postby ExSport » Mon Jul 30, 2012 9:38 pm

happy.neko wrote:h264 level determines allowed references frames count. 5.1 allows 16 reframes max for 1080p videos. So ps3 does not support HL 5.1.

I know ;)
Wanted to say that level tag is not important. There ale lot of mkv files with level 5.1 but ref. frames is max 4 so level tag is misleading in most cases. Also new PS3 fw versions started to ignore it and relevant is ref.frames only.
Limit of level 4.1 for 1080p is 4 ref. frames only but any certified HW is capable to play also 1920x800 with 6 ref. frames. It is because "lower" resolution but it is still "1080p" 8-)
Older versions had 4 ref. frames hardcoded until I found a magic formula how to count supported ref. frames depending on resolution (somewhere on the net)
ExSport
 
Posts: 2167
Joined: Mon Jan 19, 2009 5:40 pm


Return to General Help and Support

Who is online

Users browsing this forum: Bing [Bot], Google [Bot] and 9 guests