Issue with .srt "tagged" and mkv

For help and support with PS3 Media Server in general
Forum rules
Please make sure you follow the Problem Reporting Guidelines before posting if you want a reply.

Issue with .srt "tagged" and mkv

Postby Raven » Thu May 24, 2012 2:19 pm

Well, I use PMS since few years now (PC under Windows7 64bits and PS3) and it works fine :D

Yesterday, I update PMS from 1.23 to 1.52.1 and I have some trouble with MKV files with external subtitles SRT. The SRT files contains some "tags" like this:
Code: Select all
1
00:00:01,910 --> 00:00:04,560
{\pos(192,230)}<i>Pendant plus d'un siècle,
j'ai vécu caché.</i>

2
00:00:05,497 --> 00:00:06,897
<i>{\pos(192,210)}Tapi dans l'ombre,</i>

3
00:00:07,467 --> 00:00:08,667
<i>{\pos(192,210)}seul au monde.</i>

4
00:00:09,799 --> 00:00:11,249
<i>{\pos(192,210)}Jusqu'à maintenant.</i>

5
00:00:11,750 --> 00:00:13,200
Une heure de route pour cette merde.


The problem is the tag "{\pos(192,230)}" used to display at the specified position does not work:
Image
The tag seems to be not recognized and just display as text.

I have check the same video with the same subtitle on older PMS (1.23 and 1.40), it was working fine:
Image

From PMS 1.50.1, something as changed and the srt files with tags are not correctly recognized ?
Raven
 
Posts: 7
Joined: Thu May 24, 2012 1:55 pm

Re: Issue with .srt "tagged" and mkv

Postby Raven » Fri Jun 08, 2012 5:48 pm

Anyone ?

It seems to be link to Mencoder configuration. I try to change option for transcoding but no success :(
Raven
 
Posts: 7
Joined: Thu May 24, 2012 1:55 pm

Re: Issue with .srt "tagged" and mkv

Postby Raven » Thu Jul 19, 2012 5:04 pm

No idea ?
Raven
 
Posts: 7
Joined: Thu May 24, 2012 1:55 pm

Re: Issue with .srt "tagged" and mkv

Postby happy.neko » Thu Jul 19, 2012 5:50 pm

Enable option "Use ssa subtitle styling" and save.
happy.neko
Project Member
 
Posts: 478
Joined: Fri Sep 23, 2011 5:38 pm

Re: Issue with .srt "tagged" and mkv

Postby Raven » Tue Jul 24, 2012 7:38 pm

Thanks a lot for your respond.

I try to activate this option but it doesn't work, subtitle tags is not understand by mencoder.

Here a print screen of the configuration:
Image
Raven
 
Posts: 7
Joined: Thu May 24, 2012 1:55 pm

Re: Issue with .srt "tagged" and mkv

Postby xthelukex » Mon Aug 06, 2012 12:13 pm

Was there ever a solution found to this? I'm having the same issue but using older versions of Media Server doesn't seem to be helping either. Tried practically every setting on the menus.
xthelukex
 
Posts: 1
Joined: Mon Aug 06, 2012 12:02 pm

Re: Issue with .srt "tagged" and mkv

Postby Raven » Mon Aug 06, 2012 7:41 pm

The only solution for the moment is to use version 1.40... With 1.50 or 1.60, I have the subtitle tagged problem

I have upload a sample of MKV/SRT files with the subtitle tag problem : https://rapidshare.com/files/3772290299/Sample-001.zip

If someone can try and tell us if it works or not ?

Thanks
Raven
 
Posts: 7
Joined: Thu May 24, 2012 1:55 pm

Re: Issue with .srt "tagged" and mkv

Postby happy.neko » Mon Aug 06, 2012 8:18 pm

Please upload debug log from ps3ms 1.40 and latest snapshot (viewtopic.php?f=14&t=14753) for the same file.
happy.neko
Project Member
 
Posts: 478
Joined: Fri Sep 23, 2011 5:38 pm

Re: Issue with .srt "tagged" and mkv

Postby Madoka » Mon Aug 06, 2012 9:06 pm

Here is a debug file for two files that don't work. The second is the sample file from above. This is 1.60 with the 8/6 1.70 snapshot and SB36 (stops freezing with some .mkvs for me). Subtitle-wise, it plays the same with the mencoder version installed wtih 1.60.

Hopefully, Raven can upload the 1.40 debug file.

Debug Tagged Subs.7z
(5.07 KiB) Downloaded 58 times
Madoka
 
Posts: 111
Joined: Fri Feb 19, 2010 3:02 am

Re: Issue with .srt "tagged" and mkv

Postby Raven » Tue Aug 07, 2012 10:04 pm

Here it is the debug.log for sample file with PMS 1.40 and PMS 1.60

I download "pms-1.70.0-SNAPSHOT-jar-with-dependencies.jar" and rename and replace it in PMS directory but it crashed PMS. I should used PMS 1.70 or maybe "pms-1.40.0-SNAPSHOT-jar-with-dependencies.jar" but I don't know where to download it :oops:

Thanks for your help
Attachments
debug 1.40 & 1.60.zip
(7.66 KiB) Downloaded 48 times
Raven
 
Posts: 7
Joined: Thu May 24, 2012 1:55 pm

Next

Return to General Help and Support

Who is online

Users browsing this forum: No registered users and 11 guests