Looking for config in /root/.config/PMS/PMS.conf

For help and support with issues specific to Linux/Unix
Forum rules
Please make sure you follow the Problem Reporting Guidelines before posting if you want a reply.

Looking for config in /root/.config/PMS/PMS.conf

Postby br0k3nh3@rt » Thu Jun 21, 2012 12:10 am

Host: Arch Linux, Linux 3.3.7-1-ARCH #1 SMP PREEMPT Tue May 22 00:26:26 CEST 2012 x86_64 GNU/Linux
PSM: 1.53.0

First post here, but I've been using PSM for almost 8 months. Recently (since some upgrades, Jun 7 - see below) it has been acting funny. It no longer looks for the config file in /opt/pms, it now searches the path '$USER/.config/PMS'. I have been lazy so far and I had been running it like this:

Code: Select all
while 1; do sudo ./PMS.sh ; done

in a tmux session. It was working beautifully because on the odd hangup or crash the server would restart and all was well.

I did some upgrades (Arch Linux is a rolling release distro) and poof, I started having these problems. Nothing seemed like it would affect this to me though:
Code: Select all
[2012-06-07 12:24] starting full system upgrade
[2012-06-07 12:28] Running 'pacman -Sf filesystem'
[2012-06-07 12:28] warning: directory permissions differ on sys/
[2012-06-07 12:28] upgraded filesystem (2012.2-5 -> 2012.6-2)
[2012-06-07 12:28] Running 'pacman -Syu'
[2012-06-07 12:28] synchronizing package lists
[2012-06-07 12:29] starting full system upgrade
[2012-06-07 12:30] removed libusb (1.0.9-1)
[2012-06-07 12:30] upgraded bash (4.2.028-1 -> 4.2.029-1)
[2012-06-07 12:30] upgraded db (5.3.15-1 -> 5.3.21-1)
[2012-06-07 12:30] upgraded perl (5.14.2-7 -> 5.16.0-2)
[2012-06-07 12:30] upgraded automake (1.12-1 -> 1.12.1-1)
[2012-06-07 12:30] upgraded systemd-tools (184-2 -> 185-1)
[2012-06-07 12:30] upgraded colord (0.1.19-2 -> 0.1.21-1)
[2012-06-07 12:30] upgraded libtasn1 (2.12-1 -> 2.13-1)
[2012-06-07 12:30] upgraded gnutls (3.0.19-1 -> 3.0.20-1)
[2012-06-07 12:30] upgraded libldap (2.4.31-1 -> 2.4.31-2)
[2012-06-07 12:30] upgraded krb5 (1.10.1-3 -> 1.10.2-1)
[2012-06-07 12:30] upgraded libcups (1.5.3-3 -> 1.5.3-4)
[2012-06-07 12:30] installed libusbx (1.0.11-2)
[2012-06-07 12:30] installed libsystemd (185-1)
[2012-06-07 12:30] upgraded cups (1.5.3-3 -> 1.5.3-4)
[2012-06-07 12:30] upgraded postgresql-libs (9.1.3-1 -> 9.1.4-1)
[2012-06-07 12:30] upgraded dovecot (2.1.7-1 -> 2.1.7-3)
[2012-06-07 12:30] upgraded elinks (0.13-9 -> 0.13-10)
[2012-06-07 12:30] upgraded fakeroot (1.18.3-1 -> 1.18.4-1)
[2012-06-07 12:30] upgraded libx11 (1.4.99.902-1 -> 1.5.0-1)
[2012-06-07 12:30] upgraded xcb-util (0.3.8-1 -> 0.3.9-1)
[2012-06-07 12:30] upgraded startup-notification (0.12-2 -> 0.12-3)
[2012-06-07 12:30] upgraded firefox (12.0-2 -> 13.0-1)
[2012-06-07 12:30] upgraded git (1.7.10.3-1 -> 1.7.10.4-1)
[2012-06-07 12:30] upgraded vim-runtime (7.3.515-1 -> 7.3.547-1)
[2012-06-07 12:30] upgraded gvim (7.3.515-1 -> 7.3.547-1)
[2012-06-07 12:30] upgraded hddtemp (0.3.beta15.46-2 -> 0.3.beta15.46-3)
[2012-06-07 12:30] upgraded net-snmp (5.7.1-2 -> 5.7.1-3)
[2012-06-07 12:30] > Please remove your printer in cups, then add it
[2012-06-07 12:30] > back and reconfigure it to make it work again!
[2012-06-07 12:30] upgraded hplip (3.12.4-1 -> 3.12.4-4)
[2012-06-07 12:30] upgraded icu (49.1.1-2 -> 49.1.2-1)
[2012-06-07 12:30] upgraded imagemagick (6.7.6.8-1 -> 6.7.7.5-1)
[2012-06-07 12:30] upgraded iptraf-ng (1.1.1-2 -> 1.1.3.1-1)
[2012-06-07 12:30] upgraded jre7-openjdk-headless (7.b147_2.1-3 -> 7.u4_2.2-1)
[2012-06-07 12:30] upgraded jre7-openjdk (7.b147_2.1-3 -> 7.u4_2.2-1)
[2012-06-07 12:30] upgraded lib32-libx11 (1.4.99.902-1 -> 1.5.0-1)
[2012-06-07 12:30] upgraded lib32-libxft (2.3.0-1 -> 2.3.1-1)
[2012-06-07 12:30] upgraded libproxy (0.4.7-1 -> 0.4.7-2)
[2012-06-07 12:30] upgraded libxaw (1.0.10-1 -> 1.0.11-1)
[2012-06-07 12:30] upgraded libxft (2.3.0-2 -> 2.3.1-1)
[2012-06-07 12:30] upgraded mkinitcpio-busybox (1.19.4-2 -> 1.20.1-1)
[2012-06-07 12:30] warning: /etc/mkinitcpio.conf installed as /etc/mkinitcpio.conf.pacnew
[2012-06-07 12:30] upgraded mkinitcpio (0.9.0-2 -> 0.9.1-1)
[2012-06-07 12:30] upgraded perl-berkeleydb (0.50-2 -> 0.50-4)
[2012-06-07 12:30] upgraded perl-crypt-openssl-bignum (0.04-6 -> 0.04-7)
[2012-06-07 12:30] upgraded perl-crypt-openssl-random (0.04-6 -> 0.04-7)
[2012-06-07 12:30] upgraded perl-crypt-openssl-rsa (0.28-2 -> 0.28-3)
[2012-06-07 12:30] upgraded perl-crypt-ssleay (0.58-3 -> 0.58-4)
[2012-06-07 12:30] upgraded perl-digest-sha1 (2.13-2 -> 2.13-3)
[2012-06-07 12:30] upgraded perl-html-parser (3.69-1 -> 3.69-2)
[2012-06-07 12:30] upgraded perl-net-dns (0.68-1 -> 0.68-2)
[2012-06-07 12:30] upgraded perl-net-server (0.99-2 -> 2.002-1)
[2012-06-07 12:30] upgraded perl-net-ssleay (1.48-1 -> 1.48-2)
[2012-06-07 12:30] upgraded perl-netaddr-ip (4.058-1 -> 4.058-2)
[2012-06-07 12:30] upgraded perl-socket6 (0.23-1 -> 0.23-2)
[2012-06-07 12:30] upgraded perl-xml-parser (2.41-2 -> 2.41-3)
[2012-06-07 12:30] upgraded perl-yaml-syck (1.20-1 -> 1.20-2)
[2012-06-07 12:30] upgraded php (5.4.3-1 -> 5.4.3-4)
[2012-06-07 12:30] upgraded php-apache (5.4.3-1 -> 5.4.3-4)
[2012-06-07 12:30] upgraded php-gd (5.4.3-1 -> 5.4.3-4)
[2012-06-07 12:30] upgraded pinentry (0.8.1-3 -> 0.8.1-4)
[2012-06-07 12:30] upgraded rrdtool (1.4.7-1 -> 1.4.7-2)
[2012-06-07 12:30] upgraded rsync (3.0.9-2 -> 3.0.9-3)
[2012-06-07 12:30] upgraded run-parts (4.2.1-1 -> 4.3.1-1)
[2012-06-07 12:30] upgraded sox (14.4.0-1 -> 14.4.0-2)
[2012-06-07 12:30] upgraded subversion (1.7.5-1 -> 1.7.5-2)
[2012-06-07 12:30] upgraded sudo (1.8.5.p1-1 -> 1.8.5.p2-1)
[2012-06-07 12:30] upgraded tightvnc (1.3.10-7 -> 1.3.10-8)
[2012-06-07 12:30] upgraded weechat (0.3.7-1 -> 0.3.8-1)
[2012-06-07 12:30] upgraded xcb-util-keysyms (0.3.8-1 -> 0.3.9-1)
[2012-06-07 12:30] upgraded xorg-docs (1.6-2 -> 1.7-1)
[2012-06-07 12:30] upgraded xulrunner (12.0-2 -> 13.0-1)


And here is the output from pms now:
Code: Select all
14:36:07.864 [main] DEBUG o.a.c.c.ConfigurationUtils - ConfigurationUtils.locate(): base is null, name is /root/.config/PMS/PMS.conf
    14:36:07.870 [main] DEBUG o.a.c.c.DefaultFileSystem - Could not locate file /root/.config/PMS/PMS.conf at null: no protocol: /root/.config/PMS
    /PMS.conf
    14:36:07.871 [main] DEBUG o.a.c.c.ConfigurationUtils - Loading configuration from the absolute path /root/.config/PMS/PMS.conf
    14:36:07.871 [main] DEBUG o.a.c.c.PropertiesConfiguration - Base path set to file:///root/.config/PMS/PMS.conf
    14:36:07.893 [main] DEBUG o.a.c.c.PropertiesConfiguration - FileName set to PMS.conf
    14:36:07.894 [main] DEBUG o.a.c.c.PropertiesConfiguration - Base path set to /root/.config/PMS
    14:36:08,016 |-INFO in ch.qos.logback.core.joran.action.DefinePropertyAction - About to instantiate property definer of type [net.pms.logging.
    DebugLogPathDefiner]
    14:36:08,018 |-INFO in ch.qos.logback.core.joran.action.DefinePropertyAction - Popping property definer for property named [debugLogPath] from
     the object stack
    14:36:08,019 |-INFO in ch.qos.logback.core.joran.action.AppenderAction - About to instantiate appender of type [ch.qos.logback.core.ConsoleApp
    ender]
    14:36:08,019 |-INFO in ch.qos.logback.core.joran.action.AppenderAction - Naming appender as [STDOUT]
    14:36:08,090 |-INFO in ch.qos.logback.core.joran.action.AppenderAction - About to instantiate appender of type [ch.qos.logback.core.FileAppend
    er]
    14:36:08,093 |-INFO in ch.qos.logback.core.joran.action.AppenderAction - Naming appender as [debug.log]
    14:36:08,104 |-INFO in ch.qos.logback.core.FileAppender[debug.log] - File property is set to [/opt/pms/debug.log]
    14:36:08,106 |-INFO in ch.qos.logback.core.joran.action.AppenderAction - About to instantiate appender of type [ch.qos.logback.core.rolling.Ro
    llingFileAppender]
    14:36:08,107 |-INFO in ch.qos.logback.core.joran.action.AppenderAction - Naming appender as [debug.log.10MB]
    14:36:08,137 |-INFO in ch.qos.logback.core.rolling.FixedWindowRollingPolicy@4311c617 - Will use zip compression
    14:36:08,152 |-INFO in ch.qos.logback.core.rolling.RollingFileAppender[debug.log.10MB] - Active log file name: /opt/pms/debug.log
    14:36:08,152 |-INFO in ch.qos.logback.core.rolling.RollingFileAppender[debug.log.10MB] - File property is set to [/opt/pms/debug.log]
    14:36:08,152 |-INFO in ch.qos.logback.classic.joran.action.RootLoggerAction - Setting level of ROOT logger to ALL
    14:36:08,152 |-INFO in ch.qos.logback.core.joran.action.AppenderRefAction - Attaching appender named [STDOUT] to Logger[ROOT]
    14:36:08,152 |-INFO in ch.qos.logback.core.joran.action.AppenderRefAction - Attaching appender named [debug.log] to Logger[ROOT]
    14:36:08,152 |-INFO in ch.qos.logback.classic.joran.action.ConfigurationAction - End of configuration.


It still 'works' but its not honoring my configuration options. This is a headless server.
br0k3nh3@rt
 
Posts: 2
Joined: Wed Jun 20, 2012 11:53 pm

Re: Looking for config in /root/.config/PMS/PMS.conf

Postby happy.neko » Fri Jun 22, 2012 12:32 pm

And what is your question?
happy.neko
Project Member
 
Posts: 478
Joined: Fri Sep 23, 2011 5:38 pm

Re: Looking for config in /root/.config/PMS/PMS.conf

Postby br0k3nh3@rt » Sat Jun 23, 2012 7:33 am

happy.neko wrote:And what is your question?

#1 why is it not using the config located at /opt/pms/PMS.conf anymore

#2 Why does it not honor the configuration even if I put it in the apparent path its look in '$HOME/.config/PMS/PMS.conf'
br0k3nh3@rt
 
Posts: 2
Joined: Wed Jun 20, 2012 11:53 pm

Re: Looking for config in /root/.config/PMS/PMS.conf

Postby happy.neko » Sat Jun 23, 2012 6:01 pm

br0k3nh3@rt wrote:#1 why is it not using the config located at /opt/pms/PMS.conf anymore
#2 Why does it not honor the configuration even if I put it in the apparent path its look in '$HOME/.config/PMS/PMS.conf'


You can set profile directory with PMS_PROFILE environment variable before PMS.sh startup.
happy.neko
Project Member
 
Posts: 478
Joined: Fri Sep 23, 2011 5:38 pm

Re: Looking for config in /root/.config/PMS/PMS.conf

Postby chocolateboy » Mon Jun 25, 2012 10:56 pm

chocolateboy
Project Member
 
Posts: 2577
Joined: Wed Sep 16, 2009 10:05 am

Re: Looking for config in /root/.config/PMS/PMS.conf

Postby astjohn » Thu Jul 05, 2012 2:33 am

I'm having a similar issue on Ubuntu. My init.d script is something like:

Code: Select all
PATH=/sbin:/bin:/usr/sbin:/usr/bin
DESC="PS3 Media Server"
NAME=ps3mediaserver
#PS3MS_PROFILE=/etc/$NAME # 1st initialization for PS3MS_PROFILE
PS3MS_PROFILE=/home/adam/.config/$NAME
DAEMON=/usr/bin/$NAME
DAEMON_OPTS="console"
SCRIPTNAME=/etc/init.d/$NAME
PS3MS_START=1 # Wether to start or not ps3mediaserver server at boot t$
DODTIME=10


and I even changed my /etc/default/ps3mediaserver to be:

Code: Select all
PS3MS_START="1"  # change to "1" to enable ps3mediaserver autostart
PS3MS_USER="adam"
#PS3MS_PROFILE="/etc/ps3mediaserver/"
PS3MS_PROFILE="/home/adam/.config/ps3mediaserver"

# memory limit for JVM (-Xmx option)
PS3MS_MEM="768M"

# Additional options that are passed to the Daemon.
DAEMON_OPTS="console"


When I start the server using sudo /etc/init.d/ps3mediaserver start, then it always searches for a non-existant conf in /home/root/.config.
If I start the server with my regular user by dropping the sudo, all is good, but this will not work of course after reboot.

Note that I have also tried placing the conf into /etc/ps3mediaserver/ as per the default and no luck. It still searched within /home/root/.config.

Any ideas?
astjohn
 
Posts: 9
Joined: Wed Dec 08, 2010 3:08 am


Return to Linux/Unix Support

Who is online

Users browsing this forum: No registered users and 5 guests