PMS refuses to adhere to settings in PMS.conf

For help and support with issues specific to Linux/Unix
Forum rules
Please make sure you follow the Problem Reporting Guidelines before posting if you want a reply.

PMS refuses to adhere to settings in PMS.conf

Postby mysongranhills » Tue Jul 03, 2012 8:37 am

I installed PMS 1.54 on Ubuntu 12.04 LTS using the instruction in the forum. Easy enough. It starts in the background when the server starts and I was pretty happy. Obviously did something wrong and skipped a step or something b/c PMS will not start in /media/Media Drive when accessed through my Samsung TV, It always starts browsing at the root "/". Also the settings I ticked in the GUI for hiding cache folders, transcoding folders, etc. did not take effect. So yes I could stream to my samsung TV but I had to manually navigate to "/media/Media Drive" and the folders I wanted hidden were still visible when starting at "/". So First I searched my file system for PMS.conf and found it but upon opening all settings were correct. Then I stopped the service and opened the GUI and re-checked settings-again all were correct. Also tried to uninstall and reinstall and no luck. I'm very tech savvy in general, but admit to being a complete Linux noob so I'm almost positive this is my fault. I have a few theories as to how I botched this.

1.) I somehow installed multpile instances of PMS and my searching is inept and I cant find the right PMS.conf

2.) somehow the syntax in PMS.conf is wrong so it is not being read correctly

3.) I have some how angered the tech gods and they refuse to allow this to work right until I preform 1000 ftks(face-to-keyboard)

Any help greatly appreciated!
mysongranhills
 
Posts: 6
Joined: Tue Jul 03, 2012 1:35 am

Re: PMS refuses to adhere to settings in PMS.conf

Postby chocolateboy » Tue Jul 03, 2012 8:53 am

chocolateboy
Project Member
 
Posts: 2580
Joined: Wed Sep 16, 2009 10:05 am

Re: PMS refuses to adhere to settings in PMS.conf

Postby mysongranhills » Tue Jul 03, 2012 9:03 am



Yes that is where I looked and when I open the PMS.conf file everything is setup correctly.

Would you like me to copy the lines to make sure the syntax is correct?
mysongranhills
 
Posts: 6
Joined: Tue Jul 03, 2012 1:35 am

Re: PMS refuses to adhere to settings in PMS.conf

Postby happy.neko » Tue Jul 03, 2012 10:06 am

Your daemon is started under root thats why it ignores your user config.
Restart your PC then
Code: Select all
sudo stop ps3mediaserver
, then proceed with following guide:


How to run PS3 Media Server in headless mode as service / daemon (easy guide)
1. Configure PS3 Media Service in GUI mode as normal user, save and quit.
2. Edit /etc/default/ps3mediaserver
Code: Select all
sudo gedit /etc/default/ps3mediaserver

  • Change PMS_START to "yes"
  • Change PMS_USER to your login name
  • Change PMS_PROFILE to "/home/YOUR_LOGIN/.config/ps3mediaserver"
3. Start server
Code: Select all
sudo start ps3mediaserver

Now PS3 Media Server will autorun during system startup. Remember to stop it with
Code: Select all
sudo stop ps3mediaserver
if you want to start it in GUI mode later to prevent network conflicts.

This is the easiest way to run PS3 Media Server on headless server:
Configure PS3 Media Server locally in GUI mode then copy ~/.config/ps3mediaserver folder to server to /home folder of appropriate user. Then edit /etc/default/ps3mediaserver (see above) and start server.
happy.neko
Project Member
 
Posts: 478
Joined: Fri Sep 23, 2011 5:38 pm

Re: PMS refuses to adhere to settings in PMS.conf

Postby mysongranhills » Tue Jul 03, 2012 1:19 pm

That did the trick. thanks a million!!!
mysongranhills
 
Posts: 6
Joined: Tue Jul 03, 2012 1:35 am

Re: PMS refuses to adhere to settings in PMS.conf

Postby Raptor399 » Tue Jul 03, 2012 5:37 pm

mysongranhills wrote:3.) I have some how angered the tech gods and they refuse to allow this to work right until I preform 1000 ftks(face-to-keyboard)


A shame it is solved, I would have opted for 3.) ;-)

On a more serious note: shall we mold this into a new FAQ question and answer for future reference?
Raptor399
Project Member
 
Posts: 1916
Joined: Thu Mar 10, 2011 12:06 am

Re: PMS refuses to adhere to settings in PMS.conf

Postby happy.neko » Wed Jul 04, 2012 3:42 pm

Raptor399 wrote:On a more serious note: shall we mold this into a new FAQ question and answer for future reference?

Why not? :)
happy.neko
Project Member
 
Posts: 478
Joined: Fri Sep 23, 2011 5:38 pm

Re: PMS refuses to adhere to settings in PMS.conf

Postby Raptor399 » Wed Jul 04, 2012 6:04 pm

Raptor399
Project Member
 
Posts: 1916
Joined: Thu Mar 10, 2011 12:06 am

Re: PMS refuses to adhere to settings in PMS.conf

Postby chocolateboy » Wed Jul 04, 2012 6:47 pm

FYI: those instructions are mostly specific to (a specific use of) happy.neko's PPA rather than "Linux" in general. They're by no means the same thing.
chocolateboy
Project Member
 
Posts: 2580
Joined: Wed Sep 16, 2009 10:05 am


Return to Linux/Unix Support

Who is online

Users browsing this forum: Yahoo [Bot] and 4 guests