Channel plugin (Updated 12-06-23)

Discuss third-party additions, plugins and translations for PS3 Media Server

Re: Channel plugin (Updated 12-06-02)

Postby dryce » Thu Jun 21, 2012 12:03 am

RTMPDUMP is working. I can get a little more to play, but two prominent errors are still showing. I still get ffmpeg code 1 and mencoder code 3. I've attached new logs here

https://dl.dropbox.com/s/tdbogjwq6smpv9e/pms_dbg.zip?dl=1
dryce
 
Posts: 5
Joined: Sat Jun 16, 2012 7:06 pm

Re: Channel plugin (Updated 12-06-02)

Postby dryce » Fri Jun 22, 2012 5:28 am

Here is a channel log with a few errors as well. Anyone have ideas? The same issue occurs on two separate computers.

http://db.tt/i6wgUx5c
dryce
 
Posts: 5
Joined: Sat Jun 16, 2012 7:06 pm

Re: Channel plugin (Updated 12-06-02)

Postby SharkHunter » Sat Jun 23, 2012 3:03 pm

Hi all!

The observant one has noticed updateing as been rare from me lately. The reson is of course UMS. Does this mean that Channels is dead? NO!!!
Channels lives and are very well thank you. However short term focus has been on UMS. So those of you who had problems I'll look into them as soon as time emerges.
Note that (very much on NaviX) there are alot of videos that simply not work any more. Or there are some issues with the transcoding.

Small changes has been made (new SVTPlay among them) so grab the latest version (1.79) and be patient...
SharkHunter
 
Posts: 941
Joined: Tue Jun 01, 2010 8:39 pm

Channel Plugin in Linux Help Needed

Postby elgreg2 » Fri Jun 29, 2012 4:08 pm

Hi!
I cant set to work channel 179 to work. I can see only Channel Menu on PS3 like Cache, local playlist... Channel files are in /usr/lib/ps3mediaserver/channels. Pmsencoder, and pms works great, no errors. There is error in channel.log:

^M15:53:37.398 Started 1.79

^M15:53:37.416 [Channel] OpenSubs not loaded ignore integration

^M15:53:37.418 [Channel] init exp java.lang.ClassCastException: java.util.ArrayList cannot be cast to java.lang.String

Any ideas?
My system is Ubuntu 12.04 and Pms from repo.

Regards Greg
elgreg2
 
Posts: 4
Joined: Fri Jun 29, 2012 3:59 pm

Re: Channel Plugin in Linux Help Needed

Postby elgreg2 » Fri Jun 29, 2012 7:55 pm

Do i need to change something in .ch files?
elgreg2
 
Posts: 4
Joined: Fri Jun 29, 2012 3:59 pm

Re: Channel plugin (Updated 12-06-23)

Postby jumpnkick » Sat Jun 30, 2012 6:03 pm

I wanna say I'm sorry in advance if this is already answered somewhere, but the truth is I couldn't find an answer to my issue anywhere. I've installed Channels plugin yesterday, just after updating my PS3 to 4.20 firmware. Everything seemed to be fine, but actually I was never able to stream a single content. Not even one video or movie o series played and always get the same result: This content canon be played (800288E1).
On this, in the whole forum I only found this post viewtopic.php?f=6&t=14700&hilit=this+content+cannot but there's no answer to it. The only reason for me to be suspicious bout the PS3 update really, tis that post, since tis the only topic I've found bout the error am getting.
Also, (I know this must go on the Grooveshark topic, but I think it must be related to the same problem am havin) I couldn't get any results on my groove shark's searches.
I any case, thanks in advance, and hope somebody got an answer to my issues!

Am runnin PMS on a MacBook Pro I7 2.5 Ghz with OSX Lion.
Attachments
errors.zip
WEB.conf PSM.conf pmseconder.log Debug.log
(7.37 KiB) Downloaded 53 times
jumpnkick
 
Posts: 10
Joined: Sat Jun 30, 2012 7:43 am

Re: Channel plugin (Updated 12-06-23)

Postby glenrocks » Sun Jul 01, 2012 6:53 pm

jumpnkick- First of all, get detail to log by turning TRACE on in logback file.

Sharkhunter- How are you doing? Hope all well with you.
Last edited by chocolateboy on Sun Jul 01, 2012 8:10 pm, edited 1 time in total.
Reason: edit: please keep posts on-topic
glenrocks
 
Posts: 89
Joined: Sun Aug 21, 2011 5:06 pm

Re: Channel plugin (Updated 12-06-23)

Postby jumpnkick » Sun Jul 01, 2012 9:34 pm

glenrocks wrote:jumpnkick- First of all, get detail to log by turning TRACE on in logback file


glen rocks thanks for answering. Could you tell me what the logback file is please?
jumpnkick
 
Posts: 10
Joined: Sat Jun 30, 2012 7:43 am

Re: Channel plugin (Updated 12-06-23)

Postby Raptor399 » Mon Jul 02, 2012 8:05 am

jumpnkick wrote:Could you tell me what the logback file is please?


FAQ: Where are the PMS config, log, database files etc. located?

You will find a file named "logback.xml" there.
Raptor399
Project Member
 
Posts: 1916
Joined: Thu Mar 10, 2011 12:06 am

Re: Channel plugin (Updated 12-06-23)

Postby SharkHunter » Mon Jul 02, 2012 9:14 am

The words of my death are a bit premature :)

jumpnkick - this print out indicates an old "error". Try and place PMS in a ptah without spaces in it. (that is /App/PS3XXXX)
ERROR 2012-06-30 14:14:41.108 [/Applications/PS3] Fatal error in process starting:
java.io.IOException: Cannot run program "/Applications/PS3": error=2, No such file or directory
at java.lang.ProcessBuilder.start(ProcessBuilder.java:460) ~[na:1.6.0_33]
at com.chocolatey.pmsencoder.PMSEncoderProcessWrapper.run(PMSEncoderProcessWrapper.java:89) ~[na:na]
Caused by: java.io.IOException: error=2, No such file or directory
at java.lang.UNIXProcess.forkAndExec(Native Method) ~[na:1.6.0_33]
at java.lang.UNIXProcess.<init>(UNIXProcess.java:53) ~[na:1.6.0_33]
at java.lang.ProcessImpl.start(ProcessImpl.java:91) ~[na:1.6.0_33]
at java.lang.ProcessBuilder.start(ProcessBuilder.java:453) ~[na:1.6.0_33]
... 1 common frames omitted


elgreg2 - Ignore 1.79 and try 1.78 instead...
SharkHunter
 
Posts: 941
Joined: Tue Jun 01, 2010 8:39 pm

PreviousNext

Return to Additions and Plugins

Who is online

Users browsing this forum: No registered users and 3 guests