PS3 Media Server needs manual start after Restart (daemon)

For help and support with issues specific to Linux/Unix
Forum rules
Please make sure you follow the Problem Reporting Guidelines before posting if you want a reply.

Re: PS3 Media Server needs manual start after Restart (daemo

Postby happy.neko » Thu Jun 14, 2012 12:43 am

SlasherIT wrote:Should I purge on Ubuntu or Debian? I have both, along with XP in a tri-boot environment.

ubuntu

SlasherIT wrote:Also, should I test after purging on the same version, or the new updated version?

new version. i386 is up, amd64 should be in few hours.

Also double check that you edited /etc/default/ps3mediaserver:

Change PMS_USER to your login name
Change PMS_PROFILE to "/home/YOUR_LOGIN/.config/ps3mediaserver"
happy.neko
Project Member
 
Posts: 478
Joined: Fri Sep 23, 2011 5:38 pm

Re: PS3 Media Server needs manual start after Restart (daemo

Postby SlasherIT » Thu Jun 14, 2012 4:00 pm

Hey happy.neko,

I updated to the latest version on Debian. I tried it to see if the problem was fixed, sadly, not. I can confirm that the problem is still there. I have yet to test it on Ubuntu, but 99% the same problem will occur, as Debian and Ubuntu are very similar.
SlasherIT
 
Posts: 28
Joined: Mon May 21, 2012 6:49 pm

Re: PS3 Media Server needs manual start after Restart (daemo

Postby happy.neko » Fri Jun 15, 2012 5:34 pm

I have identified the problem. Init.d script starts server before networks interfaces complete initialization. I don't know how to fix this with good old LSB init scripts, Required-Start: $network does not work as intended. So I wrote new upstart scripts, and so far everything works ok.

Updated package will be published in few hours.
happy.neko
Project Member
 
Posts: 478
Joined: Fri Sep 23, 2011 5:38 pm

Re: PS3 Media Server needs manual start after Restart (daemo

Postby SlasherIT » Fri Jun 15, 2012 8:33 pm

Sweet man, really great job, I appreciate it. Can't wait to get the update :).
SlasherIT
 
Posts: 28
Joined: Mon May 21, 2012 6:49 pm

Re: PS3 Media Server needs manual start after Restart (daemo

Postby happy.neko » Fri Jun 15, 2012 10:15 pm

Update is up.

Edit /etc/default/ps3mediaserver (PMS_USER and PMS_PROFILE).

Daemon control
Code: Select all
sudo start ps3mediaserver
status ps3mediaserver
sudo stop ps3mediaserver
happy.neko
Project Member
 
Posts: 478
Joined: Fri Sep 23, 2011 5:38 pm

Re: PS3 Media Server needs manual start after Restart (daemo

Postby SlasherIT » Mon Jun 18, 2012 12:23 am

Hey happy.neko,

I'm trying to install the latest PMS package on debian. So I let it install in debian with sudo dpkg -i blablabla... then it tries to do so. Eventually it fails and says errors were encountered while processing bla bla bla.

So I open Synaptic, and get a warning about broken packages. It says, that it wants to remove sysvinit, and install upstart. Now before, I did this, and after restarting, I could not boot into debian as it said it could not find sbin/init. So I re installed the whole OS, and here I am again. What should I do? If I allow synaptic to fix 'broken packages' (PMS), my system is going to get messed up again. Help would be appreciated, thanks.
SlasherIT
 
Posts: 28
Joined: Mon May 21, 2012 6:49 pm

Re: PS3 Media Server needs manual start after Restart (daemo

Postby happy.neko » Mon Jun 18, 2012 12:33 am

I don't know if Debian uses upstart system. For now you should test with Ubuntu.
happy.neko
Project Member
 
Posts: 478
Joined: Fri Sep 23, 2011 5:38 pm

Re: PS3 Media Server needs manual start after Restart (daemo

Postby SlasherIT » Mon Jun 18, 2012 1:28 pm

Well I'm not really using Ubuntu anymore, I'm moving to Debian, I like it better. Could you help me please?
SlasherIT
 
Posts: 28
Joined: Mon May 21, 2012 6:49 pm

Re: PS3 Media Server needs manual start after Restart (daemo

Postby SlasherIT » Mon Jul 02, 2012 10:41 pm

Bump.
SlasherIT
 
Posts: 28
Joined: Mon May 21, 2012 6:49 pm

Re: PS3 Media Server needs manual start after Restart (daemo

Postby SlasherIT » Sat Jul 21, 2012 11:16 pm

happy.neko - Debian uses sysvinit, not upstart. Wheeze uses upstart, but Squeeze uses sysvinit, which is what I am using. Is there anyway I could run PMS as a daemon with sysvinit?
SlasherIT
 
Posts: 28
Joined: Mon May 21, 2012 6:49 pm

Previous

Return to Linux/Unix Support

Who is online

Users browsing this forum: No registered users and 8 guests