PS3MediaServer on Ubuntu Server 11.04 not working

For help and support with issues specific to Linux/Unix
Forum rules
Please make sure you follow the Problem Reporting Guidelines before posting if you want a reply.

PS3MediaServer on Ubuntu Server 11.04 not working

Postby Leon90 » Wed Jun 06, 2012 11:21 am


I have been using PS3MS for some time now, and it is working great ever since (mkv with subtitles on a PS3 and Samsung TV what more do i want :D )
The thing is that it is running on a Windows 7 PC, now i bought a server pc and running Ubuntu Server on it. (Headless)

I tried to get PS3MS working on it by following this guide: viewtopic.php?f=3&t=13046
- So i used:
Code: Select all
sudo add-apt-repository ppa:happy-neko/ps3mediaserver
sudo apt-get update
sudo apt-get install ps3mediaserver

- Don't know how to configure it in GUI mode since i dont have that (headless), so i just changed the config manualy (not much to change):
Code: Select all
folders = /srv/data
hostname =
port =
language =
thumbnails = true
thumbnail_seek_pos = 60
use_mplayer_for_video_thumbs = true
nbcores =
turbomode = false
minimized = false
hidevideosettings = false
usecache = true
embed_dts_in_pcm = true
charsetencoding = 850
engines = tsmuxer,mencoder,ffmpegaudio,mplayeraudio,tsmuxeraudio,mplayervideodump,mencoderwebvideo,vlcvideo,mplayerwebaudio,vlcaudio,rawthumbs
autoloadsrt = true
avisynth_convertfps = true
avisynth_script = #AviSynth script is now fully customisable !\u0001#You must use the following variables (\"clip\" being the avisynth variable of the movie):\u0001#<movie>: insert the complete DirectShowSource instruction [ clip=DirectShowSource(movie, convertfps) ]\u0001#<sub>: insert the complete TextSub\/VobSub instruction if there's any detected srt\/sub\/idx\/ass subtitle file\u0001#<moviefilename>: variable of the movie filename, if you want to do all this by yourself\u0001#Be careful, the custom script MUST return the clip object\u0001<movie>\u0001<sub>\u0001return clip
transcode_block_multiple_connections = false
tsmuxer_forcefps = true
tsmuxer_preremux_pcm = false
tsmuxer_preremux_ac3 = false
tsmuxer_mux_all_audiotracks = false
audiochannels = 6
audiobitrate = 640
maximumbitrate = 0
skiploopfilter = false
prevents_sleep_mode = true
enable_archive_browsing = true
maxvideobuffer = 400
mencoder_fontconfig = true
mencoder_font = Ubuntu
mencoder_forcefps = false
mencoder_usepcm = false
mencoder_usepcm_for_hq_audio_only = false
mencoder_intelligent_sync = true
subs_color = -1
mencoder_remux_mpeg2 = true
mencoder_remux_ac3 = false
mencoder_decode =
mencoder_encode = keyint=2:vqscale=1:vqmin=2
mencoder_vobsub_subtitle_quality = 4
mencoder_overscan_compensation_width = 0

- Edit the /etc/default/ps3mediaserver file
Code: Select all
# Defaults for ps3mediaserver initscript
# sourced by /etc/init.d/ps3mediaserver
# installed at /etc/default/ps3mediaserver by the maintainer scripts

# This is a POSIX shell fragment

PS3MS_START="1"  # change to "1" to enable ps3mediaserver autostart
# memory limit for JVM (-Xmx option)

# Additional options that are passed to the Daemon.

Found another forum where they told me to use JAVA_OPT="-Djava.awt.headless=true" didnt work for me though

- used this code to start the server:
Code: Select all
sudo /etc/init.d/ps3mediaserver start

- output
Code: Select all
Starting PS3 Media Server : ps3mediaserver

Thats all, but when i fire up my ps3 or use the Samsung TV it wont show the PS3 Media Server at all...

I searched this forum, i searched the internet but no luck.

I hope i did something wrong so its just a quick fix :?

Thanks in advance

EDIT: typo-- i use 11.04 natty of ubuntu server :D
Posts: 3
Joined: Wed Jun 06, 2012 9:11 am

Re: PS3MediaServer on Ubuntu Server 11.04 not working

Postby Leon90 » Wed Jun 06, 2012 12:15 pm

Added debug log:
Code: Select all
[main] INFO  2012-06-06 13:13:28.960 Starting PS3 Media Server 1.51.0-mencoder34587-3 (ppa:happy-neko)
[main] INFO  2012-06-06 13:13:28.961 by shagrath / 2008-2012
[main] INFO  2012-06-06 13:13:28.961
[main] INFO  2012-06-06 13:13:28.961
[main] INFO  2012-06-06 13:13:28.961
[main] INFO  2012-06-06 13:13:28.961
[main] INFO  2012-06-06 13:13:28.961 Build: f1bc902f8 (Thu Mar 15 16:18:00 2012 +0800)
[main] INFO  2012-06-06 13:13:28.961 Java: 1.6.0_22-Sun Microsystems Inc.
[main] INFO  2012-06-06 13:13:28.961 OS: Linux amd64 2.6.38-15-server
[main] INFO  2012-06-06 13:13:28.961 Encoding: UTF-8
[main] INFO  2012-06-06 13:13:28.961
[main] INFO  2012-06-06 13:13:28.961 Working directory: /usr/lib/ps3mediaserver
[main] INFO  2012-06-06 13:13:28.964 Temp folder: /tmp/ps3mediaserver-leon
[main] INFO  2012-06-06 13:13:28.964 Logging config file: /etc/ps3mediaserver/logback.headless.xml
[main] INFO  2012-06-06 13:13:28.965 debug.log: /var/log/ps3mediaserver/leon//debug.log
[main] INFO  2012-06-06 13:13:28.965
[main] INFO  2012-06-06 13:13:28.965 Profile directory: /home/leon/.config/ps3mediaserver
[main] INFO  2012-06-06 13:13:28.965 Profile path: /home/leon/.config/ps3mediaserver/PMS.conf
[main] INFO  2012-06-06 13:13:28.965 Profile status: rw
[main] INFO  2012-06-06 13:13:28.965 Profile name: server-pc
[main] INFO  2012-06-06 13:13:28.965
[main] INFO  2012-06-06 13:13:28.992 Loading MediaInfo library
[main] INFO  2012-06-06 13:13:29.007 Loaded MediaInfoLib - v0.7.54
[main] INFO  2012-06-06 13:13:29.011 Loading renderer configurations from /etc/ps3mediaserver/renderers
[main] INFO  2012-06-06 13:13:29.012 Loading configuration file: WMP.conf
[main] DEBUG 2012-06-06 13:13:29.012 Base path set to file:///etc/ps3mediaserver/renderers/WMP.conf
[main] INFO  2012-06-06 13:13:29.014 Loading configuration file: Panasonic.conf
[main] DEBUG 2012-06-06 13:13:29.014 Base path set to file:///etc/ps3mediaserver/renderers/Panasonic.conf
[main] INFO  2012-06-06 13:13:29.018 Loading configuration file: XBMC.conf
[main] DEBUG 2012-06-06 13:13:29.018 Base path set to file:///etc/ps3mediaserver/renderers/XBMC.conf
[main] INFO  2012-06-06 13:13:29.019 Loading configuration file: SonyBluray.conf
[main] DEBUG 2012-06-06 13:13:29.019 Base path set to file:///etc/ps3mediaserver/renderers/SonyBluray.conf
[main] INFO  2012-06-06 13:13:29.022 Loading configuration file: Showtime3.conf
[main] DEBUG 2012-06-06 13:13:29.022 Base path set to file:///etc/ps3mediaserver/renderers/Showtime3.conf
[main] INFO  2012-06-06 13:13:29.025 Loading configuration file: PS3.conf
[main] DEBUG 2012-06-06 13:13:29.025 Base path set to file:///etc/ps3mediaserver/renderers/PS3.conf
[main] INFO  2012-06-06 13:13:29.031 Loading configuration file: SamsungAllShare.conf
Posts: 3
Joined: Wed Jun 06, 2012 9:11 am

Re: PS3MediaServer on Ubuntu Server 11.04 not working

Postby Leon90 » Wed Jun 06, 2012 10:49 pm

LOL just added the hostname (my server ip) and a different port and it worked...
i guess leaving it empty so it chooses by itself isnt a good idea

can be closed thanks
Posts: 3
Joined: Wed Jun 06, 2012 9:11 am

Re: PS3MediaServer on Ubuntu Server 11.04 not working

Postby sork » Sat Jun 30, 2012 4:46 pm

This thread fixed the issue for me as well. On the Linux sticky thread it says to "Start in GUI mode and then save the config file." That wasn't an option for me, so I tried it on my own. It turns out something else (not sure what) was using the default port 5001. Changing that fixed everything!

Posts: 1
Joined: Sat Jun 30, 2012 4:42 pm

Return to Linux/Unix Support

Who is online

Users browsing this forum: No registered users and 1 guest