[SOLVED] Maven problems

Discuss issues related to PS3 Media Server development (only for programmers)

[SOLVED] Maven problems

Postby troop » Sat May 05, 2012 4:07 am

I'm having issues running PMS in Eclipse as per the instructions in BUILD.md, it looks like Maven cant find these dependencies:

Code: Select all
!MESSAGE The POM for com.jgoodies:common:jar:1.2.1 is missing, no dependency information available
!MESSAGE The POM for com.jgoodies:forms:jar:1.4.2 is missing, no dependency information available
!MESSAGE The POM for com.jgoodies:looks:jar:2.4.2 is missing, no dependency information available
!MESSAGE The POM for de.innosystec:java-unrar:jar:0.5 is missing, no dependency information available
!MESSAGE The POM for jwbroek.cuelib:cuelib:jar:1.2.1-2008-06-13 is missing, no dependency information available
!MESSAGE The POM for mediautil:mediautil:jar:1.0 is missing, no dependency information available

I'm completely new to Maven and not sure how to proceed, can anyone help?

Thanks!

Edit:
Found that these deps couldnt be updated from within Eclipse.

Using a Git bash shell to run mvn com.savage7.maven.plugins:maven-external-dependency-plugin:resolve-external and mvn com.savage7.maven.plugins:maven-external-dependency-plugin:install-external
troop
 
Posts: 12
Joined: Fri Apr 27, 2012 12:09 pm

Re: [SOLVED] Maven problems

Postby Raptor399 » Sat May 05, 2012 4:55 pm

troop wrote:Using a Git bash shell to run mvn com.savage7.maven.plugins:maven-external-dependency-plugin:resolve-external and mvn com.savage7.maven.plugins:maven-external-dependency-plugin:install-external

That is what the instructions in BUILD.md and the note in the pom.xml say, indeed. ;-)
Raptor399
Project Member
 
Posts: 1916
Joined: Thu Mar 10, 2011 12:06 am


Return to Developers

Who is online

Users browsing this forum: Yahoo [Bot] and 4 guests