Web content will not stream

For help and support with PS3 Media Server in general
Forum rules
Please make sure you follow the Problem Reporting Guidelines before posting if you want a reply.

Re: Web content will not stream

Postby ratherDashing » Fri Mar 30, 2012 12:44 am

Thanks for the reply.

The only thing I was trying to do was to get Groove Salad to work. I get the Web Folder now but under Videos, Audio, or Pictures I get "no titles to display" which I get to the SomaFM directory:

audiostream.Web,Audio,Radio,SomaFM=Groove Salad,http://somafm.com/groovesalad.pls,http://somafm.com/img/GrooveSaladBox.jpg

that's the WEB.conf entry I was using. What did I do wrong?
ratherDashing
 
Posts: 3
Joined: Thu Mar 29, 2012 3:57 pm

Re: Web content will not stream

Postby ratherDashing » Tue Apr 03, 2012 9:19 pm

ratherDashing wrote:Thanks for the reply.

The only thing I was trying to do was to get Groove Salad to work. I get the Web Folder now but under Videos, Audio, or Pictures I get "no titles to display" which I get to the SomaFM directory:

audiostream.Web,Audio,Radio,SomaFM=Groove Salad,http://somafm.com/groovesalad.pls,http://somafm.com/img/GrooveSaladBox.jpg

that's the WEB.conf entry I was using. What did I do wrong?


Any idea why I get no titles here? I also get it for most of the entries in the default WEB.conf (like engadget) but TED talks works fine.
ratherDashing
 
Posts: 3
Joined: Thu Mar 29, 2012 3:57 pm

Re: Web content will not stream

Postby posh_hooligan » Tue Apr 24, 2012 11:00 pm

Melchoir wrote:I don't see feeds in the XMB. Where are they expected to appear?

I can view photos, music, and videos stored locally on my server with no problem. But I've never seen a "Web" folder, although I have the default items such as "videofeed.Web,YouTube=[url]" in my WEB.conf. In the XMB, when I select "PS3 Media Server" under the "Video" column, I get only three items: "/", "iPhoto Library", and "iTunes Library".

[/code]


I have a similar problem running Windows Vista. I've put the WEB.conf file in the profile directory (even the old ones just in case) and also downloaded the pmsencoder and added that to the engine list of the PMS.conf, some threads make it seem like i need this plugin? When I load the XMB menu all I have in the folder list are drives C: D: E: and video configuration. I'm new to all of this so maybe I've missed something simple, any ideas?

Cheers, Tom
posh_hooligan
 
Posts: 1
Joined: Tue Apr 24, 2012 10:43 pm

Re: Web content will not stream: Extreme.com

Postby tmknight » Sun May 06, 2012 8:28 pm

Anyone have any luck getting Exteme.com (FKA Freecaster) working?

I had this working several PMS versions ago, but lately as far as I can get is display feed list, then error that there is no input stream to return. I've randomly had it work while playing around with various iterations, but mostly no joy. Attaching logs and confs hoping someone might be able to shed some light. FWIW, the example TED talks do work, so thinking it's something in the feed formatting.

Cheers!
Attachments
pmsencoder_info.zip
(7.2 KiB) Downloaded 66 times
SubJunk Build or Custom from SVN (depends on my mood)
Xubuntu x64 (3.2)
AMD 64 X2 4800+ [OC 2.8GHz]
4GB DDR2
JRE 6 u[latest]
Sony KDL-40W5100
tmknight
 
Posts: 43
Joined: Fri Jan 08, 2010 5:18 pm

Re: Web content will not stream: Extreme.com

Postby chocolateboy » Sun May 06, 2012 11:55 pm

This works:

Code: Select all
videofeed.Web,extreme.com=http://extreme.com/rss/mountainbike


This doesn't work:

Code: Select all
videofeed.Web,extreme.com=http://extreme.com/rss/uci-mtb-world-cup-xco-2012


- because it's not a Media RSS file. It links to web pages (HTML), not videos.

FAQ: How can I access my favourite web video/TV site through PMS?
chocolateboy
Project Member
 
Posts: 2580
Joined: Wed Sep 16, 2009 10:05 am

Re: Web content will not stream

Postby tmknight » Wed May 09, 2012 11:59 pm

I appreciate you responding chocolateboy, I have tried both (had both setup for years) and neither currently works for me. They both sure seem to be MRSS:

Extreme.com UCI MTB World Cup XCO 2012 videos:
Code: Select all
<?xml version="1.0" encoding="UTF-8"?>
<!--Generated on 2012-05-10 00:47:38 by fc2.freecaster.com
$Revision: 3754 $-->
<rss xmlns:atom="http://www.w3.org/2005/Atom" xmlns:media="http://search.yahoo.com/mrss/" xmlns:itunes="http://www.itunes.com/dtds/podcast-1.0.dtd" xmlns:fcmedia="http://freecaster.tv/rss/dtd" version="2.0">
  <channel>
    <title>Extreme.com UCI MTB World Cup XCO 2012 videos</title>
    <link>http://extreme.com/uci-mtb-world-cup-xco-2012</link>
    <description></description>
    <language>en</language>
    <ttl>30</ttl>
    <image>
      <url>http://cdn.freecaster.com/image/freecaster_logo_whitebgr.jpg</url>
      <title>Extreme.com UCI MTB World Cup XCO 2012 videos</title>
      <link>http://extreme.com/uci-mtb-world-cup-xco-2012</link>
    </image>
    <itunes:subtitle>Extreme.com - Gives you the best high quality extreme sports video and all the latest news and events from the world of action sports.</itunes:subtitle>
    <itunes:summary></itunes:summary>
    <itunes:author>Extreme.com</itunes:author>
    <itunes:explicit>no</itunes:explicit>
    <itunes:category text="Sports &amp; Recreation"/>
    <itunes:category text="TV &amp; Film"/>
    <atom:link href="http://extreme.com/rss/uci-mtb-world-cup-xco-2012" rel="self" type="application/rss+xml"/>
    <item>

Extreme.com Mountain Bike videos:
Code: Select all
<?xml version="1.0" encoding="UTF-8"?>
<!--Generated on 2012-05-10 00:46:58 by fc2.freecaster.com
$Revision: 3754 $-->
<rss xmlns:atom="http://www.w3.org/2005/Atom" xmlns:media="http://search.yahoo.com/mrss/" xmlns:itunes="http://www.itunes.com/dtds/podcast-1.0.dtd" xmlns:fcmedia="http://freecaster.tv/rss/dtd" version="2.0">
  <channel>
    <title>Extreme.com Mountain Bike videos</title>
    <link>http://extreme.com/mountainbike</link>
    <description>The best action sports videos from mountain bike all over the world. Reports and highlights from the UCI World Cups, films, rider profiles, interviews and trailers.</description>
    <language>en</language>
    <ttl>30</ttl>
    <image>
      <url>http://cdn.freecaster.com/image/freecaster_logo_whitebgr.jpg</url>
      <title>Extreme.com Mountain Bike videos</title>
      <link>http://extreme.com/mountainbike</link>
    </image>
    <itunes:subtitle>Extreme.com - Gives you the best high quality extreme sports video and all the latest news and events from the world of action sports.</itunes:subtitle>
    <itunes:summary>The best action sports videos from mountain bike all over the world. Reports and highlights from the UCI World Cups, films, rider profiles, interviews and trailers.</itunes:summary>
    <itunes:author>Extreme.com</itunes:author>
    <itunes:explicit>no</itunes:explicit>
    <itunes:category text="Sports &amp; Recreation"/>
    <itunes:category text="TV &amp; Film"/>
    <atom:link href="http://extreme.com/rss/mountainbike" rel="self" type="application/rss+xml"/>
    <item>

Clearly, I'm overlooking the obvious, but the same code worked (save that the year for UCI events has changed) up to 1.5x of PMS. I recall you had to make some changes to pmsencoder - which worked for a bit, but then stopped working again recently. But also Extreme seems to have made some changes too.

Any help you can offer to get either one working would be greatly appreciated.

Cheers!
SubJunk Build or Custom from SVN (depends on my mood)
Xubuntu x64 (3.2)
AMD 64 X2 4800+ [OC 2.8GHz]
4GB DDR2
JRE 6 u[latest]
Sony KDL-40W5100
tmknight
 
Posts: 43
Joined: Fri Jan 08, 2010 5:18 pm

Re: Web content will not stream

Postby chocolateboy » Thu May 10, 2012 12:41 am

tmknight wrote:They both sure seem to be MRSS.


The first one is because it contains media enclosures (MP4 videos). The second one isn't because it doesn't.

Any help you can offer to get either one working would be greatly appreciated.


The first one works for me. If you can't get it to work, attach the logfiles for that feed and I'll take a look. Instructions for enabling support for the second one can be found in the link I posted earlier.
chocolateboy
Project Member
 
Posts: 2580
Joined: Wed Sep 16, 2009 10:05 am

Re: Web content will not stream

Postby tmknight » Sat May 12, 2012 3:03 pm

Ah, I see: Though the header and much of the feed is in MRSS format, the thing pmsencoder is really looking for is the enclosure tag - which not every item may have, though there may be a media file associated with the item via another tag. With that, I was indeed able to play the items with enclosure tags. To that end, is there a config parameter or otherwise logic that might be added to WEB.conf/pmsencoder to filter out non-enclosure items (show only items with enclosures)?

Thanks again!
SubJunk Build or Custom from SVN (depends on my mood)
Xubuntu x64 (3.2)
AMD 64 X2 4800+ [OC 2.8GHz]
4GB DDR2
JRE 6 u[latest]
Sony KDL-40W5100
tmknight
 
Posts: 43
Joined: Fri Jan 08, 2010 5:18 pm

Re: Web content will not stream

Postby chocolateboy » Sat May 12, 2012 3:24 pm

tmknight wrote:the header and much of the feed is in MRSS format


It's not an MRSS feed. It uses the namespace for some metadata, not for media. And, no, PMSEncoder isn't "looking for" enclosures. PMS is.

is there a config parameter or otherwise logic that might be added to WEB.conf


Not to work around one dodgy feed. Besides, there are dedicated tools for feed filtering.
chocolateboy
Project Member
 
Posts: 2580
Joined: Wed Sep 16, 2009 10:05 am

Re: Web content will not stream

Postby tmknight » Sun May 13, 2012 6:28 pm

chocolateboy wrote:..there are dedicated tools for feed filtering.


That'll work, cheers
SubJunk Build or Custom from SVN (depends on my mood)
Xubuntu x64 (3.2)
AMD 64 X2 4800+ [OC 2.8GHz]
4GB DDR2
JRE 6 u[latest]
Sony KDL-40W5100
tmknight
 
Posts: 43
Joined: Fri Jan 08, 2010 5:18 pm

PreviousNext

Return to General Help and Support

Who is online

Users browsing this forum: Bing [Bot], Google [Bot] and 15 guests