Missing libraries from Mencoder/ffmpeg compile (most likely)

For help and support with issues specific to Linux/Unix
Forum rules
Please make sure you follow the Problem Reporting Guidelines before posting if you want a reply.

Missing libraries from Mencoder/ffmpeg compile (most likely)

Postby jaguar7926 » Wed Mar 25, 2009 5:33 am

I've been searching for a good UPnP media server for my PS3 recently and I must say that I believe I've found the best. Thank you!

I'll start with some basic system specs:
AMD Opteron 1220 dual-core 2.8GHz CPU
CentOS 5.2 x86_64 (headless install for this particular box)
8GB RAM

I've been attempting to get PMS running correctly on a new transcoding media server I recently built. At this point it seems as though my main issue is that both Mencoder & ffmpeg are probably not being compiled with the correct libraries to allow for playback of different file types. I have successfully downloaded & compiled the latest SVN for each program, but will only ever get "The data is corrupted" errors when attempting to play certain file types such as MKVs, certain DivXs, MPEG2s, etc. With these programs installed I am able to playback MPEG1 & AVC consistently, as well as, playback nearly all of the music I have, so I know that the programs are working just not to their full potential. I've scoured the debug.log in hopes of finding issues as to why these files won't play, but I can't find anything of note there. I've also setup PS3 Media Server on my Windows desktop with some of the same files that are on the server, but every single one of those plays very well on the PS3. This leads me to believe that the backend programs aren't configured/compiled correctly. On another note, tsMuxer has not worked for any of these files even after chmodding execute permissions on the tsMuxer file.

I know from perusing the numerous Ubuntu threads on here that it appears as though there are quite a few libraries that are needed prior to compiling Mencoder, ffmpeg, x264, etc, so my question is which libraries should I be looking for and then where exactly can I get them for my CentOS system? Please let me know if there's any more information I can provide that may help. Thank you in advance.
jaguar7926
 
Posts: 6
Joined: Wed Mar 25, 2009 4:19 am

Re: Missing libraries from Mencoder/ffmpeg compile (most likely)

Postby shagrath » Wed Mar 25, 2009 9:24 am

imho that's the major downside of Linux... If I could distribute ffmpeg in the linux package, I would :p
the server needs a recent one, and recent mencoder binaires as well
shagrath
Project Lead
 
Posts: 2668
Joined: Wed Jan 14, 2009 1:39 pm

Re: Missing libraries from Mencoder/ffmpeg compile (most likely)

Postby Topguy » Wed Mar 25, 2009 9:30 am

I still think it would be helpful to see your debug.log anyway:
* Shut down PMS service
* erase debug.log
* start PMS.
* On your PS3:
* Browse to a directory with preferably just one file.
* Try to play it.
* zip and post debug.log here.

But from your description I have a feeling that it is maybe TsMuxer that is the problem not mencoder or ffmpeg.
If you are not starting PMS.sh from the directory where PMS is unpacked, then it usually cant locate "./linux/TsMuxer"
Topguy
 
Posts: 219
Joined: Mon Jan 19, 2009 9:27 pm

Re: Missing libraries from Mencoder/ffmpeg compile (most likely)

Postby jaguar7926 » Wed Mar 25, 2009 7:20 pm

Thank you for the responses.

I've killed the PMS process, wiped out the log file and restarted the service. The log file is attached, however, I'm not currently at home, so I can't perform a browse & play. You can peruse at least the start-up for now if you wish. I will try the full suggested process tonight when I get home and re-post the log file. When I start the PMS script I use the following command:

Code: Select all
cd /usr/pms-linux-1.10.5/; ./PMS.sh;cd -


This command is executed from either the CLI when I'm logged in if I need to restart the service or from the rc.local file when the server has to boot up. I've tested both and it seems to work as it is loading my PMS.conf file correctly. I'd noticed while initially getting PMS setup that not running the script in the appropriate directory will result in the program not finding the PMS.conf file either. Using this command string has solved the issue of starting PMS on boot & from another directory, so I'm only assuming that it should also be able to find the tsMuxer file. Of course, I could be wrong.

I should also mention that I have noticed that if I attempt to play a "corrupted" file, I will see processes running for Mencoder attempting to play the files I've chosen. These processes will persist even after I've killed the PMS Java process. I realize that PMS & Mencoder are separate programs, so I'm not concerned with the fact that the Mencoder processes aren't dying at the same time as PMS when I kill PMS, but it's interesting that the Mencoder is kicking on and will persist long after I've received the data is corrupted error.

Again, thank you for the assistance. :D
Attachments
debug.zip
PMS start-up with no directory browsing or file playing output.
(2.66 KiB) Downloaded 96 times
jaguar7926
 
Posts: 6
Joined: Wed Mar 25, 2009 4:19 am

Re: Missing libraries from Mencoder/ffmpeg compile (most likely)

Postby jaguar7926 » Thu Mar 26, 2009 2:49 am

Ok, I'm home now and have checked the log file since I wiped it earlier today. It appears as though someone at my friend's house was browsing stuff on my media server with their PS3*, so I've captured the log file minus the NOTIFY messages for your browsing pleasure. I've then killed PMS, wiped the debug.log again and have started fresh. So the next log file is from a fresh start of the process and of me browsing my media server with my PS3 and attempting to play files.

On the post log file**, I first browse to an MKV, then attempt to play it with Mencoder and tsMuxer, respectively, which was unsuccessful. Then I successfully play a DivX AVI and a WMV showing as a VC-1 on the PS3. I then attempt to play a different WMV also listed as a VC-1, but this comes up as "data type not supported". I then successfully play another DivX AVI. After all of that, I killed PMS and saw that there were 3 persistent processes from mencoder that said the following:

Code: Select all
mencoder -ss 0 /data/uploads/Porn/Scene.5.Sophia.Santi.and.Jelena.Jensen.mkv -quiet


I'm not able to kill these processes with "killall" or "kill -SIGHUP". Only "kill -9" works, but that's probably more related to mencoder than PMS. The post-debug.log is the full log from this testing. Again, thank you for checking into this with/for me.

*Yes, my friend's PS3 can currently browse my media server via a VPN tunnel I've setup over which I have multicast routing in place for the SSDP transactions. Just in case, that part caught any one off guard. :D
**Yes, the test files are all porn, except for the City Of God file. They happen to be the most diverse files in my collection in terms of video formats, so they're perfect to test with. :o

NOTE:
I've also installed VLC via the Dag Wiers repository in hopes that this might fix the lack of playback via the various default web streams through PMS, but these do not work either.
Attachments
post-debug.zip
debug.log after a full log wipe and process restart with browsing and file playing.
(225.42 KiB) Downloaded 67 times
prior-debug.zip
debug.log prior to a full wipe and process restart with some remote file browsing and no NOTIFY lines.
(56.95 KiB) Downloaded 83 times
jaguar7926
 
Posts: 6
Joined: Wed Mar 25, 2009 4:19 am

Re: Missing libraries from Mencoder/ffmpeg compile (most likely)

Postby jaguar7926 » Sun Mar 29, 2009 8:13 am

I was wondering if anyone has had a chance to check this out? I've attempted to remove ffmpeg that I grabbed from the Dag repo and re-configure/compile ffmpeg (which was successful) with the necessary libraries, however this has not fixed the issue. I've also grabbed the latest tsMuxeR after the suggestion that there may be an issue with that specifically, but again, no dice. Any support, any of you can lend would be greatly appreciated. Thanks again.
jaguar7926
 
Posts: 6
Joined: Wed Mar 25, 2009 4:19 am

Re: Missing libraries from Mencoder/ffmpeg compile (most likely)

Postby mad » Tue Mar 31, 2009 7:17 pm

This was easily fixed on a Gentoo system by running an empty-tree rebuild of mplayer.
mad
 
Posts: 5
Joined: Mon Feb 09, 2009 6:52 pm

Re: Missing libraries from Mencoder/ffmpeg compile (most likely)

Postby jaguar7926 » Tue Apr 07, 2009 6:49 am

First off, I'd like to say...Fuck yeah! :D

Now on to more constructive dialog. As you may have guessed from my exclamation, I finally managed to get the back-end programs to PS3 Media Server working on my headless CentOS server. My server is now fully transcoding-on-the-fly 1080P movies as intended, as well as, actually playing back sundry file types.

So, for my fellow RH/CentOS/Fedora admins, here's a basic run down of what I needed to do to get it working. (This is outside of the information I've all ready posted.)

1) # yum update ;I've actually attempted to update several pieces several times since the last time I posted, but I must be on the cusp of some recent updates - Note: yum may break after this. It did for me, but it is recoverable. Anyway if you would like to know more about this issue specifically you can either Google it or PM me.
2) Make sure to have the RPMFusion repo added to your repository list:
# rpm -Uvh http://download1.rpmfusion.org/free/el/ ... noarch.rpm ;Double check that you're getting files from the correct architecture for your system.
3) If there are previous releases of ffmpeg, mplayer, mencoder and even VLC on your system, remove them.
# yum erase ffmpeg mplayer mencoder vlc
or
# rpm -e ffmpeg mplayer mencoder vlc
4) yum -y install ffmpeg mplayer mencoder ;If you get Transaction Check Errors during this process concerning some libs that were previously installed, then remove these as well following the same process from the previous step. It will most likely say that what you have is newer, but removing what you have will allow the package from the RPMFusion repo to install as intended.
5) After this, simply (re)start PMS if necessary and it should be working correctly.

One other tidbit, for any distro user, some of you may not know is that if you are using SSH to connect to your server, you have an X windows system installed on your local machine and you allow X11 forwarding through your client, when you run the PMS.sh script you can get the GUI for the Linux instance of the service up on your local machine. For instance, I'm on a Windows desktop and when I ran the PMS.sh script I got the Linux version of the GUI for the PMS service running on my Linux server. Just thought I'd share that. :mrgreen:

Enjoy!
jaguar7926
 
Posts: 6
Joined: Wed Mar 25, 2009 4:19 am

Re: Missing libraries from Mencoder/ffmpeg compile (most likely)

Postby jaguar7926 » Mon Apr 13, 2009 7:06 am

So, after using this for a while I'm quite happy with it. I have noticed, however, that I still have some files that will not playback and error with the "...data is corrupted" error. The odd thing is that PMS will display appropriate thumbnails for these files. I'm wondering why it can render a proper thumbnail, but not actually produce playback for the same file? I do see from the debug.log that it uses mplayer to render the thumbnail from the file and mencoder to produce the stream, but both of these programs use the same libraries and such. Any thoughts? Thank you.
jaguar7926
 
Posts: 6
Joined: Wed Mar 25, 2009 4:19 am


Return to Linux/Unix Support

Who is online

Users browsing this forum: No registered users and 5 guests