PS3 tsMuxeR problem Ubuntu 11.10 happy-neko PPA

For help and support with issues specific to Linux/Unix
Forum rules
Please make sure you follow the Problem Reporting Guidelines before posting if you want a reply.

Re: PS3 tsMuxeR problem Ubuntu 11.10 happy-neko PPA

Postby Slim_Jim » Fri Apr 06, 2012 8:06 am

I have the same issue loz describes.

Fresh install of Ubuntu 11.10 and happy-neko PPA.
Slim_Jim
 
Posts: 1
Joined: Fri Apr 06, 2012 8:02 am

Re: PS3 tsMuxeR problem Ubuntu 11.10 happy-neko PPA

Postby loz » Wed Apr 11, 2012 1:13 pm

I suspect Ubuntu 11.10 64-bit is broken.

I built a VM on my Mac with fresh install of Ubuntu 11.10 64-bit on VMWare Fusion 4. Same result. TsMuxer is broken.

When I get time I will remove the ppa and do a manual install. See if that changes anything.
loz
 
Posts: 17
Joined: Wed Mar 14, 2012 1:51 pm

Re: PS3 tsMuxeR problem Ubuntu 11.10 happy-neko PPA

Postby happy.neko » Wed Apr 11, 2012 1:41 pm

I have zero problems with tsmuxer and Ubuntu 11.10 64-bit.
Please upload media sample to mediafire and debug.log to http://pastebin.com/
happy.neko
Project Member
 
Posts: 478
Joined: Fri Sep 23, 2011 5:38 pm

Re: PS3 tsMuxeR problem Ubuntu 11.10 happy-neko PPA

Postby loz » Wed Apr 11, 2012 2:11 pm

Hi happy.necko, thanks for the response. These files played fine with my previous manual installs (pre 1.5x release) before discovering your ppa. I have been using PMS for a couple of years. Most files are m4v dvd rips using handbrake. Others are mpeg2 TS files recorded using my Topfield pvr. These used to be processed fine using tsmuxer, but no longer. Perhaps i have some other problem with my Ubuntu installation seperate to the ppa install. I have the Debug.log already posted in this thread, but I will post to pastebin as requested. I will also post a sample media file as requested.
loz
 
Posts: 17
Joined: Wed Mar 14, 2012 1:51 pm

Re: PS3 tsMuxeR problem Ubuntu 11.10 happy-neko PPA

Postby loz » Thu Apr 12, 2012 10:53 am

I have posted a sample mpg file to mediafire. This is a 5 min recording from my Topfield PVR.

http://www.mediafire.com/?1otxa5btpzx6bf8

The debug.log can be found at http://pastebin.com/e9tdMtR2

I played the movie sample.mpg using tsmuxer and got the ps3 data is corrupted message.

I then went into the transcoder folder and played the menscoder version which played fine.
loz
 
Posts: 17
Joined: Wed Mar 14, 2012 1:51 pm

Re: PS3 tsMuxeR problem Ubuntu 11.10 happy-neko PPA

Postby happy.neko » Thu Apr 12, 2012 3:16 pm

TSMuxer cant parse this sample, specifically video track. You can play it on PS3 natively without transcoding or remuxing though.

Are you sure it was playable via tsmuxer with previous versions of PS3MS?
Attachments
tsmuxer-error.png
tsMuxer error
tsmuxer-error.png (52.46 KiB) Viewed 2244 times
happy.neko
Project Member
 
Posts: 478
Joined: Fri Sep 23, 2011 5:38 pm

Re: PS3 tsMuxeR problem Ubuntu 11.10 happy-neko PPA

Postby loz » Thu Apr 12, 2012 11:32 pm

Yes certain. I have 40+ recorded movies and tv shows that we have been watching for some time.

In addition I have other problems. I cannot play most of my Handbrake ripped DVDs (.m4v) movies. Perhaps I will post another sample of one of these.
loz
 
Posts: 17
Joined: Wed Mar 14, 2012 1:51 pm

Re: PS3 tsMuxeR problem Ubuntu 11.10 happy-neko PPA

Postby happy.neko » Fri Apr 13, 2012 3:32 pm

Both mp4v and ts are supported natively by PS3, try to play them through TRANSCODING => [no encode]. There is possibility that on previous versions of PSM3 this mode was used by default, not remuxing with tsmuxer.

If you are sure that tsMuxer engine was used please find exact version of PS3MS where provided sample is working and I'll compare results to see what was changed.
happy.neko
Project Member
 
Posts: 478
Joined: Fri Sep 23, 2011 5:38 pm

Re: PS3 tsMuxeR problem Ubuntu 11.10 happy-neko PPA

Postby loz » Sat Apr 14, 2012 1:32 pm

Well yes both file formats play perfectly without muxing or transcoding.

So how can I tell PMS not to transcode or to use txmuxer on these file formats? Can you point me to some guide on how to do this?
loz
 
Posts: 17
Joined: Wed Mar 14, 2012 1:51 pm

Re: PS3 tsMuxeR problem Ubuntu 11.10 happy-neko PPA

Postby happy.neko » Fri Apr 20, 2012 2:31 pm

loz wrote:Well yes both file formats play perfectly without muxing or transcoding.

So how can I tell PMS not to transcode or to use txmuxer on these file formats? Can you point me to some guide on how to do this?


Sorry for the late reply.
Transcoding decisions are based on /etc/ps3mediaserver/renderers/PS3.conf and several hardcoded checks. Its kinda messy right now. Try renaming *.mpg files to ts and *.mp4v to mp4.
happy.neko
Project Member
 
Posts: 478
Joined: Fri Sep 23, 2011 5:38 pm

PreviousNext

Return to Linux/Unix Support

Who is online

Users browsing this forum: No registered users and 3 guests