pms-mlx (13-12-04 v1.0)

Download and discuss official beta builds here

Re: pms-mlx (12-04-01 v0.7)

Postby taconaut » Mon Apr 09, 2012 8:34 am

killa339 wrote:Awesome, that seems to have fixed it!

Cool :)

killa339 wrote:1. Do you have to link your tmdb account anymore? When I click the 'set user' button nothing happens, whereas before it would pup up a browser window to the website. From there, you would login, tell tmdb to allow access and then the user name would appear in the tmdb account name section of the media library. In the end, it looks like info was still begin pulled from tmdb. At least tmdb specific info appears to be in the database now.

Nothing has changed in there, but I've noticed the login being frequently down on the tmdb side. It shouldn't be a big issue, as I'd be surprised you've used the only feature using the configured account. If a a tmdb account has been set, a folder to rate movies on tmdb can be added when showing a file as a folder.

killa339 wrote:2. When imdb/tmdb info was being pulled for my movies, I noticed this error consistently coming up:
Code: Select all
The plugin='tmdb' returned a value of the wrong type for the FileProperty='VIDEO_REVENUE'. Expected='class java.lang.Integer', Received='class java.lang.Long'
Every revenue db entry is 0.

Had missed this one, going to fix it.

killa339 wrote:Another thing I just noticed. It seems that files with periods are not rendered properly on my tv anymore. It's not the first period that messes it up though. For example:

File name: 'Louis C.K. - Chewed Up (2008)' shows up as 'Louis C.K' on my tv. Everything after the second period is lost.
File name: 'G.I. Joe - The Rise of Cobra' shows up as 'G.I' on my tv. Everything after the second period is lost.

The full name is showing up in the library and tree views. This all worked fine with 0.6

EDIT 2:

More info on the above. If I make a folder that is A-Z or by Genre then it cuts off like in the way I mention above. These folders are set to 'display as file'. If I make a folder that is 'display as folder' then the folder on my tv has the full name but when I go inside, the file to play the video has the name cut off like I discuss above. Both have %name as the mask.

Uncheck 'hide extensions' in the navigation/share settings tab. This feature removes everything after the last dot in the file name. This tab should vanish at some point (https://github.com/taconaut/pms-mlx/issues/26).

killa339 wrote:Another bug: I have a directory initially set to 'display as file' and set thumbnails to be cover. I then chose to display as folder. In the gui, I right clicked the initial green folder, chose edit and then chose to display a picture as the thumbnail.

When I view this on my tv, I see a folder with cover icons rendered inside the folder icon, rather than the picture I chose. If I go back in, change back to 'display as file', choose the pic I wanted (removing the cover option that was there), change back to 'view as folder' then it displays properly. I guess the 'display as file' options are overriding the initial folder thumbnail setting under 'display as folder'?

I'll have to first understand the bug and then see what's going wrong..
[edit] after some coffe, it starts to make sense; your Bravia can show thumbnails for folders! None of my renderers can and folder thumbnails aren't being set by pms-mlx. I'm surprised it is configurable where you said. Pms supports folder thumbnails and it wouldn't be too much of a hassle to add it. What thumbnail do other folders show?

Thanks for the feedback!
If you always wanted to have your most recent videos at the top of the folder in the ps3 or wished you could group all videos with the same genre in one folder, have a look at pms-mlx
taconaut
Project Member
 
Posts: 1059
Joined: Sat Apr 11, 2009 12:29 am
Location: Switzerland

Re: pms-mlx (12-04-01 v0.7)

Postby taconaut » Mon Apr 09, 2012 9:59 am

So people don't get lost, I'll move this topic to the beta builds forum, as this build becomes more and more a beta build of pms.
If you always wanted to have your most recent videos at the top of the folder in the ps3 or wished you could group all videos with the same genre in one folder, have a look at pms-mlx
taconaut
Project Member
 
Posts: 1059
Joined: Sat Apr 11, 2009 12:29 am
Location: Switzerland

Re: pms-mlx (12-04-01 v0.7)

Postby killa339 » Mon Apr 09, 2012 3:01 pm

taconaut wrote:
killa339 wrote:Another thing I just noticed. It seems that files with periods are not rendered properly on my tv anymore. It's not the first period that messes it up though. For example:

File name: 'Louis C.K. - Chewed Up (2008)' shows up as 'Louis C.K' on my tv. Everything after the second period is lost.
File name: 'G.I. Joe - The Rise of Cobra' shows up as 'G.I' on my tv. Everything after the second period is lost.

The full name is showing up in the library and tree views. This all worked fine with 0.6

EDIT 2:

More info on the above. If I make a folder that is A-Z or by Genre then it cuts off like in the way I mention above. These folders are set to 'display as file'. If I make a folder that is 'display as folder' then the folder on my tv has the full name but when I go inside, the file to play the video has the name cut off like I discuss above. Both have %name as the mask.

Uncheck 'hide extensions' in the navigation/share settings tab. This feature removes everything after the last dot in the file name. This tab should vanish at some point (https://github.com/taconaut/pms-mlx/issues/26).

Yup, that fixed it. Interesting, I swear I needed to have that checked before.

taconaut wrote:
killa339 wrote:Another bug: I have a directory initially set to 'display as file' and set thumbnails to be cover. I then chose to display as folder. In the gui, I right clicked the initial green folder, chose edit and then chose to display a picture as the thumbnail.

When I view this on my tv, I see a folder with cover icons rendered inside the folder icon, rather than the picture I chose. If I go back in, change back to 'display as file', choose the pic I wanted (removing the cover option that was there), change back to 'view as folder' then it displays properly. I guess the 'display as file' options are overriding the initial folder thumbnail setting under 'display as folder'?

I'll have to first understand the bug and then see what's going wrong..

Let me know if I didn't explain it well. I think what I said makes sense. :P
killa339
 
Posts: 37
Joined: Thu Mar 17, 2011 2:46 pm

Re: pms-mlx (12-04-01 v0.7)

Postby taconaut » Mon Apr 09, 2012 3:10 pm

Just edited my post above at the same time. Does it make sense?
If you always wanted to have your most recent videos at the top of the folder in the ps3 or wished you could group all videos with the same genre in one folder, have a look at pms-mlx
taconaut
Project Member
 
Posts: 1059
Joined: Sat Apr 11, 2009 12:29 am
Location: Switzerland

Re: pms-mlx (12-04-01 v0.7)

Postby squadjot » Mon Apr 09, 2012 6:18 pm

I can not log in to tmdb via PMS.. (but i can log in TMDB with browser)

Oh another question.. do you have a list of with all the possible vars like.. "%name" , "%folder_path"..
User avatar
squadjot
 
Posts: 243
Joined: Thu Mar 25, 2010 10:03 pm

Re: pms-mlx (12-04-01 v0.7)

Postby taconaut » Mon Apr 09, 2012 6:53 pm

squadjot wrote:I can not log in to tmdb via PMS.. (but i can log in TMDB with browser)

Me neither. I think it's an issue with tmdb (or maybe the used library jtmdb). You only need to log in to rate movies from the ps3. Do you use that?

squadjot wrote:Oh another question.. do you have a list of with all the possible vars like.. "%name" , "%folder_path"..

Only the cheep version: File, Video
If you always wanted to have your most recent videos at the top of the folder in the ps3 or wished you could group all videos with the same genre in one folder, have a look at pms-mlx
taconaut
Project Member
 
Posts: 1059
Joined: Sat Apr 11, 2009 12:29 am
Location: Switzerland

Re: pms-mlx (12-04-01 v0.7)

Postby squadjot » Mon Apr 09, 2012 7:12 pm

Thanks

You only need to log in to rate movies from the ps3. Do you use that?

Well no =).. but i thought it had the effect, that MLX knew which movies you watched already ( because you've rated them ) -atleast, I think thast would be nice if that was so..

Edit: But i think the rating through XBM feature is cool, is just wasnt aware of it's existence =P
User avatar
squadjot
 
Posts: 243
Joined: Thu Mar 25, 2010 10:03 pm

Re: pms-mlx (12-04-01 v0.7)

Postby killa339 » Tue Apr 10, 2012 5:13 am

taconaut wrote:
squadjot wrote:I can not log in to tmdb via PMS.. (but i can log in TMDB with browser)

Me neither. I think it's an issue with tmdb (or maybe the used library jtmdb). You only need to log in to rate movies from the ps3. Do you use that?

Like I mentioned above, I too cannot log in to tmdb via PMS. Also, I always assumed you needed an account to actually do the tmdb importing. Didn't realize it's only for rating movies via the program. Cool.


taconaut wrote:[edit] after some coffe, it starts to make sense; your Bravia can show thumbnails for folders! None of my renderers can and folder thumbnails aren't being set by pms-mlx. I'm surprised it is configurable where you said. Pms supports folder thumbnails and it wouldn't be too much of a hassle to add it. What thumbnail do other folders show?

Well initially there is an icon of a folder representing that what you are looking at is a folder. If you set a thumbnail for it (say cover) then it takes that cover and places it really small inside that folder icon. So you see a folder and your pic in the middle of it. Looks pretty silly. If you set it to a picture and leave the path blank, then it will use the picture of a ps3 as the thumbnail. This is what PMS does for files too if you set to use a picture as a thumbnail but don't supply a path. I did notice that if you do that, it takes a lot longer for the listing to populate on the TV than if you set a thumbnail with an actual path. I've seen this behavior with versions way back. Yours and vanilla PMS.

Anyway, let me go into more detail with what I saw, because I really do think there is an issue here.

I'm in Media Library tab, under the Tree section.

- I right click a folder I added under the tree and choose edit.
- It currently is set to "Display as File" at the bottom.
- I set the thumbnail to be a cover.
- I go eh, actually I want this to be displayed as a folder so I can show other info too. I change it to "Display as folder"
- The view changes to a listing like:
Code: Select all
 %name (%year) --> depicted as a green folder in the gui
   Plot --> depicted as a green folder in the gui
     %overview
   ...

- I right click the first green folder "%name (%year)" and choose edit.
- I set the thumbnail here to be a picture of my choice.
- I save everything and look at the listing on my tv.
- Everything is being displayed, but the folder icons have tiny cover thumbnails being rendered in the center of them.
- I go back to program, change it back to "display as file"
- I change the thumbnail setting, which I had previously left as cover, to the specific pic I had set when I right clicked the green folder.
- I then change it back again to "display as folder"
- Now when I look at the listing on the tv, the covers are not displayed and the pic I wanted is now rendered in the center of the folder icon.

So, even though I can edit the folder to show a thumbnail, it seems that whatever is set under "display as file" takes precedence. Now interestingly enough, this only happens to the initial folder. All other folders inside it take the thumbnails that I set for them individually. Also, the mask setting under "view as file" takes precedence over the mask I set for the first folder. For example, even though the first folder was set to "%name (%year)" because I had only "%name" for the mask under the "display as file" view, only the name was displayed for the folder. I had to switch back to "display as file", change the mask to look exactly like it did for the other view and then change it back to "display as folder". Again, only the first folder is affected.
killa339
 
Posts: 37
Joined: Thu Mar 17, 2011 2:46 pm

Re: pms-mlx (12-04-01 v0.7)

Postby killa339 » Tue Apr 10, 2012 7:19 am

In an unrelated note, do I have to do anything special to get the Channels plugin to work with MLX? For the life of me, I cannot get it to work. In the trace it says its read in the channels and I see a channel folder, but when I go in the folder, it says it's empty. I have the .ch files and all the scripts.

I do have pmsencoder working though and can stream trailers, etc with that. Just curious if you have any tips for the Channels plugin. There is different install info for it floating around. I guess I can go poke SharkHunter about this.
killa339
 
Posts: 37
Joined: Thu Mar 17, 2011 2:46 pm

Re: pms-mlx (12-04-01 v0.7)

Postby taconaut » Tue Apr 10, 2012 7:36 am

squadjot wrote:Thanks

You only need to log in to rate movies from the ps3. Do you use that?

Well no =).. but i thought it had the effect, that MLX knew which movies you watched already ( because you've rated them ) -atleast, I think thast would be nice if that was so..

Edit: But i think the rating through XBM feature is cool, is just wasnt aware of it's existence =P

It's probably the most hidden feature (it's actually a plugin) in pms-mlx :) You have to edit the template to show a file as a folder (tree view -> right click on media library folder -> edit -> show file as folder -> edit -> right click on a folder -> add TMDb rater). This entry will only be configured if a tmdb account has been set (where it currently isn't working).

I'm going to remove the tmdb user account configuration from the general options view. As your comments show it's rather confusing. It will move to a global configuration panel for the tmdb plugin itself, but some things are missing (there's no global configuration panel for pms-mlx plugins yet).
The reason it's there is that tmdb was the first (hard coded) import engine. Now that everything has become configurable through plugins it doesn't make sense to keep it in a global view.

@killa339
As said, I've never 'intentionally' implemented support for folder thumbnails, so everything you see is some kind of side effect. I'll have a look at it when I get some time. You'll have to test it as I got no way to see folder thumbnails ;)

killa339 wrote:In an unrelated note, do I have to do anything special to get the Channels plugin to work with MLX? For the life of me, I cannot get it to work. In the trace it says its read in the channels and I see a channel folder, but when I go in the folder, it says it's empty. I have the .ch files and all the scripts.

I do have pmsencoder working though and can stream trailers, etc with that. Just curious if you have any tips for the Channels plugin. There is different install info for it floating around. I guess I can go poke SharkHunter about this.

All plugins from the original pms are supposed to work except for the AdditionalResourceFolderListener (the Channels plugin is a AdditionalFolderAtRoot). As I don't use it I can't tell how it has to be configured. Hope SharkHunter is able to help you out.
If you always wanted to have your most recent videos at the top of the folder in the ps3 or wished you could group all videos with the same genre in one folder, have a look at pms-mlx
taconaut
Project Member
 
Posts: 1059
Joined: Sat Apr 11, 2009 12:29 am
Location: Switzerland

PreviousNext

Return to Beta Builds

Who is online

Users browsing this forum: No registered users and 5 guests