PMS SubJunk Build

Download and discuss official beta builds here

Re: PMS SubJunk Build 68 (Updated 2012-03-15)

Postby medowance » Wed Mar 21, 2012 1:09 pm

plivac wrote:had SB29 running and wanted to try newer builds 51 and 68 - however when installed they cannot find PS3 (or vice versa) - when I re-install the SB29 all works good.

been having issue with subtitles on a specific torrent - they are not showing up even after remuxing in MKVGUI - maybe some advice:
http://www.nyaa.eu/?page=torrentinfo&tid=295143

thanks in advance


Same issue here, unable detect PS3

Source on WIFI; PS3 on LAN
medowance
 
Posts: 4
Joined: Mon Jul 19, 2010 9:28 am

Re: PMS SubJunk Build 68 (Updated 2012-03-15)

Postby SuperDre » Thu Mar 22, 2012 10:55 pm

Just a question about a filesupport.. MPlayer supports .bik (Bink) files, so mencoder would supposedly also support it, but it doesn't show up when I go to a folder which has some files in them.. Is there a way to get them to show up?
SuperDre
 
Posts: 81
Joined: Fri Mar 20, 2009 5:49 pm

Re: PMS SubJunk Build 68 (Updated 2012-03-15)

Postby Coltaine79 » Fri Mar 23, 2012 4:46 am

I hope this hasn't been asked before, but... any plans to add support for the "PGS" subtitle format? (i believe it's the raw subtitle stream from Blu-Ray).
Coltaine79
 
Posts: 175
Joined: Wed Aug 25, 2010 9:00 pm

Re: PMS SubJunk Build 68 (Updated 2012-03-15)

Postby Cardcaptor_RLH85 » Fri Mar 23, 2012 8:27 pm

Madoka wrote:Just popping in to say that I'm loving SB68. .ass subtitles work with .mp4 files! Woot!


Yeah, I wanted to say this too! Being able to watch files with .ass subtitles in .mp4 containers without transcoding is definitely a long-awaited improvement! I didn't even request it since I didn't think that it could be done. Thank you so much ^_^
Last edited by Cardcaptor_RLH85 on Tue Mar 27, 2012 8:23 pm, edited 1 time in total.
Cardcaptor_RLH85
 
Posts: 5
Joined: Sat Apr 23, 2011 11:02 pm

Re: PMS SubJunk Build 68 (Updated 2012-03-15)

Postby ExSport » Sat Mar 24, 2012 9:27 pm

mazey wrote:
SubJunk wrote:Yeah looks like there's something weird about the video


well all i can figure is there is nothing wrong with pms code which is a good thing, and it doesnt seem its anything u have done, it seems mencoder developers have done something because sb26,27,28 is all affected but everything sb25 and before works fine. hopefully it gets fixed along the line in time. im gonna just use sb25 for now since it plays everything flawlessly just be aware of the issue and i will continue to try new memcoder builds to see if it gets fixed and let u know. some mkv's are only affected (probably about 5% of what i have which isnt that many, mostly music videos or doco's) but it doesnt seem avi's are affected at all. as for the error msg below this was introduced in sb27 and doesnt do it in sb26 though sb26 still has the sync issue so i dont think its related unless they made the change in sb26 then started logging it in sb27.

Too many video packets in the buffer: (1052 in 33572624 bytes).
Maybe you are playing a non-interleaved stream/file or the codec failed?
For AVI files, try to force non-interleaved mode with the -ni option.

I have to agree with others that MEncoder builds after SB25 are all broken.
SB25 is OK but others (26-28) stutter in video and audio is not synced for many MKV files what I have. It is because:
Code: Select all
Too many video packets in the buffer: (502 in 33555824 bytes).
Maybe you are playing a non-interleaved stream/file or the codec failed?
For AVI files, try to force non-interleaved mode with the -ni option.

When SB25 is used, immediately after showing message:
Code: Select all
Increasing audio density to 4.
MEncoder continue displaying other messages:
Code: Select all
Unsupported PixelFormat 61
Unsupported PixelFormat 53
Unsupported PixelFormat 81
Muxer frame buffer cannot allocate memory!
Muxer frame buffer cannot allocate memory!
Muxer frame buffer cannot allocate memory!
Movie-Aspect is 2.40:1 - prescaling to correct movie aspect.
videocodec: libavcodec (1920x800 fourcc=3267706d [mpg2])
[VE_LAVC] Using constant qscale = 1.000000 (VBR).
Writing header...
INITV: 0.200, 0.158, fps: 23.976

But when more recent build is used, after "Increasing audio density to 4." it freezes for few seconds and after that this message is shown:
Code: Select all
Too many video packets in the buffer: (502 in 33555824 bytes).
Maybe you are playing a non-interleaved stream/file or the codec failed?
For AVI files, try to force non-interleaved mode with the -ni option.
Unsupported PixelFormat 61
.................

And this warning message is repeating with same freezes as transcoding continues which leads to choppy and unsynced video/audio.
Only what I can see from MEncoder output what differ is):
WORKING
Code: Select all
libavformat version 54.1.100 (internal)

NOT WORKING:
Code: Select all
libavformat version 54.2.100 (internal)

I suppose MEncoder should be reverted for SB and official builds for now until it will be fixed to avoid complains that new PMS builds works badly(stuttering, out of sync etc.).
Subjunk, hopefully you will find root cause 8-)
Many thanks for looking into it!
ExSport
EDIT:
To all who are affected, replace new MEncoder/MPlayer build (SB28) with SB25 which works without problems...until it will be fixed 8-)
ExSport
 
Posts: 2168
Joined: Mon Jan 19, 2009 5:40 pm

Re: PMS SubJunk Build 68 (Updated 2012-03-15)

Postby mazey » Sun Mar 25, 2012 2:41 am

yeah i been using sb25 hehe its nice cuz it plays everything flawlessly! i am testing all future sb mencoder builds though but yeah sb26/27/28 are all affected.
PMS 1.90.2 Snapshot - Intel Celeron G1840 Dual 2.8Ghz / Asus Z97m-plus / Corsair Vengeance 8GB / Windows 8.1 Pro (64 bit)
mazey
 
Posts: 775
Joined: Sat Oct 24, 2009 9:07 am

Re: PMS SubJunk Build 68 (Updated 2012-03-15)

Postby Madoka » Sun Mar 25, 2012 4:12 am

I know I can use -nosync in the options to disable alternatice sync method, is there a command to enable it?

And would going back to SB25 make .ass subtitles not work with .mp4 files again (well, work with the default settings like the old fix)?
Madoka
 
Posts: 111
Joined: Fri Feb 19, 2010 3:02 am

Re: PMS SubJunk Build 68 (Updated 2012-03-15)

Postby Coltaine79 » Sun Mar 25, 2012 8:09 pm

Madoka wrote:I know I can use -nosync in the options to disable alternatice sync method, is there a command to enable it?


why not simply use the Checkbox?
Coltaine79
 
Posts: 175
Joined: Wed Aug 25, 2010 9:00 pm

Re: PMS SubJunk Build 68 (Updated 2012-03-15)

Postby Coltaine79 » Sun Mar 25, 2012 8:11 pm

ExSport, the problem that you talk about - is it happening on ALL of your MKVs or just some of them?
Also do you have Alternate AV Synch on?
Coltaine79
 
Posts: 175
Joined: Wed Aug 25, 2010 9:00 pm

Re: PMS SubJunk Build 68 (Updated 2012-03-15)

Postby Madoka » Sun Mar 25, 2012 9:39 pm

Coltaine79 wrote:
Madoka wrote:I know I can use -nosync in the options to disable alternatice sync method, is there a command to enable it?

why not simply use the Checkbox?

LOL. Well, I am. The deal is I use subtitles all the time. I have found that my mkvs go way out of sync unless the alt sync box is checked, but sometimes it seems that having alt sync checked may cause a tiny delay in avis or mp4s. So, I currently have the box checked and then put in an exception in the custom settings for avis and mp4s to turn it off. I was wondering if there was a command to turn it on, so I could turn it on only for mkvs (which I don't play as much compared to mp4s) and leave it unchecked (as I want it off more than on).

I have also noticed that using subs on mp4s and overscan compensation results in some serious stuttering as if your bandwidth was not enough, but I have a wired connection. I have tried oversan compensation on some files without subs, and I do not get this issue.
Madoka
 
Posts: 111
Joined: Fri Feb 19, 2010 3:02 am

PreviousNext

Return to Beta Builds

Who is online

Users browsing this forum: No registered users and 3 guests