TRANSCODE Folder does not show audio/subtitle options

For help and support with issues specific to Linux/Unix
Forum rules
Please make sure you follow the Problem Reporting Guidelines before posting if you want a reply.

TRANSCODE Folder does not show audio/subtitle options

Postby magistratee » Sat Mar 28, 2009 6:37 am

Hello all I have a couple questions if you all can help me out. I appreciate the help. I am running a media server, unRAID. It is Linux based of slackware I believe and does not use a GUI (except for web based items for maintenance) and is cmd line based. I am not a Linux expert but I got this running on my server but I am having a couple problems. When I go to the TRANSCODE folder of a file I get a lot of options for audio/subtitles but when I go to the same file on my Linux box the only get 2 options, MENCODER of the file and TSMUX.

I have installed several codec packages (about 36) here including the major ones: jre-6u11-i586-1, a52dec-0.7.4-i486-2gds, alsa-lib-1.0.15-i486-1, amrnb-, amrwb-, cdparanoia-III10pre0-i486-1, faac-1.26-i486-1gds, faad2-2.6.1-i486-2gds, ffmpeg-20081129-i686-1sl, fontconfig-2.4.2-i486-2, freetype-2.3.5-i486-1, fribidi-0.10.9-i486-2, lame-3.98.2-i486-1kjz, lcms-1.17-i486-1, libdc1394-2.0.2-i486-1gds, libdv-1.0.0-i486-2gds, libjpeg-6b-i486-5, libmad-0.15.1b-i486-3, libmng-1.0.10-i486-1, libmpcdec-1.2.6-i486-2gds, libogg-1.1.3-i486-2, libpng-1.2.27-i486-1, libraw1394-2.0.0-i486-1gds, libtheora-1.0beta2-i486-1, libungif-4.1.4-i486-4, libvorbis-1.2.0-i486-1, libX11-1.1.5-i486-1, libXau-1.0.3-i486-1, libxcb-1.0-i486-2, libXdmcp-1.0.2-i486-1, libXext-1.0.4-i486-1, lzo-2.02-i486-1, mplayer-20081202-x86-1sl, speex-1.2rc1-i486-2kjz, twolame-0.3.12-i486-1kjz, x264-20090107-i486-1as, xvidcore-1.2.1-i486-1sl

This is my current PMS.conf:
Code: Select all
thumbnails = true
alternativeffmpegpath =
mencoder_ass = true
folders = /mnt/user/Anime
audiobitrate = 640
mencoder_usepcm = false
mencoder_mt = false
tsmuxer_preremux_pcm = true
mencoder_remux_ac3 = true
mencoder_encode = keyint=3:vqscale=2:vqmin=3
mencoder_audiolangs = jpn
mencoder_sublangs = eng

I think this part of my DEBUG file where it is trying to transcode the file:
Code: Select all
[mencoder] INFO  21:56:36.748 Starting mencoder -ss 0 -quiet /mnt/user/Anime/TU_01.mkv -quiet -quiet -oac lavc -of mpeg -mpegopts format=mpeg2:muxrate=500000:vbuf_size=1194:abuf_size=64 -ovc lavc -channels 6 -lavdopts debug=0:threads=1 -lavcopts autoaspect=1:vcodec=mpeg2video:acodec=ac3:abitrate=640:threads=1:keyint=3:vqscale=2:vqmin=3 -quiet -nofontconfig -subcp cp1252 -alang jpn -ass-color ffffff00 -ass-border-color 00000000 -ass-font-scale 1.0 -ass-force-style FontName=Arial,Outline=1,Shadow=1,MarginV=10 -slang eng -quiet -quiet -quiet -quiet -ofps 24000/1001 -quiet -quiet -mc 0 -noskip -af lavcresample=48000 -srate 48000 -o /tmp/javaps3media/mencoder1238216196673
[mencoder] INFO  21:56:36.778 Reading pipe: /tmp/javaps3media/mencoder1238216196673
[mencoder] DEBUG 21:56:36.778 Opening file /tmp/javaps3media/mencoder1238216196673 for reading...
[Timer-3] DEBUG 21:56:36.977 Buffered Space: 0 bytes
[mencoder] INFO  21:56:36.978 Attaching thread: mencoder
[Thread-106] DEBUG 21:56:36.978 MEncoder dev-SVN-r28058-4.2.3 (C) 2000-2008 MPlayer Team
[Thread-106] DEBUG 21:56:36.978 CPU: Intel(R) Celeron(R) CPU          430  @ 1.80GHz (Family: 6, Model: 22, Stepping: 1)
[Thread-106] DEBUG 21:56:36.978 CPUflags: Type: 6 MMX: 1 MMX2: 1 3DNow: 0 3DNow2: 0 SSE: 1 SSE2: 1
[Thread-106] DEBUG 21:56:36.978 Compiled with runtime CPU detection.
[Thread-106] DEBUG 21:56:36.978 success: format: 0  data: 0x0 - 0xe68a7f4
[Thread-106] DEBUG 21:56:36.978 [mkv] Track ID 1: video (V_MS/VFW/FOURCC), -vid 0
[Thread-106] DEBUG 21:56:36.979 [mkv] Track ID 2: audio (A_VORBIS), -aid 0, -alang jpn
[Thread-106] DEBUG 21:56:36.979 [mkv] Track ID 3: audio (A_VORBIS), -aid 1, -alang eng
[Thread-106] DEBUG 21:56:36.979 [mkv] Track ID 4: subtitles (S_TEXT/SSA) "Full Subtitles", -sid 0, -slang eng
[Thread-106] DEBUG 21:56:36.979 [mkv] Track ID 5: subtitles (S_TEXT/SSA) "OnScreen Subtitles", -sid 1, -slang eng
[Thread-106] DEBUG 21:56:36.979 [mkv] Will play video track 1.
[Thread-106] DEBUG 21:56:36.979 Matroska file format detected.
[Thread-106] DEBUG 21:56:36.979 VIDEO:  [XVID]  640x480  12bpp  23.976 fps    0.0 kbps ( 0.0 kbyte/s)
[Thread-106] DEBUG 21:56:36.979 [V] filefmt:31  fourcc:0x44495658  size:640x480  fps:23.976  ftime:=0.0417
[Thread-106] DEBUG 21:56:36.979 ==========================================================================
[Thread-106] DEBUG 21:56:36.979 Opening audio decoder: [ffmpeg] FFmpeg/libavcodec audio decoders
[Thread-106] DEBUG 21:56:36.979 AUDIO: 48000 Hz, 2 ch, s16le, 0.0 kbit/0.00% (ratio: 0->192000)
[Thread-106] DEBUG 21:56:36.979 Selected audio codec: [ffvorbis] afm: ffmpeg (FFmpeg Vorbis decoder)
[Thread-106] DEBUG 21:56:36.980 ==========================================================================
[Thread-106] DEBUG 21:56:36.980 PACKET SIZE: 2048 bytes, deltascr: 884
[Thread-106] DEBUG 21:56:36.980 Opening video filter: [expand osd=1]
[Thread-106] DEBUG 21:56:36.980 Expand: -1 x -1, -1 ; -1, osd: 1, aspect: 0.000000, round: 1
[Thread-106] DEBUG 21:56:36.980 ==========================================================================
[Thread-106] DEBUG 21:56:36.980 Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
[Thread-106] DEBUG 21:56:36.980 Selected video codec: [ffodivx] vfm: ffmpeg (FFmpeg MPEG-4)
[Thread-106] DEBUG 21:56:36.980 ==========================================================================
[Thread-106] DEBUG 21:56:36.980 VDec: vo config request - 640 x 480 (preferred colorspace: Planar YV12)
[Thread-106] DEBUG 21:56:36.980 VDec: using Planar YV12 as output csp (no 0)
[Thread-106] DEBUG 21:56:36.980 Movie-Aspect is 1.33:1 - prescaling to correct movie aspect.
[Thread-106] DEBUG 21:56:36.980 videocodec: libavcodec (640x480 fourcc=3267706d [mpg2])
[Thread-106] DEBUG 21:56:36.981 [VE_LAVC] Using constant qscale = 2.000000 (VBR).
[Thread-106] DEBUG 21:56:36.981 Writing header...
[Thread-103] DEBUG 21:56:36.981 Limiting audio preload to 0.4s.
[Thread-103] DEBUG 21:56:36.981 Increasing audio density to 4.
[Thread-103] DEBUG 21:56:36.981 [mpeg4 @ 0x8e03620]Invalid and inefficient vfw-avi packed B frames detected
[Thread-103] DEBUG 21:56:36.981 New_Face failed. Maybe the font path is wrong.
[Thread-103] DEBUG 21:56:36.981 Please supply the text font file (~/.mplayer/subfont.ttf).
[Thread-103] DEBUG 21:56:36.981 subtitle font: load_sub_face failed.

I am currently running this on a Celeron 430, 1GB DDR2, Gigabit Network. If the transcode folder will not work can I at least get my subtitles to work because I can set the default audio but I cannot set the default subtitle
mencoder_sublangs = eng
. I also tried doing
mencoder_audiosublangs = eng,on;
I have tried this on both the 1.04 and the 1.10.5 versions.

If you need any more info let me know. I really appreciate any help I can get. Thanks.
Posts: 5
Joined: Wed Mar 25, 2009 10:27 am

Re: TRANSCODE Folder does not show audio/subtitle options

Postby shagrath » Sat Mar 28, 2009 11:59 am

I guess it's due to your ffmpeg version who isn't up to date (ffmpeg is used to parse the video)
Project Lead
Posts: 2668
Joined: Wed Jan 14, 2009 1:39 pm

Re: TRANSCODE Folder does not show audio/subtitle options

Postby magistratee » Sun Mar 29, 2009 3:56 am

shagrath wrote:I guess it's due to your ffmpeg version who isn't up to date (ffmpeg is used to parse the video)

Thanks for the reply. I finally got the TRANSCODE folder to show all the audio/subtitle options when I used a different ffmpeg, ffmpeg-20081102-i486-1gds.tgz. I can now see all the audio/subtitle tracks now and switch between them.

Now that I have that working the only problem I have now is the subtitles. When choosing the options in the TRANSCODE folder whatever audio stream is chose with or without subtitles it will play the correct stream. The only problem now is the fact that the subtitles are not showing up. I tried using different mplayer versions such as mplayer-1.0rc2try4-i486-1kjz.tgz and mplayer-20090112-x86-1sl.tgz but when I use these I get a corrupted error message so I just used the original one I had, mplayer-20081202-x86-1sl.tgz. Do you know any other versions that are out there that I can try?

One thing I found which may be a problem is this line:
Code: Select all
[Thread-464] DEBUG 19:43:58.015 New_Face failed. Maybe the font path is wrong.
[Thread-464] DEBUG 19:43:58.015 Please supply the text font file (~/.mplayer/subfont.ttf).
[Thread-464] DEBUG 19:43:58.015 subtitle font: load_sub_face failed.

Do you know where I can get this file and install it?

Posts: 5
Joined: Wed Mar 25, 2009 10:27 am

Re: TRANSCODE Folder does not show audio/subtitle options

Postby magistratee » Sun Mar 29, 2009 10:09 am

Thanks I found out how to do some of this. I renamed a arial.ttf to the mplayer folder and disabled ASS and the subtitles work now.

The only problem remaining now is that depending on the file it will only play with either one or another version of ffmpeg and can be annoying to reinstall the compatible ffmpeg version just to play one or two files which were not able to be read by another version of fmpeg. Hopefully the next ffmpeg or pms update will correct this.
Posts: 5
Joined: Wed Mar 25, 2009 10:27 am

Return to Linux/Unix Support

Who is online

Users browsing this forum: No registered users and 1 guest