Poor PlayList Performance

For help and support with PS3 Media Server in general
Forum rules
Please make sure you follow the Problem Reporting Guidelines before posting if you want a reply.

Poor PlayList Performance

Postby Hyde » Sun Mar 18, 2012 12:14 pm

I have an .m3u format playlist created by WMP11. It's around 600k in size.

I use it to give me random play of my music library.

But the PS3 takes an age to identify and load this file. It displays on the TV in a strange way in that I get one line with album art for each track interspersed with a line that says 'Playlist', e.g

Album Art > Artist > Track Name 1
Genric Art > Playlist
Album Art > Artist > Track Name 2
Genric Art > Playlist
Album Art > Artist > Track Name 3
Genric Art > Playlist
etc.

In addition, once it's played a track it takes an age for it to pick the next one.

Anything I can do to fix this please?

Sample M3u:-
Code: Select all
#EXTM3U
#EXTINF:0,ADELE - 21 - 01 - Rolling In The Deep.flac
..\Adele\21\ADELE - 21 - 01 - Rolling In The Deep.flac

#EXTINF:0,ADELE - 21 - 02 - Rumour Has It.flac
..\Adele\21\ADELE - 21 - 02 - Rumour Has It.flac

#EXTINF:0,ADELE - 21 - 03 - Turning Tables.flac
..\Adele\21\ADELE - 21 - 03 - Turning Tables.flac
Sony Bravia KDL-40Z5800
PS3 Slim 250GB & PMS 1.72.0
Tranquil WHS (Intel Atom 230 / 1.60GHz / 1GB RAM)
Hyde
 
Posts: 46
Joined: Fri Apr 23, 2010 1:01 pm

Re: Poor PlayList Performance

Postby Hyde » Tue Mar 20, 2012 5:15 pm

Would this extract of the log file help?

Code: Select all
[Thread-18] DEBUG 16:03:21.625 Sending ALIVE...
[pool-23-thread-1] DEBUG 16:03:24.796 Reading m3u playlist: PS3 Playlist.m3u
[New I/O server worker #1-1] DEBUG 16:03:24.953 Calling SetThreadExecutionState ES_SYSTEM_REQUIRED
[pool-23-thread-1] DEBUG 16:03:25.343 Adding M3U entry: [..\Adele\21\ADELE - 21 - 01 - Rolling In The Deep.flac,ADELE - 21 - 01 - Rolling In The Deep.flac]
[pool-23-thread-1] DEBUG 16:03:25.640 Adding M3U entry: [,null]
[pool-23-thread-1] DEBUG 16:03:25.656 Adding M3U entry: [..\Adele\21\ADELE - 21 - 02 - Rumour Has It.flac,ADELE - 21 - 02 - Rumour Has It.flac]
[pool-23-thread-1] DEBUG 16:03:25.703 Adding M3U entry: [,null]
[pool-23-thread-1] DEBUG 16:03:25.718 Adding M3U entry: [..\Adele\21\ADELE - 21 - 03 - Turning Tables.flac,ADELE - 21 - 03 - Turning Tables.flac]
[pool-23-thread-1] DEBUG 16:03:25.781 Adding M3U entry: [,null]
[pool-23-thread-1] DEBUG 16:03:25.781 Adding M3U entry: [..\Adele\21\ADELE - 21 - 04 - Don�t You Remember.flac,ADELE - 21 - 04 - Don�t You Remember.flac]
[pool-23-thread-1] DEBUG 16:03:25.828 Adding M3U entry: [,null]
[pool-23-thread-1] DEBUG 16:03:25.828 Adding M3U entry: [..\Adele\21\ADELE - 21 - 05 - Set Fire To The Rain.flac,ADELE - 21 - 05 - Set Fire To The Rain.flac]


And for some reason it's decided that today I'll get random pauses in the middle of tracks, clicks and ticks noises too. Driving me nuts. I don't get this from my Logitech Media Server with my Squeezebox units :-??
Sony Bravia KDL-40Z5800
PS3 Slim 250GB & PMS 1.72.0
Tranquil WHS (Intel Atom 230 / 1.60GHz / 1GB RAM)
Hyde
 
Posts: 46
Joined: Fri Apr 23, 2010 1:01 pm

Re: Poor PlayList Performance

Postby Raptor399 » Sat Mar 24, 2012 9:33 am

Looks like unwanted entries are created for the empty lines in your .m3u file.
Fix committed.

Not sure if that will fix your problem, though.
Raptor399
Project Member
 
Posts: 1916
Joined: Thu Mar 10, 2011 12:06 am

Re: Poor PlayList Performance

Postby Hyde » Sat Mar 24, 2012 9:57 am

Cheers. Should fix the display issue at least. Do you know which build the fix will go into?
Sony Bravia KDL-40Z5800
PS3 Slim 250GB & PMS 1.72.0
Tranquil WHS (Intel Atom 230 / 1.60GHz / 1GB RAM)
Hyde
 
Posts: 46
Joined: Fri Apr 23, 2010 1:01 pm

Re: Poor PlayList Performance

Postby Raptor399 » Sat Mar 24, 2012 9:59 am

It will be in the next release. ;-)
There's no telling when that will be, though.
Raptor399
Project Member
 
Posts: 1916
Joined: Thu Mar 10, 2011 12:06 am

Re: Poor PlayList Performance

Postby Hyde » Sat Mar 24, 2012 10:02 am

Ah, okay. Just wanted to know when to test it. I'll try the nightly builds. Thanks. :-)
Sony Bravia KDL-40Z5800
PS3 Slim 250GB & PMS 1.72.0
Tranquil WHS (Intel Atom 230 / 1.60GHz / 1GB RAM)
Hyde
 
Posts: 46
Joined: Fri Apr 23, 2010 1:01 pm

Re: Poor PlayList Performance

Postby Hyde » Sat Apr 07, 2012 12:26 pm

Display issues fixed in 1.52.1-SB69 at least, could have been in an earlier release but this is the version I jumped to. :D

However, when in shuffle mode it's taking around a minute to play the next track. After three tracks I got "Could not receive the content list" error message.

Nothing in the 'Traces' tab or debug log to suggest anything is wrong either :?

The above is using the Bravia 5500.conf.

if I select the playlist via the PS3 it appears to load just fine but reports that "The data is corrupted" for all files. This is using the PS3.conf
Sony Bravia KDL-40Z5800
PS3 Slim 250GB & PMS 1.72.0
Tranquil WHS (Intel Atom 230 / 1.60GHz / 1GB RAM)
Hyde
 
Posts: 46
Joined: Fri Apr 23, 2010 1:01 pm


Return to General Help and Support

Who is online

Users browsing this forum: No registered users and 17 guests