How to install PMS on Debian 6?

For help and support with issues specific to Linux/Unix
Forum rules
Please make sure you follow the Problem Reporting Guidelines before posting if you want a reply.

How to install PMS on Debian 6?

Postby Hannobal » Thu Mar 22, 2012 5:56 pm

Hey all =)

First sorry for my bad English Skills ^^

I am searching for a media server software and all others I have tested failed and thrown some errors. So I met the PMS and it looks like it should works, but there I have some problems to get it running, too. I am using Debian 6.
I can start the application and the server, but I can't stream my Videos and Music in my Homenetwork. I have downloaded and installed only this program, nothing else.

I am frustrated so much -.-' I can't find any guide which work fine. So please put here a full working installation guide (With libaries I need and so on....).

Thanks very much for help :)


Greetings Hannobal
Hannobal
 
Posts: 11
Joined: Thu Mar 22, 2012 3:33 pm

Re: How to install PMS on Debian 6?

Postby Hannobal » Thu Mar 22, 2012 6:14 pm

.... I forget, I am coming from Germany^^ Would be pleased if there are some german peoples too ;D
Hannobal
 
Posts: 11
Joined: Thu Mar 22, 2012 3:33 pm

Re: How to install PMS on Debian 6?

Postby Hannobal » Fri Mar 23, 2012 6:10 pm

Okay, I have got working it now....
I have found this Tutorial viewtopic.php?f=3&t=5589 and it works great ! ;)

So this thread can be closed now :)
Hannobal
 
Posts: 11
Joined: Thu Mar 22, 2012 3:33 pm

Re: How to install PMS on Debian 6?

Postby chocolateboy » Fri Mar 23, 2012 11:17 pm

If you want a more up-to-date version:

zogsterjack successfully installed this package on Debian Wheezy, so Debian users feel free to test it.


viewtopic.php?f=3&t=13046

Instructions for uninstalling the old version can be found at the end of this post:

viewtopic.php?f=3&t=13573&p=65298#p65298
chocolateboy
Project Member
 
Posts: 2580
Joined: Wed Sep 16, 2009 10:05 am

Re: How to install PMS on Debian 6?

Postby Hannobal » Sat Mar 24, 2012 12:51 am

Thanks =)
But how can I add the repository to my Debian?

add-apt-repository ppa:happy-neko/ps3mediaserver


This command isn't avaible on my Debian...
Hannobal
 
Posts: 11
Joined: Thu Mar 22, 2012 3:33 pm

Re: How to install PMS on Debian 6?

Postby happy.neko » Sat Mar 24, 2012 1:53 am

On Debian you can manually download and install deb package (automatic updates will not work):

32-bit
Code: Select all
wget http://mirrors.us.kernel.org/ubuntu//pool/main/u/ubuntu-font-family-sources/ttf-ubuntu-font-family_0.80-0ubuntu1~medium_all.deb
sudo dpkg -i ttf-ubuntu-font-family_0.80-0ubuntu1~medium_all.deb
wget https://launchpad.net/~happy-neko/+archive/ps3mediaserver/+files/ps3mediaserver_1.51.0%2Bgit-2_i386.deb
sudo dpkg -i ps3mediaserver_1.51.0+git-2_i386.deb


64-bit
Code: Select all
wget http://mirrors.us.kernel.org/ubuntu//pool/main/u/ubuntu-font-family-sources/ttf-ubuntu-font-family_0.80-0ubuntu1~medium_all.deb
sudo dpkg -i ttf-ubuntu-font-family_0.80-0ubuntu1~medium_all.deb
wget https://launchpad.net/~happy-neko/+archive/ps3mediaserver/+files/ps3mediaserver_1.51.0%2Bgit-2_amd64.deb
sudo dpkg -i ps3mediaserver_1.51.0+git-2_amd64.deb
Last edited by happy.neko on Sat Mar 24, 2012 2:18 am, edited 1 time in total.
happy.neko
Project Member
 
Posts: 478
Joined: Fri Sep 23, 2011 5:38 pm

Re: How to install PMS on Debian 6?

Postby Hannobal » Sat Mar 24, 2012 1:57 am

Okay thanks :)

I will test it ;)
Hannobal
 
Posts: 11
Joined: Thu Mar 22, 2012 3:33 pm

Re: How to install PMS on Debian 6?

Postby Hannobal » Sat Mar 24, 2012 2:12 am

I can't install it.... I need the ttf-ubuntu-font-family package from Ubuntu. How can I install it? ^^
Hannobal
 
Posts: 11
Joined: Thu Mar 22, 2012 3:33 pm

Re: How to install PMS on Debian 6?

Postby happy.neko » Sat Mar 24, 2012 2:19 am

I have updated my post with font package. Try it now.
happy.neko
Project Member
 
Posts: 478
Joined: Fri Sep 23, 2011 5:38 pm

Re: How to install PMS on Debian 6?

Postby Hannobal » Sat Mar 24, 2012 4:20 pm

Okay I got it working so far, but when it's started I get the error message "No renderers were found" and on the startpanel there is a very big red "X"

Here is my logfile....

Code: Select all
[main] DEBUG 2012-03-24 16:04:08.742 non loopback/ipv4 addresses: [/192.168.178.51]
[main] DEBUG 2012-03-24 16:04:08.742 sub address for eth0 is []
[main] DEBUG 2012-03-24 16:04:08.742 found eth0 -> 192.168.178.51
[main] DEBUG 2012-03-24 16:04:08.743 non loopback/ipv4 addresses: []
[main] DEBUG 2012-03-24 16:04:08.743 sub address for lo is []
[main] DEBUG 2012-03-24 16:04:08.743 has /127.0.0.1, which is skipped, because loopback=true, ipv6=false
[main] DEBUG 2012-03-24 16:04:08.743 found lo, without valid address
[main] INFO  2012-03-24 16:04:09.522 Starting PS3 Media Server 1.51.0-2 (ppa:happy-neko)
[main] INFO  2012-03-24 16:04:09.523 by shagrath / 2008-2012
[main] INFO  2012-03-24 16:04:09.524 http://ps3mediaserver.org
[main] INFO  2012-03-24 16:04:09.524 https://github.com/ps3mediaserver/ps3mediaserver
[main] INFO  2012-03-24 16:04:09.524 http://ps3mediaserver.blogspot.com
[main] INFO  2012-03-24 16:04:09.525
[main] INFO  2012-03-24 16:04:09.525 Build: f1bc902f8 (Thu Mar 15 16:18:00 2012 +0800)
[main] INFO  2012-03-24 16:04:09.526 Java: 1.6.0_18-Sun Microsystems Inc.
[main] INFO  2012-03-24 16:04:09.527 OS: Linux amd64 2.6.32-5-amd64
[main] INFO  2012-03-24 16:04:09.527 Encoding: UTF-8
[main] INFO  2012-03-24 16:04:09.527
[main] INFO  2012-03-24 16:04:09.528 Working directory: /usr/lib/ps3mediaserver
[main] INFO  2012-03-24 16:04:09.537 Temp folder: /tmp/ps3mediaserver-root
[main] INFO  2012-03-24 16:04:09.538 Logging config file: /etc/ps3mediaserver/logback.xml
[main] INFO  2012-03-24 16:04:09.538 debug.log: /var/log/ps3mediaserver/root//debug.log
[main] INFO  2012-03-24 16:04:09.539
[main] INFO  2012-03-24 16:04:09.539 Profile directory: /root/.config/ps3mediaserver
[main] INFO  2012-03-24 16:04:09.540 Profile path: /root/.config/ps3mediaserver/PMS.conf
[main] INFO  2012-03-24 16:04:09.543 Profile status: rw
[main] INFO  2012-03-24 16:04:09.544 Profile name: debianvm
[main] INFO  2012-03-24 16:04:09.544
[main] INFO  2012-03-24 16:04:09.583 Loading MediaInfo library
[main] INFO  2012-03-24 16:04:09.606 Loaded MediaInfoLib - v0.7.54
[main] INFO  2012-03-24 16:04:09.613 Loading renderer configurations from /etc/ps3mediaserver/renderers
[main] INFO  2012-03-24 16:04:09.614 Loading configuration file: Kuro.conf
[main] DEBUG 2012-03-24 16:04:09.615 Base path set to file:///etc/ps3mediaserver/renderers/Kuro.conf
[main] INFO  2012-03-24 16:04:09.616 Loading configuration file: Bravia4500.conf
[main] DEBUG 2012-03-24 16:04:09.617 Base path set to file:///etc/ps3mediaserver/renderers/Bravia4500.conf
[main] INFO  2012-03-24 16:04:09.622 Loading configuration file: Panasonic.conf
[main] DEBUG 2012-03-24 16:04:09.623 Base path set to file:///etc/ps3mediaserver/renderers/Panasonic.conf
[main] INFO  2012-03-24 16:04:09.627 Loading configuration file: N900.conf
[main] DEBUG 2012-03-24 16:04:09.627 Base path set to file:///etc/ps3mediaserver/renderers/N900.conf
[main] INFO  2012-03-24 16:04:09.628 Loading configuration file: Android.conf
[main] DEBUG 2012-03-24 16:04:09.629 Base path set to file:///etc/ps3mediaserver/renderers/Android.conf
[main] INFO  2012-03-24 16:04:09.630 Loading configuration file: FreeboxHD.conf
[main] DEBUG 2012-03-24 16:04:09.630 Base path set to file:///etc/ps3mediaserver/renderers/FreeboxHD.conf
[main] INFO  2012-03-24 16:04:09.631 Loading configuration file: SamsungAllShare.conf
[main] DEBUG 2012-03-24 16:04:09.632 Base path set to file:///etc/ps3mediaserver/renderers/SamsungAllShare.conf
[main] INFO  2012-03-24 16:04:09.633 Loading configuration file: XBOX360.conf
[main] DEBUG 2012-03-24 16:04:09.634 Base path set to file:///etc/ps3mediaserver/renderers/XBOX360.conf
[main] INFO  2012-03-24 16:04:09.635 Loading configuration file: PhilipsPFL.conf
[main] DEBUG 2012-03-24 16:04:09.636 Base path set to file:///etc/ps3mediaserver/renderers/PhilipsPFL.conf
[main] INFO  2012-03-24 16:04:09.640 Loading configuration file: WMP.conf
[main] DEBUG 2012-03-24 16:04:09.641 Base path set to file:///etc/ps3mediaserver/renderers/WMP.conf
[main] INFO  2012-03-24 16:04:09.642 Loading configuration file: FreecomMusicPal.conf
[main] DEBUG 2012-03-24 16:04:09.642 Base path set to file:///etc/ps3mediaserver/renderers/FreecomMusicPal.conf
[main] INFO  2012-03-24 16:04:09.643 Loading configuration file: AirPlayer.conf
[main] DEBUG 2012-03-24 16:04:09.644 Base path set to file:///etc/ps3mediaserver/renderers/AirPlayer.conf
[main] INFO  2012-03-24 16:04:09.646 Loading configuration file: XBMC.conf
[main] DEBUG 2012-03-24 16:04:09.646 Base path set to file:///etc/ps3mediaserver/renderers/XBMC.conf
[main] INFO  2012-03-24 16:04:09.647 Loading configuration file: Streamium.conf
[main] DEBUG 2012-03-24 16:04:09.648 Base path set to file:///etc/ps3mediaserver/renderers/Streamium.conf
[main] INFO  2012-03-24 16:04:09.650 Loading configuration file: iPad-iPhone.conf
[main] DEBUG 2012-03-24 16:04:09.650 Base path set to file:///etc/ps3mediaserver/renderers/iPad-iPhone.conf
[main] INFO  2012-03-24 16:04:09.652 Loading configuration file: Bravia5500.conf
[main] DEBUG 2012-03-24 16:04:09.652 Base path set to file:///etc/ps3mediaserver/renderers/Bravia5500.conf
[main] INFO  2012-03-24 16:04:09.654 Loading configuration file: Realtek.conf
[main] DEBUG 2012-03-24 16:04:09.654 Base path set to file:///etc/ps3mediaserver/renderers/Realtek.conf
[main] INFO  2012-03-24 16:04:09.656 Loading configuration file: WDTVLive.conf
[main] DEBUG 2012-03-24 16:04:09.656 Base path set to file:///etc/ps3mediaserver/renderers/WDTVLive.conf
[main] INFO  2012-03-24 16:04:09.657 Loading configuration file: PS3.conf
[main] DEBUG 2012-03-24 16:04:09.658 Base path set to file:///etc/ps3mediaserver/renderers/PS3.conf
[main] INFO  2012-03-24 16:04:09.661 Loading configuration file: Showtime3.conf
[main] DEBUG 2012-03-24 16:04:09.662 Base path set to file:///etc/ps3mediaserver/renderers/Showtime3.conf
[main] INFO  2012-03-24 16:04:09.675 Loading configuration file: BraviaEX.conf
[main] DEBUG 2012-03-24 16:04:09.675 Base path set to file:///etc/ps3mediaserver/renderers/BraviaEX.conf
[main] INFO  2012-03-24 16:04:09.678 Loading configuration file: Philips.conf
[main] DEBUG 2012-03-24 16:04:09.686 Base path set to file:///etc/ps3mediaserver/renderers/Philips.conf
[main] INFO  2012-03-24 16:04:09.687 Loading configuration file: PopcornHour.conf
[main] DEBUG 2012-03-24 16:04:09.687 Base path set to file:///etc/ps3mediaserver/renderers/PopcornHour.conf
[main] INFO  2012-03-24 16:04:09.688 Loading configuration file: SamsungWiseLink.conf
[main] DEBUG 2012-03-24 16:04:09.689 Base path set to file:///etc/ps3mediaserver/renderers/SamsungWiseLink.conf
[main] INFO  2012-03-24 16:04:09.690 Loading configuration file: SonyBluray.conf
[main] DEBUG 2012-03-24 16:04:09.690 Base path set to file:///etc/ps3mediaserver/renderers/SonyBluray.conf
[main] INFO  2012-03-24 16:04:09.693 Checking MPlayer font cache. It can take a minute or so.
[main] DEBUG 2012-03-24 16:04:09.701 launching: /usr/lib/ps3mediaserver/linux/mplayer
[main] INFO  2012-03-24 16:04:09.719 Done!
[main] INFO  2012-03-24 16:04:09.734 Searching for plugins in /usr/lib/ps3mediaserver/plugins
[main] INFO  2012-03-24 16:04:09.740 No plugins found
[main] INFO  2012-03-24 16:04:09.756 Registering transcoding engine: FFmpeg Audio
[main] INFO  2012-03-24 16:04:09.759 Registering transcoding engine: MEncoder
[main] INFO  2012-03-24 16:04:09.759 Registering transcoding engine: MPlayer Audio
[main] INFO  2012-03-24 16:04:09.760 Registering transcoding engine: MEncoder Web
[main] INFO  2012-03-24 16:04:09.760 Registering transcoding engine: MPlayer Video Dump
[main] INFO  2012-03-24 16:04:09.761 Registering transcoding engine: MPlayer Web
[main] INFO  2012-03-24 16:04:09.763 Registering transcoding engine: tsMuxeR
[main] INFO  2012-03-24 16:04:09.763 Registering transcoding engine: Audio High Fidelity
[main] INFO  2012-03-24 16:04:09.764 Registering transcoding engine: VLC Audio Streaming
[main] INFO  2012-03-24 16:04:09.764 Registering transcoding engine: VLC Video Streaming
[main] INFO  2012-03-24 16:04:09.765 Registering transcoding engine: dcraw Thumbnailer
[main] DEBUG 2012-03-24 16:04:09.972 default network interface address from [InterfaceAssociation(addr=/192.168.178.51, iface=name:eth0 (eth0), parent=null), InterfaceAssociation(addr=null, iface=name:lo (lo), parent=null)]
[main] INFO  2012-03-24 16:04:09.972 Using address /192.168.178.51 found on network interface: name:eth0 (eth0)
[main] INFO  2012-03-24 16:04:09.973 Created socket: /192.168.178.51:5001
[main] DEBUG 2012-03-24 16:04:10.103 Using database URL: jdbc:h2:/var/lib/ps3mediaserver/database-root/medias
[main] INFO  2012-03-24 16:04:10.103 Using database located at: /var/lib/ps3mediaserver/database-root
[main] DEBUG 2012-03-24 16:04:10.786 Database file count: 0
[main] DEBUG 2012-03-24 16:04:10.786 Database version: 1.51.0-2 (ppa:happy-neko)
[main] INFO  2012-03-24 16:04:10.796 A tiny cache admin interface is available at: http://192.168.178.51:5001/console/home
[main] DEBUG 2012-03-24 16:04:10.868 Sending ALIVE...
[main] INFO  2012-03-24 16:04:10.872 Using the following UUID configured in PMS.conf: a3796556-da73-40f3-b732-3b3a279c7ef8
[main] INFO  2012-03-24 16:04:14.786 The server should now appear on your renderer
[UPNP-AliveMessageSender] DEBUG 2012-03-24 16:04:24.785 Sending ALIVE...
[UPNP-AliveMessageSender] DEBUG 2012-03-24 16:04:49.133 Sending ALIVE...
[UPNP-AliveMessageSender] DEBUG 2012-03-24 16:07:53.552 Sending ALIVE...
[UPNP-AliveMessageSender] DEBUG 2012-03-24 16:10:57.747 Sending ALIVE...
[AWT-EventQueue-0] INFO  2012-03-24 16:12:25.049 Configuration saved to: /root/.config/ps3mediaserver/PMS.conf
Hannobal
 
Posts: 11
Joined: Thu Mar 22, 2012 3:33 pm

Next

Return to Linux/Unix Support

Who is online

Users browsing this forum: No registered users and 1 guest