Easy setup guide for Ubuntu / Debian (DEB packages and repo)

For help and support with issues specific to Linux/Unix
Forum rules
Please make sure you follow the Problem Reporting Guidelines before posting if you want a reply.

Re: Complete DEB packages for Ubuntu / Debian (32/64 bit)

Postby happy.neko » Tue Feb 07, 2012 7:52 pm

1. Great. I think I narrowed it down to default configs installation script. Should be fixed in next version.
2. Please run
Code: Select all
fc-list | grep -i ubuntu
and post result. By the way what version of ubuntu are you running?
happy.neko
Project Member
 
Posts: 478
Joined: Fri Sep 23, 2011 5:38 pm

Re: Complete DEB packages for Ubuntu / Debian (32/64 bit)

Postby lordfreak » Tue Feb 07, 2012 7:54 pm

1. Alright, great!
2. That didn't return anything. fc-list did return fonts, so I'm guessing I don't have the ubuntu font installed?
Running ubuntu server 10.04
lordfreak
 
Posts: 12
Joined: Tue Feb 07, 2012 6:32 pm

Re: Complete DEB packages for Ubuntu / Debian (32/64 bit)

Postby happy.neko » Tue Feb 07, 2012 7:59 pm

Yeah, it means "ubuntu" font is not shipped with 10.04. And its used in my default config.
Try to change it to some other font from fc-list (for ex. Arial, preferably without spaces in name because there is bug in PMS with font names escaping) and see if it makes a difference.
happy.neko
Project Member
 
Posts: 478
Joined: Fri Sep 23, 2011 5:38 pm

Re: Complete DEB packages for Ubuntu / Debian (32/64 bit)

Postby lordfreak » Tue Feb 07, 2012 8:52 pm

I tried to change the font to arial, after installing the font. This resulted in the video not even starting. Just a black screen for like 15 minutes and then a screen with data not supported.
So I change the mencoder fontconfig to false. Same effect.
Then I installed the Ubuntu font and the command indeed indicated that I had the ubuntu font. Changed the font to ubuntu again, same problem.
Removed all the fonts and the video worked again, untill it just remained stuck at one point.

edit: maybe I should mention i'm running 64-bit
lordfreak
 
Posts: 12
Joined: Tue Feb 07, 2012 6:32 pm

Re: Complete DEB packages for Ubuntu / Debian (32/64 bit)

Postby happy.neko » Wed Feb 08, 2012 3:44 pm

Very strange. Looks like severe bugs on 10.04 version of mencoder. Maybe other 10.04 users can confirm / deny these issues. 11.10 works fine for me, no font problems.
Do you try system reboot? Simple, but sometimes very effective :) Whats your system RAM size?
happy.neko
Project Member
 
Posts: 478
Joined: Fri Sep 23, 2011 5:38 pm

Re: Complete DEB packages for Ubuntu / Debian (32/64 bit)

Postby lordfreak » Wed Feb 08, 2012 8:57 pm

Well, the problem has been solved.
I had a script running that checked the permission of folders and changed them to 770 and a user/group.
The folder the video was from was included in this, so I'm guessing PMS just couldn't access it anymore.

What I did notice though that when another program is running (ex. sabnzbd) pms doesn't take any of the cpu-power anymore. It just stops encoding.
I do have enough power to run both (Amd Phenom II X6 + 8GB ram), but all the pms processes just stop.

One other particular thing is that when playing a .iso it just fast forwards. So when just playing it, it start to fast forward by itself.....

edit: I'm pretty sure the problem of fast forwarding from iso's has something to do with the package.
I tested this on another pc that runs ubuntu 11.04 x64.
With the normal install I can run the iso just fine, with this package not.
So I changed all the settings from your install to the ones I have from the default one, nothing changed.

It may also be due to PMS itself, the default is 1.50.0.

Here is a debug.log, maybe you can use it: http://pastebin.com/gyMnU2HJ
lordfreak
 
Posts: 12
Joined: Tue Feb 07, 2012 6:32 pm

Re: Complete DEB packages for Ubuntu / Debian (32/64 bit)

Postby lordfreak » Thu Feb 09, 2012 5:06 pm

Well, all my problems are solved! (except for the subtitle square thing).
So I thought I would share so other people can use this if they have problems:

1. The .iso's:
They played to fast, solution:
Just set mencoder_remux_mpeg2 = true (which is standard) to false, It now play normal.

2. In some file's I did have the audio track, but I couldn't hear spoken things. (so music oke, dialogue no sound).
solution: set mencoder_use_pcm = true to mencoder_use_pcm = false
and set mencoder_remux_ac3 = true to mencoder_remux_ac3 = false

I want to thank you for the awesome package and your program!
lordfreak
 
Posts: 12
Joined: Tue Feb 07, 2012 6:32 pm

Re: Complete DEB packages for Ubuntu / Debian (32/64 bit)

Postby happy.neko » Thu Feb 09, 2012 7:27 pm

1. Actually "mencoder_remux_ac3 = false" and "mencoder_remux_mpeg2 = true" should be default settings on my package. Please check /etc/skel/.config/ps3mediaserver/PMS.conf

2. While keeping mencoder_remux_ac3 = false please change "mencoder_use_pcm" to true and test for sound problems.
happy.neko
Project Member
 
Posts: 478
Joined: Fri Sep 23, 2011 5:38 pm

Re: Complete DEB packages for Ubuntu / Debian (32/64 bit)

Postby lordfreak » Thu Feb 09, 2012 9:55 pm

1. you're right about the default settings. But putting mencoder_remux_mpeg2 = true gave me problems, so I had to turn it to false.
2. I changed only mencoder_use_pcm to true and got problems. turned it to false again, no more problem.

Could of course be just my set-up though
lordfreak
 
Posts: 12
Joined: Tue Feb 07, 2012 6:32 pm

Re: Complete DEB packages for Ubuntu / Debian (32/64 bit)

Postby happy.neko » Thu Feb 09, 2012 10:19 pm

1. My bad. I misread your explanation and thought that "mencoder_remux_mpeg2 = false" gave you problems. Please try decreasing transcoding buffer down to 200 Mb and try remuxing again.
2. Can you upload sample of this file to mediafire or send me PM link?
happy.neko
Project Member
 
Posts: 478
Joined: Fri Sep 23, 2011 5:38 pm

PreviousNext

Return to Linux/Unix Support

Who is online

Users browsing this forum: No registered users and 7 guests