Why is my Media library so slow to browse

For help and support with PS3 Media Server in general
Forum rules
Please make sure you follow the Problem Reporting Guidelines before posting if you want a reply.

Why is my Media library so slow to browse

Postby Uridium » Wed Mar 25, 2009 10:44 am

I have a 2Tb media library stored on 2x 1Tb Esata disks attached to PC running PS3MS.

Browsing folders on the PS3 lately seems to take an eternity with large folders of movies taking several minutes for coverart to display and on occasions it just refuses to even show the cover art. I've tried with Media library enabled and disabled; makes no difference.

PC isn't the latest spec but it's a P4D 2.8Ghz with 4Gb Ram running Vista 32-Bit
Both PC and PS3 are attached to a Gigabit switch so bandwidth isn't the issue. Now I'm sure it has been getting slower and slower with the last few builds of PS3MS but it's becoming almost unuseable now

Any Ideas?
Uridium
 
Posts: 132
Joined: Thu Jan 22, 2009 11:22 pm

Re: Why is my Media library so slow to browse

Postby Ingo » Wed Mar 25, 2009 12:56 pm

Same here with 1,5 TB of video/audio files stored on internal disks, a QuadCore and 3 GB RAM. OS is Vista 32bit, PMS is 1.10.6.

It's been quite fast in earlier version but now it takes minutes to show 100 files in a subdirectory (a couple of file will be displayed, then 10 secs pause, then the next couple of files and so forth). Quite annoying.

Wouldn't be that much of a problem if the media library would work, but scanning my collection crashes at some point and just leaves an unusable database which is 850 MB large...

Otherwise of course PMS still rocks!

Cheers, Ingo
Ingo
 
Posts: 17
Joined: Mon Jan 19, 2009 7:01 am

Re: Why is my Media library so slow to browse

Postby meskibob » Wed Mar 25, 2009 1:03 pm

Try reseting the media library, disable it, close out PMS, reopen it, and then enable the library. That should hopefully reset the db, and then all you need to do is browse in the XMB to start creating the cache. Obviously when you're creating the cache the first time it'll be slow to browse, but after that it should be much faster. You don't need to do the scan through the GUI to take advantage of the cached browsing.
I provide NO application support via PM or email, so please post your question to the forum per the Forum Rules.
meskibob
Moderator
 
Posts: 4760
Joined: Mon Jan 19, 2009 4:11 pm

Re: Why is my Media library so slow to browse

Postby Uridium » Wed Mar 25, 2009 1:13 pm

meskibob wrote:Try reseting the media library, disable it, close out PMS, reopen it, and then enable the library. That should hopefully reset the db, and then all you need to do is browse in the XMB to start creating the cache. Obviously when you're creating the cache the first time it'll be slow to browse, but after that it should be much faster. You don't need to do the scan through the GUI to take advantage of the cached browsing.



Done that last night, no difference at all. (and with a 2tb library the rebuild takes hours :( )

The slowness is there whether i use media library or not and also after a complete deletion/recreation.

It does seem to be an issue with the newer versions. Think I'm going to roll back a few versions tonight and see if it improves.

Quick question though....I prefer to browse manually added folders than use the media library as it's easier for wife/kids to find there TV/Movies; If the media library is enabled but i browse added folders instead of using media library on XMB will caching still occur?
Uridium
 
Posts: 132
Joined: Thu Jan 22, 2009 11:22 pm

Re: Why is my Media library so slow to browse

Postby Ingo » Wed Mar 25, 2009 1:22 pm

Did exactly those steps. No change.

And what does it help if after caching those files I can see them faster the next time - if I shut down the PS3, or Folding@Home kicks in? I don't keep running the PS3 24/7...

I would very much like to see the file list as fast as before. Please have a look at this...

Regards, Ingo
Ingo
 
Posts: 17
Joined: Mon Jan 19, 2009 7:01 am

Re: Why is my Media library so slow to browse

Postby Uridium » Wed Mar 25, 2009 1:37 pm

Ingo wrote:Did exactly those steps. No change.

And what does it help if after caching those files I can see them faster the next time - if I shut down the PS3, or Folding@Home kicks in? I don't keep running the PS3 24/7...

I would very much like to see the file list as fast as before. Please have a look at this...

Regards, Ingo


I've removed all trace of the current verison and done a clean install of V1.03, I'll test it later and let you know if this speeds things back up again ;)
Uridium
 
Posts: 132
Joined: Thu Jan 22, 2009 11:22 pm

Re: Why is my Media library so slow to browse

Postby meskibob » Wed Mar 25, 2009 1:55 pm

Uridium wrote:Quick question though....I prefer to browse manually added folders than use the media library as it's easier for wife/kids to find there TV/Movies; If the media library is enabled but i browse added folders instead of using media library on XMB will caching still occur?
Yes.
Ingo wrote:And what does it help if after caching those files I can see them faster the next time - if I shut down the PS3, or Folding@Home kicks in? I don't keep running the PS3 24/7...?
I think you misunderstood... It's not a cache on the PS3. It's essentially a parsing database that PMS uses to keep track of what files are in what directory, and it is kept on the PC. Without it, PMS has to parse out all of the files in a directory everytime you go to it, which is much slower than just creating a list of files from the database. My apologies if my usage of "cache" was confusing.
I provide NO application support via PM or email, so please post your question to the forum per the Forum Rules.
meskibob
Moderator
 
Posts: 4760
Joined: Mon Jan 19, 2009 4:11 pm

Re: Why is my Media library so slow to browse

Postby Ingo » Wed Mar 25, 2009 7:07 pm

Ok, so I did the following:

- Disabled media library, saved settings, quit PMS.
- Manually deleted the files in /database.
- Restarted PMS, enabled media library, saved settings.
- In the XMB I browsed the directory with >100 files. Took - well, let's just say, quite a while ;)
- Restarted PMS.
- Went back to the PS3, browsed again - much faster, almost instantaneously! Great!

Well, that's fine, because that speeds up browsing across restarts of the PS3.

So that still leaves two requests, if I may be so bold ;)

1) Please have a look into speeding up freshly added directories
2) The Media Library isn't usable for me as it is - shall I provide a log (this could be huge)?

Cheers, Ingo
Ingo
 
Posts: 17
Joined: Mon Jan 19, 2009 7:01 am

Re: Why is my Media library so slow to browse

Postby meskibob » Wed Mar 25, 2009 7:35 pm

Ingo wrote:1) Please have a look into speeding up freshly added directories
These will still have to be parsed in some fashion, and I'm not sure how much more shagrath et al can do to improve that speed. But you never know... :D
Ingo wrote:2) The Media Library isn't usable for me as it is...
I'm not sure what you mean by this...
I provide NO application support via PM or email, so please post your question to the forum per the Forum Rules.
meskibob
Moderator
 
Posts: 4760
Joined: Mon Jan 19, 2009 4:11 pm

Re: Why is my Media library so slow to browse

Postby Uridium » Wed Mar 25, 2009 8:13 pm

@Ingo,

Couple of questions

Can you just confirm that you restarted the PS3 and PMS and the folder still browsed very fast?

are the folders you are browsing within the Media Library folder itself or are they normal folders on the PC you have manaully added into PS3 Media Server?
Uridium
 
Posts: 132
Joined: Thu Jan 22, 2009 11:22 pm

Next

Return to General Help and Support

Who is online

Users browsing this forum: No registered users and 12 guests