PMS just stopped working not sure why

For help and support with issues specific to Mac OS X
Forum rules
Please make sure you follow the Problem Reporting Guidelines before posting if you want a reply.

PMS just stopped working not sure why

Postby bobbyc » Tue Nov 15, 2011 9:20 am

Everything was working fine and turned on the system today but it won't connect. It reads "Searching for renderers." I went ahead and updated to 1.40 but still no luck.
I have my PS3 to my Mac Pro (Version 10.6.8) connected via Ethernet not wi-fi. I'm forcing the IP on the server in PMS due to having a few laptops here. So I'm using 10.0.1.3. I have no firewall on either. Java is updated as I've checked software update on my mac and all is installed. Any idea anyone can give to see what the issue might be?
Here is the trace log:
Code: Select all
main] INFO  00:30:59.049 Loading MediaInfo library
[main] INFO  00:30:59.092 Loaded MediaInfoLib - v0.7.47
[main] INFO  00:30:59.097 Loading renderer configurations from /Applications/PS3 Media Server.app/Contents/Resources/Java/renderers
[main] INFO  00:30:59.098 Loading configuration file: AirPlayer.conf
[main] INFO  00:30:59.112 Loading configuration file: Android.conf
[main] INFO  00:30:59.114 Loading configuration file: Bravia4500.conf
[main] INFO  00:30:59.116 Loading configuration file: Bravia5500.conf
[main] INFO  00:30:59.119 Loading configuration file: BraviaEX.conf
[main] INFO  00:30:59.122 Loading configuration file: FreeboxHD.conf
[main] INFO  00:30:59.125 Loading configuration file: FreecomMusicPal.conf
[main] INFO  00:30:59.128 Loading configuration file: iPad-iPhone.conf
[main] INFO  00:30:59.130 Loading configuration file: Kuro.conf
[main] INFO  00:30:59.132 Loading configuration file: N900.conf
[main] INFO  00:30:59.134 Loading configuration file: Panasonic.conf
[main] INFO  00:30:59.137 Loading configuration file: Philips.conf
[main] INFO  00:30:59.139 Loading configuration file: PopcornHour.conf
[main] INFO  00:30:59.141 Loading configuration file: PS3.conf
[main] INFO  00:30:59.145 Loading configuration file: Realtek.conf
[main] INFO  00:30:59.148 Loading configuration file: Samsung.conf
[main] INFO  00:30:59.149 Loading configuration file: Showtime3.conf
[main] INFO  00:30:59.152 Loading configuration file: SonyBluray.conf
[main] INFO  00:30:59.155 Loading configuration file: Streamium.conf
[main] INFO  00:30:59.156 Loading configuration file: WDTVLive.conf
[main] INFO  00:30:59.158 Loading configuration file: WMP.conf
[main] INFO  00:30:59.160 Loading configuration file: XBMC.conf
[main] INFO  00:30:59.161 Loading configuration file: XBOX360.conf
[main] INFO  00:30:59.163 Checking MPlayer font cache. It can take a minute or so.
[main] INFO  00:30:59.245 Done!
[main] INFO  00:30:59.253 Loading plugins from /Applications/PS3 Media Server.app/Contents/Resources/Java/plugins
[main] INFO  00:30:59.254 No plugins found
[main] INFO  00:30:59.256 Registering transcoding engine: FFmpeg Audio
[main] INFO  00:30:59.259 Registering transcoding engine: MEncoder
[main] INFO  00:30:59.259 Registering transcoding engine: MPlayer Audio
[main] INFO  00:30:59.260 Registering transcoding engine: MEncoder Web
[main] INFO  00:30:59.260 Registering transcoding engine: MPlayer Video Dump
[main] INFO  00:30:59.260 Registering transcoding engine: MPlayer Web
[main] INFO  00:30:59.261 Registering transcoding engine: TsMuxer
[main] INFO  00:30:59.262 Registering transcoding engine: Audio High Fidelity
[main] INFO  00:30:59.262 Registering transcoding engine: VLC Audio Streaming
[main] INFO  00:30:59.262 Registering transcoding engine: VLC Video Streaming
[main] INFO  00:30:59.263 Registering transcoding engine: Raws Thumbnailer
[main] INFO  00:30:59.318 Scanning network interface en3 / en3
[main] INFO  00:30:59.319 Scanning network interface en2 / en2
[main] INFO  00:30:59.320 Scanning network interface en0 / en0
[main] INFO  00:30:59.320 Scanning network interface lo0 / lo0
[main] INFO  00:30:59.321 Using forced address 10.0.1.3
[main] INFO  00:30:59.322 Created socket: /10.0.1.3:5001
[main] INFO  00:30:59.378 org.jboss.netty.channel.ChannelException: Failed to bind to: /10.0.1.3:5001
[main] INFO  00:30:59.379    at org.jboss.netty.bootstrap.ServerBootstrap.bind(ServerBootstrap.java:303)
[main] INFO  00:30:59.379    at net.pms.network.HTTPServer.start(HTTPServer.java:157)
[main] INFO  00:30:59.379    at net.pms.PMS.init(PMS.java:473)
[main] INFO  00:30:59.380    at net.pms.PMS.createInstance(PMS.java:878)
[main] INFO  00:30:59.380    at net.pms.PMS.main(PMS.java:975)
[main] INFO  00:30:59.380    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
[main] INFO  00:30:59.380    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
[main] INFO  00:30:59.381    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
[main] INFO  00:30:59.381    at java.lang.reflect.Method.invoke(Method.java:597)
[main] INFO  00:30:59.381    at apple.launcher.LaunchRunner.run(LaunchRunner.java:116)
[main] INFO  00:30:59.382    at apple.launcher.LaunchRunner.callMain(LaunchRunner.java:51)
[main] INFO  00:30:59.382    at apple.launcher.JavaApplicationLauncher.launch(JavaApplicationLauncher.java:52)
[main] INFO  00:30:59.382 Caused by: java.net.BindException: Can't assign requested address
[main] INFO  00:30:59.383    at sun.nio.ch.Net.bind(Native Method)
[main] INFO  00:30:59.383    at sun.nio.ch.ServerSocketChannelImpl.bind(ServerSocketChannelImpl.java:126)
[main] INFO  00:30:59.383    at sun.nio.ch.ServerSocketAdaptor.bind(ServerSocketAdaptor.java:59)
[main] INFO  00:30:59.383    at org.jboss.netty.channel.socket.nio.NioServerSocketPipelineSink.bind(NioServerSocketPipelineSink.java:148)
[main] INFO  00:30:59.384    at org.jboss.netty.channel.socket.nio.NioServerSocketPipelineSink.handleServerSocket(NioServerSocketPipelineSink.java:100)
[main] INFO  00:30:59.384    at org.jboss.netty.channel.socket.nio.NioServerSocketPipelineSink.eventSunk(NioServerSocketPipelineSink.java:74)
[main] INFO  00:30:59.385    at org.jboss.netty.channel.Channels.bind(Channels.java:468)
[main] INFO  00:30:59.385    at org.jboss.netty.channel.AbstractChannel.bind(AbstractChannel.java:200)
[main] INFO  00:30:59.386    at org.jboss.netty.bootstrap.ServerBootstrap$Binder.channelOpen(ServerBootstrap.java:348)
[main] INFO  00:30:59.386    at org.jboss.netty.channel.Channels.fireChannelOpen(Channels.java:176)
[main] INFO  00:30:59.387    at org.jboss.netty.channel.socket.nio.NioServerSocketChannel.<init>(NioServerSocketChannel.java:85)
[main] INFO  00:30:59.387    at org.jboss.netty.channel.socket.nio.NioServerSocketChannelFactory.newChannel(NioServerSocketChannelFactory.java:142)
[main] INFO  00:30:59.388    at org.jboss.netty.channel.socket.nio.NioServerSocketChannelFactory.newChannel(NioServerSocketChannelFactory.java:90)
[main] INFO  00:30:59.388    at org.jboss.netty.bootstrap.ServerBootstrap.bind(ServerBootstrap.java:282)
[main] INFO  00:30:59.388    ... 11 more

bobbyc
 
Posts: 2
Joined: Tue Nov 15, 2011 8:09 am

Re: PMS just stopped working not sure why

Postby Flaxion » Tue Nov 15, 2011 10:05 am

I am having the exact same issue.

It used to work and I haven't made any changes really. Here my debug.log

Code: Select all
[main] DEBUG 10:00:14.479 Choosing java look and feel: com.apple.laf.AquaLookAndFeel
[main] INFO  10:00:17.776 Starting PS3 Media Server 1.40.0
[main] INFO  10:00:17.781 by shagrath / 2008-2011
[main] INFO  10:00:17.781 http://ps3mediaserver.org
[main] INFO  10:00:17.783 http://code.google.com/p/ps3mediaserver
[main] INFO  10:00:17.783 http://ps3mediaserver.blogspot.com
[main] INFO  10:00:17.783
[main] INFO  10:00:17.784 Java: 1.6.0_29-Apple Inc.
[main] INFO  10:00:17.785 OS: Mac OS X x86_64 10.7.2
[main] INFO  10:00:17.785 Encoding: UTF-8
[main] INFO  10:00:17.786 Working directory: /Applications/PS3 Media Server.app/Contents/Resources/Java
[main] INFO  10:00:17.791 Temp folder: /var/folders/10/350t6g1x1sbcjsr6hx170qkc0000gn/T/ps3mediaserver
[main] INFO  10:00:17.792 Logging config file: /Applications/PS3 Media Server.app/Contents/Resources/Java/logback.xml
[main] INFO  10:00:17.792 debug.log: /Applications/PS3 Media Server.app/Contents/Resources/Java/debug.log
[main] INFO  10:00:17.792
[main] INFO  10:00:17.793 Profile directory: /Users/flaxion/Library/Application Support/PMS
[main] INFO  10:00:17.794 Profile path: /Users/flaxion/Library/Application Support/PMS/PMS.conf
[main] INFO  10:00:17.796 Profile status: rw
[main] INFO  10:00:17.797 Profile name: simon-hermansen.lan
[main] INFO  10:00:17.797
[main] INFO  10:00:17.801 Loading MediaInfo library
[main] INFO  10:00:17.928 Loaded MediaInfoLib - v0.7.47
[main] INFO  10:00:17.935 Loading renderer configurations from /Applications/PS3 Media Server.app/Contents/Resources/Java/renderers
[main] INFO  10:00:17.936 Loading configuration file: AirPlayer.conf
[main] INFO  10:00:17.946 Loading configuration file: Android.conf
[main] INFO  10:00:17.956 Loading configuration file: Bravia4500.conf
[main] INFO  10:00:17.959 Loading configuration file: Bravia5500.conf
[main] INFO  10:00:17.963 Loading configuration file: BraviaEX.conf
[main] INFO  10:00:17.967 Loading configuration file: FreeboxHD.conf
[main] INFO  10:00:17.969 Loading configuration file: FreecomMusicPal.conf
[main] INFO  10:00:17.983 Loading configuration file: iPad-iPhone.conf
[main] INFO  10:00:17.998 Loading configuration file: Kuro.conf
[main] INFO  10:00:18.002 Loading configuration file: N900.conf
[main] INFO  10:00:18.005 Loading configuration file: Panasonic.conf
[main] INFO  10:00:18.008 Loading configuration file: Philips.conf
[main] INFO  10:00:18.021 Loading configuration file: PopcornHour.conf
[main] INFO  10:00:18.023 Loading configuration file: PS3.conf
[main] INFO  10:00:18.029 Loading configuration file: Realtek.conf
[main] INFO  10:00:18.033 Loading configuration file: Samsung.conf
[main] INFO  10:00:18.035 Loading configuration file: Showtime3.conf
[main] INFO  10:00:18.039 Loading configuration file: SonyBluray.conf
[main] INFO  10:00:18.043 Loading configuration file: Streamium.conf
[main] INFO  10:00:18.045 Loading configuration file: WDTVLive.conf
[main] INFO  10:00:18.047 Loading configuration file: WMP.conf
[main] INFO  10:00:18.050 Loading configuration file: XBMC.conf
[main] INFO  10:00:18.065 Loading configuration file: XBOX360.conf
[main] INFO  10:00:18.080 Checking MPlayer font cache. It can take a minute or so.
[main] DEBUG 10:00:18.081 launching: osx/mplayer
[main] INFO  10:00:18.300 Done!
[main] INFO  10:00:18.309 Loading plugins from /Applications/PS3 Media Server.app/Contents/Resources/Java/plugins
[main] INFO  10:00:18.311 No plugins found
[main] INFO  10:00:18.318 Registering transcoding engine: FFmpeg Audio
[main] INFO  10:00:18.343 Registering transcoding engine: MEncoder
[main] INFO  10:00:18.344 Registering transcoding engine: MPlayer Audio
[main] INFO  10:00:18.345 Registering transcoding engine: MEncoder Web
[main] INFO  10:00:18.346 Registering transcoding engine: MPlayer Video Dump
[main] INFO  10:00:18.346 Registering transcoding engine: MPlayer Web
[main] INFO  10:00:18.347 Registering transcoding engine: TsMuxer
[main] INFO  10:00:18.348 Registering transcoding engine: Audio High Fidelity
[main] INFO  10:00:18.349 Registering transcoding engine: VLC Audio Streaming
[main] INFO  10:00:18.349 Registering transcoding engine: VLC Video Streaming
[main] INFO  10:00:18.350 Registering transcoding engine: Raws Thumbnailer
[main] INFO  10:00:18.464 Scanning network interface vmnet8 / vmnet8
[main] INFO  10:00:18.466 Scanning network interface vmnet1 / vmnet1
[main] INFO  10:00:18.467 Scanning network interface en4 / en4
[main] INFO  10:00:18.468 Scanning network interface en1 / en1
[main] INFO  10:00:18.468 Scanning network interface lo0 / lo0
[main] INFO  10:00:18.469 Using forced address 192.168.1.127
[main] INFO  10:00:18.470 Created socket: /192.168.1.127:5001
[main] INFO  10:00:18.563 org.jboss.netty.channel.ChannelException: Failed to bind to: /192.168.1.127:5001
[main] INFO  10:00:18.564    at org.jboss.netty.bootstrap.ServerBootstrap.bind(ServerBootstrap.java:303)
[main] INFO  10:00:18.564    at net.pms.network.HTTPServer.start(HTTPServer.java:157)
[main] INFO  10:00:18.565    at net.pms.PMS.init(PMS.java:473)
[main] INFO  10:00:18.565    at net.pms.PMS.createInstance(PMS.java:878)
[main] INFO  10:00:18.565    at net.pms.PMS.main(PMS.java:975)
[main] INFO  10:00:18.566    at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
[main] INFO  10:00:18.566    at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
[main] INFO  10:00:18.566    at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
[main] INFO  10:00:18.567    at java.lang.reflect.Method.invoke(Method.java:597)
[main] INFO  10:00:18.567    at apple.launcher.LaunchRunner.run(LaunchRunner.java:116)
[main] INFO  10:00:18.567    at apple.launcher.LaunchRunner.callMain(LaunchRunner.java:51)
[main] INFO  10:00:18.567    at apple.launcher.JavaApplicationLauncher.launch(JavaApplicationLauncher.java:52)
[main] INFO  10:00:18.568 Caused by: java.net.BindException: Can't assign requested address
[main] INFO  10:00:18.568    at sun.nio.ch.Net.bind(Native Method)
[main] INFO  10:00:18.568    at sun.nio.ch.ServerSocketChannelImpl.bind(ServerSocketChannelImpl.java:126)
[main] INFO  10:00:18.569    at sun.nio.ch.ServerSocketAdaptor.bind(ServerSocketAdaptor.java:59)
[main] INFO  10:00:18.569    at org.jboss.netty.channel.socket.nio.NioServerSocketPipelineSink.bind(NioServerSocketPipelineSink.java:148)
[main] INFO  10:00:18.569    at org.jboss.netty.channel.socket.nio.NioServerSocketPipelineSink.handleServerSocket(NioServerSocketPipelineSink.java:100)
[main] INFO  10:00:18.570    at org.jboss.netty.channel.socket.nio.NioServerSocketPipelineSink.eventSunk(NioServerSocketPipelineSink.java:74)
[main] INFO  10:00:18.572    at org.jboss.netty.channel.Channels.bind(Channels.java:468)
[main] INFO  10:00:18.572    at org.jboss.netty.channel.AbstractChannel.bind(AbstractChannel.java:200)
[main] INFO  10:00:18.572    at org.jboss.netty.bootstrap.ServerBootstrap$Binder.channelOpen(ServerBootstrap.java:348)
[main] INFO  10:00:18.573    at org.jboss.netty.channel.Channels.fireChannelOpen(Channels.java:176)
[main] INFO  10:00:18.574    at org.jboss.netty.channel.socket.nio.NioServerSocketChannel.<init>(NioServerSocketChannel.java:85)
[main] INFO  10:00:18.574    at org.jboss.netty.channel.socket.nio.NioServerSocketChannelFactory.newChannel(NioServerSocketChannelFactory.java:142)
[main] INFO  10:00:18.574    at org.jboss.netty.channel.socket.nio.NioServerSocketChannelFactory.newChannel(NioServerSocketChannelFactory.java:90)
[main] INFO  10:00:18.575    at org.jboss.netty.bootstrap.ServerBootstrap.bind(ServerBootstrap.java:282)
[main] INFO  10:00:18.575    ... 11 more
 


I have both tried with non-IP-forcing and with ip-forcing (to the ip, that my PS3 has).

What can I do? :/
Flaxion
 
Posts: 1
Joined: Tue Nov 15, 2011 10:01 am

Re: PMS just stopped working not sure why

Postby bobbyc » Tue Nov 15, 2011 5:15 pm

Hey Flaxion,
I totally overlooked something. For some reason the ip of my system changed and since I use force IP it must match this. I was looking at the log and it seems you might have the same issue. If you are using a router make sure you have the same ip address you are entering in the main panel of PMS. Go to your Settings-Network and under Ethernet look at the ip address. If you are on router with hard patched into the ps3 it should be something like 10.0.1.2 or whatever you have. Now add that into the force ip of our PMS under General Configuration, Save it. Quick the PMS and turn on your ps3, launch it again and it should recognize it. I hope that works out for you.
bobbyc
 
Posts: 2
Joined: Tue Nov 15, 2011 8:09 am

Re: PMS just stopped working not sure why

Postby Raptor399 » Tue Nov 15, 2011 7:57 pm

And if that doesn't work, check the FAQ.
Raptor399
Project Member
 
Posts: 1916
Joined: Thu Mar 10, 2011 12:06 am

Re: PMS just stopped working not sure why

Postby thecrushinator » Mon Oct 15, 2012 1:36 am

I went to use my ps3 this morning, and found that it would not recognize my computer. Either the wmp or the ps3 media server would not show up on the ps3. I tried various ideas i had read on the internet, ie: new rules with the fire wall, and forcing my ip etc.. bu t none of it worked. The thing that eventually worked was to just turn off my computer, the ps3 and my wireless router. And ta da it worked. Sometimes the simplest solution is the best. Hope this helps
thecrushinator
 
Posts: 1
Joined: Mon Oct 15, 2012 1:29 am


Return to Mac OS X Support

Who is online

Users browsing this forum: Yahoo [Bot] and 3 guests