Ice films [PMS Encoder]

Discuss third-party additions, plugins and translations for PS3 Media Server

Ice films [PMS Encoder]

Postby smoothness05 » Mon Nov 14, 2011 9:57 pm

Hi sharkhunter,

Thank you for your latest one click installer...I had some issues with it but did some research on the forums and solved the "DLNA" issue by deleting the "subsonic.jar" plugin.

Now that i can access "Channels" and "Ice films"...I am able to browse movies and tv shows but when i click on any tv show or movie and try to view one of the sources i get. "data is corrupted"

Is there any way i can fix this ? I mainly just want to be able to view ice films on ps3. maybe i have to take out other plugins...



Thanks.
smoothness05
 
Posts: 2
Joined: Mon Nov 14, 2011 9:10 pm

Re: Ice films [PMS Encoder]

Postby SharkHunter » Wed Nov 16, 2011 11:10 am

Taking out plugins will not help you. You might have hit the folder depth limit. Try going back to the root folder and then in to the folder called "Folder Limit".
SharkHunter
 
Posts: 941
Joined: Tue Jun 01, 2010 8:39 pm

Re: Ice films [PMS Encoder]

Postby rohan.verma » Wed Dec 21, 2011 2:19 am

I'm having the same issue. I'm not sure what to do....I have not gotten a single video via the icefilms channel to work. So I'm sure it's a setting item for me.
I did see the Folder Limit folder and then it went away, I wasn't sure what to do with it...
Please help, much appreciated =)
rohan.verma
 
Posts: 1
Joined: Wed Dec 21, 2011 2:17 am

Re: Ice films [PMS Encoder]

Postby SharkHunter » Wed Dec 21, 2011 8:52 am

IceFilms has been down a couple of days. It seems to be back online again (although you never know). FolderLimit will help you if you use a PS3 which only allows you to have a depth of 8 folders. Once You hit that limit no matter what you do you'll get "Corrupted file" (or similar). Try and back out to the "root" again and the you can continue browsing in the "FolderLimit" folder.
SharkHunter
 
Posts: 941
Joined: Tue Jun 01, 2010 8:39 pm

Re: Ice films [PMS Encoder]

Postby smoothness05 » Tue Jan 03, 2012 9:02 pm

Alright thanks for getting back to me sharkhunter i will try this and see what happens
smoothness05
 
Posts: 2
Joined: Mon Nov 14, 2011 9:10 pm

Re: Ice films [PMS Encoder]

Postby rdizzy » Thu Jan 05, 2012 2:46 am

I am also having the same "the data is corrupt" issue when trying to watch movies via icefilms channel.
I'm running OSX Snow Leopard, followed the "Normal Install" instructions here - https://github.com/SharkHunter/Channel/ ... stallation, and the Perl install via terminal of the get-flash-videos here - http://code.google.com/p/get-flash-vide ... stallation

I don't know if it matters, but the first link for the 'get-flash-videos script' under "Normal Install" returns a 404.

Here's what comes up in debug.log

Code: Select all
[New I/O server worker #1-1] INFO  18:34:49.561 Starting transcode/remux of Source #2 MegaVideo

[osx/ffmpeg] DEBUG 18:34:49.983 Starting /Applications/PS3 Media Server.app/Contents/Resources/Java/osx/ffmpeg -v 0 -y -threads 2 -r 24 -i http://www.megavideo.com/?d=7Y5CQPGM -threads 2 -target ntsc-dvd /private/var/folders/ep/epsv44dzFS0xwe96XDG7S++++TI/-Tmp-/ps3mediaserver/pmsencoder_transcoder_out_1325727289564_36

[New I/O server worker #1-1] ERROR 18:35:01.187 There is no inputstream to return for Source #2 MegaVideo [PMSEncoder]


Any thoughts???
rdizzy
 
Posts: 2
Joined: Thu Jan 05, 2012 2:37 am

Re: Ice films [PMS Encoder]

Postby SharkHunter » Thu Jan 05, 2012 8:59 am

Have you set the perl.path and the get-flash-videos.path in the PMS.conf? It doesn't look like it since perl isn't started in the log above.
SharkHunter
 
Posts: 941
Joined: Tue Jun 01, 2010 8:39 pm

Re: Ice films [PMS Encoder]

Postby rdizzy » Thu Jan 05, 2012 3:28 pm

Ahh I must've forgot that, but have since put it in. here's what it's saying now

Code: Select all
[New I/O server worker #1-4] INFO  07:23:44.971 Starting transcode/remux of Source #2 MegaVideo
[mkfifo] DEBUG 07:23:44.975 Starting mkfifo -m 777 /var/folders/ep/epsv44dzFS0xwe96XDG7S++++TI/-Tmp-/ps3mediaserver/pmsencoder_transcoder_out_1325773424974_38
[mkfifo] DEBUG 07:23:45.011 Unix process ID (mkfifo): 2442
[osx/ffmpeg] DEBUG 07:23:45.362 Starting /Applications/PS3 Media Server.app/Contents/Resources/Java/osx/ffmpeg -v 0 -y -threads 2 -r 24 -i http://www.megavideo.com/?d=OATJ3SLK -threads 2 -target ntsc-dvd /private/var/folders/ep/epsv44dzFS0xwe96XDG7S++++TI/-Tmp-/ps3mediaserver/pmsencoder_transcoder_out_1325773424974_38
[osx/ffmpeg] DEBUG 07:23:45.396 Reading pipe: /var/folders/ep/epsv44dzFS0xwe96XDG7S++++TI/-Tmp-/ps3mediaserver/pmsencoder_transcoder_out_1325773424974_38
[Thread-31] DEBUG 07:23:56.597 Stopping process: osx/ffmpeg
[Thread-31] DEBUG 07:23:56.598 Stopping Unix process 2442: mkfifo
[New I/O server worker #1-4] ERROR 07:23:56.597 There is no inputstream to return for Source #2 MegaVideo [PMSEncoder]


and it is still returning with "The Data is Corrupt"
rdizzy
 
Posts: 2
Joined: Thu Jan 05, 2012 2:37 am

Re: Ice films [PMS Encoder]

Postby SharkHunter » Thu Jan 05, 2012 3:47 pm

Still you are not running perl. The commandline would read something like perl get_flash_videose.pl ttp://www.megavideo.com/?d=OATJ3SLK| /Applications/PS3 Media Server.app/Contents/Resources/Java/osx/ffmpeg -v 0 -y -threads 2 -r 24 -i - -threads 2 -target ntsc-dvd /private/var/folders/ep/epsv44dzFS0xwe96XDG7S++++TI/-Tmp-/ps3mediaserver/pmsencoder_transcoder_out_1325773424974_38
SharkHunter
 
Posts: 941
Joined: Tue Jun 01, 2010 8:39 pm

Re: Ice films [PMS Encoder]

Postby whoizerwin » Wed Jan 11, 2012 5:31 pm

Hmm Interesting, this is probably why it isn't working for me either.
However I have just checked the PMS.conf and there is no such line as perl.path or get-flash-videos.path

Where should I put these for Mac OSX? Is it maybe possible that you can post your PMS.conf since it is working for you?

Thanks mate!
whoizerwin
 
Posts: 4
Joined: Wed Dec 21, 2011 2:47 am

Next

Return to Additions and Plugins

Who is online

Users browsing this forum: No registered users and 2 guests