PS3 Media Server 1.40.0 is released

Announcements about PS3 Media Server

Re: PS3 Media Server 1.40.0 is released

Postby SubJunk » Mon Sep 26, 2011 10:57 pm

What's that part "-mmacosx-version-min=10.6", can you change that to "-mmacosx-version-min=10.5" or even lower?
SubJunk
 
Posts: 1212
Joined: Fri Mar 27, 2009 5:25 am

Re: PS3 Media Server 1.40.0 is released

Postby thecontact » Mon Sep 26, 2011 11:46 pm

well I tried both versions ( 1.40 and 1.30 ) both give the same "data corrupted" message on my ps3 with MKV files using MEncoder some of the files work with the other encoder without subtitles. I'm running Mac OS X 10.6.8, also known as Snow Leopard on an Intel Macbook pro with a i7 2.66 ghz with the NVIDIA graphic board. Can't seem to find the problem.

I have both VLC and Perian installed, maybe conflict with codec's ? But i believe that PMS runs as a stand alone program without the need for additional software. The MKV's I'm trying to see are all 720p or 1080p with H.264 codec and DTS sound some have subs in the contender and some have external subs ( I'm portuguese, and my parents don't understand english, so I'm trying to stream some videos for them with the subs ).

Could the problem be with the files or a new codec in the files that MEncoder can't encode? If that's so, it's weird too, because some mkv's are month's old
thecontact
 
Posts: 3
Joined: Fri Sep 23, 2011 4:05 am

Re: PS3 Media Server 1.40.0 is released

Postby Raptor399 » Tue Sep 27, 2011 7:25 am

SubJunk wrote:What's that part "-mmacosx-version-min=10.6", can you change that to "-mmacosx-version-min=10.5" or even lower?

Yes, but it seems to have little effect.

Plus, the error on OSX 10.5 is about not being able to find a dynamic library:
Code: Select all
dyld: unknown required load command 0x80000022

The resulting binary has still not been compiled with --enable-static, so I suspect it still requires dynamic libraries that do not exist on OSX 10.5.
Raptor399
Project Member
 
Posts: 1916
Joined: Thu Mar 10, 2011 12:06 am

Re: PS3 Media Server 1.40.0 is released

Postby SubJunk » Tue Sep 27, 2011 7:54 am

I had assumed you were compiling statically. It's probably important to solve whatever problem is preventing the --enable-static flag.
I personally compile mine with just --enable-static and --enable-runtime-cpudetection, no other flags.
SubJunk
 
Posts: 1212
Joined: Fri Mar 27, 2009 5:25 am

Re: PS3 Media Server 1.40.0 is released

Postby Raptor399 » Tue Sep 27, 2011 8:02 am

SubJunk wrote:I had assumed you were compiling statically. It's probably important to solve whatever problem is preventing the --enable-static flag.
I personally compile mine with just --enable-static and --enable-runtime-cpudetection, no other flags.

Aye!

Alas even the simplest "./configure --enable-static" (skipping extra CFLAGS, CXXFLAGS or LDFLAGS) doesn't work:
Code: Select all
/tmp/i386/src/mplayer> ./configure --enable-static
Checking for cc version ... 4.2.1
Checking for working compiler ...
Error: Compiler is not functioning correctly. Check your installation and custom CFLAGS  .

Check "config.log" if you do not understand why it failed.
/tmp/i386/src/mplayer> env | grep FLAGS
/tmp/i386/src/mplayer> more config.log
configuration: --enable-static

============ Checking for cc version ============
Result is: 4.2.1
##########################################

============ Checking for working compiler ============

int main(void) { return 0; }

cc    /var/folders/22/mk15r87109qf3h56sxm74ptr0000gn/T//mplayer-configure-5946-3735/tmp.c -falign-loops=16 -shared-libgcc -mdynamic-no-pic -I. -Iffmpeg  -static -lm    -o /var/folders/22/mk15r87109qf3h56sxm74ptr0000gn/T//mplayer-configure-5946-3735/tmp
ld: library not found for -lcrt0.o
collect2: ld returned 1 exit status
Raptor399
Project Member
 
Posts: 1916
Joined: Thu Mar 10, 2011 12:06 am

Re: PS3 Media Server 1.40.0 is released

Postby SubJunk » Tue Sep 27, 2011 11:26 am

Woops, I got my threads confused and thought I was responding in our private category. I'll respond to your last post in there :)
SubJunk
 
Posts: 1212
Joined: Fri Mar 27, 2009 5:25 am

Re: PS3 Media Server 1.40.0 is released

Postby Madoka » Wed Sep 28, 2011 10:06 pm

SJ, does this build use your mencoder builds? I noticed that the ass subtitle font is back to the original font from before your modifications. Or perhaps you fixed it?
Last edited by Madoka on Wed Sep 28, 2011 10:37 pm, edited 1 time in total.
Madoka
 
Posts: 111
Joined: Fri Feb 19, 2010 3:02 am

Re: PS3 Media Server 1.40.0 is released

Postby SubJunk » Wed Sep 28, 2011 10:12 pm

No, this build uses the old one still :) I'm still waiting to fix a few bugs in the new one
SubJunk
 
Posts: 1212
Joined: Fri Mar 27, 2009 5:25 am

Re: PS3 Media Server 1.40.0 is released

Postby MeAngry » Thu Sep 29, 2011 11:02 am

I'm having some troubles with the linux build of this version that I didn't have with 1.30.1. This is what the log says, and it does that with every single file I play:

Code: Select all
[New I/O server worker #1-5] INFO  20:48:20.051 Starting transcode/remux of 10x01 - Lottery Fever.mkv
[mkfifo] DEBUG 20:48:20.114 Starting mkfifo --mode=777 /tmp/ps3mediaserver/mencoder1317235700114
[mkfifo] DEBUG 20:48:20.134 Unix process ID (mkfifo): 21938
[mencoder] DEBUG 20:48:20.167 Starting mencoder -ss 0 -quiet /mnt/media/Series/Family Guy/Season 10/10x01 - Lottery Fever.mkv -quiet -quiet -oac copy -of mpeg -quiet -quiet -mpegopts format=mpeg2:muxrate=500000:vbuf_size=1194:abuf_size=64 -ovc lavc -channels 6 -lavdopts debug=0:threads=4 -lavcopts autoaspect=1:vcodec=mpeg2video:acodec=ac3:abitrate=640:threads=4:keyint=5:vqscale=1:vqmin=2:vrc_maxrate=60000:vrc_buf_size=7000 -quiet -quiet -subdelay 20000 -quiet -quiet -ofps 24000/1001 -quiet -quiet -lavdopts fast -mc 0 -noskip -af lavcresample=48000 -srate 48000 -o /tmp/ps3mediaserver/mencoder1317235700114
[mencoder] DEBUG 20:48:20.189 Reading pipe: /tmp/ps3mediaserver/mencoder1317235700114
[mencoder] ERROR 20:48:20.191 Fatal error in process initialization:
java.io.FileNotFoundException: /tmp/ps3mediaserver/mencoder1317235700114 (No such file or directory)
   at java.io.RandomAccessFile.open(Native Method) ~[na:1.6.0_20]
   at java.io.RandomAccessFile.<init>(RandomAccessFile.java:233) ~[na:1.6.0_20]
   at java.io.RandomAccessFile.<init>(RandomAccessFile.java:118) ~[na:1.6.0_20]
   at net.pms.io.PipeProcess.getInputStream(PipeProcess.java:128) ~[pms.jar:na]
   at net.pms.io.ProcessWrapperImpl.run(ProcessWrapperImpl.java:120) ~[pms.jar:na]
[mencoder] DEBUG 20:48:20.192 Stopping Unix process 21943: mencoder
[mencoder] DEBUG 20:48:20.194 Stopping Unix process 21938: mkfifo
[New I/O server worker #1-5] INFO  20:48:31.272 java.lang.NullPointerException
[New I/O server worker #1-5] INFO  20:48:31.273    at net.pms.network.RequestV2.answer(RequestV2.java:325)
[New I/O server worker #1-5] INFO  20:48:31.273    at net.pms.network.RequestHandlerV2.writeResponse(RequestHandlerV2.java:220)
[New I/O server worker #1-5] INFO  20:48:31.273    at net.pms.network.RequestHandlerV2.messageReceived(RequestHandlerV2.java:194)
[New I/O server worker #1-5] INFO  20:48:31.273    at org.jboss.netty.handler.stream.ChunkedWriteHandler.handleUpstream(ChunkedWriteHandler.java:148)
[New I/O server worker #1-5] INFO  20:48:31.274    at org.jboss.netty.handler.codec.http.HttpChunkAggregator.messageReceived(HttpChunkAggregator.java:116)
[New I/O server worker #1-5] INFO  20:48:31.274    at org.jboss.netty.channel.Channels.fireMessageReceived(Channels.java:302)
[New I/O server worker #1-5] INFO  20:48:31.274    at org.jboss.netty.handler.codec.replay.ReplayingDecoder.unfoldAndfireMessageReceived(ReplayingDecoder.java:522)
[New I/O server worker #1-5] INFO  20:48:31.274    at org.jboss.netty.handler.codec.replay.ReplayingDecoder.callDecode(ReplayingDecoder.java:506)
[New I/O server worker #1-5] INFO  20:48:31.275    at org.jboss.netty.handler.codec.replay.ReplayingDecoder.messageReceived(ReplayingDecoder.java:443)
[New I/O server worker #1-5] INFO  20:48:31.275    at org.jboss.netty.channel.Channels.fireMessageReceived(Channels.java:274)
[New I/O server worker #1-5] INFO  20:48:31.275    at org.jboss.netty.channel.Channels.fireMessageReceived(Channels.java:261)
[New I/O server worker #1-5] INFO  20:48:31.275    at org.jboss.netty.channel.socket.nio.NioWorker.read(NioWorker.java:349)
[New I/O server worker #1-5] INFO  20:48:31.275    at org.jboss.netty.channel.socket.nio.NioWorker.processSelectedKeys(NioWorker.java:280)
[New I/O server worker #1-5] INFO  20:48:31.276    at org.jboss.netty.channel.socket.nio.NioWorker.run(NioWorker.java:200)
[New I/O server worker #1-5] INFO  20:48:31.276    at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110)
[New I/O server worker #1-5] INFO  20:48:31.276    at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603)
[New I/O server worker #1-5] INFO  20:48:31.276    at java.lang.Thread.run(Thread.java:636)


Version 1.30.1 is working perfectly with all my files. If I run the mencoder command myself, it has problems finding the path to the file because it doesn't have quotes around them. Is it true that the command is executed without quotes around the file path or is that a debugging error? Because it would explain why none of my files are playing.

I also had this error some versions ago but it got fixed at some point, so it might be a regression.
MeAngry
 
Posts: 8
Joined: Tue May 12, 2009 8:54 pm

Re: PS3 Media Server 1.40.0 is released

Postby Raptor399 » Thu Sep 29, 2011 6:38 pm

MeAngry wrote:If I run the mencoder command myself, it has problems finding the path to the file because it doesn't have quotes around them. Is it true that the command is executed without quotes around the file path or is that a debugging error? Because it would explain why none of my files are playing.

Nope.
Each of the arguments is a seperate argument string provided to a ProcessBuilder object. To run the command the ProcessBuilder is started. This keeps arguments with spaces intact.

What is printed is not the exact command that the ProcessBuilder runs. Instead a string is made from all arguments concatenated. Granted, some of the arguments could use some tokenizing before printing. For now, you'll have to manually add quotes yourself to get a command that you can really execute.
Raptor399
Project Member
 
Posts: 1916
Joined: Thu Mar 10, 2011 12:06 am

PreviousNext

Return to Announcements

Who is online

Users browsing this forum: Yahoo [Bot] and 5 guests