PS3mediaserver on Debian

For help and support with issues specific to Linux/Unix
Forum rules
Please make sure you follow the Problem Reporting Guidelines before posting if you want a reply.

Re: PS3mediaserver on Debian

Postby Topguy » Tue Jan 27, 2009 11:55 pm

I used this recipe: http://www.gossamer-threads.com/lists/mythtv/mythtvnz/367722?page=last

And it worked quite well. So i have a binary but not sure if its working because I dont have a dual-core to test it on. :roll:

You can find them at http://drop.io/topguyz if anyone have the time and equipment to test them.

Its built on Debian Lenny so it will probably not work on anything else than fairly new Debian based distros.
Topguy
 
Posts: 219
Joined: Mon Jan 19, 2009 9:27 pm

Re: PS3mediaserver on Debian

Postby lavvan » Sun Feb 15, 2009 12:01 am

New problem

I installed the new 1.04 version. Now nothing is working. I`m just getting corrupt file.

Any help would be very helpfull. Attaching the packed debug file
Attachments
debug.rar
(26.4 KiB) Downloaded 55 times
lavvan
 
Posts: 14
Joined: Mon Jan 19, 2009 12:26 am

Re: PS3mediaserver on Debian

Postby lavvan » Sun Feb 15, 2009 4:30 am

New problem

I installed the new 1.04 version. Now nothing is working. I`m just getting corrupt file.

Any help would be very helpfull. Attaching the packed debug file
OK, no need to answer. I figured it out, or at least got it to work :D
lavvan
 
Posts: 14
Joined: Mon Jan 19, 2009 12:26 am

Re: PS3mediaserver on Debian

Postby lavvan » Tue Mar 10, 2009 12:19 am

hi!

I`ve intalled the new version of the server and having some problems.
I`m not able to run any files.. just get unsupported.

here is the error message i`m getting all the time in the debug:

Code: Select all
[Thread-664] DEBUG 00:00:36.591 Searching a subtitle track with lang: ger
[mkfifo] INFO  00:00:36.632 Starting mkfifo --mode=777 /tmp/javaps3media/mencoder1236639636632
[mencoder] INFO  00:00:36.682 Starting mencoder -ss 0 -quiet /storage/disk1/Film/Babylon A.D HD/Babylon.A.D.2008.Extended.Cut.720p.BluRay.DTS.x264-ESiR.mkv -quiet -quiet -oac lavc -of mpeg -lavfopts format=asf -mpegopts format=mpeg2:muxrate=500000:vbuf_size=1194:abuf_size=64 -ovc lavc -channels 6 -lavdopts debug=0:threads=2 -lavcopts autoaspect=1:vcodec=mpeg2video:acodec=ac3:abitrate=640:threads=2:keyint=1:vqscale=1:vqmin=1 -quiet -nofontconfig -subcp cp1252 -subfont /usr/share/fonts/truetype/ttf-dejavu/DejaVuSans.ttf -ass-color ffffff00 -ass-border-color 00000000 -ass-font-scale 1.0 -ass-force-style FontName=Arial,Outline=1,Shadow=1,MarginV=10 -quiet -quiet -subdelay 20000 -quiet -quiet -ofps 24000/1001 -quiet -quiet -mc 0 -noskip -af lavcresample=48000 -srate 48000 -o /tmp/javaps3media/mencoder1236639636632
[mencoder] 00:00:36.697 Fatal error in process starting: : Cannot run program "mencoder": java.io.IOException: error=2, No such file or directory
java.io.IOException: Cannot run program "mencoder": java.io.IOException: error=2, No such file or directory
   at java.lang.ProcessBuilder.start(ProcessBuilder.java:459)
   at net.pms.io.ProcessWrapperImpl.run(ProcessWrapperImpl.java:83)
Caused by: java.io.IOException: java.io.IOException: error=2, No such file or directory
   at java.lang.UNIXProcess.<init>(UNIXProcess.java:148)
   at java.lang.ProcessImpl.start(ProcessImpl.java:65)
   at java.lang.ProcessBuilder.start(ProcessBuilder.java:452)
   ... 1 more
[mencoder] TRACE 00:00:36.697 java.io.IOException: Cannot run program "mencoder": java.io.IOException: error=2, No such file or directory
[mencoder] TRACE 00:00:36.697    at java.lang.ProcessBuilder.start(ProcessBuilder.java:459)
[mencoder] TRACE 00:00:36.697    at net.pms.io.ProcessWrapperImpl.run(ProcessWrapperImpl.java:83)
[mencoder] TRACE 00:00:36.697 Caused by: java.io.IOException: java.io.IOException: error=2, No such file or directory
[mencoder] TRACE 00:00:36.697    at java.lang.UNIXProcess.<init>(UNIXProcess.java:148)
[mencoder] TRACE 00:00:36.697    at java.lang.ProcessImpl.start(ProcessImpl.java:65)
[mencoder] TRACE 00:00:36.697    at java.lang.ProcessBuilder.start(ProcessBuilder.java:452)
[mencoder] TRACE 00:00:36.697    ... 1 more
[mencoder] TRACE 00:00:36.697 [mencoder] 00:00:36.697 Fatal error in process starting: : Cannot run program "mencoder": java.io.IOException: error=2, No such file or directory
[mencoder] INFO  00:00:36.697 Stopping process: mencoder
[mencoder] INFO  00:00:36.697 Stopping process: mkfifo
[mencoder] DEBUG 00:00:36.698 Killing the Unix process: 3677
[mencoder] INFO  00:00:36.701 Stopping process: mkfifo
[Thread-667] DEBUG 00:00:36.701 kill: No such process
[mencoder] DEBUG 00:00:36.701 Killing the Unix process: 3677
[Thread-669] DEBUG 00:00:36.704 kill: No such process
[Thread-664] DEBUG 00:00:42.783 Wrote on socket: Content-Type: video/mpeg
[Thread-664] DEBUG 00:00:42.783 Wrote on socket: Connection: keep-alive
[Thread-664] DEBUG 00:00:42.783 Wrote on socket: Server: Linux-i386-2.6.26-1-686, UPnP/1.0, PMS/1.10.5
[Thread-664] DEBUG 00:00:42.783 Wrote on socket: Content-Length: 0
[Thread-664] DEBUG 00:00:42.783 Wrote on socket:
[Thread-664] DEBUG 00:00:42.783 Close Connection

I`m gessing this is another resault of my newbie skills :D
lavvan
 
Posts: 14
Joined: Mon Jan 19, 2009 12:26 am

Re: PS3mediaserver on Debian

Postby Topguy » Wed Mar 11, 2009 11:41 pm

lavvan wrote:hi!

Code: Select all
[mencoder] 00:00:36.697 Fatal error in process starting: : Cannot run program "mencoder": java.io.IOException: error=2, No such file or directory
java.io.IOException: Cannot run program "mencoder": java.io.IOException: error=2, No such file or directory


I`m gessing this is another resault of my newbie skills :D


Could be... but the problem should be simple to fix. Install "mencoder" or make sure that mencoder is in the path when starting PMS.
"which mencoder" will tell you if the command is available.
Topguy
 
Posts: 219
Joined: Mon Jan 19, 2009 9:27 pm

Re: PS3mediaserver on Debian

Postby lavvan » Sun Apr 05, 2009 12:35 am

I have got the mediaserver 1.10.5 working, but I`m having some difficulties with some .mkv files. They work with 1.04 version so I`m gessing it has something to do with the builds i`m using?

Here is the debug file:
debug.rar
(16.3 KiB) Downloaded 61 times


Any idea why this .mkv won`t start?
lavvan
 
Posts: 14
Joined: Mon Jan 19, 2009 12:26 am

Re: PS3mediaserver on Debian

Postby shagrath » Sun Apr 05, 2009 1:42 am

lavvan wrote:I have got the mediaserver 1.10.5 working, but I`m having some difficulties with some .mkv files. They work with 1.04 version so I`m gessing it has something to do with the builds i`m using?

Here is the debug file:
debug.rar


Any idea why this .mkv won`t start?



disable the "switch to tsmuxer" option
shagrath
Project Lead
 
Posts: 2667
Joined: Wed Jan 14, 2009 1:39 pm

Re: PS3mediaserver on Debian

Postby lavvan » Sun Apr 05, 2009 10:21 am

disable the "switch to tsmuxer" option
Didn`t work..

Here`s the debug file with the "switch to tsmuxer" option disabled:
debug.rar
(13.66 KiB) Downloaded 65 times
lavvan
 
Posts: 14
Joined: Mon Jan 19, 2009 12:26 am

Re: PS3mediaserver on Debian

Postby shagrath » Sun Apr 05, 2009 12:52 pm

mencoder seems stuck

get the command from the line 1839 of your log and start it, just to see if this is working at least
shagrath
Project Lead
 
Posts: 2667
Joined: Wed Jan 14, 2009 1:39 pm

Re: PS3mediaserver on Debian

Postby lavvan » Sun Apr 05, 2009 2:28 pm

This is what i get when running the command:

Code: Select all
server01:/storage/disk1/PMS#  mencoder -ss 0 -quiet /storage/disk1/Film/Bangkok Dangerous HD/bkd-septic.mkv -quiet -quiet -oac lavc -of mpeg -lavfopts
MEncoder SVN-r28572-4.3.2 (C) 2000-2009 MPlayer Team
Error parsing option on the command line: -lavfopts

Exiting... (error parsing command line)
server01:/storage/disk1/PMS#


If i remove the -lavfopts, i get:

Code: Select all
server01:/storage/disk1/PMS#  mencoder -ss 0 -quiet /storage/disk1/Film/Bangkok Dangerous HD/bkd-septic.mkv -quiet -quiet -oac lavc -of mpeg
MEncoder SVN-r28572-4.3.2 (C) 2000-2009 MPlayer Team

Exiting... (No output file specified, please see the -o option.)
server01:/storage/disk1/PMS#
lavvan
 
Posts: 14
Joined: Mon Jan 19, 2009 12:26 am

PreviousNext

Return to Linux/Unix Support

Who is online

Users browsing this forum: No registered users and 4 guests