Directory Size - DLNA Error 2006

For help and support with PS3 Media Server in general
Forum rules
Please make sure you follow the Problem Reporting Guidelines before posting if you want a reply.

Re: Directory Size - DLNA Error 2006

Postby natjen » Mon Oct 04, 2010 5:21 am

maxand wrote:Been a few months, anyone have luck successfully opening folders with numerous files?

I have a folder with about 10,000 ripped MP3s (around 40GB) unable to be accessed with the most recent PS3MS. On the advice of this thread, I downloaded an older version of PS3 Media Server and the folders and files became visible on the PS3. However, when I go to copy them to my PS3 hard drive, I get a 80030420 error (no idea what this means, nothing online about it) before the copy process is about to begin. Any advice on where to go from here? By the way, I am using a crossover cable to copy files over to my PS3, it has worked well for video folders 20GB+.

THIS is what I'm referring to, you are the one asking for help here!

Above you are saying you get a problem when copying files to your PS3 hard drive. How is copying files to a hard drive anything to do with PMS?
Posts: 69
Joined: Sat Oct 03, 2009 12:01 pm

Re: Directory Size - DLNA Error 2006

Postby natjen » Mon Oct 04, 2010 5:24 am

jtag wrote:
natjen wrote:How can it be a bug in PMS when you are failing to copy them to your PS3 Hard Drive? You wouldn't be using PMS to copy them to you hard drive would you?

What do you mean by copy them to your PS3 Hard Drive (it is not clear)? Coping the files from server PMS HDD location to PS3 HDD it is a different problem.

The problem here has that the files are not visible (not accessible) from PS3 to PMS HDD server location.
If you use an older PMS version the files are visible! So, it is a bug in the latest version.

I get it now, I was never replying to your issue, go back a couple, I was reffering to maxand's issues.

So in your case, what version of PMS are you on, and do you use the Media Library?
Posts: 69
Joined: Sat Oct 03, 2009 12:01 pm

Re: Directory Size - DLNA Error 2006

Postby jtag » Tue Oct 05, 2010 1:39 am

My stable version is: Linux v1.10.5
Posts: 27
Joined: Sat Apr 24, 2010 9:39 pm

Re: Directory Size - DLNA Error 2006

Postby jtag » Mon Oct 11, 2010 11:55 pm

I have used v1.20.409 BETA on the new Ubuntu server 64amd 10.10 and I was able to open big files. I did not have the error: "A DLNA protocol error (2006) has ocured"
Posts: 27
Joined: Sat Apr 24, 2010 9:39 pm

Re: Directory Size - DLNA Error 2006

Postby toodrunk82 » Thu Nov 25, 2010 12:33 pm

This is driving me crazy. It started from nothing, i tried it ALL but even on a folder with just 1 video file, the error occurs. So i just re-installed the PMS and it worked again. No need to unnistall, just re-install, but when i turn off the PC or the PS3, the next time i try to use it, it happens again, so i have to re-install again. It is very annoying. Any solutions yet?
Posts: 1
Joined: Thu Nov 25, 2010 12:27 pm

Re: Directory Size - DLNA Error 2006

Postby meskibob » Thu Nov 25, 2010 9:23 pm

That sounds like a file permissions issue. Reinstall with Run as Administrator on the installer or disable UAC. If you're not using Win Vista/7, please start a new thread per viewtopic.php?f=6&t=496
I provide NO application support via PM or email, so please post your question to the forum per the Forum Rules.
Posts: 4806
Joined: Mon Jan 19, 2009 4:11 pm

Re: Directory Size - DLNA Error 2006

Postby nox216 » Sat Apr 16, 2011 3:33 am

I know this is an old(ish) thread, but I ran into this issue on my headless Ubuntu server and got a little bit more information narrowed down. I can confirm that the problem does not exist until revision 391.

I successfully tested up from the revision associated with 1.04 to r390, and the directories all loaded (at varying speeds). At r391, I start getting DLNA 2006 errors on my test directories. Unfortunately, r391 looks like quite a big check-in involving the introduction of a number of threading features, so debugging is going to be a pain from here on out.

Hope this helps someone track it down.
Posts: 1
Joined: Sat Apr 16, 2011 3:28 am

Re: Directory Size - DLNA Error 2006

Postby radamo » Fri Apr 29, 2011 9:34 pm

I am running 1.21.1 on Win 7 64 bit. Running a Quad Core Q6600 at 3 Ghz and 4 Gb or RAM. I have hard wired ethernet with a gigabit connection (I am sure the pS3 is only 100M but the network is Gigabit). I am getting this error when trying to look at a directory with about 24 playlists. It loads the first 10 playlists (really slow before they appear) then after about 20 seconds I get DLNA Error 2006 and I see no more than the first 10 playlists.

What is http v2 and does it have any effect on this?
Should I have the "cores for transcoding" set to 4 or just 2 or something else???

Anything else I should be looking at?

Posts: 37
Joined: Sat Jan 31, 2009 5:12 pm

Re: Directory Size - DLNA Error 2006

Postby Drag0nFly » Sun May 22, 2011 2:44 pm

I am experiencing this error as well. As others have mentioned, previous versions of PMS (1.03/1.04) work without issues and directory scanning is instantaneous.

However, all the latest PMS builds are next to unusable. The directory listings either time out or only genereate a partial index. And this is not even from directories which contain many files at all (46 in total, including directories).
Something extremely nasty has happened with the way PMS generate these listings, and I am surprised it is still a problem.

I don't mind using the older versions were it not that my 25 fps .mkv videos do not play without stutter on 60 Hz (US PS3), which the new PMS does infact support. I've yet to try 1.10.5 (and 1.10.1) to see if they behave more correctly.
Posts: 11
Joined: Thu Feb 12, 2009 6:59 pm

Re: Directory Size - DLNA Error 2006

Postby ccb056 » Sun Jun 05, 2011 5:27 pm

I have this same problem. Is this being worked on? Are there any programs out there that don't have this problem (doesn't have to be freeware)
Posts: 1
Joined: Sun Jun 05, 2011 5:25 pm


Return to General Help and Support

Who is online

Users browsing this forum: No registered users and 7 guests