PS3 Media Server 1.21.1 is released

Announcements about PS3 Media Server

Re: PS3 Media Server 1.21.1 is released

Postby audioguy » Fri Apr 15, 2011 11:39 pm

Glad someone is working on the OSX release. Has anyone tested the Audio High Fidelity engine on OSX, it's been broken. I looked at the log and it is trying to load win/fake.jpg in order to create the blank video before it is muxed with the audio. Probably just a windows path that needs to be changed to reflect OSX? This is the big feature I've been missing since I would like to play 24bit 96khz flac files on OSX.
Great work guys
audioguy
 
Posts: 2
Joined: Fri Apr 15, 2011 11:34 pm

Re: PS3 Media Server 1.21.1 is released

Postby SubJunk » Fri Apr 15, 2011 11:53 pm

taconaut wrote:@SubJunk
Ahh for OSX it's not a compilation, but a runtime issue. Possibly I've got the same problem with mlx and nobody has mentioned it (there were pretty few download for this platform). Anyway, I'll give it a go when I can. I'm usually coding on a mac but I never serve stuff from there, the server runs on a win7 machine (since last week...)
SVN tagging is pretty straight forward. All it does, is making a copy of the files to another location. If you're using tortoiseSVN, the easiest is probably to do a 'Show log' on the project (ps3mediaserver), select the revision you want to tag (r548) -> Create branch/tag from revision and copy it to URL 'https://ps3mediaserver.googlecode.com/svn/tags/1.21.0' (the only existing tag is 1.10)
I created a tag for the latest release :) Seems like a good habit to get into. Thanks for the instructions :)

mojo21 wrote:Is there a way to make the thumbnails larger for video files in this new release??
The thumbnails are as large as they can be on PS3; the size is determined by the PS3 and not by us :)

audioguy wrote:Glad someone is working on the OSX release. Has anyone tested the Audio High Fidelity engine on OSX, it's been broken. I looked at the log and it is trying to load win/fake.jpg in order to create the blank video before it is muxed with the audio. Probably just a windows path that needs to be changed to reflect OSX? This is the big feature I've been missing since I would like to play 24bit 96khz flac files on OSX.
Great work guys
Thanks for reporting the issue, I have fixed it in r552 so it will be fixed in the next release (and in SB23 when I release it later today, if anyone wants to build that for OS X :))
SubJunk
 
Posts: 1210
Joined: Fri Mar 27, 2009 5:25 am

Re: PS3 Media Server 1.21.1 is released

Postby Luxfero » Sat Apr 16, 2011 3:11 am

Can I install on top of pms-setup-windows-1.20.412, or should I uninstall and fresh install? Thanks for the update.
Luxfero
 
Posts: 20
Joined: Sun Jan 24, 2010 4:01 am

Re: PS3 Media Server 1.21.1 is released

Postby SubJunk » Sat Apr 16, 2011 3:14 am

Luxfero wrote:Can I install on top of pms-setup-windows-1.20.412, or should I uninstall and fresh install? Thanks for the update.
Hi Luxfero :) It makes no difference
SubJunk
 
Posts: 1210
Joined: Fri Mar 27, 2009 5:25 am

Re: PS3 Media Server 1.21.1 is released

Postby Luxfero » Sat Apr 16, 2011 3:23 am

Thanks, keep up the good work.
Luxfero
 
Posts: 20
Joined: Sun Jan 24, 2010 4:01 am

Re: PS3 Media Server 1.21.1 is released

Postby audioguy » Sat Apr 16, 2011 6:19 pm

Thanks for fixing the path in r552, the code looks good - one question though, -vcodec libx264 didn't work with the version of ffmpeg that was packaged with 1.20.409 for the mac is there a new version of ffmpeg that will fix this?

Some Ideas:
The PS3 actually could be a great audio source for audiophiles feeding external digital converters from the optical port, it has low jitter and sound very good with 16/44 CD quality audio. The optical output is limited to 44.1,48,88.2,176.4 khz - there is no support for 96khz from the optical output. The PS3 will downconvert 96khz to 48khz, not the best solution, my solution would be to use SOX to downconvert all high res audio to 88.2khz. It would also be nice to have the option to have all flac audio at any sample rate, etc be displayed under video using the same process as 24 bit audio, this option and the downconvert option probably should be in the GUI somewhere.

Thanks again, impressive work.
audioguy
 
Posts: 2
Joined: Fri Apr 15, 2011 11:34 pm

Re: PS3 Media Server 1.21.1 is released

Postby taconaut » Sun Apr 17, 2011 12:59 pm

SubJunk wrote:
taconaut wrote:
SubJunk wrote:I think there is an error with compiling mac builds right now, do you have a fix for that?

Last one I've compiled was r512 (with pms-mlx) and didn't have any issues with it. Have you got a link to what the trouble is?
I'll give it a try tonight as the mac is @home
There an issue on our tracker about it here, let me know if it works for you :)

I've checked out tag 1.21.1 (thanks ;)) and had a look at this. It's related to the font cache, but I was able to play a film with soft subs. I'd say this is a non-issue showing an error message that shouldn't be there.

The problem lies with
Code: Select all
PMS.java 404: checkProcessExistence("MPlayer", true, getConfiguration().getTempFolder(), configuration.getMplayerPath(), "dummy");
When setting the working dir, OSX tries to run relative paths in there. When returning absolute paths from MacDefaultPaths, the error doesn't occure anymore. It doesn't create a font cache file in the working dir though (as on Ubuntu 10.10). The fonts cache gets only created when ran on windows. I'm not sure if the fonts cache should also be created for other platforms than windows!? If not, this check will avoid the error:

Code: Select all
Index: net/pms/PMS.java
===================================================================
--- net/pms/PMS.java   (revision 553)
+++ net/pms/PMS.java   (working copy)
@@ -399,10 +399,12 @@
       
       RendererConfiguration.loadRendererConfigurations();
       
-      minimal("Checking MPlayer font cache. It can take a minute or so.");
-      checkProcessExistence("MPlayer", true, null, configuration.getMplayerPath(), "dummy");
-      checkProcessExistence("MPlayer", true, getConfiguration().getTempFolder(), configuration.getMplayerPath(), "dummy");
-      minimal("Done!");
+      if(isWindows()){
+         minimal("Checking MPlayer font cache. It can take a minute or so.");
+         checkProcessExistence("MPlayer", true, null, configuration.getMplayerPath(), "dummy");
+         checkProcessExistence("MPlayer", true, getConfiguration().getTempFolder(), configuration.getMplayerPath(), "dummy");
+         minimal("Done!");         
+      }
       
       // check the existence of Vsfilter.dll
       if (registry.isAvis() && registry.getAvsPluginsDir() != null) {
If you always wanted to have your most recent videos at the top of the folder in the ps3 or wished you could group all videos with the same genre in one folder, have a look at pms-mlx
taconaut
Project Member
 
Posts: 1065
Joined: Sat Apr 11, 2009 12:29 am
Location: Switzerland

Re: PS3 Media Server 1.21.1 is released

Postby ROL » Mon Apr 18, 2011 6:30 am

SubJunk, why don't you guys use the zaxtron's Mac OS X build? His build fixed several issues and it uses newer version of MEnconder/MPlayer plugins. Maybe you guys can add him to the development team and use his source in the official build? Of course it would be nice to have all the additional features from 1.21.1 as well. This was the version I downloaded last month, it worked fine for me and few others in that thread. It solved the MKV header compression issue I was having. He also posted a newer version here to support earlier Mac OS X version, I haven't tried that one though.

Thanks
ROL
 
Posts: 5
Joined: Fri Feb 18, 2011 4:45 am

Re: PS3 Media Server 1.21.1 is released

Postby SubJunk » Mon Apr 18, 2011 7:39 am

His work looks promising, I'm sure if he expresses interest in joining the development team we would be thrilled to have him. None of the current developers use OS X so it would fill that gap.
SubJunk
 
Posts: 1210
Joined: Fri Mar 27, 2009 5:25 am

Re: PS3 Media Server 1.21.1 is released

Postby beetuna » Wed Apr 20, 2011 2:21 am

I'm having issues with ISO playback in this release. This is the only release that has caused micro-stutter.

No need to repost the issue, already posted here: viewtopic.php?f=6&t=10790

Just curious, is anyone else having these issues?
beetuna
 
Posts: 7
Joined: Tue Apr 19, 2011 2:44 am

PreviousNext

Return to Announcements

Who is online

Users browsing this forum: No registered users and 14 guests